TechDraw TemplateHowTo

From FreeCAD Documentation
Revision as of 20:28, 24 November 2018 by Vocx (talk | contribs) (New introduction section to explain what is being done)
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano


Introduction

This tutorial shows you how to create an SVG file that can be used as a bacground template for the TechDraw Workbench pages.

This tutorial assumes you are moderately familiar with Inkscape and SVG, as well as FreeCAD and the TechDraw Workbench.

Steps

We're going to make a simple template for US Letter size paper in landscape orientation. A copy of the result of this HowTo is available in your FreeCAD Template directory (HowToExample.svg).

  • open a new document in Inkscape
  • in Document Properties
    • select a page size (US Letter) & orientation (landscape)
    • set default units and page size units to mm (279.4 x 215.9)
InkDocProp.png


InkXMLNameSpace.png


  • draw outlines, zone numbers, centerlines, etc
  • draw the boxes and lines for the title block.
  • add and position your static text
  • add and position your editable text
  • you now have your finished artwork - something like this:
InkFinishedArt.png


  • use the XML Editor to add "freecad:editable" tag to each editable <text> item
    • assign a meaningful field name to each editable text
InkXMLeditableTag.png


  • use XML editor to adjust viewbox to match your page size in mm
InkXMLviewBox.png


  • your template will now appear much too big.
InkMuchTooBig.png


  • We need to shrink it.
    • Edit>Select All in All Layers (or box select. make sure you select everything)
    • adjust the W: and H: spinboxes to match your artwork's size in mm
      • page-size less any applicable margins
    • use "Align and Distribute" or X/Y spinboxes to position artwork on page if required.
    • your template should now look right, just like it did in the finished artwork picture above.
  • ensure that all your editable texts are "ungrouped" (shift-ctl-g)
  • select everything on your page (box select or Edit>SelectAll) and Edit>Copy
  • Layer>Delete Current Layer
  • Edit>Paste in Place


  • Your template should now look right and shouldn't have any unwanted transforms
  • Save your template
  • try it in FreeCAD.
FCTemplateHow.png


Notes

- Don't use Layers until you've mastered template creation without them. Layers (and Groups) can automatically insert unwanted transforms into your SVG.

Categroy:Tutorial