Difference between revisions of "TechDraw TemplateHowTo"

From FreeCAD Documentation
Jump to navigation Jump to search
(creation)
 
Line 1: Line 1:
 +
<translate>
 +
__NOTOC__
 +
<!--T:1-->
 
===How to Make a TechDraw Template===
 
===How to Make a TechDraw Template===
  
Line 37: Line 40:
 
*Save your template
 
*Save your template
 
*try it in FreeCAD.
 
*try it in FreeCAD.
 +
 +
<!--T:10-->
 +
Back to [[TechDraw_Templates|Templates]].
 +
 +
 +
<!--T:20-->
 +
[[Category:User Documentation]]
 +
</translate>
 +
<languages/>

Revision as of 02:04, 8 February 2018

How to Make a TechDraw Template

This HowTo assumes you are familiar with FreeCAD, Inkscape and Svg.

We're going to make a template for US Letter paper in landscape orientation.

  • open a new document in Inkscape
  • in Document Properties
    • select a page size (US Letter) & orientation (landscape)
    • set default units and page size units to mm (279.4 x 215.9)
  • use the XML Editor to add freecad namespace clause to the <svg> item

Note: don't use Layers until you've mastered template creation without them. Layers (and Groups) can automatically insert unwanted transforms into your SVG.

  • draw outlines, zone numbers, centerlines, etc
  • draw the boxes and lines for the title block.
  • add and position your static text
  • add and position your editable text
  • use the XML Editor to add "freecad:editable" tag to each editable <text> item
    • assign a meaningful field name to each editable text
  • use XML editor to adjust viewbox to match your page size in mm
    • your template will now appear much too big.
    • Edit>Select All in All Layers (or box select. make sure you select everything)
    • adjust the W: and H: spinboxes to match your artwork's size in mm
      • page-size less any applicable margins
    • use "Align and Distribute" or X/Y spinboxes to position artwork on page if required.
    • your template should now look right.
  • ensure that all your editable texts are "ungrouped" (shift-ctl-g)
  • select everything on your page (box select or Edit>SelectAll) and Edit>Copy
  • Layer>Delete Current Layer
  • Edit>Paste in Place
  • Your template should now look right and shouldn't have any unwanted transforms
  • Save your template
  • try it in FreeCAD.

Back to Templates.

Other languages:
Deutsch • ‎English • ‎français • ‎italiano