Difference between revisions of "TechDraw SaveSVG/de"

From FreeCAD Documentation
Jump to navigation Jump to search
(2 intermediate revisions by the same user not shown)
Line 32: Line 32:
 
==Hinweise==
 
==Hinweise==
  
<div class="mw-translate-fuzzy">
 
 
* [[TechDraw Hatch/de|Schraffurmuster]] werden aufgrund einer Einschränkung in der SVG-Unterstützung von Qt4 nicht nach [[SVG/de|SVG]] exportiert.
 
* [[TechDraw Hatch/de|Schraffurmuster]] werden aufgrund einer Einschränkung in der SVG-Unterstützung von Qt4 nicht nach [[SVG/de|SVG]] exportiert.
 
* Textpositionen und -größen werden in der exportierten Datei nicht korrekt dargestellt. Die Verwendung der Standardschriftart »System« in der Zeichnung verbessert das Größenproblem erheblich.
 
* Textpositionen und -größen werden in der exportierten Datei nicht korrekt dargestellt. Die Verwendung der Standardschriftart »System« in der Zeichnung verbessert das Größenproblem erheblich.
 
* Aus einer gespeicherten [[SVG/de|SVG]]-Zeichnung in Inkscape eine [[DXF/de|DXF]]-Datei exportieren: Um in Inkscape V0.48 mit dem richtigen Maßstab nach DXF zu exportieren, wählen Sie »Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)« als Exportformat und wählen Sie »Basiseinheit: px« im nächsten Dialogfeld. Die Zeichnung ist noch nicht im richtigen Maßstab, sondern hat einen Maßstab von 10:1. Um den korrekten Maßstab auf LibreCAD zu erhalten, wählen Sie »Edit → Current Drawing Preferences → General Factor« von 0.1. Das Ergebnis trotzdem mit einer bekannten Entfernung überprüfen!
 
* Aus einer gespeicherten [[SVG/de|SVG]]-Zeichnung in Inkscape eine [[DXF/de|DXF]]-Datei exportieren: Um in Inkscape V0.48 mit dem richtigen Maßstab nach DXF zu exportieren, wählen Sie »Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)« als Exportformat und wählen Sie »Basiseinheit: px« im nächsten Dialogfeld. Die Zeichnung ist noch nicht im richtigen Maßstab, sondern hat einen Maßstab von 10:1. Um den korrekten Maßstab auf LibreCAD zu erhalten, wählen Sie »Edit → Current Drawing Preferences → General Factor« von 0.1. Das Ergebnis trotzdem mit einer bekannten Entfernung überprüfen!
 
* Seit FreeCAD 0.18 ist es möglich, mit [[TechDraw SaveDXF/de|DXF speichern]] direkt nach [[DXF/de|DXF]] zu exportieren.
 
* Seit FreeCAD 0.18 ist es möglich, mit [[TechDraw SaveDXF/de|DXF speichern]] direkt nach [[DXF/de|DXF]] zu exportieren.
</div>
 
  
==Properties==
+
==Eigenschaften==
  
 
==Programmierung==
 
==Programmierung==
Line 53: Line 51:
  
  
<div class="mw-translate-fuzzy">
 
 
{{Docnav/de
 
{{Docnav/de
 
|[[TechDraw_Dimension_Link/de|Bemaßungen verlinken]]
 
|[[TechDraw_Dimension_Link/de|Bemaßungen verlinken]]
Line 62: Line 59:
 
|IconR=techdraw-saveDXF.svg
 
|IconR=techdraw-saveDXF.svg
 
}}
 
}}
</div>
 
  
 
{{TechDraw Tools navi{{#translation:}}}}
 
{{TechDraw Tools navi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}

Revision as of 14:28, 25 April 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

TechDraw ExportPage.png SVG speichern

Menüeintrag
TechDraw → Seite exportieren
Arbeitsbereich
TechDraw
Standardtastenkürzel
None
In der Version eingeführt
-
Siehe auch
Vorlagen, SVG speichern


Beschreibung

Das Werkzeug »SVG speichern« speichert das aktuelle Zeichenblatt als SVG-Datei.

Anwendung

  1. Auf die Schaltfläche TechDraw SaveSVG.png Seite in SVG-Datei exportieren klicken.
  2. Ein Dialogfeld zum Speichern von Dateien wird geöffnet.
  3. Wählen Sie einen Speicherort und einen Dateinamen aus.

Hinweise

  • Schraffurmuster werden aufgrund einer Einschränkung in der SVG-Unterstützung von Qt4 nicht nach SVG exportiert.
  • Textpositionen und -größen werden in der exportierten Datei nicht korrekt dargestellt. Die Verwendung der Standardschriftart »System« in der Zeichnung verbessert das Größenproblem erheblich.
  • Aus einer gespeicherten SVG-Zeichnung in Inkscape eine DXF-Datei exportieren: Um in Inkscape V0.48 mit dem richtigen Maßstab nach DXF zu exportieren, wählen Sie »Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)« als Exportformat und wählen Sie »Basiseinheit: px« im nächsten Dialogfeld. Die Zeichnung ist noch nicht im richtigen Maßstab, sondern hat einen Maßstab von 10:1. Um den korrekten Maßstab auf LibreCAD zu erhalten, wählen Sie »Edit → Current Drawing Preferences → General Factor« von 0.1. Das Ergebnis trotzdem mit einer bekannten Entfernung überprüfen!
  • Seit FreeCAD 0.18 ist es möglich, mit DXF speichern direkt nach DXF zu exportieren.

Eigenschaften

Programmierung

Siehe auch: TechDraw API und FreeCAD Scripting Basics.

Das Werkzeug »SVG speichern« kann sowohl in Makros als auch aus der Python-Konsole heraus mittels folgender Funktion angesprochen werden:

TechDrawGui.exportPageAsSvg(DrawPageObject,FilePath)

Beachten Sie, dass das FreeCADGui-Modul aktiv sein muss, um diese Funktion nutzen zu können.