Difference between revisions of "TechDraw SaveSVG/de"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "{{GuiCommand/de|Name=TechDraw ExportPage|Name/de=SVG speichern|Workbenches=TechDraw|MenuLocation=TechDraw → Seite exportieren|Shortcut=|SeeAlso=}}")
(41 intermediate revisions by 4 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{GuiCommand/de|Name=TechDraw  ExportPage|Name/de=SVG speichern|Workbenches=[[TechDraw Module/de|TechDraw]]|MenuLocation=TechDraw → Seite exportieren|Shortcut=|SeeAlso=}}
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/de
 +
|[[TechDraw_Dimension_Link/de|Bemaßungen verlinken]]
 +
|[[TechDraw_SaveDXF/de|DXF speichern]]
 +
|[[TechDraw_Module/de|TechDraw-Arbeitsbereich]]
 +
|IconL=Techdraw_Dimension_VExtent.svg
 +
|IconC=Workbench_TechDraw.svg
 +
|IconR=techdraw-saveDXF.svg
 +
}}
 +
</div>
 +
 
 +
<div class="mw-translate-fuzzy">
 +
{{GuiCommand/de
 +
|Name=TechDraw  ExportPage|Name/de=SVG speichern
 +
|MenuLocation=TechDraw → Seite exportieren
 +
|Workbenches=[[TechDraw Module/de|TechDraw]]
 +
|SeeAlso=[[TechDraw Templates/de|Vorlagen]], [[Draft SVG/de|SVG speichern]]
 +
}}
 +
</div>
  
==Description==
+
==Beschreibung==
The Export page tool saves the current drawing page as an SVG file
 
  
==How to use==
+
Das Werkzeug »SVG speichern« speichert das aktuelle Zeichenblatt als [[SVG/de|SVG]]-Datei.
# Press the {{KEY|[[Image:TechDraw_SaveSVG.png|24px]] [[TechDraw_SaveSVG|Export page]]}} button
 
# A File Save dialog will open.  Select a location and file name.
 
  
==Options==
+
==Anwendung==
None.
 
  
==Properties==
+
# Auf die Schaltfläche {{Button|[[Image:TechDraw_SaveSVG.png|16px]] [[TechDraw_SaveSVG/de|Seite in SVG-Datei exportieren]]}} klicken.
* n/a
+
# Ein Dialogfeld zum Speichern von Dateien wird geöffnet.
 +
# Wählen Sie einen Speicherort und einen Dateinamen aus.
 +
 
 +
==Hinweise==
 +
 
 +
* [[TechDraw Hatch/de|Schraffurmuster]] werden aufgrund einer Einschränkung in der SVG-Unterstützung von Qt4 nicht nach [[SVG/de|SVG]] exportiert.
 +
* Textpositionen und -größen werden in der exportierten Datei nicht korrekt dargestellt. Die Verwendung der Standardschriftart »System« in der Zeichnung verbessert das Größenproblem erheblich.
 +
* Aus einer gespeicherten [[SVG/de|SVG]]-Zeichnung in Inkscape eine [[DXF/de|DXF]]-Datei exportieren: Um in Inkscape V0.48 mit dem richtigen Maßstab nach DXF zu exportieren, wählen Sie »Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)« als Exportformat und wählen Sie »Basiseinheit: px« im nächsten Dialogfeld. Die Zeichnung ist noch nicht im richtigen Maßstab, sondern hat einen Maßstab von 10:1. Um den korrekten Maßstab auf LibreCAD zu erhalten, wählen Sie »Edit → Current Drawing Preferences → General Factor« von 0.1. Das Ergebnis trotzdem mit einer bekannten Entfernung überprüfen!
 +
* Seit FreeCAD 0.18 ist es möglich, mit [[TechDraw SaveDXF/de|DXF speichern]] direkt nach [[DXF/de|DXF]] zu exportieren.
 +
 
 +
==Eigenschaften==
 +
 
 +
==Programmierung==
 +
 
 +
{{Emphasis|Siehe auch:}} [[TechDraw API/de|TechDraw API]] und [[FreeCAD Scripting Basics/de|FreeCAD Scripting Basics]].
 +
 
 +
Das Werkzeug »SVG speichern« kann sowohl in [[macros/de|Makros]] als auch aus der [[Python/de|Python]]-Konsole heraus mittels folgender Funktion angesprochen werden:
  
==Scripting==
 
This function is available via Python by using.
 
 
{{Code|code=
 
{{Code|code=
 
TechDrawGui.exportPageAsSvg(DrawPageObject,FilePath)
 
TechDrawGui.exportPageAsSvg(DrawPageObject,FilePath)
 
}}
 
}}
Note that the FreeCADGui module must be active to use this function.
+
Beachten Sie, dass das FreeCADGui-Modul aktiv sein muss, um diese Funktion nutzen zu können.
==Notes==
+
 
* Hatch patterns are not exported to SVG due to a limitation in Qt4's SVG support.
+
 
* Text positions and sizes are not correct in the exported file.  Using the "system" default font in the drawing improves the size problem considerably.
+
{{Docnav/de
* Creating DXF from saved Svg drawing in Inkscape: To export to DXF with the correct scale in Inkscape v0.48, choose "Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)" as export format and choose "Base unit": "px" in the next dialog. The drawing is not on scale yet but has a scale of 10:1. To get the correct scale on LibreCAD, choose "Edit → Current Drawing Preferences → General Factor" of 0.1. Check with a known distance, anyway!
+
|[[TechDraw_Dimension_Link/de|Bemaßungen verlinken]]
 +
|[[TechDraw_SaveDXF/de|DXF speichern]]
 +
|[[TechDraw_Module/de|TechDraw-Arbeitsbereich]]
 +
|IconL=Techdraw_Dimension_Link.png
 +
|IconC=Workbench_TechDraw.svg
 +
|IconR=techdraw-saveDXF.svg
 +
}}
 +
 
 +
{{TechDraw Tools navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}

Revision as of 14:28, 25 April 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский

TechDraw ExportPage.png SVG speichern

Menüeintrag
TechDraw → Seite exportieren
Arbeitsbereich
TechDraw
Standardtastenkürzel
None
In der Version eingeführt
-
Siehe auch
Vorlagen, SVG speichern


Beschreibung

Das Werkzeug »SVG speichern« speichert das aktuelle Zeichenblatt als SVG-Datei.

Anwendung

  1. Auf die Schaltfläche TechDraw SaveSVG.png Seite in SVG-Datei exportieren klicken.
  2. Ein Dialogfeld zum Speichern von Dateien wird geöffnet.
  3. Wählen Sie einen Speicherort und einen Dateinamen aus.

Hinweise

  • Schraffurmuster werden aufgrund einer Einschränkung in der SVG-Unterstützung von Qt4 nicht nach SVG exportiert.
  • Textpositionen und -größen werden in der exportierten Datei nicht korrekt dargestellt. Die Verwendung der Standardschriftart »System« in der Zeichnung verbessert das Größenproblem erheblich.
  • Aus einer gespeicherten SVG-Zeichnung in Inkscape eine DXF-Datei exportieren: Um in Inkscape V0.48 mit dem richtigen Maßstab nach DXF zu exportieren, wählen Sie »Desktop Cutting Plotter (AutoCAD DXF R14) (*.dxf)« als Exportformat und wählen Sie »Basiseinheit: px« im nächsten Dialogfeld. Die Zeichnung ist noch nicht im richtigen Maßstab, sondern hat einen Maßstab von 10:1. Um den korrekten Maßstab auf LibreCAD zu erhalten, wählen Sie »Edit → Current Drawing Preferences → General Factor« von 0.1. Das Ergebnis trotzdem mit einer bekannten Entfernung überprüfen!
  • Seit FreeCAD 0.18 ist es möglich, mit DXF speichern direkt nach DXF zu exportieren.

Eigenschaften

Programmierung

Siehe auch: TechDraw API und FreeCAD Scripting Basics.

Das Werkzeug »SVG speichern« kann sowohl in Makros als auch aus der Python-Konsole heraus mittels folgender Funktion angesprochen werden:

TechDrawGui.exportPageAsSvg(DrawPageObject,FilePath)

Beachten Sie, dass das FreeCADGui-Modul aktiv sein muss, um diese Funktion nutzen zu können.