Difference between revisions of "Std SaveAs/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "{{Std Base/it}} {{Userdocnavi/it}}")
(Updating to match new version of source page)
 
(27 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{GuiCommand/it|Name=Std_SaveAs|Name/it=Salva con nome|MenuLocation=[[Std_File_Menu/it|File]] → Salva con nome...|Workbenches=Tutti|Shortcut=Maiusc+Crtl+S|SeeAlso=[[Std_Save/it|Salva]]}}
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_Save/it|Salva]]
 +
|[[Std_SaveaCopy/it|Salva una copia]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=Std_Save.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
 +
 
 +
<div class="mw-translate-fuzzy">
 +
{{GuiCommand/it
 +
|Name=Std_SaveAs
 +
|Name/it=Salva con nome
 +
|MenuLocation=File → Salva con nome...
 +
|Workbenches=Tutti
 +
|SeeAlso=[[Std_SaveaCopy/it|Salva una copia]], [[Std_Save/it|Salva]]
 +
}}
 +
</div>
  
 
==Descrizione==
 
==Descrizione==
Salva il documento attivo con un nuovo nome di file.
 
  
==Uso==
+
Il comando '''Salva con nome''' salva il documento attivo con un nuovo nome di file.
Scegliere {{KEY| File}}  {{KEY|[[Image:Std_SaveAs.png|32px]] Salva con nome...}} dal menu principale.
+
 
 +
==Utilizzo==
 +
 
 +
# Selezionare {{MenuCommand|File → Salva con nome...}} nel menu.
 +
# Immettere un nome per il file nella finestra di dialogo.
 +
# Premere il pulsante {{Button|Salva}}.
 +
 
 +
== Opzioni ==
  
Il comando {{KEY/it|Salva con nome...}} permette di salvare il documento attivo del progetto in corso.
+
* Premere il tasto {{KEY|Esc}} o il pulsante {{Button|Annulla}} per annullare il comando.
  
Apre una finestra per definire il '''percorso''' e il '''nome''':
+
==Note==
[[Image:FileSaveAs.png|left]]
 
{{clear}}
 
Salva i documenti del progetto in file distinti.
 
Se nel progetto esistono altri documenti questi non vengono salvati.
 
Il nome assegnato al documento per salvarlo diventa anche il nome utilizzato per la radice di quel documento nell'albero della struttura.
 
Nei salvataggi successivi, se eseguiti con {{KEY/it|Salva}}, vengono automaticamente utilizzati il percorso e il nome definiti per il primo salvataggio. Per salvare il file in una posizione diversa o attribuire ad esso un nuovo nome occorre riutilizzare il comando {{KEY/it|Salva con nome...}}.
 
  
 +
* Questo comando può essere utilizzato anche per salvare i grafici delle dipendenze. Vedere [[Std DependencyGraph/it|Grafico delle dipendenze]].
  
Quando si tenta di chiudere un documento non salvato, o modificato, o di uscire da FreeCAD con documenti da salvare, si riceve un avviso:
+
==Preferenze==
[[Image:UnsavedDocument.png|left]]
 
{{clear}}
 
  
 +
* L'ultima posizione del file utilizzato viene memorizzata in: {{MenuCommand|Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath}}.
  
La cartella di destinazione dei file salvati si può anche definire nella scheda [[Std DlgParameter/it|Editore dei parametri]] dal menu '''Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath'''.<br />
+
==Script==
[[Image:FileOpenSavePath.png]]
 
{{clear}}
 
  
 +
{{Emphasis|Vedere anche:}} [[FreeCAD Scripting Basics/it|Script di base per FreeCAD]]
  
Altre opzioni si trovano nel menu '''Modifica → Preferenze → Generale → Documento → Archiviazione'''
+
Per salvare un documento con un nuovo nome, utilizzare il metodo {{incode|saveAs}} dell'oggetto documento. Per un esempio di scripting vedere [[Std_New/it|Nuovo]].
  
Choose {{MenuCommand|File → [[Image:Std_SaveAs.png|16px]] Save As...}} from the top menu.
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_Save/it|Salva]]
 +
|[[Std_SaveaCopy/it|Salva una copia]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=Std_Save.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
  
{{Std Base/it}}
+
{{Std Base navi{{#translation:}}}}
{{Userdocnavi/it}}
+
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}

Latest revision as of 21:52, 5 October 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Std Save.svg Salva Pagina precedente:
Pagina successiva: Salva una copia Arrow-right.svg

Std SaveAs.svg Salva con nome

Nome nel codice
Std_SaveAs
Posizione nel menu
File → Salva con nome...
Ambiente
Tutti
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Salva una copia, Salva


Descrizione

Il comando Salva con nome salva il documento attivo con un nuovo nome di file.

Utilizzo

  1. Selezionare File → Salva con nome... nel menu.
  2. Immettere un nome per il file nella finestra di dialogo.
  3. Premere il pulsante Salva.

Opzioni

  • Premere il tasto Esc o il pulsante Annulla per annullare il comando.

Note

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Vedere anche: Script di base per FreeCAD

Per salvare un documento con un nuovo nome, utilizzare il metodo saveAs dell'oggetto documento. Per un esempio di scripting vedere Nuovo.

Arrow-left.svg Std Save.svg Salva Pagina precedente:
Pagina successiva: Salva una copia Arrow-right.svg