Difference between revisions of "Std Save/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "Nei salvataggi successivi vengono automaticamente utilizzati il percorso e il nome definiti per il primo salvataggio. Per salvare il file in una posizione diversa o attribui...")
(Updating to match new version of source page)
 
(43 intermediate revisions by 2 users not shown)
Line 1: Line 1:
{{GuiCommand/it|Name=Std Save|Name/it=Salva|MenuLocation=[[Std_File_Menu/it|File]] → Salva|Workbenches=Tutti|Shortcut=Crtl+S|SeeAlso=[[Std_SaveAs/it|Salva con nome...]]}}
+
<languages/>
 +
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_CloseAll/it|Chiudi tutto]]
 +
|[[Std_SaveAs/it|Salva con nome]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=
 +
|IconR=Std_SaveAs.svg
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
 +
 
 +
<div class="mw-translate-fuzzy">
 +
{{GuiCommand/it
 +
|Name=Std_Save
 +
|Name/it=Salva
 +
|MenuLocation=File → Salva
 +
|Workbenches=Tutti
 +
|Shortcut={{KEY|Ctrl}}+{{KEY|S}}
 +
|SeeAlso=[[Std_SaveAs/it|Salva con nome]], [[Std_SaveaCopy/it|Salva una copia]], [[Std_SaveAll/it|Salva tutto]]
 +
}}
 +
</div>
 +
 
 +
==Descrizione==
  
Il comando {{KEY/it|Salva}} permette di salvare il documento attivo del progetto in corso. Salva i documenti del progetto in file distinti.  
+
Il comando '''Salva''' salva il documento attivo.
  
Se nel progetto esistono altri documenti questi non vengono salvati.
+
==Utilizzo==
  
La prima volta che un documento viene salvato appare una finestra per definire il percorso e il nome:
+
# Esistono diversi modi per invocare il comando:
 +
#* Premere il pulsante {{Button|[[Image:Std_Save.svg|16px]] '''Salva'''}}.
 +
#* Selezionare l'opzione {{MenuCommand|File → [[Image:Std_Save.svg|16px]] Salva}} dal menu.
 +
#* Usare la scorciatoia da tastiera: {{KEY|Ctrl}}+{{KEY|S}}.
 +
# Per i nuovi documenti: immettere un nome file nella finestra di dialogo e premere il pulsante {{Button|Salva}}.
  
 +
==Opzioni==
  
[[Image:FileSaveAs.png|left]]
+
* Per i nuovi documenti: premere il tasto {{KEY|Esc}} o il pulsante {{Button|Annulla}} per annullare il comando.
{{clear}}
 
  
 +
==Note==
  
Il nome assegnato al documento per salvarlo diventa anche il nome utilizzato per la radice di quel documento nell'albero della struttura.
+
* Questo comando può essere utilizzato anche per salvare i grafici delle dipendenze. Vedere [[Std DependencyGraph/it|Grafico delle dipendenze]].
  
Nei salvataggi successivi vengono automaticamente utilizzati il percorso e il nome definiti per il primo salvataggio.
+
==Preferenze==
  
Per salvare il file in una posizione diversa o attribuire ad esso un nuovo nome occorre utilizzare il comando {{KEY/it|Salva con nome...}}.
+
* L'ultima posizione del file utilizzato viene memorizzata in: {{MenuCommand|Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath}}.
  
When you try to close a modified document, or exit FreeCAD with modified documents in use, you will receive a warning:
+
==Script==
  
[[Image:UnsavedDocument.png|left]]
+
{{Emphasis|Vedere anche:}} [[FreeCAD Scripting Basics/it|Script di base per FreeCAD]]
{{clear}}
 
  
 +
Per salvare un documento, utilizzare il metodo {{incode|save}} dell'oggetto documento. Un nuovo documento deve prima essere salvato con il metodo {{incode|saveAs}} dell'oggetto documento. Per un esempio di scripting vedere [[Std_New/it|Nuovo]].
  
You can define a default location for opening and saving files using the menu Tools → Edit Parameters → BaseApp →  Preferences → General → FileOpenSavePath.
 
  
[[Image:FileOpenSavePath.png|left]]
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_CloseAll/it|Chiudi tutto]]
 +
|[[Std_SaveAs/it|Salva con nome]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=
 +
|IconR=Std_SaveAs.svg
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
  
[[Category:Documentation]]
+
{{Std Base navi{{#translation:}}}}
[[Category:Command_Reference]]
+
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}
<languages/>
 

Latest revision as of 15:27, 12 December 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский • ‎한국어
Arrow-left.svg Chiudi tutto Pagina precedente:
Pagina successiva: Salva con nome Std SaveAs.svg Arrow-right.svg

Std Save.svg Salva

Nome nel codice
Std_Save
Posizione nel menu
File → Salva
Ambiente
Tutti
Avvio veloce
Ctrl+S
Introdotto nella versione
-
Vedere anche
Salva con nome, Salva una copia, Salva tutto


Descrizione

Il comando Salva salva il documento attivo.

Utilizzo

  1. Esistono diversi modi per invocare il comando:
    • Premere il pulsante Std Save.svg Salva.
    • Selezionare l'opzione File → Std Save.svg Salva dal menu.
    • Usare la scorciatoia da tastiera: Ctrl+S.
  2. Per i nuovi documenti: immettere un nome file nella finestra di dialogo e premere il pulsante Salva.

Opzioni

  • Per i nuovi documenti: premere il tasto Esc o il pulsante Annulla per annullare il comando.

Note

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Vedere anche: Script di base per FreeCAD

Per salvare un documento, utilizzare il metodo save dell'oggetto documento. Un nuovo documento deve prima essere salvato con il metodo saveAs dell'oggetto documento. Per un esempio di scripting vedere Nuovo.


Arrow-left.svg Chiudi tutto Pagina precedente:
Pagina successiva: Salva con nome Std SaveAs.svg Arrow-right.svg