Difference between revisions of "Std Save/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
(25 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
<div class="mw-translate-fuzzy">
+
{{Docnav/it
{{GuiCommand/it|Name=Std Save|Name/it=Salva|MenuLocation=[[Std_File_Menu/it|File]] → Salva|Workbenches=Tutti|Shortcut=Crtl+S|SeeAlso=[[Std_SaveAs/it|Salva con nome...]]}}
+
|[[Std_CloseAll/it|Chiudi tutto]]
</div>
+
|[[Std_SaveAs/it|Salva con nome]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=
 +
|IconR=Std_SaveAs.svg
 +
|IconC=Freecad.svg
 +
}}
  
Il comando {{KEY/it|Salva}} permette di salvare il documento attivo del progetto in corso. Salva i documenti del progetto in file distinti.
+
{{GuiCommand/it
 +
|Name=Std_Save
 +
|Name/it=Salva
 +
|MenuLocation=File → Salva
 +
|Workbenches=Tutti
 +
|Shortcut={{KEY|Ctrl}}+{{KEY|S}}
 +
|SeeAlso=[[Std_SaveAs/it|Salva con nome]], [[Std_SaveaCopy/it|Salva una copia]], [[Std_SaveAll/it|Salva tutto]]
 +
}}
  
Se nel progetto esistono altri documenti questi non vengono salvati.
+
==Descrizione==
  
La prima volta che un documento viene salvato appare una finestra per definire il percorso e il nome:
+
Il comando '''Salva''' salva il documento attivo.
  
[[Image:FileSaveAs.png]]
+
==Utilizzo==
  
Il nome assegnato al documento per salvarlo diventa anche il nome utilizzato per la radice di quel documento nell'albero della struttura.
+
# Esistono diversi modi per invocare il comando:
 +
#* Premere il pulsante {{Button|[[Image:Std_Save.svg|16px]] '''Salva'''}}.
 +
#* Selezionare l'opzione {{MenuCommand|File → [[Image:Std_Save.svg|16px]] Salva}} dal menu.
 +
#* Usare la scorciatoia da tastiera: {{KEY|Ctrl}}+{{KEY|S}}.
 +
# Per i nuovi documenti: immettere un nome file nella finestra di dialogo e premere il pulsante {{Button|Salva}}.
  
Nei salvataggi successivi vengono automaticamente utilizzati il percorso e il nome definiti per il primo salvataggio.
+
==Opzioni==
  
Per salvare il file in una posizione diversa o attribuire ad esso un nuovo nome occorre utilizzare il comando {{KEY/it|Salva con nome...}}.
+
* Per i nuovi documenti: premere il tasto {{KEY|Esc}} o il pulsante {{Button|Annulla}} per annullare il comando.
  
Quando si tenta di chiudere un documento non salvato, o modificato, o di uscire da FreeCAD con documenti da salvare, si riceve un avviso:
+
==Note==
  
[[Image:UnsavedDocument.png]]
+
* Questo comando può essere utilizzato anche per salvare i grafici delle dipendenze. Vedere [[Std DependencyGraph/it|Grafico delle dipendenze]].
  
La cartella di destinazione dei file salvati si può anche definire nella scheda [[Std DlgParameter/it|Editore dei parametri]] dal menu {{MenuCommand|Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath}}.
+
==Preferenze==
  
[[Image:FileOpenSavePath.png|left]]
+
* L'ultima posizione del file utilizzato viene memorizzata in: {{MenuCommand|Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath}}.
  
{{Std Base/it}}
+
==Script==
{{Userdocnavi/it}}
+
 
 +
{{Emphasis|Vedere anche:}} [[FreeCAD Scripting Basics/it|Script di base per FreeCAD]]
 +
 
 +
Per salvare un documento, utilizzare il metodo {{incode|save}} dell'oggetto documento. Un nuovo documento deve prima essere salvato con il metodo {{incode|saveAs}} dell'oggetto documento. Per un esempio di scripting vedere [[Std_New/it|Nuovo]].
 +
 
 +
{{Docnav/it
 +
|[[Std_CloseAll/it|Chiudi tutto]]
 +
|[[Std_SaveAs/it|Salva con nome]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=
 +
|IconR=Std_SaveAs.svg
 +
|IconC=Freecad.svg
 +
}}
 +
 
 +
{{Std Base navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}

Revision as of 07:08, 27 June 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Chiudi tutto Pagina precedente:
Pagina successiva: Salva con nome Std SaveAs.svg Arrow-right.svg

Std Save.svg Salva

Nome nel codice
Std_Save
Posizione nel menu
File → Salva
Ambiente
Tutti
Avvio veloce
Ctrl+S
Introdotto nella versione
-
Vedere anche
Salva con nome, Salva una copia, Salva tutto


Descrizione

Il comando Salva salva il documento attivo.

Utilizzo

  1. Esistono diversi modi per invocare il comando:
    • Premere il pulsante Std Save.svg Salva.
    • Selezionare l'opzione File → Std Save.svg Salva dal menu.
    • Usare la scorciatoia da tastiera: Ctrl+S.
  2. Per i nuovi documenti: immettere un nome file nella finestra di dialogo e premere il pulsante Salva.

Opzioni

  • Per i nuovi documenti: premere il tasto Esc o il pulsante Annulla per annullare il comando.

Note

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Vedere anche: Script di base per FreeCAD

Per salvare un documento, utilizzare il metodo save dell'oggetto documento. Un nuovo documento deve prima essere salvato con il metodo saveAs dell'oggetto documento. Per un esempio di scripting vedere Nuovo.

Arrow-left.svg Chiudi tutto Pagina precedente:
Pagina successiva: Salva con nome Std SaveAs.svg Arrow-right.svg