Difference between revisions of "Std Save/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 +
{{Docnav
 +
|[[Std_CloseAll|Std CloseAllWindows]]
 +
|[[Std_SaveAs|Std SaveAs]]
 +
|[[Std_File_Menu|Std File Menu]]
 +
|IconL=
 +
|IconR=Std_SaveAs.svg
 +
|IconC=Freecad.svg
 +
}}
 +
 +
<div class="mw-translate-fuzzy">
 
{{GuiCommand/it|Name=Std Save|Name/it=Salva|MenuLocation=[[Std_File_Menu/it|File]] → Salva|Workbenches=Tutti|Shortcut=Crtl+S|SeeAlso=[[Std_SaveAs/it|Salva con nome...]]}}
 
{{GuiCommand/it|Name=Std Save|Name/it=Salva|MenuLocation=[[Std_File_Menu/it|File]] → Salva|Workbenches=Tutti|Shortcut=Crtl+S|SeeAlso=[[Std_SaveAs/it|Salva con nome...]]}}
 +
</div>
 +
 +
==Description==
  
Il comando {{KEY/it|Salva}} permette di salvare il documento attivo del progetto in corso. Salva i documenti del progetto in file distinti.  
+
The '''Std Save''' command saves the active document.
  
Se nel progetto esistono altri documenti questi non vengono salvati.
+
==Usage==
  
La prima volta che un documento viene salvato appare una finestra per definire il percorso e il nome:
+
# There are several ways to invoke the command:
 +
#* Press the {{Button|[[Image:Std_Save.svg|16px]] [[Std_Save|Std Save]]}} button.
 +
#* Select the {{MenuCommand|File → [[Image:Std_Save.svg|16px]] Save}} option from the menu.
 +
#* Use the keyboard shortcut: {{KEY|Ctrl}}+{{KEY|S}}.
 +
# For new documents: enter a filename in the dialog box and press the {{Button|Save}} button.
  
[[Image:FileSaveAs.png]]
+
==Options==
  
Il nome assegnato al documento per salvarlo diventa anche il nome utilizzato per la radice di quel documento nell'albero della struttura.
+
* For new documents: press {{KEY|Esc}} or the {{Button|Cancel}} button to abort the command.
  
Nei salvataggi successivi vengono automaticamente utilizzati il percorso e il nome definiti per il primo salvataggio.
+
==Preferences==
  
Per salvare il file in una posizione diversa o attribuire ad esso un nuovo nome occorre utilizzare il comando {{KEY/it|Salva con nome...}}.
+
* The last used file location is stored: {{MenuCommand|Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath}}.
  
Quando si tenta di chiudere un documento non salvato, o modificato, o di uscire da FreeCAD con documenti da salvare, si riceve un avviso:
+
==Scripting==
  
[[Image:UnsavedDocument.png]]
+
{{Emphasis|See also:}} [[FreeCAD_Scripting_Basics|FreeCAD Scripting Basics]].
  
La cartella di destinazione dei file salvati si può anche definire nella scheda [[Std DlgParameter/it|Editore dei parametri]] dal menu {{MenuCommand|Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath}}.
+
To save a document use the {{incode|save}} method of the document object. A new document must first be saved with the  {{incode|saveAs}} method of the document object. For a scripting example see [[Std_New|Std New]].
  
[[Image:FileOpenSavePath.png|left]]
+
{{Docnav
 +
|[[Std_CloseAll|Std CloseAllWindows]]
 +
|[[Std_SaveAs|Std SaveAs]]
 +
|[[Std_File_Menu|Std File Menu]]
 +
|IconL=
 +
|IconR=Std_SaveAs.svg
 +
|IconC=Freecad.svg
 +
}}
  
{{Std Base navi/it}}
+
{{Std Base navi{{#translation:}}}}
{{Userdocnavi/it}}
+
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}

Revision as of 21:35, 23 March 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский

Std Save.svg Salva

Nome nel codice
Std Save
Posizione nel menu
File → Salva
Ambiente
Tutti
Avvio veloce
Crtl+S
Introdotto nella versione
-
Vedere anche
Salva con nome...


Description

The Std Save command saves the active document.

Usage

  1. There are several ways to invoke the command:
    • Press the Std Save.svg Std Save button.
    • Select the File → Std Save.svg Save option from the menu.
    • Use the keyboard shortcut: Ctrl+S.
  2. For new documents: enter a filename in the dialog box and press the Save button.

Options

  • For new documents: press Esc or the Cancel button to abort the command.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To save a document use the save method of the document object. A new document must first be saved with the saveAs method of the document object. For a scripting example see Std New.