Std Rétablir

From FreeCAD Documentation
Revision as of 18:30, 7 May 2021 by Donatello (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎한국어
Arrow-left.svg Page précédente : Std Undo.svg Annuler
Page suivante : Couper Std Cut.svg Arrow-right.svg

Std Redo.svg Std Rétablir

Emplacement du menu
Édition → Rétablir
Ateliers
Tous
Raccourci par défaut
Ctrl+Y
Introduit dans la version
-
Voir aussi
Std Annuler

Description

La commande Std Rétablir inverse l'action de la commande Std Annuler.

Utilisation

  1. Il existe plusieurs façons d'appeler la commande :
    • Appuyez sur le bouton Std Redo.svg Rétablir.
    • Sélectionnez l'option Édition → Std Redo.svg Rétablir dans le menu.
    • Utilisez le raccourci clavier : Ctrl+Y.

Options

  • Pour Rétablir plusieurs actions, cliquez sur la flèche noire vers le bas à droite du bouton Std Redo.svg Std Rétablir et sélectionnez dans la liste.

Préférences

  • La fonctionnalité Annuler/Rétablir peut être désactivée en définissant Outils → Editer paramètres... → BaseApp → Preferences → Document → UsingUndo sur false, mais ce n'est pas recommandé. Ce paramètre peut également être modifié dans l'Editeur de préférences.
  • Le nombre maximum d'étapes Annuler / Rétablir est contrôlé par Outils → Éditer paramètres... → BaseApp → Préférences → Document → MaxUndoSize. Ce paramètre peut également être modifié dans l'Éditeur de préférences.

Script

Voir aussi : FreeCAD Script de base.

Pour Rétablir une action qui vient d'être annulée, utilisez la méthode redo de l'objet document.

import FreeCAD

FreeCAD.ActiveDocument.redo()
Arrow-left.svg Page précédente : Std Undo.svg Annuler
Page suivante : Couper Std Cut.svg Arrow-right.svg