Difference between revisions of "Std Open"

From FreeCAD Documentation
Jump to navigation Jump to search
m
(Marked this version for translation)
 
(30 intermediate revisions by 5 users not shown)
Line 1: Line 1:
{{GuiCommand|Name=Std_Open|Workbenches=All|SeeAlso=[[Std_Save]],[[Std_Import]]}}
+
<languages/>
 +
<translate>
 +
<!--T:9-->
 +
{{Docnav
 +
|[[Std_New|Std New]]
 +
|[[Std_Close|Std CloseActiveWindow]]
 +
|[[Std_File_Menu|Std File Menu]]
 +
|IconL=Std_New.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
  
Opens and loads project files into FreeCAD's workspace and depending on the installed extension modules further file types are supported such as IGES, STEP, BREP, STL, OBJ, PLY and so on.
+
<!--T:1-->
 +
{{GuiCommand
 +
|Name=Std Open
 +
|MenuLocation=File → Open...
 +
|Workbenches=All
 +
|Shortcut={{KEY|Ctrl}}+{{KEY|O}}
 +
|SeeAlso=[[Std_Import|Std Import]], [[Std_New|Std New]]
 +
}}
  
When loading files always a new document gets created. If you want to load a file into an existing document use the [[Std_Import]] instead.
+
==Description== <!--T:2-->
  
FreeCAD project files have the extension "FCStd". To get more information about the internal layout of FreeCAD projects files read the article [[File Format FCStd]].
+
<!--T:10-->
 +
The '''Std Open''' command opens a file. If the file is not a native FreeCAD file (*.FCStd) its geometry will be imported into a new document. See [[Std_Import|Std Import]] for more information.
  
{{languages | {{es|Std_Open/es}} }}
+
==Usage== <!--T:6-->
 +
 
 +
<!--T:11-->
 +
# There are several ways to invoke the command:
 +
#* Press the {{Button|[[Image:Std_Open.svg|16px]] [[Std_Open|Std Open]]}} button.
 +
#* Select the {{MenuCommand|File → [[Image:Std_Open.svg|16px]] Open...}} option from the menu.
 +
#* Use the keyboard shortcut: {{KEY|Ctrl}}+{{KEY|O}}.
 +
# Optionally select the correct file format in the dialog box.
 +
# Select a file.
 +
# Press the {{Button|Open}} button.
 +
 
 +
==Options== <!--T:12-->
 +
 
 +
<!--T:13-->
 +
* Press {{KEY|Esc}} or the {{Button|Cancel}} button to abort the command.
 +
 
 +
==Preferences== <!--T:14-->
 +
 
 +
<!--T:15-->
 +
* The last used file location is stored: {{MenuCommand|Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath}}.
 +
 
 +
==Scripting== <!--T:16-->
 +
 
 +
<!--T:17-->
 +
{{Emphasis|See also:}} [[FreeCAD_Scripting_Basics|FreeCAD Scripting Basics]].
 +
 
 +
<!--T:18-->
 +
To open a document use the {{incode|open}} method of the FreeCAD application. For a scripting example see [[Std_New|Std New]].
 +
 
 +
<!--T:19-->
 +
{{Docnav
 +
|[[Std_New|Std New]]
 +
|[[Std_Close|Std CloseActiveWindow]]
 +
|[[Std_File_Menu|Std File Menu]]
 +
|IconL=Std_New.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
 +
 
 +
</translate>
 +
{{Std Base navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}
 +
{{clear}}

Latest revision as of 21:25, 23 March 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎română • ‎русский • ‎日本語

Std Open.svg Std Open

Menu location
File → Open...
Workbenches
All
Default shortcut
Ctrl+O
Introduced in version
-
See also
Std Import, Std New


Description

The Std Open command opens a file. If the file is not a native FreeCAD file (*.FCStd) its geometry will be imported into a new document. See Std Import for more information.

Usage

  1. There are several ways to invoke the command:
    • Press the Std Open.svg Std Open button.
    • Select the File → Std Open.svg Open... option from the menu.
    • Use the keyboard shortcut: Ctrl+O.
  2. Optionally select the correct file format in the dialog box.
  3. Select a file.
  4. Press the Open button.

Options

  • Press Esc or the Cancel button to abort the command.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To open a document use the open method of the FreeCAD application. For a scripting example see Std New.