Difference between revisions of "Std CloseAllWindows/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
 
(31 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{GuiCommand/it|Name=Std_CloseAll|Name/it=Chiudi tutto|MenuLocation=[[Std_File_Menu/it|Menu File]] → Chiudi tutto|Workbenches=Tutti|Shortcut=...|SeeAlso=[[Std_Close/it|Chiudi]], [[Std_SaveAs/it|Salva con nome...]] e [[Std_Save/it|Salva]]}}
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_Close/it|Chiudi]]
 +
|[[Std_Save/it|Salva]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=
 +
|IconR=Std_Save.svg
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
  
=== Descrizione ===
+
<div class="mw-translate-fuzzy">
Il comando chiude tutti i documenti del progetto, anche quelli non attivi. Con questo comando non si esce da FreeCAD.
+
{{GuiCommand/it
 +
|Name=Std_CloseAllWindows
 +
|Name/it=Chiudi tutto
 +
|Empty=1
 +
|MenuLocation=File → Chiudi tutto
 +
|Workbenches=Tutti
 +
|SeeAlso=[[Std_Close/it|Chiudi]]
 +
}}
 +
</div>
  
Se nel progetto ci sono dei documenti non salvati, o modificati, visualizza un messaggio e chiede se si desidera salvarli:
+
==Descrizione==
[[Image:UnsavedDocument.png]]
 
  
In caso di risposta affermativa,
+
Il comando '''Chiudi tutto''' chiude tutte le finestre, chiudendo così tutti i documenti.
* se il documento è già stato salvato, usa il nome e l'indirizzo impostati,
 
* se il documento non è mai stato salvato, apre la finestra per definire il percorso e assegnare un nome al documento:
 
[[Image:FileSaveAs.png]]
 
{{clear}}
 
  
 +
==Utilizzo==
  
Il comando {{KEY|Chiudi}} invece chiude solo il documento attivo e permette di continuare a lavorare su altri documenti del progetto.
+
# Selezionare {{MenuCommand|File → Chiudi tutto}} dal menu.
{{clear}}
+
# Se il documento attivo non è stato salvato, una finestra di dialogo richiederà di salvarlo:
 +
#* Premere il pulsante {{Button|Salva}} Se necessario, inserire prima un nome per il file.
 +
#* Premere il pulsante {{Button|Tralascia}} per eliminare il documento e perdere tutte le modifiche.
  
{{Std Base}}
+
==Opzioni==
{{Userdocnavi}}
+
 
 +
* Quando viene visualizzata la finestra di dialogo: premere {{KEY|Esc}} o il pulsante {{KEY|Annulla}} per interrompere il comando.
 +
* Se sono presenti più documenti non salvati: selezionare la casella di controllo {{CheckBox|TRUE|Applica la risposta a tutti}} per evitare che venga richiesto separatamente per ogni documento non salvato.
 +
 
 +
==Note==
 +
 
 +
* Un documento può anche essere chiuso facendo clic con il pulsante destro del mouse nella [[Tree_view/it|Vista ad albero]] e selezionando {{MenuCommand|Chiudi il documento}} dal menu di scelta rapida.
 +
 
 +
==Preferenze==
 +
 
 +
* L'ultima posizione del file utilizzato viene memorizzata in: {{MenuCommand|Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath}}.
 +
 
 +
==Script==
 +
 
 +
{{Emphasis|Vedere anche:}} [[FreeCAD Scripting Basics/it|Script di base per FreeCAD]]
 +
 
 +
Per chiudere un documento usare il metodo {{incode|closeDocument}} dell'applicazione FreeCAD. Per un esempio di scripting vedere [[Std_New/it|Std Nuovo]].
 +
 
 +
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_Close/it|Chiudi]]
 +
|[[Std_Save/it|Salva]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=
 +
|IconR=Std_Save.svg
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
 +
 
 +
{{Std Base navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}

Latest revision as of 20:55, 6 October 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Chiudi Pagina precedente:
Pagina successiva: Salva Std Save.svg Arrow-right.svg

Chiudi tutto

Nome nel codice
Std_CloseAllWindows
Posizione nel menu
File → Chiudi tutto
Ambiente
Tutti
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Chiudi


Descrizione

Il comando Chiudi tutto chiude tutte le finestre, chiudendo così tutti i documenti.

Utilizzo

  1. Selezionare File → Chiudi tutto dal menu.
  2. Se il documento attivo non è stato salvato, una finestra di dialogo richiederà di salvarlo:
    • Premere il pulsante Salva Se necessario, inserire prima un nome per il file.
    • Premere il pulsante Tralascia per eliminare il documento e perdere tutte le modifiche.

Opzioni

  • Quando viene visualizzata la finestra di dialogo: premere Esc o il pulsante Annulla per interrompere il comando.
  • Se sono presenti più documenti non salvati: selezionare la casella di controllo CheckBoxTrue.svg Applica la risposta a tutti per evitare che venga richiesto separatamente per ogni documento non salvato.

Note

  • Un documento può anche essere chiuso facendo clic con il pulsante destro del mouse nella Vista ad albero e selezionando Chiudi il documento dal menu di scelta rapida.

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Vedere anche: Script di base per FreeCAD

Per chiudere un documento usare il metodo closeDocument dell'applicazione FreeCAD. Per un esempio di scripting vedere Std Nuovo.

Arrow-left.svg Chiudi Pagina precedente:
Pagina successiva: Salva Std Save.svg Arrow-right.svg