Difference between revisions of "Std Close/ru"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
(Updating to match new version of source page)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 
{{Docnav
 
{{Docnav
|[[Std_Open|Std Open]]
+
|[[Std_Open|Open]]
|[[Std_CloseAll|Std CloseAllWindows]]
+
|[[Std_CloseAll|CloseAllWindows]]
|[[Std_File_Menu|Std File Menu]]
+
|[[Std_File_Menu|File Menu]]
 
|IconL=Std_Open.svg
 
|IconL=Std_Open.svg
 
|IconR=
 
|IconR=
Line 54: Line 54:
  
 
{{Docnav
 
{{Docnav
|[[Std_Open|Std Open]]
+
|[[Std_Open|Open]]
|[[Std_CloseAll|Std CloseAllWindows]]
+
|[[Std_CloseAll|CloseAllWindows]]
|[[Std_File_Menu|Std File Menu]]
+
|[[Std_File_Menu|File Menu]]
 
|IconL=Std_Open.svg
 
|IconL=Std_Open.svg
 
|IconR=
 
|IconR=

Revision as of 20:50, 30 March 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Previous: Std Open.svg Open

Std Close.png Std Close

Расположение в меню
File → Закрыть
Верстаки
All
Быстрые клавиши
Ctrl+W
Представлено в версии
-
См. также
Закрыть всё


Закрывает текущий документ.

The Std CloseActiveWindow command closes the active document.

Usage

  1. There are several ways to invoke the command:
    • Select the File → Close option from the menu.
    • Use the keyboard shortcut: Ctrl+F4.
  2. If the active document has not been saved a dialog box will prompt you to save it:
    • Press the Save button to save the document. If required enter a filename first.
    • Press the Discard button to discard the document and lose all changes.

Options

  • If the active document has not been saved: press Esc or the Cancel button to abort the command.

Notes

  • A document can also be closed by right clicking it in the Tree view and selecting Close document from the context menu.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To close a document use the closeDocument method of the FreeCAD application. For a scripting example see Std New.

Arrow-left.svg Previous: Std Open.svg Open