Difference between revisions of "Std Close/ru"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "Закрывает текущий документ.")
(Updating to match new version of source page)
(6 intermediate revisions by the same user not shown)
Line 1: Line 1:
 +
<languages/>
 +
{{Docnav
 +
|[[Std_Open|Open]]
 +
|[[Std_CloseAll|CloseAllWindows]]
 +
|[[Std_File_Menu|File Menu]]
 +
|IconL=Std_Open.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
  
 +
<div class="mw-translate-fuzzy">
 
{{GuiCommand/ru
 
{{GuiCommand/ru
 
|Name=Std Close
 
|Name=Std Close
Line 8: Line 18:
 
|SeeAlso=[[Std CloseAll/ru|Закрыть всё]]
 
|SeeAlso=[[Std CloseAll/ru|Закрыть всё]]
 
}}
 
}}
 +
</div>
  
 +
<div class="mw-translate-fuzzy">
 +
Закрывает текущий документ.
 +
</div>
  
Закрывает текущий документ.
+
The '''Std CloseActiveWindow''' command closes the active document.
 +
 
 +
==Usage==
 +
 
 +
# There are several ways to invoke the command:
 +
#* Select the {{MenuCommand|File → Close}} option from the menu.
 +
#* Use the keyboard shortcut: {{KEY|Ctrl}}+{{KEY|F4}}.
 +
# If the active document has not been saved a dialog box will prompt you to save it:
 +
#* Press the {{Button|Save}} button to save the document. If required enter a filename first.
 +
#* Press the {{Button|Discard}} button to discard the document and lose all changes.
 +
 
 +
==Options==
 +
 
 +
* If the active document has not been saved: press {{KEY|Esc}} or the {{Button|Cancel}} button to abort the command.
 +
 
 +
==Notes==
 +
 
 +
* A document can also be closed by right clicking it in the [[Tree_view|Tree view]] and selecting {{MenuCommand|Close document}} from the context menu.
 +
 
 +
==Preferences==
 +
 
 +
* The last used file location is stored: {{MenuCommand|Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath}}.
 +
 
 +
==Scripting==
 +
 
 +
{{Emphasis|See also:}} [[FreeCAD_Scripting_Basics|FreeCAD Scripting Basics]].
 +
 
 +
To close a document use the {{incode|closeDocument}} method of the FreeCAD application. For a scripting example see [[Std_New|Std New]].
  
 +
{{Docnav
 +
|[[Std_Open|Open]]
 +
|[[Std_CloseAll|CloseAllWindows]]
 +
|[[Std_File_Menu|File Menu]]
 +
|IconL=Std_Open.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
  
 +
{{Std Base navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}
 
{{clear}}
 
{{clear}}
<languages/>
 

Revision as of 20:50, 30 March 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Previous: Std Open.svg Open

Std Close.png Std Close

Расположение в меню
File → Закрыть
Верстаки
All
Быстрые клавиши
Ctrl+W
Представлено в версии
-
См. также
Закрыть всё


Закрывает текущий документ.

The Std CloseActiveWindow command closes the active document.

Usage

  1. There are several ways to invoke the command:
    • Select the File → Close option from the menu.
    • Use the keyboard shortcut: Ctrl+F4.
  2. If the active document has not been saved a dialog box will prompt you to save it:
    • Press the Save button to save the document. If required enter a filename first.
    • Press the Discard button to discard the document and lose all changes.

Options

  • If the active document has not been saved: press Esc or the Cancel button to abort the command.

Notes

  • A document can also be closed by right clicking it in the Tree view and selecting Close document from the context menu.

Preferences

  • The last used file location is stored: Tools → Edit parameters... → BaseApp → Preferences → General → FileOpenSavePath.

Scripting

See also: FreeCAD Scripting Basics.

To close a document use the closeDocument method of the FreeCAD application. For a scripting example see Std New.

Arrow-left.svg Previous: Std Open.svg Open