Difference between revisions of "Std CloseActiveWindow/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "{{Std Base/it}} {{Userdocnavi/it}}")
(Updating to match new version of source page)
 
(32 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 +
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_Open/it|Apri]]
 +
|[[Std_CloseAll/it|Chiudi tutto]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=Std_Open.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
  
{{GuiCommand/it|Name=Std_Close|Name/it=Chiudi|MenuLocation=[[Std_File_Menu/it|File]] → Chiudi|Workbenches=Tutti|Shortcut=Crtl+W|SeeAlso=[[Std_CloseAll/it|Chiudi tutto]], [[Std_SaveAs/it|Salva con nome...]] e [[Std_Save/it|Salva]]}}
+
<div class="mw-translate-fuzzy">
 +
{{GuiCommand/it
 +
|Name=Std_CloseActiveWindow
 +
|Name/it=Chiudi
 +
|Empty=1
 +
|MenuLocation=File → Chiudi
 +
|Workbenches=Tutti
 +
|Shortcut={{KEY|Ctrl}}+{{KEY|F4}}
 +
|SeeAlso=[[Std_CloseAll/it|Chiudi tutto]]
 +
}}
 +
</div>
  
 +
==Descrizione==
  
=== Descrizione ===
+
Il comando '''Chiudi''' chiude la finestra attiva. Per chiudere un documento, tutte le sue finestre devono essere chiuse.
  
Il comando chiude solo il documento attivo e permette di continuare a lavorare su altri documenti del progetto.
+
==Utilizzo==
  
Se il documento non è stato salvato, o ha subito delle modifiche, visualizza un messaggio e chiede se si desidera salvarlo:
+
# Esistono diversi modi per invocare il comando:
 +
#* Selezionare {{MenuCommand|File → Chiudi}} dal menu.
 +
#* Usare la scorciatoia da tastiera: {{KEY|Ctrl}}+{{KEY|F4}}.
 +
# Per chiudere un documento: ripetere questo per tutte le finestre che appartengono al documento.
 +
# Quando si chiude l'ultima finestra di un documento che non è stato salvato, una finestra di dialogo chiede se si vuole salvarlo:
 +
#* Premere il pulsante {{Button|Salva}} Se necessario, inserire prima un nome per il file.
 +
#* Premere il pulsante {{Button|Tralascia}} per eliminare il documento e perdere tutte le modifiche.
  
 +
==Opzioni==
  
[[Image:UnsavedDocument.png]]
+
* Quando viene visualizzata la finestra di dialogo: premere {{KEY|Esc}} o il pulsante {{KEY|Annulla}} per annullare il comando.
  
 +
==Note==
  
 +
* Il comando può solo chiudere le finestre [[Std_ViewDockUndockFullscreen/it|agganciate]].
 +
* Un documento può anche essere chiuso facendo clic con il pulsante destro del mouse nella [[Tree_view/it|Vista ad albero]] e selezionando {{MenuCommand|Chiudi il documento}} dal menu di scelta rapida.
  
In caso di risposta affermativa,
+
==Preferenze==
* se il documento è già stato salvato, usa il nome e l'indirizzo impostati,
 
* se il documento non è mai stato salvato, apre la finestra per definire il percorso e assegnare un nome al documento:
 
  
[[Image:FileSaveAs.png|left]]
+
* L'ultima posizione del file utilizzato viene memorizzata in: {{MenuCommand|Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath}}.
{{clear}}
 
  
 +
==Script==
  
 +
{{Emphasis|Vedere anche:}} [[FreeCAD Scripting Basics/it|Script di base per FreeCAD]]
  
Il comando {{KEY/it|Chiudi tutto}} chiude invece tutti i documenti del progetto.
+
Per chiudere un documento usare il metodo {{incode|closeDocument}} dell'applicazione FreeCAD. Per un esempio di scripting vedere [[Std_New/it|Std Nuovo]].
  
Con questo comando non si esce da FreeCAD.
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/it
 +
|[[Std_Open/it|Apri]]
 +
|[[Std_CloseAll/it|Chiudi tutto]]
 +
|[[Std_File_Menu/it|Menu File]]
 +
|IconL=Std_Open.svg
 +
|IconR=
 +
|IconC=Freecad.svg
 +
}}
 +
</div>
  
 
+
{{Std Base navi{{#translation:}}}}
=== Link ===
+
{{Userdocnavi{{#translation:}}}}
[[ComandiPerCategorie/it|Comandi per categorie]]
 
 
 
{{Std Base/it}}
 
{{Userdocnavi/it}}
 
 
{{clear}}
 
{{clear}}

Latest revision as of 20:55, 6 October 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎română • ‎русский
Arrow-left.svg Std Open.svg Apri Pagina precedente:
Pagina successiva: Chiudi tutto Arrow-right.svg

Chiudi

Nome nel codice
Std_CloseActiveWindow
Posizione nel menu
File → Chiudi
Ambiente
Tutti
Avvio veloce
Ctrl+F4
Introdotto nella versione
-
Vedere anche
Chiudi tutto


Descrizione

Il comando Chiudi chiude la finestra attiva. Per chiudere un documento, tutte le sue finestre devono essere chiuse.

Utilizzo

  1. Esistono diversi modi per invocare il comando:
    • Selezionare File → Chiudi dal menu.
    • Usare la scorciatoia da tastiera: Ctrl+F4.
  2. Per chiudere un documento: ripetere questo per tutte le finestre che appartengono al documento.
  3. Quando si chiude l'ultima finestra di un documento che non è stato salvato, una finestra di dialogo chiede se si vuole salvarlo:
    • Premere il pulsante Salva Se necessario, inserire prima un nome per il file.
    • Premere il pulsante Tralascia per eliminare il documento e perdere tutte le modifiche.

Opzioni

  • Quando viene visualizzata la finestra di dialogo: premere Esc o il pulsante Annulla per annullare il comando.

Note

  • Il comando può solo chiudere le finestre agganciate.
  • Un documento può anche essere chiuso facendo clic con il pulsante destro del mouse nella Vista ad albero e selezionando Chiudi il documento dal menu di scelta rapida.

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Script

Vedere anche: Script di base per FreeCAD

Per chiudere un documento usare il metodo closeDocument dell'applicazione FreeCAD. Per un esempio di scripting vedere Std Nuovo.

Arrow-left.svg Std Open.svg Apri Pagina precedente:
Pagina successiva: Chiudi tutto Arrow-right.svg