Difference between revisions of "Std Base/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "=== Structure des barres d'outils ===")
 
(46 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
  
[[Image:freecad16.svg|64px]]
+
{{Docnav/fr
 +
|[[Workbenches/fr|Ateliers]]
 +
|[[Arch Module/fr|Atelier Arch]]
 +
|IconL=
 +
|IconR=Workbench_Arch.svg
 +
}}
 +
 
 +
[[Image:Freecad.svg|thumb|128px|Icône de Std Base]]
  
 
{{TOCright}}
 
{{TOCright}}
  
== Introduction ==
+
==Introduction==
 +
 
 +
[[Std_Base/fr|Std Base]] n'est pas vraiment un atelier mais plutôt une catégorie de commandes et d'outils "standard" qui sont définis au cœur du système et qui peuvent être utilisés dans tous les ateliers.
 +
 
 +
==Outils==
 +
 
 +
La plupart des outils [[Std_Base/fr|Std Base]] sont accessibles depuis le [[Standard_Menu/fr|menu standard]] et les barres d'outils. Ceux qui ne sont disponibles que via une barre d'outils ou un menu contextuel sont répertoriés sous [[#Additional_tools|Outils supplémentaires]].
 +
 
 +
Il existe 7 menus standard. Chaque sous-menu a une page dédiée. Cliquez simplement sur l'un des noms ci-dessous.
 +
 
 +
<!--Veuillez garder les informations ci-dessous synchronisées avec Std_Base, Standard_Menu, Std_File_Menu etc.-->
 +
{{StdMenu
 +
|
 +
[[Std_File_Menu/fr|Fichier]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Edit_Menu/fr|Edition]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_View_Menu/fr|Affichage]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Tools_Menu/fr|Outils]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Macro_Menu/fr|Macro]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Windows_Menu/fr|Fenêtre]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Help_Menu/fr|Aide]]
 +
}}
 +
 
 +
== Barres d'outils ==
 +
<!--Veuillez ne pas ajouter d'informations supplémentaires dans la section Barres d'outils. Gardez-la propre: juste l'icône et le lien de la page. Au moins la version doit être fournie car cela indique immédiatement à l'utilisateur si l'outil existe ou non dans la version qu'il utilise.-->
 +
 
 +
Pour un accès rapide à la documentation des outils standards, ils sont listés ci-dessous. La plupart de ces outils sont également accessibles à partir du menu standard.
 +
 
 +
=== Barre d'outils Structure ===
 +
 
 +
* [[File:Std_Part.svg|32px]] [[Std_Part/fr|Std Part]]
 +
* [[File:Std_Group.svg|32px]] [[Std_Group/fr|Std Group]]
 +
* [[File:Std_LinkMake.svg|32px]] [[Std_LinkMake/fr|Std Créer lien]] {{Version/fr|0.19}}
 +
* [[File:Std_LinkMakeRelative.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] Std LinkActions
 +
** [[File:Std_LinkMakeRelative.svg|32px]] [[Std_LinkMakeRelative/fr|Std Créer lien relatif]] {{Version/fr|0.19}}
 +
** [[File:Std_LinkReplace.svg|32px]] [[Std_LinkReplace/fr|Std Lien remplacement]] {{Version/fr|0.19}}
 +
** [[File:Std_LinkUnlink.svg|32px]] [[Std_LinkUnlink/fr|Std Supprimer lien]] {{Version/fr|0.19}}
 +
** [[File:Std_LinkImport.svg|32px]] [[Std_LinkImport/fr|Std Importer lien]] {{Version/fr|0.19}}
 +
** [[File:Std_LinkImportAll.svg|32px]] [[Std_LinkImportAll/fr|Std Importer tous les liens]] {{Version/fr|0.19}}
 +
 
 +
=== Barre d'outils de fichier ===
 +
 
 +
* [[File:Std_New.svg|32px]] [[Std_New/fr|Std Nouveau]]
 +
* [[File:Std_Open.svg|32px]] [[Std_Open/fr|Std Ouvrir]]
 +
* [[File:Std_Save.svg|32px]] [[Std_Save/fr|Std Enregistrer]]
 +
* [[File:Std_Print.svg|32px]] [[Std_Print/fr|Std Imprimer]]
 +
* [[File:Std_Cut.svg|32px]] [[Std_Cut/fr|Std Couper]]
 +
* [[File:Std_Copy.svg|32px]] [[Std_Copy/fr|Std Copier]]
 +
* [[File:Std_Paste.svg|32px]] [[Std_Paste/fr|Std Coller]]
 +
* [[File:Std_Undo.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] [[Std_Undo/fr|Std Annuler]]
 +
* [[File:Std_Redo.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] [[Std_Redo/fr|Std Rétablir]]
 +
* [[File:Std_Refresh.svg|32px]] [[Std_Refresh/fr|Std Rafrîchir]]
 +
* [[File:Std_WhatsThis.svg|32px]] [[Std_WhatsThis/fr|Std Qu'est ce que c'est?]]
 +
 
 +
===Barre d'outils d'atelier===
 +
 
 +
* [[Std_Workbench/fr|Std Atelier]]
  
[[Std_Base/fr|Std Base]] n'est pas un véritable atelier. Cette page regroupe simplement toutes les commandes du système de base qui n'appartiennent pas à un plan de travail spécifique, mais qui peuvent être utilisées dans chacune d'entre elles.
+
=== Barre d'outils de macro ===
  
== Outils ==
+
* [[File:Std_DlgMacroRecord.svg|32px]] [[Std_DlgMacroRecord/fr|Enregistrement de macro...]]
 +
* [[File:Std_MacroStopRecord.svg|32px]] [[Std_MacroStopRecord/fr|Arrêter l'enregistrement de la macro]]
 +
* [[File:Std_DlgMacroExecute.svg|32px]] [[Std_DlgMacroExecute/fr|Macros...]]
 +
* [[File:Std_DlgMacroExecuteDirect.svg|32px]] [[Std_DlgMacroExecuteDirect/fr|Lancer la macro]]
  
La plupart des commandes de cette page sont accessibles depuis les menus, les barres d’outils et les menus contextuels.
+
=== Barre d'outils de affichage ===
  
=== Menus Standards ===
+
* [[File:Std_ViewFitAll.svg|32px]] [[Std_ViewFitAll/fr|Std Tout afficher]]
 +
* [[File:Std_ViewFitSelection.svg|32px]] [[Std_ViewFitSelection/fr|Std Afficher la sélection]]
 +
* [[File:Std_DrawStyleAsIs.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] [[Std_DrawStyle/fr|Std Style de représentation]]
 +
** [[File:Std_DrawStyleAsIs.svg|32px]] [[Std_DrawStyle#As_is/fr|Std DrawStyle#Comme actuellement]]
 +
** [[File:Std_DrawStylePoints.svg|32px]] [[Std_DrawStyle#Points/fr|Std DrawStyle#Points]]
 +
** [[File:Std_DrawStyleWireFrame.svg|32px]] [[Std_DrawStyle#Wireframe/fr|Std DrawStyle#Filaire]]
 +
** [[File:Std_DrawStyleHiddenLine.svg|32px]] [[Std_DrawStyle#Hidden_line/fr|Std DrawStyle#Ligne cachée]]
 +
** [[File:Std_DrawStyleNoShading.svg|32px]] [[Std_DrawStyle#No_shading/fr|Std DrawStyle#Pas d'ombrage]]
 +
** [[File:Std_DrawStyleShaded.svg|32px]] [[Std_DrawStyle#Shaded/fr|Std DrawStyle#Ombré]]
 +
** [[File:Std_DrawStyleFlatLines.svg|32px]] [[Std_DrawStyle#Flat_lines/fr|Std DrawStyle#Lignes plates]]
 +
* [[File:Std_SelBoundingBox.svg|32px]] [[Std_SelBoundingBox/fr|Std Boîte de délimitation]] {{Version/fr|0.19}}
 +
* [[File:Std_SelBack.svg|32px]] [[Std_SelBack/fr|Std Sélection précédente]] {{Version/fr|0.19}}
 +
* [[File:Std_SelForward.svg|32px]] [[Std_SelForward/fr|Std Sélection suivante]] {{Version/fr|0.19}}
 +
* [[File:Std_LinkSelectLinked.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] {{Version/fr|0.19}}
 +
** [[File:Std_LinkSelectLinked.svg|32px]] [[Std_LinkSelectLinked/fr|Std Le lien sélectionné]] {{Version/fr|0.19}}
 +
** [[File:Std_LinkSelectLinkedFinal.svg|32px]] [[Std_LinkSelectLinkedFinal/fr|Std Le lien le plus profond]] {{Version/fr|0.19}}
 +
** [[File:Std_LinkSelectAllLinks.svg|32px]] [[Std_LinkSelectAllLinks/fr|Std Sélection de tous les liens]] {{Version/fr|0.19}}
 +
* [[File:Std_TreeSyncView.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeSyncView.svg|32px]] [[Std_TreeSyncView/fr|Std Synchronisation vue arborescente]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeSyncSelection.svg|32px]] [[Std_TreeSyncSelection/fr|Std Expansion synchrone arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeSyncPlacement.svg|32px]] [[Std_TreeSyncPlacement/fr|Std Synchronisation placement arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreePreSelection.svg|32px]] [[Std_TreePreSelection/fr|Std Préselection arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeRecordSelection.svg|32px]] [[Std_TreeRecordSelection/fr|Std Enregistrer l'arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeSingleDocument.svg|32px]] [[Std_TreeSingleDocument/fr|Std Un seul document arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeMultiDocument.svg|32px]] [[Std_TreeMultiDocument/fr|Std Plusieurs documents arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeCollapseDocument.svg|32px]] [[Std_TreeCollapseDocument/fr|Std Réduire développer l'arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeDrag.svg|32px]] [[Std_TreeDrag/fr|Std Déplacer dans l'arborescence]] {{Version/fr|0.19}}
 +
** [[File:Std_TreeSelection.svg|32px]] [[Std_TreeSelection/fr|Std Aller à la sélection arborescence]] {{Version/fr|0.19}}
 +
* [[File:Std_ViewIsometric.svg|32px]] [[Std_ViewIsometric/fr|Std Vue isométrique]]
 +
* [[File:Std_ViewFront.svg|32px]] [[Std_ViewFront/fr|Std Vue de face]]
 +
* [[File:Std_ViewTop.svg|32px]] [[Std_ViewTop/fr|Std Vue de dessus]]
 +
* [[File:Std_ViewRight.svg|32px]] [[Std_ViewRight/fr|Std Vue de droite]]
 +
* [[File:Std_ViewRear.svg|32px]] [[Std_ViewRear/fr|Std Vue de l'arrière]]
 +
* [[File:Std_ViewBottom.svg|32px]] [[Std_ViewBottom/fr|Std Vue de dessous]]
 +
* [[File:Std_ViewLeft.svg|32px]] [[Std_ViewLeft/fr|Std Vue de gauche]]
 +
* [[File:Std_MeasureDistance.svg|32px]] [[Std_MeasureDistance/fr|Std Mesurer une distance]]
  
Le [[Standard_Menu/fr|Menu Standard]] est composé de sept sub-menus.
+
==Outils supplémentaires==
* [[Std_File_Menu/fr|Menu Fichier]]
 
* [[Std_Edit_Menu/fr|Menu Edition]]
 
* [[Std_View_Menu/fr|Menu Vue]]
 
* [[Std_Tools_Menu/fr|Menu Outils]]
 
* [[Std_Macro_Menu/fr|Menu Macro]]
 
* [[Std_Windows_Menu/fr|Menu Fenêtres]]
 
* [[Std_Help_Menu/fr|Menu Aide]]
 
  
=== Structure des barres d'outils ===
+
* [[Std_TransformManip|Std TransformManip]] / [[Std_Transform/fr|Std Transformation]]: Transforme un objet dans la vue 3D.
 +
* [[Std_Expressions/fr|Std Expressions]]: Expressions. {{Version/fr|0.19}}
 +
* [[File:Std_TreeSelectAllInstances.svg|32px]] [[Std_TreeSelectAllInstances/fr|Std TreeSelectAllInstances]]: sélectionne toutes les instances d'un objet. {{Version/fr|0.19}}
 +
* [[File:Std_LinkMakeGroup.svg|32px]] [[Std_LinkMakeGroup/fr|Std LinkMakeGroup]]: Crée un groupe de liens. {{Version/fr|0.19}}
  
These commands allow structuring the model tree to have better organization of the existing shapes, and to create "Links" which are useful to create assemblies.
+
{{Docnav/fr
* [[File:Std_Part.svg|32px]] [[Std_Part|Std Part]] {{Version|0.17}}
+
|[[Workbenches/fr|Ateliers]]
* [[File:Std_Group.svg|32px]] [[Std_Group|Std Group]] {{Version|0.17}}
+
|[[Arch Module/fr|Atelier Arch]]
* [[File:Std_LinkMake.svg|32px]] [[Std_LinkMake|Std LinkMake]] {{Version|0.19}}
+
|IconL=
* [[File:Std_LinkActions.svg|32px]] [[Std_LinkActions|Std LinkActions]] {{Version|0.19}}
+
|IconR=Workbench_Arch.svg
 +
}}
  
{{Std Base}}
+
{{Std Base navi{{#translation:}}}}
{{Userdocnavi}}
+
{{Userdocnavi{{#translation:}}}}
 +
[[Category:Workbenches{{#translation:}}]]
 +
{{clear}}

Latest revision as of 14:30, 17 September 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎中文(简体)‎
Arrow-left.svg Page précédente : Ateliers
Page suivante : Atelier Arch Workbench Arch.svg Arrow-right.svg
Icône de Std Base

Introduction

Std Base n'est pas vraiment un atelier mais plutôt une catégorie de commandes et d'outils "standard" qui sont définis au cœur du système et qui peuvent être utilisés dans tous les ateliers.

Outils

La plupart des outils Std Base sont accessibles depuis le menu standard et les barres d'outils. Ceux qui ne sont disponibles que via une barre d'outils ou un menu contextuel sont répertoriés sous Outils supplémentaires.

Il existe 7 menus standard. Chaque sous-menu a une page dédiée. Cliquez simplement sur l'un des noms ci-dessous.

Fichier     Edition     Affichage     Outils     Macro     Fenêtre     Aide

Barres d'outils

Pour un accès rapide à la documentation des outils standards, ils sont listés ci-dessous. La plupart de ces outils sont également accessibles à partir du menu standard.

Barre d'outils Structure

Barre d'outils de fichier

Barre d'outils d'atelier

Barre d'outils de macro

Barre d'outils de affichage

Outils supplémentaires

Arrow-left.svg Page précédente : Ateliers
Page suivante : Atelier Arch Workbench Arch.svg Arrow-right.svg