Difference between revisions of "Std Base"

From FreeCAD Documentation
Jump to navigation Jump to search
(Marked this version for translation)
(As I understand from Standard Menu entry: There is one THE standard menu, composed of sub-menus. Thus, standard menuS does not exist!?)
 
(66 intermediate revisions by 5 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 
<translate>
 
<translate>
 +
 +
<!--T:13-->
 +
{{Docnav
 +
|[[Workbenches|Workbenches]]
 +
|[[Arch Module|Arch Module]]
 +
|IconL=
 +
|IconR=Workbench_Arch.svg
 +
}}
 +
 +
<!--T:14-->
 +
[[Image:Freecad.svg|thumb|128px|Std Base icon]]
  
 
</translate>
 
</translate>
[[Image:freecad16.svg|64px]]
+
{{TOCright}}
 
<translate>
 
<translate>
  
<!--T:1-->
+
==Introduction== <!--T:2-->
{{TOCright}}
 
 
 
== Introduction == <!--T:2-->
 
  
 
<!--T:3-->
 
<!--T:3-->
The [[Std_Base|Std Base]] is not a real workbench. This page just collects all commands from the base system which do not belong to a specific workbench, but which may be used in all of them.
+
[[Std_Base|Std Base]] is not really a workbench, but rather a category of "standard" commands and tools that are defined in the core of the system, and that can can be used in all workbenches.
  
== Tools == <!--T:4-->
+
==Tools== <!--T:4-->
  
 
<!--T:5-->
 
<!--T:5-->
Most of the commands in this page can be accessed from menus, toolbars, and context menus.
+
Most [[Std_Base|Std Base]] tools can be accessed from the [[Standard_Menu|standard menu]], and standard toolbars. Those that are only available via a context menu are listed under [[#Additional_tools|Additional tools]].
  
=== Standard menu === <!--T:6-->
+
<!--T:15-->
 +
There are 7 standard sub-menus. Each sub-menu has a dedicated page. Just click on any of the names below.
  
<!--T:7-->
+
<!--T:12-->
The [[Standard_Menu|Standard Menu]] is composed of seven sub-menus.
+
<!--Please keep info below synchronized with Std_Base, Standard_Menu, Std_File_Menu etc.-->
* [[Std_File_Menu|File menu]]
+
{{StdMenu
* [[Std_Edit_Menu|Edit menu]]
+
|
* [[Std_View_Menu|View menu]]
+
[[Std_File_Menu|File]]
* [[Std_Tools_Menu|Tools menu]]
+
&nbsp;&nbsp;&nbsp;
* [[Std_Macro_Menu|Macro menu]]
+
[[Std_Edit_Menu|Edit]]
* [[Std_Windows_Menu|Windows menu]]
+
&nbsp;&nbsp;&nbsp;
* [[Std_Help_Menu|Help menu]]
+
[[Std_View_Menu|View]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Tools_Menu|Tools]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Macro_Menu|Macro]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Windows_Menu|Windows]]
 +
&nbsp;&nbsp;&nbsp;
 +
[[Std_Help_Menu|Help]]
 +
}}
  
=== Structure toolbar === <!--T:8-->
+
==Toolbars== <!--T:18-->
 +
<!--Please do not add extra information to the Toolbars section. Keep it clean: just the icon and the page link.
 +
  At least the version should be provided because this immediately tells the user whether the tool exists or not
 +
in the version that he or she uses.-->
 +
 
 +
<!--T:19-->
 +
For quick access to the documentation of the standard tools, they are listed below. Most of these tools can also be accessed from the standard menu.
 +
 
 +
===Structure toolbar=== <!--T:8-->
  
 
<!--T:9-->
 
<!--T:9-->
These commands allow structuring the model tree to have better organization of the existing shapes, and to create "Links" which are useful to create assemblies.
+
* [[File:Std_Part.svg|32px]] [[Std_Part|Std Part]]
* [[File:Std_Part.svg|32px]] [[Std_Part|Std Part]] {{Version|0.17}}
+
* [[File:Std_Group.svg|32px]] [[Std_Group|Std Group]]
* [[File:Std_Group.svg|32px]] [[Std_Group|Std Group]] {{Version|0.17}}
 
 
* [[File:Std_LinkMake.svg|32px]] [[Std_LinkMake|Std LinkMake]] {{Version|0.19}}
 
* [[File:Std_LinkMake.svg|32px]] [[Std_LinkMake|Std LinkMake]] {{Version|0.19}}
* [[File:Std_LinkActions.svg|32px]] [[Std_LinkActions|Std LinkActions]] {{Version|0.19}}
+
* [[File:Std_LinkMakeRelative.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] Std LinkActions
 +
** [[File:Std_LinkMakeRelative.svg|32px]] [[Std_LinkMakeRelative|Std LinkMakeRelative]] {{Version|0.19}}
 +
** [[File:Std_LinkReplace.svg|32px]] [[Std_LinkReplace|Std LinkReplace]] {{Version|0.19}}
 +
** [[File:Std_LinkUnlink.svg|32px]] [[Std_LinkUnlink|Std LinkUnlink]] {{Version|0.19}}
 +
** [[File:Std_LinkImport.svg|32px]] [[Std_LinkImport|Std LinkImport]] {{Version|0.19}}
 +
** [[File:Std_LinkImportAll.svg|32px]] [[Std_LinkImportAll|Std LinkImportAll]] {{Version|0.19}}
 +
 
 +
===File toolbar=== <!--T:20-->
 +
 
 +
<!--T:21-->
 +
* [[File:Std_New.svg|32px]] [[Std_New|Std New]]
 +
* [[File:Std_Open.svg|32px]] [[Std_Open|Std Open]]
 +
* [[File:Std_Save.svg|32px]] [[Std_Save|Std Save]]
 +
* [[File:Std_Print.svg|32px]] [[Std_Print|Std Print]]
 +
* [[File:Std_Cut.svg|32px]] [[Std_Cut|Std Cut]]
 +
* [[File:Std_Copy.svg|32px]] [[Std_Copy|Std Copy]]
 +
* [[File:Std_Paste.svg|32px]] [[Std_Paste|Std Paste]]
 +
* [[File:Std_Undo.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] [[Std_Undo|Std Undo]]
 +
* [[File:Std_Redo.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] [[Std_Redo|Std Redo]]
 +
* [[File:Std_Refresh.svg|32px]] [[Std_Refresh|Std Refresh]]
 +
* [[File:Std_WhatsThis.svg|32px]] [[Std_WhatsThis|Std WhatsThis]]
 +
 
 +
===Workbench toolbar=== <!--T:22-->
 +
 
 +
<!--T:23-->
 +
* [[Std_Workbench|Std Workbench]]
 +
 
 +
===Macro toolbar=== <!--T:24-->
 +
 
 +
<!--T:25-->
 +
* [[File:Std_DlgMacroRecord.svg|32px]] [[Std_DlgMacroRecord|Std DlgMacroRecord]]
 +
* [[File:Std_MacroStopRecord.svg|32px]] [[Std_MacroStopRecord|Std MacroStopRecord]]
 +
* [[File:Std_DlgMacroExecute.svg|32px]] [[Std_DlgMacroExecute|Std DlgMacroExecute]]
 +
* [[File:Std_DlgMacroExecuteDirect.svg|32px]] [[Std_DlgMacroExecuteDirect|Std DlgMacroExecuteDirect]]
 +
 
 +
===View toolbar=== <!--T:26-->
 +
 
 +
<!--T:27-->
 +
* [[File:Std_ViewFitAll.svg|32px]] [[Std_ViewFitAll|Std ViewFitAll]]
 +
* [[File:Std_ViewFitSelection.svg|32px]] [[Std_ViewFitSelection|Std ViewFitSelection]]
 +
* [[File:Std_DrawStyleAsIs.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] [[Std_DrawStyle|Std DrawStyle]]
 +
** [[File:Std_DrawStyleAsIs.svg|32px]] [[Std_DrawStyle#As_is|Std DrawStyle#As is]]
 +
** [[File:Std_DrawStylePoints.svg|32px]] [[Std_DrawStyle#Points|Std DrawStyle#Points]]
 +
** [[File:Std_DrawStyleWireFrame.svg|32px]] [[Std_DrawStyle#Wireframe|Std DrawStyle#Wireframe]]
 +
** [[File:Std_DrawStyleHiddenLine.svg|32px]] [[Std_DrawStyle#Hidden_line|Std DrawStyle#Hidden line]]
 +
** [[File:Std_DrawStyleNoShading.svg|32px]] [[Std_DrawStyle#No_shading|Std DrawStyle#No shading]]
 +
** [[File:Std_DrawStyleShaded.svg|32px]] [[Std_DrawStyle#Shaded|Std DrawStyle#Shaded]]
 +
** [[File:Std_DrawStyleFlatLines.svg|32px]] [[Std_DrawStyle#Flat_lines|Std DrawStyle#Flat lines]]
 +
* [[File:Std_SelBoundingBox.svg|32px]] [[Std_SelBoundingBox|Std SelBoundingBox]] {{Version|0.19}}
 +
* [[File:Std_SelBack.svg|32px]] [[Std_SelBack|Std SelBack]] {{Version|0.19}}
 +
* [[File:Std_SelForward.svg|32px]] [[Std_SelForward|Std SelForward]] {{Version|0.19}}
 +
* [[File:Std_LinkSelectLinked.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] Std LinkSelectActions
 +
** [[File:Std_LinkSelectLinked.svg|32px]] [[Std_LinkSelectLinked|Std LinkSelectLinked]] {{Version|0.19}}
 +
** [[File:Std_LinkSelectLinkedFinal.svg|32px]] [[Std_LinkSelectLinkedFinal|Std LinkSelectLinkedFinal]] {{Version|0.19}}
 +
** [[File:Std_LinkSelectAllLinks.svg|32px]] [[Std_LinkSelectAllLinks|Std LinkSelectAllLinks]] {{Version|0.19}}
 +
* [[File:Std_TreeSyncView.svg|32px]][[File:Toolbar_flyout_arrow.svg|16px]] Std TreeViewActions
 +
** [[File:Std_TreeSyncView.svg|32px]] [[Std_TreeSyncView|Std TreeSyncView]] {{Version|0.19}}
 +
** [[File:Std_TreeSyncSelection.svg|32px]] [[Std_TreeSyncSelection|Std TreeSyncSelection]] {{Version|0.19}}
 +
** [[File:Std_TreeSyncPlacement.svg|32px]] [[Std_TreeSyncPlacement|Std TreeSyncPlacement]] {{Version|0.19}}
 +
** [[File:Std_TreePreSelection.svg|32px]] [[Std_TreePreSelection|Std TreePreSelection]] {{Version|0.19}}
 +
** [[File:Std_TreeRecordSelection.svg|32px]] [[Std_TreeRecordSelection|Std TreeRecordSelection]] {{Version|0.19}}
 +
** [[File:Std_TreeSingleDocument.svg|32px]] [[Std_TreeSingleDocument|Std TreeSingleDocument]] {{Version|0.19}}
 +
** [[File:Std_TreeMultiDocument.svg|32px]] [[Std_TreeMultiDocument|Std TreeMultiDocument]] {{Version|0.19}}
 +
** [[File:Std_TreeCollapseDocument.svg|32px]] [[Std_TreeCollapseDocument|Std TreeCollapseDocument]] {{Version|0.19}}
 +
** [[File:Std_TreeDrag.svg|32px]] [[Std_TreeDrag|Std TreeDrag]] {{Version|0.19}}
 +
** [[File:Std_TreeSelection.svg|32px]] [[Std_TreeSelection|Std TreeSelection]] {{Version|0.19}}
 +
* [[File:Std_ViewIsometric.svg|32px]] [[Std_ViewIsometric|Std ViewIsometric]]
 +
* [[File:Std_ViewFront.svg|32px]] [[Std_ViewFront|Std ViewFront]]
 +
* [[File:Std_ViewTop.svg|32px]] [[Std_ViewTop|Std ViewTop]]
 +
* [[File:Std_ViewRight.svg|32px]] [[Std_ViewRight|Std ViewRight]]
 +
* [[File:Std_ViewRear.svg|32px]] [[Std_ViewRear|Std ViewRear]]
 +
* [[File:Std_ViewBottom.svg|32px]] [[Std_ViewBottom|Std ViewBottom]]
 +
* [[File:Std_ViewLeft.svg|32px]] [[Std_ViewLeft|Std ViewLeft]]
 +
* [[File:Std_MeasureDistance.svg|32px]] [[Std_MeasureDistance|Std MeasureDistance]]
 +
 
 +
==Additional tools== <!--T:16-->
 +
 
 +
<!--T:17-->
 +
* [[Std_TransformManip|Std TransformManip]] / [[Std_Transform|Std Transform]]: Transforms an object in the 3d view.
 +
* [[Std_Expressions|Std Expressions]]: Expression actions. {{Version|0.19}}
 +
* [[File:Std_TreeSelectAllInstances.svg|32px]] [[Std_TreeSelectAllInstances|Std TreeSelectAllInstances]]: Selects all instances of an object. {{Version|0.19}}
 +
* [[File:Std_LinkMakeGroup.svg|32px]] [[Std_LinkMakeGroup|Std LinkMakeGroup]]: Creates a group of links. {{Version|0.19}}
 +
 
 +
<!--T:28-->
 +
{{Docnav
 +
|[[Workbenches|Workbenches]]
 +
|[[Arch Module|Arch Module]]
 +
|IconL=
 +
|IconR=Workbench_Arch.svg
 +
}}
  
<!--T:10-->
 
{{Std Base}}
 
{{Userdocnavi}}
 
 
</translate>
 
</translate>
 +
{{Std Base navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}
 +
[[Category:Workbenches{{#translation:}}]]
 +
{{clear}}

Latest revision as of 09:46, 5 October 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎русский • ‎中文(简体)‎
Arrow-left.svg Previous: Workbenches
Std Base icon

Introduction

Std Base is not really a workbench, but rather a category of "standard" commands and tools that are defined in the core of the system, and that can can be used in all workbenches.

Tools

Most Std Base tools can be accessed from the standard menu, and standard toolbars. Those that are only available via a context menu are listed under Additional tools.

There are 7 standard sub-menus. Each sub-menu has a dedicated page. Just click on any of the names below.

File     Edit     View     Tools     Macro     Windows     Help

Toolbars

For quick access to the documentation of the standard tools, they are listed below. Most of these tools can also be accessed from the standard menu.

Structure toolbar

File toolbar

Workbench toolbar

Macro toolbar

View toolbar

Additional tools

Arrow-left.svg Previous: Workbenches