Difference between revisions of "Std Base"

From FreeCAD Documentation
Jump to navigation Jump to search
m (space)
m (Move {{TOCright}} out of translation tags + fix templates)
(One intermediate revision by the same user not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 +
[[Image:freecad16.svg|64px]]
 
<translate>
 
<translate>
 +
 +
== Introduction == <!--T:2-->
  
 
</translate>
 
</translate>
[[Image:freecad16.svg|64px]]
+
{{TOCright}}
 
<translate>
 
<translate>
 
<!--T:1-->
 
{{TOCright}}
 
 
== Introduction == <!--T:2-->
 
  
 
<!--T:3-->
 
<!--T:3-->
Line 23: Line 21:
  
 
=== Standard menu === <!--T:6-->
 
=== Standard menu === <!--T:6-->
 +
 +
{{StdMenu| File &nbsp;&nbsp;&nbsp;  Edit &nbsp;&nbsp;&nbsp;  View &nbsp;&nbsp;&nbsp;  Tools &nbsp;&nbsp;&nbsp;  Macro &nbsp;&nbsp;&nbsp;  Windows &nbsp;&nbsp;&nbsp;  Help }}
 +
{{Caption|The [[Standard_Menu|Standard Menu]] is composed of seven sub-menus.}}
  
 
<!--T:7-->
 
<!--T:7-->
The [[Standard_Menu|Standard Menu]] is composed of seven sub-menus.
+
* {{StdMenu|[[Std_File_Menu|File]]}} menu
* [[Std_File_Menu|File menu]]
+
* {{StdMenu|[[Std_Edit_Menu|Edit]]}} menu
* [[Std_Edit_Menu|Edit menu]]
+
* {{StdMenu|[[Std_View_Menu|View]]}} menu
* [[Std_View_Menu|View menu]]
+
* {{StdMenu|[[Std_Tools_Menu|Tools]]}} menu
* [[Std_Tools_Menu|Tools menu]]
+
* {{StdMenu|[[Std_Macro_Menu|Macro]]}} menu
* [[Std_Macro_Menu|Macro menu]]
+
* {{StdMenu|[[Std_Windows_Menu|Windows]]}} menu
* [[Std_Windows_Menu|Windows menu]]
+
* {{StdMenu|[[Std_Help_Menu|Help]]}} menu
* [[Std_Help_Menu|Help menu]]
 
  
 
=== Structure toolbar === <!--T:8-->
 
=== Structure toolbar === <!--T:8-->
Line 42: Line 42:
 
* [[File:Std_LinkMake.svg|32px]] [[Std_LinkMake|Std LinkMake]] {{Version|0.19}}
 
* [[File:Std_LinkMake.svg|32px]] [[Std_LinkMake|Std LinkMake]] {{Version|0.19}}
 
* [[File:Std_LinkActions.svg|32px]] [[Std_LinkActions|Std LinkActions]] {{Version|0.19}}
 
* [[File:Std_LinkActions.svg|32px]] [[Std_LinkActions|Std LinkActions]] {{Version|0.19}}
 
<!--T:10-->
 
{{Std Base}}
 
{{Userdocnavi}}
 
 
  
 
</translate>
 
</translate>
 +
{{Std Base{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}

Revision as of 21:44, 23 February 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎中文(简体)‎

Freecad16.svg

Introduction

The Std Base is not a real workbench. This page just collects all commands from the base system which do not belong to a specific workbench, but which may be used in all of them.

The base commands and functions normally start with the prefix Std, indicating that they are "standard".

Tools

Most of the commands in this page can be accessed from menus, toolbars, and context menus.

Standard menu

File     Edit     View     Tools     Macro     Windows     Help

The Standard Menu is composed of seven sub-menus.


Structure toolbar

These commands allow structuring the model tree to have better organization of the existing shapes, and to create "Links" which are useful to create assemblies.