Difference between revisions of "Standard Menu/pt"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
(Updating to match new version of source page)
 
(3 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
__NOTOC__
+
{{clear}}
{{docnav
+
{{TOCright}}
|[[Robot Workbench|Robot Workbench]]
 
|[[Macros|Macros]]
 
}}
 
  
 
==Introduction==
 
==Introduction==
  
The standard menu allows access to functions which are used in all workbenches. The menu may look slightly different depending on the desktop environment (KDE, Gnome, Windows, OS X, etc.).
+
The standard menu gives access to tools that can be used in all workbenches. The menu may look slightly different depending on the desktop environment (KDE, Gnome, Windows, OS X, etc.). Workbenches can also add sub-menus depending on how they decide to structure their tools.
  
Different workbenches can also add menus depending on how they decide to structure their own tools.
+
<!--Please keep info below synchronized with Std_Base, Std_File_Menu etc.-->
 
+
{{StdMenu
{{StdMenu| File &nbsp;&nbsp;&nbsp; Edit &nbsp;&nbsp;&nbsp; View &nbsp;&nbsp;&nbsp; Tools &nbsp;&nbsp;&nbsp; Macro &nbsp;&nbsp;&nbsp; Windows &nbsp;&nbsp;&nbsp; Help }}
+
|
 
+
[[Std_File_Menu|File]]
==File menu==
+
&nbsp;&nbsp;&nbsp;
 
+
[[Std_Edit_Menu|Edit]]
The [[Std_File_Menu|File]] menu provides functions related to file input and output, such as Open, Print, Export, etc.
+
&nbsp;&nbsp;&nbsp;
 
+
[[Std_View_Menu|View]]
==Edit menu==
+
&nbsp;&nbsp;&nbsp;
 
+
[[Std_Tools_Menu|Tools]]
The [[Std_Edit_Menu|Edit]] menu provides functions related to changing the model, such as Copy, Paste, etc.
+
&nbsp;&nbsp;&nbsp;
 
+
[[Std_Macro_Menu|Macro]]
==View menu==
+
&nbsp;&nbsp;&nbsp;
 
+
[[Std_Windows_Menu|Windows]]
The [[Std_View_Menu|View]] menu provides functions related to the display of the [[3D view|3D view]], as well as choosing which components of the main window and panels to show.
+
&nbsp;&nbsp;&nbsp;
 
+
[[Std_Help_Menu|Help]]
==Tools menu==
+
}}
 
+
{{Caption|The standard menu}}
The [[Std_Tools_Menu|Tools]] menu provides functions for debugging models, customizing FreeCAD's behavior, as well as auxiliary functions such as the [[Std_ExportGraphviz|dependency graph]].
 
 
 
==Macro menu==
 
 
 
The [[Std_Macro_Menu|Macro]] menu provides functions related to the recording and execution of [[macros|macros]].
 
 
 
==Windows menu==
 
  
The [[Std_Windows_Menu|Windows]] menu allows switching and arranging open windows of the application.
+
==Sub-menus==
  
==Help menu==
+
The standard menu is composed of 7 sub-menus:
  
The [[Std_Help_Menu|Help]] menu provides access to the help system, links to the website, forum, scripting documentation, and also shows the information about the application.
+
<!--Please keep info below synchronized with Std_File_Menu etc.-->
 +
* {{StdMenu|[[Std_File_Menu|File]]}} The File menu provides tools related to file input and output.
 +
* {{StdMenu|[[Std_Edit_Menu|Edit]]}} The Edit menu provides tools to change the model.
 +
* {{StdMenu|[[Std_View_Menu|View]]}} The View menu provides tools to change the [[3D view|3D view]] and the view properties of objects in the model, and tools related to the display of interface components.
 +
* {{StdMenu|[[Std_Tools_Menu|Tools]]}} The Tools menu provides tools for debugging models, customizing FreeCAD's behavior, as well as auxiliary tools.
 +
* {{StdMenu|[[Std_Macro_Menu|Macro]]}} The Macro menu provides tools related to the recording and execution of [[Macros|macros]].
 +
* {{StdMenu|[[Std_Windows_Menu|Windows]]}} The Windows menu allows switching and rearranging of [[Main_view_area|Main view area]] windows.
 +
* {{StdMenu|[[Std_Help_Menu|Help]]}} The Help menu provides access to the help system and links to the FreeCAD website and forum.
  
<div class="mw-translate-fuzzy">
 
{{docnav/pt|Robot Workbench/pt|Macros/pt}}
 
</div>
 
  
{{Std Base}}
+
{{Std Base navi{{#translation:}}}}
{{Userdocnavi}}
+
{{Userdocnavi{{#translation:}}}}
 +
{{Interface navi{{#translation:}}}}
 +
{{clear}}

Latest revision as of 20:16, 22 June 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎русский • ‎українська • ‎한국어

Introduction

The standard menu gives access to tools that can be used in all workbenches. The menu may look slightly different depending on the desktop environment (KDE, Gnome, Windows, OS X, etc.). Workbenches can also add sub-menus depending on how they decide to structure their tools.

File     Edit     View     Tools     Macro     Windows     Help

The standard menu


Sub-menus

The standard menu is composed of 7 sub-menus:

  • File The File menu provides tools related to file input and output.
  • Edit The Edit menu provides tools to change the model.
  • View The View menu provides tools to change the 3D view and the view properties of objects in the model, and tools related to the display of interface components.
  • Tools The Tools menu provides tools for debugging models, customizing FreeCAD's behavior, as well as auxiliary tools.
  • Macro The Macro menu provides tools related to the recording and execution of macros.
  • Windows The Windows menu allows switching and rearranging of Main view area windows.
  • Help The Help menu provides access to the help system and links to the FreeCAD website and forum.


Template:Std Base navi/pt

Template:Interface navi/pt