Difference between revisions of "Preferences Editor/pl"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "{| class="wikitable float-right mw-collapsible mw-collapsed" !style="width: 33%;"|Nazwa !style="width: 66%;"|Opis |- | {{MenuCommand|Automatycznie sprawdzaj aktualizacje podcz...")
Line 428: Line 428:
 
|-
 
|-
 
| {{MenuCommand|Zapamiętaj aktywne środowisko pracy w zakładce}} {{Version/pl|0.19}}
 
| {{MenuCommand|Zapamiętaj aktywne środowisko pracy w zakładce}} {{Version/pl|0.19}}
| Jeśli opcja jest zaznaczona, aplikacja będzie pamiętać, które Środowisko pracy jest aktywne dla każdej z zakładek niezależnie. W ten sposób aktywne Środowisko pracy zostanie automatycznie przywrócone przy zmianie zakładki w widoku [https://en.wikipedia.org/wiki/Multiple_document_interface multiple-document interface (MDI)].
+
| Jeśli opcja jest zaznaczona, aplikacja zapamięta aktywne środowisko pracy dla każdej zakładki w [[Main_view_area/pl|głównym obszarze widoku]] niezależnie. Po przejściu do innej zakładki środowisko pracy zostanie automatycznie przywrócone.
 
|-
 
|-
 
| {{MenuCommand|Wyłącz sprzętowe wspomaganie renderowania}} {{Version/pl|0.19}}
 
| {{MenuCommand|Wyłącz sprzętowe wspomaganie renderowania}} {{Version/pl|0.19}}

Revision as of 04:45, 21 May 2022

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎中文(台灣)‎ • ‎日本語 • ‎한국어

Wprowadzenie

Aby uruchomić Edytor ustawień wybierz menu Edycja → Preferencje. W systemie Mac OS opcja Preferencje ... pojawia się w menu FreeCAD (jest to domyślne miejsce preferencji na Macu).

FreeCAD wykorzystuje koncepcję środowiska pracy, gdzie każde z nich jest odpowiedzialne za konkretne zadania i funkcje. Każde z nich może mieć swoje własne preferencje. Pojawią się one w edytorze Preferencji tylko wtedy, gdy dany moduł został załadowany w bieżącej sesji programu FreeCAD. Aby dowiedzieć się więcej, zobacz stronę Środowiska pracy.

Jeśli nie jest załadowane żadne środowisko pracy, w edytorze Preferencji pojawi się pięć pozycji: Ogólne, Wyświetlanie, Środowiska pracy, Menadżer dodatków i Import Eksport. Pod nimi pojawią się wszystkie wczytane te środowiska, które mają swoje własne preferencje.

Proszę zwrócić uwagę na to, że kliknięcie przycisku Zresetuj w lewym dolnym rogu ekranu preferencji ustawi wszystkie z opcji FreeCAD na ich wartości domyślne.

Niektóre zaawansowane preferencje mogą być zmienione tylko w Edytorze parametrów. Na stronie Dostrajanie parametrów znajduje się lista niektórych z nich.

Ogólne

Ta sekcja menu konfiguracji zawiera dziewięć zakładek: Ogólne, Dokument, Zaznaczenie, Pamięć podręczna, Edytor, Konsola Pyton, Okno raportów, Makrodefinicje i Jednostki.

Ogólne

W zakładce Ogólne można wybrać następujące opcje:

Nazwa Opis
Zmień język Określa język interfejsu użytkownika programu FreeCAD.
Format liczb dostępne w wersji 0.20 Określa format liczby. Dostępne są następujące opcje:
  • System operacyjny: Używany jest separator dziesiętny zdefiniowany przez system operacyjny.
  • Wybrany język: Używany jest separator dziesiętny wybranego języka interfejsu FreeCAD.
  • C/POSIX: Jako separator dziesiętny używana jest kropka.
Zastąp separator dziesiętny dostępne w wersji 0.20 Jeśli opcja jest zaznaczona, separator dziesiętny klawiatury numerycznej zostanie zastąpiony separatorem zdefiniowanym w ustawieniu Format liczb (wymagane ponowne uruchomienie).
Pakiety preferencji dostępne w wersji 0.20 Wyświetla on listę dostępnych pakietów preferencji oraz pozwala na zapisywanie nowych.
Rozmiar listy ostatnio używanych plików Określa, ile plików powinno znajdować się na liście ostatnio używanych plików.
Aktywuj kafle w tle Jeśli opcja jest zaznaczona, tło głównego okna FreeCAD będzie domyślnie składać się z tych obrazów: Background.png

Ta opcja działa tylko wtedy, gdy nie zaznaczono opcji Styl arkusza.

Obraz można zmienić poprzez dodanie folderów Gui/Images do lokalizacji:

%APPDATA%/FreeCAD (na Windows),

$HOME/.FreeCAD (dla Linux) lub

$HOME/Library/Preferences/FreeCAD (dla MacOS).

Umieść plik o nazwie background.png w folderze Images i odznacz / zaznacz tę opcję, aby zobaczyć zmieniony plik.

Włącz miganie kursora Jeśli opcja jest zaznaczona, kursor tekstowy w konsoli Python i w edytorze makrodefinicji będzie migał.
Styl arkusza Określa arkusz stylów. Arkusze stylów określają, jak wygląda interfejs użytkownika FreeCAD. Szczegóły techniczne dotyczące arkuszy stylów można znaleźć na stronie motywy.
Rozmiar ikon paska narzędzi Określa rozmiar ikon paska narzędzi. Dostępne są następujące opcje:
  • Mały (16px),
  • Średni (24px) * Duży (32px),
  • Duży (32px),
  • Bardzo duży (48px).
Tryb widoku drzewa Określa sposób wyświetlania widoku drzewa w interfejsie użytkownika (wymagane ponowne uruchomienie). Dostępne są następujące opcje:
  • Widok połączony: Łączy widok drzewa i widok właściwości w jeden panel.
  • Widok drzewa i widok właściwości: Rozdzielenie widoku drzewa i widoku właściwości na osobne panele.
  • Obydwa: Pokazuje wszystkie trzy panele.
Po uruchomieniu załaduj automatycznie środowisko pracy Wybór, które środowisko pracy będzie używane bezpośrednio po uruchomieniu programu FreeCAD.
Włącz ekran powitalny przy uruchamianiu Gdy to pole wyboru jest zaznaczone, podczas uruchamiania wyświetlany jest ekran powitalny programu FreeCAD.

Obraz ekranu powitalnego można zmienić poprzez umieszczenie pliku o nazwie splash_image.png w folderze Images wspomnianym już przy opisie opcji Aktywuj kafle w tle.

Preferences General Tab General.png

Dokument

W zakładce Dokument można wybrać następujące opcje:

Nazwa Opis
Utwórz nowy dokument w trakcie uruchamiania Jeśli opcja jest zaznaczona, FreeCAD utworzy nowy dokument po uruchomieniu.
Poziom kompresji podczas zapisu Specyfikacja poziomu kompresji dla plików {FCStd. Pliki FCStd} są plikami skompresowanymi w formacie ZIP. Dlatego możesz zmienić ich rozszerzenie {.FCStd na .zip} i otworzyć je za pomocą programu do archiwizacji ZIP.
Użyj cofnij / ponów w dokumentach Jeśli to pole jest zaznaczone, wszystkie zmiany w dokumentach są zapisywane tak, aby można je było cofnąć/odtworzyć.
Maksymalna ilość kroków cofnij / ponów Określa, ile kroków Cofnij/Zmień powinno zostać zarejestrowanych (0-99).
Zezwolenie na przerwanie przeliczania. Zezwolenie na przerwanie przeliczania dokumentu przez naciśnięcie klawisza Esc. Może to nieznacznie wydłużyć czas ponownego przeliczania.
Uruchomienie automatycznego odzyskiwania przy starcie Jeśli jest dostępny plik odzyskiwania, FreeCAD automatycznie uruchomi funkcję odzyskiwania pliku w momencie jego uruchomienia. W ten sposób pliki mogą zostać odtworzone, jeśli wystąpi awaria.
Zapisz informacje automatycznego odzyskiwania co: Określ, jak często będzie zapisywany plik odzyskiwania.
Podczas zapisywania dokumentu dołącz miniaturkę do pliku projektu Jeśli to pole jest zaznaczone, po zapisaniu dokumentu zostanie również zapisana miniaturka. Miniaturka będzie wyświetlana na przykład na liście ostatnio zapisanych plików środowiska pracy Start. Możliwe jest wybranie Rozmiaru między 128 × 128 a 512 × 512 pikseli dla miniatury. Typowe rozmiary to potęgi liczby dwa: 128, 256, 512.
Dodaj logo programu do wygenerowanej miniatury Jeśli to pole jest zaznaczone, logo programu FreeCAD Freecad.svg zostanie dodane do miniaturki. Ta opcja działa tylko wtedy, gdy opcja Podczas zapisywania dokumentu dołącz miniaturkę do pliku projektu jest aktywna.
Maksymalna liczba plików kopii zapasowych podczas zapisywania dokumentu Jeśli to pole jest zaznaczone, pliki kopii zapasowej będą zapisywane podczas zapisywania dokumentu. Można określić, ile plików kopii zapasowych będzie przechowywanych. Zawierają one wcześniej zapisaną wersję dokumentu. Pierwszy plik kopii zapasowej będzie miał rozszerzenie .FCStd1, drugi .FCStd2 i tak dalej.
Użyj daty i rozszerzenie FCBak Jeśli to pole jest zaznaczone, pliki kopii zapasowych otrzymają rozszerzenie .FCbak, a ich nazwy plików otrzymają przyrostek daty zgodnie z określonym Formatem daty. Opis formatu daty znajduje się na stronie Arkusz informacyjny dotyczący formatów daty i czasu.

Przy domyślnych ustawieniach plik kopii zapasowej otrzyma np. nazwę TD-Cube.20200315-215654.FCBak (oryginalna nazwa pliku to TD-Cube.FCStd).

Zezwalaj na umieszczenie duplikatów etykiet obiektów w obrębie jednego dokumentu Jeśli to pole jest zaznaczone, obiekty mogą mieć tę samą etykietę / nazwę. Na przykład różne części lub elementy mogą mieć wtedy identyczną nazwę w obrębie tego samego dokumentu.
Wyłącz częściowe ładowanie połączonych obiektów zewnętrznych Jeśli opcja częściowego wczytywania zewnętrznych obiektów połączonych jest włączona, podczas automatycznego otwierania połączonego dokumentu wraz z dokumentem głównym wczytywane są tylko obiekty połączone i ich zależności. Takiego częściowo wczytanego dokumentu nie można edytować. Aby wczytać go w całości, należy dwukrotnie kliknąć ikonę dokumentu w widoku drzewa. Bardziej szczegółowe wyjaśnienie tej funkcji można znaleźć na stronie dokumentacja środowiska Złożenie 3.
Nazwa autora Wszystkie powstające dokumenty otrzymają określoną nazwę autora. Pole autora należy pozostawić puste na wypadek gdy autor ma pozostać anonimowy. Jeżeli zaznaczona jest opcja Ustaw przy zapisywaniu, pole Last modified by zostanie ustawione na określonego autora w trakcie zapisywania pliku. Informacje te można wyświetlić za pomocą menu Plik → Informacje o projekcie.
Nazwa firmy Wszystkie utworzone dokumenty otrzymają podaną nazwę firmy.
Licencja domyślna Wybór domyślnej licencji dla nowych dokumentów. W przypadku wstępnie zdefiniowanej licencji link Adres URL licencji zostanie automatycznie ustawiony. Wybierz Inne, aby uzyskać licencję własną lub specjalną.
Adres URL licencji Wskazanie adresu URL opisującego licencję wybraną w polu Licencja domyślna

Preferences General Tab Document.png

Zaznaczenie

W zakładce Zaznaczenie (dostępne w wersji 0.19) można wybrać następujące opcje:

Nazwa Opis
Przełącz automatycznie do widoku 3D zawierającego wybrany element Włącza Tryb synchronizacji widoku w widoku drzewa.
Automatycznie rozwiń drzewko gdy odpowiedni obiekt jest zaznaczony w oknie widoku 3D Włącza Tryb synchronizacji zaznaczenia w widoku drzewa.
Wyróżnij obiekt w oknie widoku 3D, gdy kursor myszki znajduje się nad pozycją drzewa Włącza Tryb wyboru wstępnego w widoku drzewa.
Zapisuj zaznaczenie w widoku drzewa, aby cofnąć / ponowić za pomocą przycisku nawigacji Włącza Tryb zapisu zaznaczenia w widoku drzewa.
Dodaj pola wyboru do zaznaczenia w drzewie dokumentu Każdy element widoku drzewa otrzyma pole wyboru. Jest to przydatne na przykład do zaznaczania wielu elementów podczas pracy z ekranem dotykowym.

Preferences General Tab Selection.png

Pamięć podręczna

Te preferencje są związane z katalogiem pamięci podręcznej, w którym program FreeCAD przechowuje pliki tymczasowe.

W zakładce Pamięć podręczna (dostępne w wersji 0.20) można wybrać następujące opcje:

Nazwa Opis
Lokalizacja Określa ścieżkę dostępu do katalogu pamięci podręcznej.
Sprawdzaj rozmiar pamięci przy starcie programu Określa częstotliwość sprawdzania rozmiaru katalogu. Dostępne opcje to:
  • Zawsze,
  • Codziennie,
  • Tygodniowo,
  • Miesięcznie,
  • Rocznie,
  • Nigdy.
Limit rozmiaru pamięci podręcznej Określa maksymalny rozmiar katalogu. Zostaniesz powiadomiony, jeśli podczas sprawdzania rozmiar przekroczy tę wartość. Dostępne opcje to:
  • 100 MB,
  • 300 MB,
  • 500 MB,
  • 1 GB,
  • 2 GB,
  • 3 GB.
Aktualny rozmiar Pokazuje aktualny rozmiar katalogu, jeśli jest dostępny. Naciśnij przycisk Sprawdź teraz ..., aby zaktualizować wartość.

Preferences General Tab Cache.png

Edytor

Ustawienia edytora preferencji mają wpływ na zachowanie edytora makrodefinicji. Edytor ten można otworzyć za pomocą menu Makro → Makra... → Edycja lub Utwórz.

Ustawienia kolorów i czcionek są również używane przez Konsolę Pythona.

W zakładce Edytor można wybrać następujące opcje:

Nazwa Opis
Włacz numerowanie linii Jeśli opcja ta jest zaznaczona, to wiersze kodu będą numerowane..
Włącz duży kursor Jeśli opcja ta jest zaznaczona, kursor będzie miał kształt bloku.
Rozmiar tabulacji Określa raster tabulatora ( liczbę spacji). Jeśli na przykład ustawiono go na 6, naciśnięcie klawisza Tab spowoduje przeskok do znaku 7 lub 13 lub 19 itd. w zależności od bieżącej pozycji kursora. To ustawienie jest używane tylko wtedy, gdy wybrano opcję Kontroluj tabulacje.
Rozmiar wcięcia Określa, ile spacji zostanie wstawionych po naciśnięciu klawisza Tab. To ustawienie jest używane tylko wtedy, gdy wybrano opcję Wstaw spacje.
Kontroluj tabulacje Jeśli opcja jest zaznaczona, naciśnięcie klawisza Tab spowoduje wstawienie tabulatora z rastrem określonym przez opcję Rozmiar tabulacji.
Wstaw spacje Jeśli opcja ta jest zaznaczona, naciśnięcie klawisza Tab spowoduje wstawienie spacji w ilości określonej przez opcję Rozmiar wcięcia.
Wyświetl elementy Określa format kodu, do którego zostaną zastosowane ustawienia kolorów i czcionek. Wynik można sprawdzić w polu Podgląd.
Czcionka Określa rodzinę czcionek, która powinna być używana dla wybranego typu kodu.
Rozmiar Określa rozmiar czcionki, która powinna być używana dla wybranego typu kodu.
Kolor Określa barwę, która ma być używana dla wybranego typu kodu.

Preferences General Tab Editor.png

Konsola Python

Ustawienia kolorów i czcionek są również używane przez konsole Python. Konsolę tę można otworzyć za pomocą opcji menu Widok → Panele → Konsola Python.

Należy pamiętać, że ustawienia kolorów i czcionek konsoli definiuje się na karcie Edytor.

W zakładce Konsola Pyton (dostępne w wersji 0.20) można wybrać następujące opcje:

Nazwa Opis
Włącz zawijanie tekstu Jeśli opcja ta jest zaznaczona, słowa będą zawijane, jeśli przekroczą dostępny w konsoli rozmiar wiersza.
Włącz duży kursor Jeśli opcja ta jest zaznaczona, kursor będzie miał kształt bloku.
Zapisz dziennik działań Jeśli opcja ta jest zaznaczona, historia poleceń środowiska Python jest zapisywana przez wszystkie sesje.

Preferences General Tab Python console.png

Widok raportu

Preferencje te mają wpływ na sposób działania okna Widoku raportu. Ten panel może być załaczony za pomocą menu Widok → Panele → Widok raportu.

W zakładce Widok raportu można zdefiniować, następujące opcje:

Nazwa Opis
Rejestruj zwykłe wiadomości Jeśli opcja zostanie zaznaczona, normalne wiadomości będą rejestrowane. Będą one wyświetlane w panelu Widok raportu w kolorze ustawionym dla Zwykłych wiadomości.
Rejestruj wiadomości dziennika Jeśli to pole jest zaznaczone, zapisywane są również informacje z logów. Informacje te będą wyświetlane w panelu Widok raportu w kolorze ustawionym w opcji Wiadomości dziennika. Panel ten jest wyświetlany za pomocą menu Widok → Panele → Widok raportu.
Rejestruj ostrzeżenia Jeśli to pole jest zaznaczone, zapisywane są komunikaty ostrzeżeń. Będą one wyświetlane w panelu Widok raportu w kolorze ustawionym dla Ostrzeżenia.
Rejestruj komunikaty błędów Jeśli to pole jest zaznaczone, będą zapisywane komunikaty o błędach. Będą one wyświetlane w panelu Widok raportu w kolorze ustawionym dla Błędów.
Pokaż okno Widok raportu po wystąpieniu błędu Jeśli to pole jest zaznaczone, panel widoku raportu pojawi się automatycznie, jak tylko zostanie zarejestrowany błąd.
Pokaż okno Widok raportu po wystąpieniu ostrzeżenia Jeśli to pole jest zaznaczone, panel widoku raportu pojawi się automatycznie gdy zostanie zarejestrowane ostrzeżenie.
Pokaż okno Widok raportu po wystąpieniu zwykłej wiadomości Jeśli to pole jest zaznaczone, panel widoku raportu pojawi się automatycznie gdy zostanie zarejestrowany zwykły komunikat.
Pokaż okno Widok raportu z wiadomościami dziennika Jeśli to pole jest zaznaczone, panel widoku raportu będzie wyświetlany automatycznie po zarejestrowaniu komunikatu dziennika.
Dołączaj znacznik czasu do każdej pozycji wpisu Jeśli to pole zostanie zaznaczone, każdy komunikat i ostrzeżenie będzie otrzymywać informacje z oznaczeniem czasu.
Zwykłe wiadomości Określa kolor czcionki dla normalnych wiadomości w panelu widok raportu.
Wiadomości dziennika Określa kolor czcionki dla komunikatów dziennika w panelu widok raportu.
Ostrzeżenia Określa kolor czcionki dla komunikatów ostrzeżeń w panelu widok raportu.
Błędy Określa kolor czcionki dla komunikatów błędów w panelu widok raportu.
Przekieruj wiadomości wewnętrzne środowiska Python do Widoku raportu Jeśli to pole jest zaznaczone, wewnętrzne wyjście środowiska Python zostanie przekierowane z konsoli Python do panelu Widoku raportu. Konsola Pythona jest wyświetlana z poziomu menu Widok → Panele → Konsola Python.
Przekieruj błędy wewnętrzne środowiska Python do Widoku raportu Jeśli to pole jest zaznaczone, wewnętrzne komunikaty o błędach Pythona zostaną przekierowane z konsoli Python do panelu Widoku raportu.

Preferences General Tab Output window.png

Makropolecenia

W zakładce Makropolecenia można zdefiniować następujące opcje:

Nazwa Opis
Uruchom makro w środowisku lokalnym Jeśli pole jest zaznaczone, zmienne zdefiniowane przez makra są tworzone jako zmienne lokalne, w przeciwnym razie są to zmienne globalne Python.
Ścieżka do plików makrodefinicji Określenie ścieżki do folderu plików makrodefinicji.
Nagrywanie poleceń GUI Jeśli pole jest zaznaczone, nagrana makrodefinicja będzie również zawierać polecenia interfejsu użytkownika.
Zarejestruj jako komentarz Jeśli pole jest zaznaczone, nagrana makrodefinicja będzie również zawierać polecenia interfejsu użytkownika, ale jako komentarze. Jest to przydatne, jeśli nie chcesz wykonywać widocznych akcji podczas uruchamiania makra, ale zobaczyć, co można zrobić w sposób widoczny.
Pokaż polecenia skryptu w konsoli Python Jeśli pole jest zaznaczone, polecenia wykonywane przez skrypty makro są wyświetlane w konsoli Python. Konsola jest dostępna z poziomu menu Widok → Panele → konsola Python.
Rozmiar listy ostatnio używanych makrodefinicji Kontroluje liczbę ostatnio wyświetlanych makrodefinicji w menu.
Liczba skrótów Kontroluje liczbę ostatnich makrodefinicji, które otrzymują dynamicznie przypisane skróty.
Klawiszy modyfikujące Kontroluje, które kombinacje klawiszy są używane dla skrótów, na przykład Ctrl + Shift + tworzy skróty w postaci Ctrl + Shift + 1, Ctrl + Shift + 2 itd.

Preferences General Tab Macro.png

Jednostki

W zakładce Jednostki możesz ustawić następujące parametry:

Nazwa Opis
System jednostek Określa system jednostek, który ma być używany we wszystkich częściach programu FreeCAD.
Liczba cyfr po przecinku Liczba miejsc po przecinku, która powinna być wyświetlana dla liczb i wymiarów w programie FreeCAD.
Najmniejszy ułamek cala Minimalna wielkość ułamkowa cala, która powinna być wyświetlana. To ustawienie jest dostępne tylko wtedy, gdy używany jest system jednostek Building US (ft-in/sqft/cuft).

Preferences General Tab Units.png

Wyświetlanie

Ta sekcja preferencji posiada trzy standardowe zakładki: Widok 3D i Nawigacja i Kolory. Czwarta zakładka, Widok siatki, jest dodawana, jeśli załadowano środowisko pracy Projekt Siatki.

Widok 3D

W zakładce Widok 3D można skonfigurować następujące opcje:

Nazwa Opis
Pokaż w narożniku symbol układu współrzędnych Jeśli to pole jest zaznaczone, zawsze będzie wyświetlany główny układ współrzędnych w prawym dolnym rogu okna widoku 3D.

Opcja Względna wielkość dostępne w wersji 0.20 definiuje rozmiar reprezentacji jako procent rozmiaru okna przeglądarki (wartość minimalna wysokości i szerokości).

Domyślnie pokazuj krzyżyk osi modelu dostępne w wersji 0.19 Jeśli to pole jest zaznaczone, przy otwieraniu lub tworzeniu pliku domyślnie wyświetlany będzie krzyż osi w oknie widoku 3D.
Pokaż licznik klatek na sekundę Jeśli opcja jest zaznaczona, to czas potrzebny na wykonanie ostatniej operacji i wynikowa liczba klatek na sekundę zawsze będzie wyświetlana w lewym dolnym rogu okna widoku 3D.
Zapamiętaj aktywne środowisko pracy w zakładce dostępne w wersji 0.19 Jeśli opcja jest zaznaczona, aplikacja zapamięta aktywne środowisko pracy dla każdej zakładki w głównym obszarze widoku niezależnie. Po przejściu do innej zakładki środowisko pracy zostanie automatycznie przywrócone.
Wyłącz sprzętowe wspomaganie renderowania dostępne w wersji 0.19 Jeśli opcja jest zaznaczona, OpenGL program będzie używać CPU zamiast GPU. Opcja ta jest przydatna przy rozwiązywaniu problemów z kartą graficzną i sterownikami. Zmiana tej opcji wymaga ponownego uruchomienia aplikacji.
Użyj OpenGL VBO (Vertex Buffer Object) Jeśli opcja jest zaznaczona, Vertex Buffer Objects (VBO) będzie używany. VBO jest funkcją OpenGL która oferuje procedury przesyłania danych o wierzchołkach (położenie, wektor normalny, kolor itp.) od karty graficznej. VBO oferuje znaczny wzrost wydajności, ponieważ dane znajdują się w pamięci graficznej, a nie w pamięci systemowej i dlatego mogą być renderowane bezpośrednio przez GPU. Więcej informacji na temat tła można znaleźć na witrynie Zrozumieć obiekty OpenGL.
Pamięć podręczna dla Renderowania dostępne w wersji 0.19 Render Cache lub Render Acceleration jest wyjaśnione bardziej szczegółowo na stronie Link#render-caching. Istnieją trzy opcje:
  • Automatycznie (domyślnie), niech Coin3D zdecyduje, w której pamięci buforować.
  • Rozproszone, włącz pamięć podręczną dla wszystkich węzłów głównych źródła widoku.
  • Scentralizowane, wyłącz pamięć podręczną we wszystkich węzłach wszystkich źródeł widoków i buforuj tylko w węźle głównym wykresu sceny. Zapewnia to najszybszą wydajność renderowania, ale wolniejszą reakcję na wszelkie zmiany sceny.
Wygładzanie Wybór, czy i jakiego rodzaju multisample anti-aliasing będzie w użyciu.
Przezroczystość obiektów dostępne w wersji 0.19 Renderuj obiekty przezroczyste. Dostępne są następujące typy:
  • Jeden przebieg (domyślnie), renderowanie odbywa się w jednym przebiegu. Dla obiektów nie będących bryłami, takich jak powierzchnie lub siatki, może to prowadzić do powstania artefaktów. Ten obraz pokazuje taki artefakt (czarny trójkąt) i że typ Przejście od tyłu unika tego.
  • Przebieg od tyłu, ma wpływ tylko na obiekty nie będące obiektami stałymi. Są one następnie renderowane w dwóch przebiegach: Wielokąty zwrócone do tyłu są renderowane w pierwszym przejściu, a zwrócone do przodu w drugim przejściu.
Rozmiar znacznika punktu Określa rozmiar wierzchołków (punktów) w środowisku pracy Szkicownik. Obszar punktów, który można kliknąć, można dodatkowo powiększyć, zwiększając promień kliknięcia Pick radius.
Promień kliknięcia — wybrania (px) Określa obszar wybierania elementów w oknie widoku 3D. Większa wartość ułatwia wybieranie elementów, ale może uniemożliwić wybranie niektórych małych elementów.
Odległość między oczami dla trybu stereo Określa odległość między oczami używaną dla projekcji stereoskopowych. Podana wartość jest współczynnikiem, który zostanie pomnożony przez rozmiar ramki konturu obiektu 3D, który jest aktualnie wyświetlany.
Kolor podświetlenia Jeśli opcja jest zaznaczona, podświetlenie jest włączone przy użyciu zdefiniowanego koloru. Podświetlenie jest używane do renderowania tylnych boków ścian (zazwyczaj nie widać ich w bryłach, chyba, że tniemy jedną z płaszczyzną przycięcia, lub jeśli ściany nie są poprawnie ustawione). Opcja jest aktywna tylko dla obiektów, których właściwość oświetlenia (na zakładce Widok) jest ustawiona na wartość Jedna strona. Jeśli opcja jest wyłączona, tylne strony ścian obiektów w trybie oświetlenia Jedna strona będą czarne.

Powiązane ustawienie Intensywności określa intensywność podświetlenia.

Typ projekcji Określa typ rzutowania ujęcia widoku. Dostępne są następujące opcje:

Preferences Display Tab 3D View.png

Nawigacja

W zakładce Nawigacja można skonfigurować następujące opcje:

Nazwa Opis
Kostka nawigacyjna Jeśli opcja jest zaznaczona, kostka nawigacyjna zawsze będzie wyświetlana w oknie widoku 3D.

Powiązany parametr Ilość kroków na pełen obrót określa, ile kroków (skoków) jest wymaganych podczas używania strzałek obrotu kostki nawigacyjnej.

Powiązana opcja Narożnik określa miejsce wyświetlania kostki nawigacyjnej w oknie widoku 3D.

Jeśli zaznaczono Obróć do najbliższego, Po kliknięciu ściany sześcianu widok 3D jest obracany do najbliższej najbardziej logicznej pozycji, w oparciu o bieżącą orientację sześcianu. W przeciwnym razie kliknięcie ściany zawsze spowoduje wykonanie obrotu o tę samą wartość. dostępne w wersji 0.20

Rozmiar kostki nawigacyjnej Definiuje rozmiar sześcianu. dostępne w wersji 0.20

Styl nawigacji w przestrzeni 3D Określa styl nawigacji myszką. Aby wyświetlić szczegóły każdego stylu, zaznacz go, i naciśnij przycisk Myszka ....
Technika orbitalna Określa styl orbity obrotu używany w trybie obrotu. Dostępne opcje to:
  • Trackball: Poruszanie myszą w poziomie spowoduje obrót widoku wokół osi Y.
  • Turntable: Poruszanie myszą w poziomie spowoduje obrót widoku wokół osi Z.
Tryb obrotu Określa środek obrotu. Dostępne są następujące opcje:
  • Środek okna,
  • Przyciągnij do kursora,
  • Środek obiektu.
Domyślna orientacja ujęcia widoku Wybór orientacji ujęcia widoku dla nowych dokumentów. Tego ustawienia używa również polecenie Std: Widok domyślny.
Przybliż ujęcie widoku Wpływa na początkowy poziom powiększenia ujęcia widoku dla nowych dokumentów. Ustawiona wartość to średnica kuli, która mieści się w oknie widoku 3D. Domyślnie jest to 100 mm. Ustawia również początkowy rozmiar elementów początkowych (płaszczyzn bazowych dla nowych zawartości środowiska Projekt Części i części środowiska Część).
Włącz animację Jeśli ta opcja jest zaznaczona i Styl nawigacji w przestrzeni 3D jest ustawiony na CAD, obroty mogą być animowane. Jeśli kursor myszki jest przesuwany przy wciśniętym kółku przewijania i prawym przycisku myszki, widok jest obracany. Jeśli kursor będzie się poruszał przy zwolnionym prawym przycisku myszki, obrót będzie kontynuowany. Aby zakończyć animację, kliknij lewym przyciskiem myszki.
Powiększ przy kursorze Jeśli opcja jest zaznaczona, operacje powiększania będą wykonywane w położeniu kursora myszki. W przeciwnym razie operacje powiększania będą wykonywane na środku bieżącego widoku. Krok powiększenia określa, w jakim stopniu będzie wykonywane powiększenie. Krok powiększenia równy 1 oznacza współczynnik 7,5 dla każdego kroku powiększenia.
Odwrócenie operacji przybliż / oddal Jeśli opcja jest zaznaczona, kierunek wykonywania operacji powiększania zostanie odwrócony.
Wyłącz gest obrotu na ekranie dotykowym Jeśli ta opcja jest zaznaczona, a Styl nawigacji w przestrzeni 3D jest ustawiony na Gesture, gest odchylania będzie wyłączony w przypadku powiększania przez szczypanie (powiększanie dwoma palcami).

Preferences Display Tab Navigation.png

Kolory

W zakładce Kolory można skonfigurować następujące opcje:

Nazwa Opis
Włącz podświetlanie wskazania Jeśli to pole wyboru jest zaznaczone, wybór wstępny jest włączony i wskazany element zostanie podświetlony określonym kolorem. Preselekcja oznacza, że np. krawędzie w częściach zostaną podświetlone podczas wskazywania kursorem myszki, oraz że mogą zostać wybrane.
Włącz podświetlanie zaznaczenia Jeśli to pole wyboru jest zaznaczone, podświetlenie wyboru jest aktywne i zostanie zastosowany określony kolor.
Pojedynczy kolor Jeśli opcja zostanie wybrana, tło części będzie miało wybrany kolor.
Gradient kolorów Jeśli opcja zostanie wybrana, tło dla części będzie miało pionowy gradient kolorów. Pierwszy kolor to kolor na górze tła, a drugi to kolor na dole.
Edytowany Obiekt Wybór koloru tła dla obiektów w widoku drzewa, które są aktualnie edytowane.
Aktywna zawartość Wybór koloru tła dla aktywnych obiektów w widoku drzewa. Na przykład, jeśli w widoku drzewa znajduje się kilka elementów, a jedna część jest przełączona jako aktywna, otrzyma wybrany kolor tła w widoku drzewa.

Preferences Display Tab Colors.png

Widok siatki

Ta zakładka jest dostępna tylko wtedy, gdy środowisko pracy Projekt Siatki zostało załadowane.

W zakładce Widok siatki można skonfigurować następujące opcje:

Nazwa Opis
Domyślny kolor siatki Wybór domyślnego koloru dla powierzchni nowo utworzonych siatek.
Domyślny kolor linii Wybór domyślnego koloru linii dla nowo utworzonych siatek.
Przeźroczystość siatki Określa domyślną przezroczystość siatki.
Przeźroczystość linii Określa domyślną przezroczystość linii siatki.
Rendering dwustronny Jeżeli opcja jest zaznaczona, domyślną wartością dla właściwości WIDOKOświetlenie jest Dwustronne zamiast Jednostronne. Wartość Dwustronne oznacza, że kolor wewnętrznej strony powierzchni jest taki sam jak kolor strony zewnętrznej. Jednostronne oznacza, że ich kolorem jest albo kolor podświetlenia jeśli jest włączony, albo czarny.
Pokaż ramkę otaczającą dla podświetlonych lub wybranych siatek Jeżeli opcja jest zaznaczona, domyślną wartością dla właściwości WIDOKStyl wyboru jest Ramka otaczająca zamiast Kształt. Wartość Ramka otaczająca oznacza, że jeśli siatki są podświetlone lub wybrane, wyświetlana jest podświetlona ramka otaczająca. Wartość Kształt oznacza, że sam kształt jest wtedy podświetlony.
Zdefiniuj wektor normalny dla wierzchołka Jeżeli opcja jest zaznaczona, Cieniowanie Phong jest używane, w przeciwnym razie stosuje się cieniowanie płaskie. Cieniowanie określa wygląd powierzchni.

W przypadku cieniowania płaskiego nie określa się normalności powierzchni na punkt, co prowadzi do nierzeczywistego wyglądu zakrzywionych powierzchni, natomiast zastosowanie cieniowania Phong prowadzi do uzyskania gładszego wyglądu.

Kąt załamania Kąt załamania to kąt progowy między dwiema powierzchniami. Można go ustawić tylko wtedy, gdy opcja Zdefiniuj wektor normalny dla wierzchołka jest używana.
Jeśli kąt nachylenia powierzchni ≥ kąt załamania, stosuje się cieniowanie ścian.
Jeśli kąt nachylenia powierzchni < kąt załamania, stosuje się gładkie zacienienie.

Preferences Display Tab Mesh view.png

Środowiska pracy

Ta sekcja preferencji posiada jedną kartę: Niezaładowane środowiska pracy.

Niezaładowane środowiska pracy

Aby ograniczyć zużycie zasobów, FreeCAD nie ładuje automatycznie wszystkich dostępnych środowisk pracy. I tylko wtedy, gdy środowisko pracy zostało załadowane, jego preferencje, jeśli takowe istnieją, pojawiają się w edytorze Preferencji.

W wersji FreeCAD 0.19 zakładka Niezaładowane środowiska pracy wyświetla listę zainstalowanych środowisk pracy, które nie zostały jeszcze załadowane. Aby załadować jedno lub więcej środowisk, należy zaznaczyć je na liście i nacisnąć przycisk Załaduj wybrane.

W wersji FreeCAD 0.20 zakładka Niezaładowane środowiska pracy wyświetla listę wszystkich zainstalowanych środowisk pracy. Aby załadować środowisko pracy należy nacisnąć jego indywidualny przycisk Wczytaj teraz. Jeśli zaznaczysz pole wyboru CheckBoxTrue.svg Wczytaj automatycznie dla danego środowiska pracy, będzie ono automatycznie ładowane podczas uruchamiania programu FreeCAD. Ładowanie większej ilości środowisk pracy spowolni uruchamianie, ale przełączanie się pomiędzy tymi, które zostały już załadowane jest szybsze.

Jeśli nowo załadowane środowisko pracy posiada dedykowane preferencje, pojawią się one w nowej sekcji w edytorze Preferencji. Niektóre środowiska pracy dodają wsparcie dla dodatkowych formatów importu i eksportu. Jeśli istnieją jakieś powiązane preferencje, pojawią się one na jednej lub więcej nowych zakładkach w sekcji konfiguracji Importu Eksportu edytora Preferencji.

Aby zapoznać się z listą preferencji środowiska pracy, zobacz sekcję Preferencje środowisk pracy

Preferences Workbenches Tab Available Workbenches.png

Menadżer dodatków

Ta sekcja preferencji ma jedną kartę: Opcje Menadżera dodatków.

Opcje Menadżera dodatków

Te ustawienia kontrolują sposób działania Menedżera dodatków.

W zakładce Opcje Menadżera dodatków (dostępne w wersji 0.20) można wybrać następujące opcje:

Nazwa Opis
Automatycznie sprawdzaj aktualizacje podczaa uruchomienia (wymaga GitPython) Jeśli opcja ta jest zaznaczona, Menedżer dodatków będzie sprawdzał dostępność aktualizacji przy starcie. Aby to działało, muszą być zainstalowane środowiska GitPython i Git.
Pobierz metadane makrodefinicji (około 10MB) Jeśli to opcja jest zaznaczona, metadane dotyczące makrodefinicji są pobierane w celu wyświetlenia ich na głównej liście dodatków w menedżerze dodatków. Dane te są buforowane lokalnie.
Częstotliwość aktualizacji pamięci podręcznej Kontroluje częstotliwość, z jaką aktualizowane są lokalnie buforowane dodatki i informacje o metadanych. Dostępne opcje to:
  • Ręcznie (bez aktualizacji automatycznych)
  • Codziennie
  • Tygodniowo
Ukryj dodatki wymagające środowiska Python 2 Jeśli ta opcja jest zaznaczona, dodatki oznaczone jako " Wyłącznie Python 2" nie są uwzględniane w zestawieniu. Jest mało prawdopodobne, aby te dodatki działały w bieżącej wersji programu FreeCAD.
Ukryj dodatki oznaczone jako przestarzałe Jeśli ta opcja jest zaznaczona, dodatki oznaczone jako "Nieaktualne" nie będą uwzględniane na liście.
Ukryj dodatki które wymagają nowszej wersji programu FreeCAD Jeśli ta opcja jest zaznaczona, dodatki, które wymagają nowszej wersji programu FreeCAD, nie są uwzględniane w zestawieniu.
Repozytoria uzytkownika (jedno na wiersz) W tym miejscu można określić własne repozytoria. Powinny one zawierać nazwę gałęzi, której chcesz użyć (zazwyczaj "master" lub "main").
Serwer pośredniczący Menedżer dodatków zawiera eksperymentalną obsługę serwerów proxy wymagających uwierzytelnienia, skonfigurowanych jako serwery proxy zdefiniowane przez użytkownika.
Plik wykonywalny Python (opcjonalnie) Menedżer dodatków próbuje wybrać plik wykonywalny Python, który powinien zostać użyty do automatycznej instalacji zależności Pythona za pomocą polecenia. Aby zastąpić ten wybór, można tutaj podać ścieżkę do pliku wykonywalnego.
Pokaż opcję zmiany gałęzi (wymaga GitPython) Dla deweloperów i beta-testerów Menedżer dodatków może udostępnić interfejs na ekranie szczegółów dodatku, który umożliwia przełączanie, która gałąź git jest aktualnie sprawdzana. Jest to opcja przeznaczona tylko dla zaawansowanych użytkowników, ponieważ może się zdarzyć, że wersja dodatku z inną gałęzią niż podstawowa może spowodować niestabilność i problemy z kompatybilnością. Aby to działało, musi być zainstalowany GitPython. Należy zachować ostrożność.

Preferences Addon Manager Tab Addon manager options.png

Import Eksport

Ustawienia Import-Export wpływają na sposób importowania i eksportowania plików do i z FreeCAD. Są one opisane na stronie Preferencje eksportu, importu.

Preferencje środowisk pracy

Preferencje dla wbudowanych środowisk pracy są wymienione poniżej. Odnośniki te są również wymienione w Category:Preferences. Niektóre środowiska pracy nie mają ustawień.

Tworzenie skryptów

Zobacz również: FreeCAD podstawy tworzenia skryptów.

Przykład skryptu można znaleźć w Std DlgParameter.

Powiązane