Difference between revisions of "Preferences Editor/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
 
(18 intermediate revisions by 3 users not shown)
Line 33: Line 33:
 
|-
 
|-
 
| {{MenuCommand/fr|Activer l'arrière-plan en mosaïque}}
 
| {{MenuCommand/fr|Activer l'arrière-plan en mosaïque}}
| Si cette case est cochée, l’arrière-plan de la fenêtre principale de FreeCAD sera par défaut constitué de mosaïques de cette image: [[File:Background.png|64px]]
+
| Si cette case est cochée, l’arrière-plan de la fenêtre principale de FreeCAD sera par défaut constitué de mosaïques de cette image: | [[File:Background.png|64px]]
  
 
Cette option n’a un effet que si {{MenuCommand/fr|Feuille de style}}/''Aucune feuille de style'' est sélectionné.
 
Cette option n’a un effet que si {{MenuCommand/fr|Feuille de style}}/''Aucune feuille de style'' est sélectionné.
Line 53: Line 53:
 
| Sélection de la taille des icônes de la barre d’outils
 
| Sélection de la taille des icônes de la barre d’outils
 
|-
 
|-
| {{MenuCommand/fr|Module chargé automatiquement après le démarrage}}
+
| {{MenuCommand/fr|Mode d'affichage d'arborescence}}
| Sélection de l'atelier à utiliser directement après le démarrage de FreeCAD
+
| Personnalisation de l'affichage de l'arborescence dans le panneau (redémarrage requis). Les options sont les suivantes:
 +
* '''Vue combinée''': combine l'arborescence et la vue des propriétés dans un seul panneau.
 +
* '''TreeView and PropertyView''': divise l'arborescence et la vue des propriétés en panneau séparé.
 +
* '''Both''': conserve les trois panneaux et vous pouvez avoir deux ensembles d'arborescence et de propriété.
 
|-
 
|-
| {{MenuCommand/fr|Activer l'écran de démarrage au démarrage}}
+
| {{MenuCommand/fr|Module de chargement automatique après le démarrage}}
| Si cette case est cochée, l'écran de démarrage de FreeCAD apparaît au démarrage.
+
| Sélection du plan de travail qui sera utilisé directement après le démarrage de FreeCAD
 +
|-
 +
| {{MenuCommand/fr|Active l'écran de démarrage au démarrage}}
 +
| Si cette case est cochée, l'écran de démarrage de FreeCAD s'affiche au démarrage.
  
 
L'image de l'écran de démarrage peut être modifiée en ajoutant les dossiers {{FileName|Gui/Images}} dans le dossier {{FileName|%APPDATA%/FreeCAD}} (où %APPDATA% est le dossier d’installation spécifique à l’utilisateur de FreeCAD de votre système d’exploitation). Mettez-y un fichier nommé {{FileName|splash_image.png}} et redémarrez FreeCAD pour voir l'écran de démarrage modifié.
 
L'image de l'écran de démarrage peut être modifiée en ajoutant les dossiers {{FileName|Gui/Images}} dans le dossier {{FileName|%APPDATA%/FreeCAD}} (où %APPDATA% est le dossier d’installation spécifique à l’utilisateur de FreeCAD de votre système d’exploitation). Mettez-y un fichier nommé {{FileName|splash_image.png}} et redémarrez FreeCAD pour voir l'écran de démarrage modifié.
Line 69: Line 75:
 
===Document===
 
===Document===
  
Dans l'onglet ''Document'', vous pouvez spécifier les éléments suivants :
+
Dans l'onglet ''Document'', vous pouvez spécifier les éléments suivants:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Nom
 
!style="width: 33%;"|Nom
Line 77: Line 83:
 
| Si coché, FreeCAD créera un nouveau document au démarrage
 
| Si coché, FreeCAD créera un nouveau document au démarrage
 
|-
 
|-
| {{MenuCommand/fr|Niveau de compression du document}}
+
| {{MenuCommand/fr|Niveau de compression de sauvegarde du document}}
| Spécification du niveau de compression pour les fichiers {{FileName|FCStd}}. Les fichiers {{FileName|FCStd}} sont des fichiers compressés au format ZIP. Par conséquent, vous pouvez renommer leur suffixe {{FileName|.FCStd}} en {{FileName|.zip}} et les ouvrir avec un programme d’archive ZIP.
+
| Spécification du niveau de compression pour les fichiers {{FileName|FCStd}}. Les fichiers {{FileName|FCStd}} sont des fichiers compressés ZIP. Par conséquent, vous pouvez renommer leur suffixe {{FileName|.FCStd}} en {{FileName|.zip}} et les ouvrir avec un programme d'archive ZIP.
 
|-
 
|-
| {{MenuCommand/fr|Utiliser Annuler / Rétablir sur les documents}}
+
| {{MenuCommand/fr|Utilisation des fonctions Annuler /Rétablir sur les documents}}
| Si coché, toutes les modifications dans les documents sont stockées de manière à pouvoir être annulées / rétablies
+
| Si cette case est cochée, toutes les modifications apportées aux documents sont stockées afin de pouvoir être annulées /refaites.
 
|-
 
|-
| {{MenuCommand/fr|Nombre maximum d'actions Annuler / Rétablir}}
+
| {{MenuCommand/fr|Nombre maximum d'étapes d'annulation /de rétablissement}}
| Spécification du nombre d'actions Annuler / Rétablir à mémoriser
+
| Spécification du nombre d'étapes Annuler /Rétablir à enregistrer
 
|-
 
|-
| {{MenuCommand/fr|Lancer AutoRecovery au démarrage}}
+
| {{MenuCommand/fr|Autoriser l'interruption du recalcul}}
| Si un fichier de récupération est disponible, FreeCAD lancera automatiquement une récupération de fichier au démarrage. De cette façon, les fichiers peuvent être restaurés en cas de blocage.
+
| Permet d'interrompre le recalcul du document en appuyant sur {{KEY|Esc}}. Cela peut augmenter légèrement le temps de recalcul.
 
|-
 
|-
| {{MenuCommand/fr|Enregistrer l'information AutoRecovery chaque}}
+
| {{MenuCommand/fr|Exécuter la récupération automatique au démarrage}}
 +
| Si un fichier de récupération est disponible, FreeCAD exécutera automatiquement une récupération de fichier au démarrage. De cette façon, les fichiers peuvent être restaurés en cas de panne.
 +
|-
 +
| {{MenuCommand/fr|Enregistrer les informations de récupération automatique tous les}}
 
| Spécification de la fréquence d'écriture d'un fichier de récupération.
 
| Spécification de la fréquence d'écriture d'un fichier de récupération.
 
|-
 
|-
| {{MenuCommand/fr|Enregistrer la vignette dans le fichier projet lors de la sauvegarde du document}}
+
| {{MenuCommand/fr|Enregistrer la miniature dans le fichier de projet lors de l'enregistrement du document}}
| Si cette case est cochée, une vignette sera également enregistrée lors de la sauvegarde du document. La vignette sera par exemple affichée dans la liste des fichiers récents dans l'atelier [[Start_Workbench/fr|Start]].
+
| Si cette case est cochée, une miniature sera également stockée lors de l'enregistrement du document. La vignette sera par exemple affichée dans la liste des fichiers récents dans l'[[Start_Workbench/fr|atelier Start]]. Il est possible de sélectionner une '' 'Taille' '' entre 128 × 128 et 512 × 512 pixels pour la vignette. Les tailles courantes sont les puissances de deux: 128, 256, 512.
 +
|-
 +
| {{MenuCommand/fr|Ajouter le logo du programme à la miniature générée}}
 +
| Si cette case est cochée, le logo du programme FreeCAD [[image:FreeCAD-logo.svg|24px]] sera ajouté à la vignette. Cette option n'a d'effet que si {{MenuCommand/fr| Enregistrer la miniature dans le fichier de projet lors de l'enregistrement du document}} est utilisé.
 
|-
 
|-
| {{MenuCommand/fr|Ajouter le logo du programme à la vignette générée}}
+
| {{MenuCommand/fr|Nombre maximal de fichiers de sauvegarde à conserver lors de la réenregistrement de document}}
| Si cette case est cochée, le logo du programme FreeCAD [[image: FreeCAD-logo.svg|24px]] sera ajouté à la vignette. Cette option n'a d'effet que si {{MenuCommand/fr|Enregistrer la vignette dans le fichier projet lors de la sauvegarde du document}} est utilisé.
+
| Si cette case est cochée, les fichiers de sauvegarde seront conservés lors de l'enregistrement du document. Vous pouvez spécifier combien de fichiers de sauvegarde seront conservés. Ils contiennent la version du document précédemment enregistrée. Le premier fichier de sauvegarde aura le suffixe de fichier {{FileName|.FCStd1}}, le second {{FileName|.FCStd2}} et ainsi de suite.
 
|-
 
|-
| {{MenuCommand/fr|Nombre maximal de fichiers de sauvegarde à conserver lors de la sauvegarde du document}}
+
| {{MenuCommand/fr|Utiliser la date et l'extension FCBak}}
| Si cette case est cochée, les fichiers de sauvegarde seront conservés lors de la sauvegarde du document. Vous pouvez spécifier combien de fichiers de sauvegarde seront conservés. Ils contiennent la version précédemment enregistrée du document. Le premier fichier de sauvegarde porte le suffixe {{FileName|.FCStd1}}, le second {{FileName|.FCStd2}}, etc.
+
| Si coché, les fichiers de sauvegarde auront l'extension ''.FCbak'' et leurs noms de fichiers auront un suffixe de date selon le format de date spécifié. Pour une description du format de date, voir [https://devhints.io/datetime ce site].
 +
Avec les paramètres par défaut, le fichier de sauvegarde obtiendra par exemple ce nom '' TD-Cube.20200315-215654.FCBak '' (le nom de fichier d'origine est '' TD-Cube.FCStd '').
 
|-
 
|-
| {{MenuCommand/fr|Désactiver le chargement partiel d'objets externes liés}}
+
| {{MenuCommand/fr|Autoriser les étiquettes d'objet en double dans un document}}
| Activer le chargement partiel du document externe lié. Lorsque cette option est activée, seuls les objets référencés et leurs dépendances sont chargés lorsqu'un document lié est automatiquement ouvert avec le document principal. Un document partiellement chargé ne peut pas être édité. Double-cliquez sur l'icône du document dans l'arborescence pour la recharger complètement. Vous trouverez une explication plus détaillée de la fonctionnalité sur la page [https://github.com/realthunder/FreeCAD_assembly3/wiki/Core-Changes#partial-document-loading Assembly3 documentation page]
+
| Si coché, les objets peuvent avoir le même label /nom. Par exemple, différentes parties ou fonctions peuvent avoir le même nom dans le même document.
 
|-
 
|-
| {{MenuCommand/fr|Autoriser la duplication des étiquettes dans un document}}
+
| {{MenuCommand/fr|Désactiver le chargement partiel des objets liés externes}}
| Si coché, les objets peuvent avoir le même label/nom. Par exemple, différentes parties ou caractéristiques peuvent alors porter le même nom dans le même document.
+
| Activez le chargement partiel du document lié externe. Lorsque cette option est activée, seuls les objets référencés et leurs dépendances seront chargés lorsqu'un document lié est ouvert automatiquement avec le document principal. Un document partiellement chargé ne peut pas être modifié. Double-cliquez sur l'icône du document dans l'arborescence pour le recharger complètement. Une explication plus détaillée de la fonctionnalité peut être trouvée sur la page de documentation [https://github.com/realthunder/FreeCAD_assembly3/wiki/Core-Changes#partial-document-loading Assembly3]
 
|-
 
|-
 
| {{MenuCommand/fr|Nom de l'auteur}}
 
| {{MenuCommand/fr|Nom de l'auteur}}
| Tous les documents qui seront créés auront le nom d’auteur spécifié. Laissez le champ auteur vide pour un auteur anonyme. Si l'option {{MenuCommand/fr|Set on save}} est cochée, le champ ''Dernière modification par'' sera défini sur l'auteur spécifié lors de l'enregistrement du fichier. Ce champ peut être visualisé par le menu {{MenuCommand/fr|Fichier → Informations sur le projet}}.
+
| Tous les documents qui seront créés obtiendront le nom d'auteur spécifié. Laissez le champ auteur vide pour un auteur anonyme. Si l'option {{MenuCommand/fr| Set on save}} est cochée, le champ '' Last modified by '' sera défini sur l'auteur spécifié lors de l'enregistrement du fichier. Ce champ peut être affiché à l'aide du menu {{MenuCommand/fr|Fichier → Project information}}.
 
|-
 
|-
| {{MenuCommand/fr|Société}}
+
| {{MenuCommand/fr|Entreprise}}
| Tous les documents qui seront créés auront le nom de société spécifié
+
| Tous les documents qui seront créés recevront le nom de l'entreprise spécifié
 
|-
 
|-
 
| {{MenuCommand/fr|Licence par défaut}}
 
| {{MenuCommand/fr|Licence par défaut}}
| Sélection d'une licence par défaut pour les nouveaux documents. Pour une licence prédéfinie, {{MenuCommand/fr|URL de licence}} sera automatiquement défini en conséquence. Sélectionnez « Autre » pour une licence propre ou spéciale.
+
| Sélection d'une licence par défaut pour les nouveaux documents. Pour une licence prédéfinie, {{MenuCommand/fr|URL de licence}} sera automatiquement définie en conséquence. Sélectionnez «Autre» pour une licence propre ou spéciale.
 
|-
 
|-
 
| {{MenuCommand/fr|URL de licence}}
 
| {{MenuCommand/fr|URL de licence}}
| Spécification de l'URL décrivant la licence sélectionnée dans {{MenuCommand/fr|Licence par défaut}}
+
| Spécification d'une URL décrivant la licence sélectionnée dans {{MenuCommand/fr|Licence par défaut}}
 
|}
 
|}
  
Line 179: Line 192:
 
|-
 
|-
 
| {{MenuCommand/fr|Afficher la vue rapport en cas d'erreur ou d'avertissement}}
 
| {{MenuCommand/fr|Afficher la vue rapport en cas d'erreur ou d'avertissement}}
| Si cette case est cochée, le panneau d'affichage du rapport s'affichera automatiquement dès qu'une erreur ou un avertissement est enregistré.
+
| Si cette case est cochée, le panneau de la[[Report_view/fr|Vue rapport]] s'affichera automatiquement dès qu'une erreur ou un avertissement est enregistré.
 
|-
 
|-
 
| {{MenuCommand/fr|Messages normaux}}
 
| {{MenuCommand/fr|Messages normaux}}
Line 258: Line 271:
 
Cet onglet est toujours disponible, et contrôle certaines caractéristiques de [[3D view|3D view]].
 
Cet onglet est toujours disponible, et contrôle certaines caractéristiques de [[3D view|3D view]].
  
 +
<div class="mw-translate-fuzzy">
 
Dans l'onglet ''Vue 3D'', vous pouvez spécifier les éléments suivants :
 
Dans l'onglet ''Vue 3D'', vous pouvez spécifier les éléments suivants :
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
Line 326: Line 340:
 
| {{MenuCommand/fr|Type de caméra}}
 
| {{MenuCommand/fr|Type de caméra}}
 
| Sélection du type de projection de la caméra.
 
| Sélection du type de projection de la caméra.
 +
</div>
  
 
* '''Rendu en perspective''', les objets apparaîtront en [https://fr.wikipedia.org/wiki/Perspective_(repr%C3%A9sentation) perspective].
 
* '''Rendu en perspective''', les objets apparaîtront en [https://fr.wikipedia.org/wiki/Perspective_(repr%C3%A9sentation) perspective].
Line 331: Line 346:
 
|}
 
|}
  
 +
 +
[[Image:Preference_Display_Tab_01.png]]
 +
 +
===Navigation===
 +
 +
 +
This tab is always available, and controls the behavior of the navigation tools.
 +
 +
 +
In the ''Navigation'' tab you can specify the following:
 +
{| class="wikitable float-right mw-collapsible mw-collapsed"
 +
!style="width: 33%;"|Name
 +
!style="width: 66%;"|Description
 +
|-
 +
| {{MenuCommand|Navigation cube}}
 +
|  If checked, the [[Navigation_Cube|navigation cube]] will always be shown. Related {{MenuCommand|Steps by turn}} defines how many steps (notches) will be applied when using the Navigation cube rotation arrows. Related {{MenuCommand|Corner}} defines where the Navigation cube is displayed on the screen when creating/opening a document
 +
|-
 +
| {{MenuCommand|3D Navigation}}
 +
|  Selection of a [[Mouse_Model|navigation settings set]]. To see what each set defines, select a set and press the button {{Button|Mouse...}}.
 +
|-
 +
| {{MenuCommand|Orbit style}}
 +
|  Selection of the rotation orbit style. When viewing a part in the x-y plane an being in the rotation mode of the 3D navigation, the difference is: If '''Trackball''' is selected, moving the mouse horizontally will rotate the part around the y-axis, if '''Turntable''' is selected the part will be rotated around the z-axis.
 +
|-
 +
| {{MenuCommand|New Document Camera Orientation}}
 +
|  Selection of the camera orientation for new documents
 +
|-
 +
| {{MenuCommand|New Document Scale}}
 +
|  Affects the initial "zoom level" of camera for new documents. The value you set is the diameter of a sphere that fits in 3D view. Default is 100 mm, convenient for objects like boxes for Arduino. It also sets initial size of origin features (base planes in a new PartDesign Body).
 +
|-
 +
| {{MenuCommand|Enable animation}}
 +
|  If checked, rotations can be animated. If for example the {{MenuCommand|3D Navigation}} set ''CAD'' is used and the mouse is moved while the scroll wheel and the right mouse button is pressed, parts are rotated. If one keeps the mouse moving while releasing e.g. the right mouse button, the rotation will continue as animation. To end the animation left-click with the mouse.
 +
|-
 +
| {{MenuCommand|Zoom at cursor}}
 +
|  If checked, zoom operations will be performed at the position of the mouse pointer. Otherwise zoom operations will be performed at the center of the current view. The {{MenuCommand|Zoom step}} defines how much will be zoomed. A zoom step of  '1' means a factor of 7.5 for every zoom step.
 +
|-
 +
| {{MenuCommand|Invert zoom}}
 +
|  If checked, the direction of zoom operations will be inverted.
 +
|-
 +
| {{MenuCommand|Disable touchscreen tilt gesture}}
 +
|  If checked, the tilting gesture will be disabled for pinch-zooming (two-finger zooming). This only affects the {{MenuCommand|3D Navigation}} set ''Gesture''.
 +
|-
 +
| {{MenuCommand|Rotate at cursor}}
 +
|  If checked, rotations in 3D will use the current cursor position as center for the rotation. Otherwise always the center of the screen will be used.
 +
|}
 +
 +
<div class="mw-translate-fuzzy">
 
[[Image:Preference_Display_Tab_01_fr.png]]
 
[[Image:Preference_Display_Tab_01_fr.png]]
 +
</div>
  
 
===Couleurs===
 
===Couleurs===
Line 337: Line 399:
 
Cet onglet est toujours disponible.
 
Cet onglet est toujours disponible.
  
 +
<div class="mw-translate-fuzzy">
 
Dans l'onglet ''Couleurs'', vous pouvez spécifier les éléments suivants :
 
Dans l'onglet ''Couleurs'', vous pouvez spécifier les éléments suivants :
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
Line 366: Line 429:
 
| Sélection de la couleur d'arrière-plan des conteneurs actifs dans l'arborescence. Par exemple, s'il y a plusieurs parties dans la vue arborescente et qu'une partie est basculée en tant que [[PartDesign_Body/fr#Statut_actif|corps actif]], la couleur d'arrière-plan sélectionnée apparaît dans la vue arborescente.
 
| Sélection de la couleur d'arrière-plan des conteneurs actifs dans l'arborescence. Par exemple, s'il y a plusieurs parties dans la vue arborescente et qu'une partie est basculée en tant que [[PartDesign_Body/fr#Statut_actif|corps actif]], la couleur d'arrière-plan sélectionnée apparaît dans la vue arborescente.
 
|}
 
|}
 +
</div>
  
 
[[Image:Preference_Display_Tab_02_fr.png]]
 
[[Image:Preference_Display_Tab_02_fr.png]]
Line 373: Line 437:
 
Cet onglet n'apparaît que si vous vous trouvez dans les ateliers [[Part_Module/fr|Part]] ou [[PartDesign_Workbench/fr|PartDesign]] ou si vous avez déjà travaillé dans ces ateliers avant.
 
Cet onglet n'apparaît que si vous vous trouvez dans les ateliers [[Part_Module/fr|Part]] ou [[PartDesign_Workbench/fr|PartDesign]] ou si vous avez déjà travaillé dans ces ateliers avant.
  
 +
<div class="mw-translate-fuzzy">
 
Dans l'onglet ''Couleurs de la pièce'', vous pouvez spécifier les éléments suivants :
 
Dans l'onglet ''Couleurs de la pièce'', vous pouvez spécifier les éléments suivants :
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
Line 398: Line 463:
 
| {{MenuCommand|Couleur de texte par défaut}}
 
| {{MenuCommand|Couleur de texte par défaut}}
 
| Sélection de la couleur de texte par défaut pour les annotations de document. Il n'y a actuellement aucune boîte de dialogue permettant d'ajouter des annotations aux documents. Des annotations peuvent être ajoutées seulement depuis la console Python avec cette commande :
 
| Sélection de la couleur de texte par défaut pour les annotations de document. Il n'y a actuellement aucune boîte de dialogue permettant d'ajouter des annotations aux documents. Des annotations peuvent être ajoutées seulement depuis la console Python avec cette commande :
 +
</div>
  
 
<code>obj=App.ActiveDocument.addObject("App::Annotation", "Label")</code>
 
<code>obj=App.ActiveDocument.addObject("App::Annotation", "Label")</code>
Line 454: Line 520:
 
Cette section est incomplète et nécessite de mentionner les pages de préférences de chaque atelier de base}}
 
Cette section est incomplète et nécessite de mentionner les pages de préférences de chaque atelier de base}}
  
Preferences for the more common workbenches are linked below.
+
<div class="mw-translate-fuzzy">
Some workbenches have no preferences.
+
Les préférences pour les ateliers les plus courants sont liées ci-dessous. Certains ateliers n'ont aucune préférence. D'autres ateliers facultatifs peuvent ne pas être répertoriés.
Other optional workbenches may not be listed.
+
</div>
  
 +
<div class="mw-translate-fuzzy">
 
* [[Arch Preferences/fr|Arch Préférences]]
 
* [[Arch Preferences/fr|Arch Préférences]]
 
* [[Draft Preferences/fr|Draft Préférences]]
 
* [[Draft Preferences/fr|Draft Préférences]]
Line 482: Line 549:
 
* Test Framework Préférences (aucune)
 
* Test Framework Préférences (aucune)
 
* Web Préférences (aucune)
 
* Web Préférences (aucune)
 +
</div>
  
 
=== Ateliers externes ===
 
=== Ateliers externes ===
Line 497: Line 565:
 
}}
 
}}
  
{{Userdocnavi/fr}}
+
[[Category:Preferences{{#translation:}}]]
 +
{{Userdocnavi{{#translation:}}}}

Latest revision as of 18:50, 28 March 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Introduction

Le réglage des préférences de FreeCAD est accessible par le menu Édition→ Préférences.

Les fonctionnalités de FreeCAD sont séparées en différents modules, chaque module étant responsable du fonctionnement d'un atelier spécifique. FreeCAD utilise aussi un concept nommé late loading (chargement tardif), qui veut dire que les composants ne sont chargés que lorsqu'ils sont nécessaires. Vous avez peut-être remarqué que quand vous sélectionnez un atelier dans la barre d'outil de FreeCAD, l'atelier et tout ses composants se chargent à ce moment. Ceci inclut ses réglages de préférences.

Sans aucun module chargé, vous aurez accès à deux sections de configuration, responsables des réglages de préférences générales et des réglages d'affichage. Lorsque vous vous trouvez dans un certain atelier, les préférences de cet atelier apparaissent en tant que nouvelle section et les formats de fichier pris en charge par l'atelier apparaissent en tant que nouvel onglet dans la section Importer-Exporter.

Cliquez sur le bouton Réinitialiser situé dans le coin inférieur gauche de la fenêtre des préférences définit les valeurs par défaut de toutes les préférences de FreeCAD.

Préférences générales

Cette section de préférences a 6 onglets : Général, Document, Éditeur, Fenêtre de sortie, Macro, et Unités.

Général

Dans l'onglet Général, vous pouvez spécifier les éléments suivants:

Nom Description
Changer la langue Sélectionnez la langue de l'interface utilisateur de FreeCAD
Taille de la liste des fichiers récents Spécification du nombre de fichiers à répertorier dans la liste des fichiers récents
Activer l'arrière-plan en mosaïque Background.png

Cette option n’a un effet que si Feuille de style/Aucune feuille de style est sélectionné.

L'image peut être modifiée en ajoutant les dossiers Gui/Images dans le dossier

%APPDATA%/FreeCAD (sous Windows),

$HOME/.FreeCAD (sur Linux) ou

$HOME/Library/Preferences/FreeCAD (sous MacOS).

Placez-y un fichier nommé background.png et cochez/décocher cette option pour voir le fichier modifié.

Feuille de style Sélection d'une feuille de style. Les feuilles de style définissent l'apparence de l'interface utilisateur de FreeCAD.
Taille des icônes de la barre d'outils Sélection de la taille des icônes de la barre d’outils
Mode d'affichage d'arborescence Personnalisation de l'affichage de l'arborescence dans le panneau (redémarrage requis). Les options sont les suivantes:
  • Vue combinée: combine l'arborescence et la vue des propriétés dans un seul panneau.
  • TreeView and PropertyView: divise l'arborescence et la vue des propriétés en panneau séparé.
  • Both: conserve les trois panneaux et vous pouvez avoir deux ensembles d'arborescence et de propriété.
Module de chargement automatique après le démarrage Sélection du plan de travail qui sera utilisé directement après le démarrage de FreeCAD
Active l'écran de démarrage au démarrage Si cette case est cochée, l'écran de démarrage de FreeCAD s'affiche au démarrage.

L'image de l'écran de démarrage peut être modifiée en ajoutant les dossiers Gui/Images dans le dossier %APPDATA%/FreeCAD (où %APPDATA% est le dossier d’installation spécifique à l’utilisateur de FreeCAD de votre système d’exploitation). Mettez-y un fichier nommé splash_image.png et redémarrez FreeCAD pour voir l'écran de démarrage modifié.

Activer le retour à la ligne Les mots seront enveloppés lorsqu'ils dépasseront l'espace horizontal disponible dans la console Python. Cette console s’affiche à l’aide du menu View → Panels → Console Python.

Preference General Tab 01 fr.png

Document

Dans l'onglet Document, vous pouvez spécifier les éléments suivants:

Nom Description
Créer un nouveau document au démarrage Si coché, FreeCAD créera un nouveau document au démarrage
Niveau de compression de sauvegarde du document Spécification du niveau de compression pour les fichiers FCStd. Les fichiers FCStd sont des fichiers compressés ZIP. Par conséquent, vous pouvez renommer leur suffixe .FCStd en .zip et les ouvrir avec un programme d'archive ZIP.
Utilisation des fonctions Annuler /Rétablir sur les documents Si cette case est cochée, toutes les modifications apportées aux documents sont stockées afin de pouvoir être annulées /refaites.
Nombre maximum d'étapes d'annulation /de rétablissement Spécification du nombre d'étapes Annuler /Rétablir à enregistrer
Autoriser l'interruption du recalcul Permet d'interrompre le recalcul du document en appuyant sur Esc. Cela peut augmenter légèrement le temps de recalcul.
Exécuter la récupération automatique au démarrage Si un fichier de récupération est disponible, FreeCAD exécutera automatiquement une récupération de fichier au démarrage. De cette façon, les fichiers peuvent être restaurés en cas de panne.
Enregistrer les informations de récupération automatique tous les Spécification de la fréquence d'écriture d'un fichier de récupération.
Enregistrer la miniature dans le fichier de projet lors de l'enregistrement du document Si cette case est cochée, une miniature sera également stockée lors de l'enregistrement du document. La vignette sera par exemple affichée dans la liste des fichiers récents dans l'atelier Start. Il est possible de sélectionner une 'Taille' entre 128 × 128 et 512 × 512 pixels pour la vignette. Les tailles courantes sont les puissances de deux: 128, 256, 512.
Ajouter le logo du programme à la miniature générée Si cette case est cochée, le logo du programme FreeCAD FreeCAD-logo.svg sera ajouté à la vignette. Cette option n'a d'effet que si Enregistrer la miniature dans le fichier de projet lors de l'enregistrement du document est utilisé.
Nombre maximal de fichiers de sauvegarde à conserver lors de la réenregistrement de document Si cette case est cochée, les fichiers de sauvegarde seront conservés lors de l'enregistrement du document. Vous pouvez spécifier combien de fichiers de sauvegarde seront conservés. Ils contiennent la version du document précédemment enregistrée. Le premier fichier de sauvegarde aura le suffixe de fichier .FCStd1, le second .FCStd2 et ainsi de suite.
Utiliser la date et l'extension FCBak Si coché, les fichiers de sauvegarde auront l'extension .FCbak et leurs noms de fichiers auront un suffixe de date selon le format de date spécifié. Pour une description du format de date, voir ce site.

Avec les paramètres par défaut, le fichier de sauvegarde obtiendra par exemple ce nom TD-Cube.20200315-215654.FCBak (le nom de fichier d'origine est TD-Cube.FCStd ).

Autoriser les étiquettes d'objet en double dans un document Si coché, les objets peuvent avoir le même label /nom. Par exemple, différentes parties ou fonctions peuvent avoir le même nom dans le même document.
Désactiver le chargement partiel des objets liés externes Activez le chargement partiel du document lié externe. Lorsque cette option est activée, seuls les objets référencés et leurs dépendances seront chargés lorsqu'un document lié est ouvert automatiquement avec le document principal. Un document partiellement chargé ne peut pas être modifié. Double-cliquez sur l'icône du document dans l'arborescence pour le recharger complètement. Une explication plus détaillée de la fonctionnalité peut être trouvée sur la page de documentation Assembly3
Nom de l'auteur Tous les documents qui seront créés obtiendront le nom d'auteur spécifié. Laissez le champ auteur vide pour un auteur anonyme. Si l'option Set on save est cochée, le champ Last modified by sera défini sur l'auteur spécifié lors de l'enregistrement du fichier. Ce champ peut être affiché à l'aide du menu Fichier → Project information.
Entreprise Tous les documents qui seront créés recevront le nom de l'entreprise spécifié
Licence par défaut Sélection d'une licence par défaut pour les nouveaux documents. Pour une licence prédéfinie, URL de licence sera automatiquement définie en conséquence. Sélectionnez «Autre» pour une licence propre ou spéciale.
URL de licence Spécification d'une URL décrivant la licence sélectionnée dans Licence par défaut

Preference General Tab 02 fr.png

Éditeur

Les paramètres de préférences de l'éditeur affectent le comportement de l'éditeur de macro. L'éditeur peut être ouvert à l’aide du menu Macro → Macros ... → Éditer/Créer.

Les paramètres de couleur et de police affectent également la console Python. Cette console s’affiche à l’aide du menu Affichage → Panneaux → Console Python.

Dans l'onglet Éditeur, vous pouvez spécifier les éléments suivants :

Nom Description
Éléments d'affichage Sélection du type de code. Les paramètres de couleur et de police seront appliqués au type sélectionné. Le résultat est visible dans le champ Aperçu.
Police Spécification de la famille de polices à utiliser pour le type de code sélectionné
Taille Spécification de la taille de la police à utiliser pour le type de code sélectionné
Activer la numérotation des lignes Si coché, les lignes de code seront numérotées
Taille des tabulations Spécification du raster de tabulation (combien d'espaces). Si, par exemple, il est réglé sur "6", une pression sur Tab permet de passer au caractère 7, 13, 19, etc., en fonction de la position actuelle du curseur. Ce paramètre est utilisé uniquement si Garder les tabulations est activé.
Taille de retrait Spécification du nombre d'espaces insérés lors de la pression de Tab. Ce paramètre est utilisé uniquement si Insérer des espaces est sélectionné.
Garder les tabulations Si cette option est sélectionnée, une pression sur Tab insérera une tabulation avec le raster défini par Taille des tabulations.
Insérer des espaces Si cette option est sélectionnée, une pression sur Tab insérera le nombre d'espaces définis par Taille de retrait.

Preference General Tab 03 fr.png

Fenêtre de sortie

Les préférences de sortie affectent le comportement de la vue Rapport.

Dans l'onglet Fenêtre de Sortie, vous pouvez spécifier les éléments suivants :

Nom Description
Enregistrer les messages du journal Si coché, les messages de journalisation seront également enregistrés. Ils seront affichés dans le panneau d'affichage Rapport avec la couleur définie dans Journal des messages. Ce panneau s’affiche à l’aide du menu Affichage → Panneaux → Vue rapport.
Enregistrer les avertissements Si coché, les avertissements seront enregistrés. Ils seront affichés dans le panneau d'affichage Rapport avec la couleur définie dans Avertissements.
Enregistrer les messages d'erreur Si coché, les messages d'erreur seront enregistrés. Ils seront affichés dans le panneau d'affichage Rapport avec la couleur définie dans Erreurs.
Afficher la vue rapport en cas d'erreur ou d'avertissement Si cette case est cochée, le panneau de laVue rapport s'affichera automatiquement dès qu'une erreur ou un avertissement est enregistré.
Messages normaux Spécification de la couleur de la police pour les messages normaux dans le panneau d'affichage Rapport.
Journal des messages Spécification de la couleur de police pour les messages de journal dans le panneau d'affichage Rapport.
Avertissements Spécification de la couleur de police pour les messages d'avertissement dans le panneau d'affichage Rapport.
Erreurs Spécification de la couleur de la police pour les messages d'erreur dans le panneau d'affichage Rapport.
Rediriger les messages internes Python vers la Vue rapport Si cette case est cochée, la sortie interne Python sera redirigée de la console Python vers le panneau d'affichage Rapport. La console Python s’affiche à l’aide du menu Affichage → Panneaux → Console Python.
Rediriger les erreurs internes Python vers la Vue rapport Si cette case est cochée, les messages d'erreur interne Python seront redirigés de la console Python vers le panneau d'affichage Rapport.

Preference General Tab 04 fr.png

Macro

Ces options contrôlent certains aspects de l'exécution des macros.

Dans l'onglet Macro, vous pouvez spécifier les éléments suivants :

Nom Description
Exécuter les macros dans l'environnement local Si coché, les variables définies par les macros sont créées en tant que variables locales, sinon en tant que variables globales Python
Chemin de la macro Spécification d'un chemin d'accès aux fichiers de macros
Enregistrement des commandes de l'interface graphique Si coché, les macros enregistrées contiendront également les commandes d'interface utilisateur.
Enregistrer comme un commentaire Si coché, les Macros enregistrées contiendront également des commandes d'interface utilisateur, mais sous forme de commentaires. Ceci est utile si vous ne souhaitez pas exécuter d'actions visibles lors de l'exécution de la macro mais voir ce qui peut être fait de manière visible.
Afficher les commandes de script dans la console Python Si cette case est cochée, les commandes exécutées par les scripts de macro sont affichées dans la console Python. Cette console s’affiche à l’aide du menu Affichage → Panneaux → Console Python.

Preference General Tab 05 fr.png

Unités

Cet onglet configure la manière dont les Unités sont affichées.

Dans l'onglet Unités, vous pouvez spécifier les éléments suivants :

Nom Description
Système de l'utilisateur Sélection d'un système d'unités devant être utilisé pour toutes les parties de FreeCAD
Nombre de décimales Nombre de décimales à afficher pour les nombres et les dimensions dans FreeCAD
Fraction minimale en pouce La fraction minimale en pouce qui doit être affichée. Ce paramètre est uniquement disponible si le système d’unités Construction US (ft-en/sqft/pi3) est utilisé.

Preference General Tab 06 fr.png

Préférences d'affichage

Cette section de préférences comporte deux onglets généraux, 3D View et Colors, et d'autres onglets en fonction des ateliers utilisés.

Vue 3D

Cet onglet est toujours disponible, et contrôle certaines caractéristiques de 3D view.

Dans l'onglet Vue 3D, vous pouvez spécifier les éléments suivants :

Nom Description
Afficher le système de coordonnées dans le coin Si coché, le système de coordonnées principal sera toujours affiché en bas à droite dans les fichiers ouverts.
Afficher le compteur d'images par seconde Si cette case est cochée, le temps nécessaire à la dernière opération et la fréquence d'images seront toujours indiqués en bas à gauche des fichiers ouverts.
Afficher le cube de navigation Si cette case est cochée, le cube de navigation sera toujours affiché sur le Coin sélectionné des fichiers ouverts.
Utiliser OpenGL Vertex Buffer Object Si cette case est cochée, Vertex Buffer Objects (VBO) sera utilisé. Un VBO est une fonctionnalité OpenGL qui fournit des méthodes pour télécharger des données de vertex (position, vecteur normal, couleur, etc.) sur la carte graphique. Les VBO offrent des gains de performances substantiels car les données résident dans la mémoire de la carte graphique plutôt que dans la mémoire système et peuvent donc être restituées directement par le GPU. Pour plus d'informations, voir cette page web.
Cache de rendu introduced in version 0.19 "Cache de rendu" ou "Accélération de rendu" sont expliqués plus en détail dans

Link#render-caching. Il y a 3 options:

  • Auto (par défaut), laissez Coin3D décider où mettre en cache.
  • Distributed, active manuellement le cache pour tous les nœuds racine du fournisseur de vue.
  • Centralized, désactive manuellement le cache sur tous les nœuds de tous les fournisseurs de vues et uniquement sur le nœud racine du graphe de la scène. Ceci offre une vitesse de rendu plus rapide mais une réponse plus lente à tout changement de scène.
Permettre l'animation Si coché, les rotations peuvent être animées. Si, par exemple, Navigation 3D est défini sur CAD et que la souris est déplacée alors que la molette de défilement et le bouton droit de la souris sont enfoncés, les pièces sont pivotées. Si vous maintenez la souris en mouvement tout en lâchant, par exemple le bouton droit de la souris, la rotation se poursuivra sous forme d'animation. Pour terminer l'animation, cliquez avec le bouton gauche de la souris.
Navigation 3D Sélection d'un ensemble de paramètres de navigation. Pour voir ce que chaque ensemble définit, sélectionnez un ensemble et appuyez sur le bouton Souris....
Style d'orbite Sélection du style d'orbite de rotation. Lorsque vous visualisez une pièce dans le plan XY et que vous vous trouvez en mode de rotation de la navigation 3D, la différence est la suivante: Si Trackball est sélectionné, déplacez la souris horizontalement pour faire pivoter la pièce autour de l'axe des Y, si Platine est sélectionné, la pièce sera pivotée autour de l'axe des Z.
Anticrénelage Sélection si et quel type d'anticrénelage multi-échantillons est utilisé.
Nouvelle orientation de la caméra du document Sélection de l'orientation de la caméra pour les nouveaux documents.
Nouvelle échelle de document affecte le "niveau de zoom" initial de la caméra pour les nouveaux documents. La valeur que vous définissez est le diamètre d'une sphère qui convient à la vue 3D. La valeur par défaut est 100 mm, ce qui est pratique pour les objets tels que les boîtes pour Arduino. Il définit également la taille initiale des entités d'origine (plans de base dans un nouveau corps PartDesign).
Zoom sur le curseur Si cette case est cochée, les opérations de zoom seront effectuées à la position du pointeur de la souris. Sinon, les opérations de zoom seront effectuées au centre de la vue actuelle. Le pas de Zoom définit l'amplitude du zoom. Un pas de zoom de '1' signifie un facteur de 7,5 pour chaque pas de zoom.
Inverser le zoom Si coché, le sens des opérations de zoom sera inversé.
Désactiver l'inclinaison par geste de l'écran tactile Si cette case est cochée, le geste d’inclinaison sera désactivé pour le zoom par pincement (zoom à deux doigts). Ceci n'affecte que le Navigation 3D défini sur Gesture.
Glisser au curseur Si cette case est cochée, les rotations en 3D utiliseront la position actuelle du curseur comme centre de la rotation. Sinon, le centre de l'écran sera toujours utilisé.
Taille du marqueur Sélection de la taille des sommets (points) dans Sketcher. La zone cliquable des points peut également être agrandie en augmentant le rayon de sélection (onglet Couleurs).
Distance entre les yeux pour les modes stéréo Spécification de la distance œil-à-œil utilisée pour les projections stéréoscopiques. La valeur spécifiée est un facteur qui sera multiplié par la taille bounding box de l'objet 3D actuellement affiché.
Activer la couleur de rétroéclairage Si coché, le rétroéclairage est activé avec la couleur définie. Le rétroéclairage est utilisé pour le rendu des côtés arrières des faces (en général, vous ne les voyez pas dans les solides, sauf si vous en coupez une avec un plan de découpe ou si les faces ne sont pas orientées correctement). Il n'est actif que pour les objets dont la propriété Lighting (onglet View) est définie sur "One side". Si cette option est désactivée, le verso des faces des objets en mode d'éclairage "One side" sera noir.
Intensité du rétro-éclairage Spécification de l'intensité du rétro-éclairage. Ce paramètre est activé uniquement si Activer la couleur de rétroéclairage est coché.
Type de caméra Sélection du type de projection de la caméra.
  • Rendu en perspective, les objets apparaîtront en perspective.
  • Rendu orthogonal, les objets seront projetés en mode orthogonal.


Preference Display Tab 01.png

Navigation

This tab is always available, and controls the behavior of the navigation tools.


In the Navigation tab you can specify the following:

Name Description
Navigation cube If checked, the navigation cube will always be shown. Related Steps by turn defines how many steps (notches) will be applied when using the Navigation cube rotation arrows. Related Corner defines where the Navigation cube is displayed on the screen when creating/opening a document
3D Navigation Selection of a navigation settings set. To see what each set defines, select a set and press the button Mouse....
Orbit style Selection of the rotation orbit style. When viewing a part in the x-y plane an being in the rotation mode of the 3D navigation, the difference is: If Trackball is selected, moving the mouse horizontally will rotate the part around the y-axis, if Turntable is selected the part will be rotated around the z-axis.
New Document Camera Orientation Selection of the camera orientation for new documents
New Document Scale Affects the initial "zoom level" of camera for new documents. The value you set is the diameter of a sphere that fits in 3D view. Default is 100 mm, convenient for objects like boxes for Arduino. It also sets initial size of origin features (base planes in a new PartDesign Body).
Enable animation If checked, rotations can be animated. If for example the 3D Navigation set CAD is used and the mouse is moved while the scroll wheel and the right mouse button is pressed, parts are rotated. If one keeps the mouse moving while releasing e.g. the right mouse button, the rotation will continue as animation. To end the animation left-click with the mouse.
Zoom at cursor If checked, zoom operations will be performed at the position of the mouse pointer. Otherwise zoom operations will be performed at the center of the current view. The Zoom step defines how much will be zoomed. A zoom step of '1' means a factor of 7.5 for every zoom step.
Invert zoom If checked, the direction of zoom operations will be inverted.
Disable touchscreen tilt gesture If checked, the tilting gesture will be disabled for pinch-zooming (two-finger zooming). This only affects the 3D Navigation set Gesture.
Rotate at cursor If checked, rotations in 3D will use the current cursor position as center for the rotation. Otherwise always the center of the screen will be used.

Preference Display Tab 01 fr.png

Couleurs

Cet onglet est toujours disponible.

Dans l'onglet Couleurs, vous pouvez spécifier les éléments suivants :

Nom Description
Activer la surbrillance de présélection Si cette case est cochée, la présélection est activée et sera mise en évidence par la couleur spécifiée. La présélection signifie que, par exemple, des arêtes dans certaines parties seront mises en surbrillance lorsque vous les survolez avec la souris pour indiquer qu'elles peuvent être sélectionnées.
Activer la surbrillance de sélection Si cette case est cochée, la surbrillance de la sélection est activée et la couleur spécifiée sera utilisée pour cela.
Sélectionner le rayon Définit la zone de sélection des éléments en vue 3D. Une valeur plus grande facilite la tâche, mais rend impossible la sélection de petits éléments.
Couleur simple Si sélectionné, l’arrière-plan des pièces aura la couleur sélectionnée.
Dégradé de couleurs Si sélectionné, l’arrière-plan des pièces aura le dégradé de couleur sélectionné.
Couleur intermédiaire N'est activé que si Dégradé de couleurs est sélectionné. Si cette case est cochée, le dégradé de couleur aura la couleur sélectionnée en tant que couleur intermédiaire.
Objet en cours d'édition Sélection de la couleur d'arrière-plan pour les objets de la vue arborescente en cours d'édition.
Conteneur actif Sélection de la couleur d'arrière-plan des conteneurs actifs dans l'arborescence. Par exemple, s'il y a plusieurs parties dans la vue arborescente et qu'une partie est basculée en tant que corps actif, la couleur d'arrière-plan sélectionnée apparaît dans la vue arborescente.

Preference Display Tab 02 fr.png

Couleurs des pièces

Cet onglet n'apparaît que si vous vous trouvez dans les ateliers Part ou PartDesign ou si vous avez déjà travaillé dans ces ateliers avant.

Dans l'onglet Couleurs de la pièce, vous pouvez spécifier les éléments suivants :

Nom Description
Couleur des formes par défaut Sélection de la couleur par défaut pour les nouvelles formes. Si l'option Couleur des formes aléatoire est activée, une couleur aléatoire est utilisée.
Couleur de ligne par défaut Sélection de la couleur de ligne par défaut pour les nouvelles formes.
Épaisseur de trait par défaut Spécification de l'épaisseur de trait par défaut pour les nouvelles formes.
Couleur de sommet par défaut Sélection de la couleur par défaut pour les nouveaux vertices.
Taille de sommet par défaut Spécification de la taille par défaut pour les nouveaux vertices.
Couleur de la boite englobante Sélection de la couleur de Bounding box dans la vue 3D.
Couleur de texte par défaut Sélection de la couleur de texte par défaut pour les annotations de document. Il n'y a actuellement aucune boîte de dialogue permettant d'ajouter des annotations aux documents. Des annotations peuvent être ajoutées seulement depuis la console Python avec cette commande :

obj=App.ActiveDocument.addObject("App::Annotation", "Label")

Cette console est affichée à l'aide du menu Affichage → Panneaux → Console Python.

Preference Display Tab 03 fr.png

Vue maillage

Cet onglet ne s'affiche que si vous êtes dans l'atelier Mesh ou si vous avez déjà été dans cet atelier.

Dans l'onglet Vue Maillage, vous pouvez spécifier les éléments suivants :

Nom Description
Couleur de maillage par défaut Sélection de la couleur par défaut pour les nouveaux maillages
Couleur de ligne par défaut Sélection de la couleur de ligne par défaut pour les nouveaux maillages
Transparence du maillage Spécification de la transparence par défaut pour les nouveaux maillages
Transparence de ligne Spécification de la transparence de ligne par défaut pour les nouveaux maillages
Rendu bi-faces Si coché, le rendu de la face inférieure de la surface sera identique à celui de la face supérieure. Si non coché, cela dépendra de l'option Activer la couleur de rétroéclairage (voir la section Vue 3D). La couleur de rétroéclairage sera utilisée ou noire.
Afficher le cadre de sélection pour les maillages mis en surbrillance ou sélectionnés Si coché, un cadre de sélection jaune s'affiche pour les maillages sélectionnés ou en surbrillance.
Définissez la valeur normale par sommet Si coché, l'ombrage progressif sera utilisé, sinon l'ombrage est uniforme. L'ombrage définit l'apparence des surfaces. Avec un ombrage uniforme, les normales de surface ne sont pas définies par sommet, ce qui donne un aspect irréel aux surfaces courbes, tandis que l'utilisation de l'ombrage progressif permet d'obtenir un aspect plus lisse.
Angle de courbure L'angle de courbure est un angle de seuil entre deux faces. Il ne peut être défini que si l'option Définir la normale par sommet est utilisée.
Si angle entre faces ≥ angle de froissage, l’ombrage des facettes est utilisé
Si angle entre faces < angle de froissage, l’ombrage est uniforme

Mesh View Preferences.png

Options d'Import-Export

Les paramètres d'import-export affectent la manière dont les fichiers sont importés et exportés vers et depuis FreeCAD. Ils sont décrits dans la page Préférences d’import-export.

Préférences d'ateliers

Cette section est incomplète et nécessite de mentionner les pages de préférences de chaque atelier de base


Les préférences pour les ateliers les plus courants sont liées ci-dessous. Certains ateliers n'ont aucune préférence. D'autres ateliers facultatifs peuvent ne pas être répertoriés.

Ateliers externes

Cette section est incomplète et nécessite de mentionner les pages de préférences de chaque atelier externe