Difference between revisions of "Preferences Editor/de"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
 
(79 intermediate revisions by 4 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{docnav/de
+
{{Docnav/de
|[[Document structure|Document structure]]
+
|[[Document structure/de|Dokumentenstruktur]]
|[[Import Export Preference|Import Export Preference]]
+
|[[Import_Export_Preferences/de|Import Export Einstellungen]]
 
}}
 
}}
  
Die Einstellungen für FreeCAD befinden sich im Verzeichnis {{MenuCommand|Bearbeiten → Einstellungen}}
+
==Einführung==
  
Die FreeCAD Funktionalität ist in verschiedene Module unterteilt, wobei jedes Modul für die Arbeit mit einer bestimmten [[Workbenches|Arbeitsbereichen]] verantwortlich ist. FreeCAD verwendet auch ein Konzept namens late loading, d.h. Komponenten werden nur dann geladen, wenn sie benötigt werden. Du hast vielleicht bemerkt, dass bei der Auswahl eines Arbeitsbereichs in der FreeCAD Werkzeugleiste dieser Arbeitsbereich und alle ihre Komponenten in diesem Moment geladen werden. Dazu gehören auch die Einstellungen.
+
Die Einstellungssystem für FreeCAD befindet sich in den {{MenuCommand|[[Std Edit Menu/de|Bearbeiten]] → Einstellungen...}}. Im Mac OS erscheint die {{MenuCommand|Einstellungen...}} Menüoption im FreeCAD Menü anstatt im Bearbeitungsmenü (dies ist der vorgegebene Ort für Einstellungen auf dem Mac).
  
Ohne geladenes Modul hast Du Zugriff auf zwei Konfigurationsabschnitte, die für die allgemeinen Anwendungseinstellungen und die Anzeigeeinstellungen verantwortlich sind. Wenn Du dich in einem bestimmten Arbeitsbereich befindest, erscheinen die Einstellungen dieses Arbeitsbereichs als neuer Abschnitt und die von dem Arbeitsbereich unterstützten Dateiformate als neue Registerkarte im Abschnitt {{MenuCommand|Import-Export}}.
+
{{TOCright}}
 +
Die FreeCAD Funktionalität sind in verschiedene Module unterteilt, jedes Modul ist für die Arbeit mit einem bestimmten [[Workbenches/de|Arbeitsbereich]] zuständig. FreeCAD verwendet auch das Konzept  '''"late loading"''', d.h., dass '''Komponenten nur dann geladen werden, wenn sie benötigt werden'''. Man erkennt, dass bei der Auswahl eines Arbeitsbereichs in der FreeCAD Werkzeugleiste dieser Arbeitsbereich und all seine Komponenten in diesem Moment geladen werden. '''Dies schließt auch seine bevorzugten Einstellungen ein'''.
  
Wenn du auf die Schaltfläche {{Button|Reset}} in der unteren linken Ecke einer beliebigen Einstellungsanzeige klickst, wird '''all''' der FreeCAD Einstellungen auf ihre Standardwerte gesetzt.
+
Ohne ein geladenes Modul hat man Zugriff auf zwei Konfigurationsabschnitte, die für die allgemeinen Anwendungs- und die Anzeigeeinstellungen zuständig sind. Befindet man sich in einem bestimmten Arbeitsbereich, erscheinen die Einstellungen dieses Arbeitsbereichs als neuer Abschnitt und die von diesem Arbeitsbereich unterstützten Dateiformate erscheinen als neue Registerkarte im Abschnitt {{MenuCommand|[[#Import-Export Settings|Import-Export]]}}.
 +
 
 +
Klicken der {{Button|Reset}} Schaltfläche in der unteren linken Ecke einer beliebigen Einstellungsanzeige, wird '''alle''' FreeCAD Einstellungen auf ihre Standardwerte setzen.
 +
 
 +
{{emphasis|Note:}} for more fine-tuned control of preferences see [[Parameter editor]] and [[Fine-tuning]]
  
 
==Allgemeine Einstellung==
 
==Allgemeine Einstellung==
  
Dieser Einstellungsbereich hat 6 Registerkarten: Allgemein, Dokument, Editor, Ausgabefenster, Makro und Einheiten.
+
Dieser Einstellungsbereich hat 6 Reiter: Allgemein, Dokument, Editor, Ausgabefenster, Makro und Einheiten.
  
 
===Allgemeines===
 
===Allgemeines===
Line 24: Line 29:
 
!style="width: 66%;"|Beschreibung
 
!style="width: 66%;"|Beschreibung
 
|-
 
|-
| {{MenuCommand|Change language}}
+
| {{MenuCommand|Sprache ändern}}
 
| Wähle die Sprache der Benutzeroberfläche von FreeCAD aus.
 
| Wähle die Sprache der Benutzeroberfläche von FreeCAD aus.
 
|-
 
|-
| {{MenuCommand|Größe der Liste der letzten Dateien}}}}}
+
| {{MenuCommand|Größe der Liste der letzten Dateien}}
 
| Gib an, wie viele Dateien in der Liste der letzten Dateien aufgelistet werden sollen.
 
| Gib an, wie viele Dateien in der Liste der letzten Dateien aufgelistet werden sollen.
 
|-
 
|-
| {{MenuCommand|Aktivieren des gekachelten Hintergrunds}}}}
+
| {{MenuCommand|Aktivieren des gekachelten Hintergrunds}}
 
| Wenn diese Option aktiviert ist, besteht der Hintergrund des Hauptfensters von FreeCAD standardmäßig aus Kacheln dieses Bildes: [[File:Background.png|64px]]
 
| Wenn diese Option aktiviert ist, besteht der Hintergrund des Hauptfensters von FreeCAD standardmäßig aus Kacheln dieses Bildes: [[File:Background.png|64px]]
  
Line 37: Line 42:
 
Das Bild kann geändert werden, indem die Ordner {{FileName|Gui/Images}} im Ordner hinzufügt werden.
 
Das Bild kann geändert werden, indem die Ordner {{FileName|Gui/Images}} im Ordner hinzufügt werden.
  
[https://www.howtogeek.com/318177/what-is-the-appdata-folder-in-windows/ {{FileName|%APPDATA%]/FreeCAD}} (on Windows),
+
[https://www.howtogeek.com/318177/what-is-the-appdata-folder-in-windows/ {{FileName|%APPDATA%]/FreeCAD}} (in Windows),
  
{{FileName/de|$HOME/.FreeCAD}} (auf Linux) oder
+
{{FileName|$HOME/.FreeCAD}} (auf Linux) oder
  
 
{{FileName|$HOME/Library/Preferences/FreeCAD}} (auf MacOS).
 
{{FileName|$HOME/Library/Preferences/FreeCAD}} (auf MacOS).
  
Lege dort eine Datei namens {{FileName|background.png}} an und deaktiviere diese Option, um die geänderte Datei anzuzeigen.
+
Dort eine Datei mit dem Namen {{FileName|background.png}} anlegen und diese Option abwählen/wählen, um die geänderte Datei anzuzeigen.
 
|-
 
|-
| {{MenuCommand|Style sheet}}
+
| {{MenuCommand|Formatvorlage}}
 
| Auswahl einer Formatvorlage. Die Formatvorlagen definieren, wie die Benutzeroberfläche von FreeCAD aussieht.
 
| Auswahl einer Formatvorlage. Die Formatvorlagen definieren, wie die Benutzeroberfläche von FreeCAD aussieht.
 
|-
 
|-
| {{MenuCommand|Size of toolbar icons}}
+
| {{MenuCommand|Größe der Werkzeugleistensymbole}}
| Auswahl der Größe für die Symbole der Werkzeugleiste
+
| Auswahl der Größe für die Werkzeugleistensymbole
 +
|-
 +
| {{MenuCommand|Baumansichtsmodus}}
 +
| Anpassung, wie die Baumansicht im Paneel angezeigt wird (Neustart erforderlich). Die Optionen sind:
 +
* '''Combo Ansicht''': Kombiniert die Baumansicht und die Eigenschaftsansicht in einem Paneel.
 +
* '''Baumansicht und Eigenschaftsansicht''': teile die Baumansicht und die Eigenschaftsansicht in ein separates Paneel.
 +
* '''Beide'''': alle drei Paneele beibehalten, und du kannst zwei Sätze von Baumansicht und Eigenschaftsansicht haben.
 
|-
 
|-
| {{MenuCommand|Auto load module after start up}}
+
| {{MenuCommand|Modul nach dem Start automatisch laden}}
| Auswahl, welcher Arbeitsbereich direkt nach dem Start von FreeCAD verwendet wird.
+
| Auswahl, welcher Arbeitsbereich direkt nach dem Start von FreeCAD verwendet werden soll
 
|-
 
|-
| {{MenuCommand|Enable splash screen at start up}}
+
| {{MenuCommand|Startbildschirm beim Start aktivieren}}
| Wenn diese Option aktiviert ist, wird beim Start der Splash-Screen von FreeCAD angezeigt.
+
| Wenn diese Option angehakt ist, wird der Startbildschirm von FreeCAD beim Start angezeigt.
  
Das Splash-Screen-Bild kann geändert werden, indem die Ordner {{FileName|Gui/Images}}} im Ordner {{FileName|%APPDATA%/FreeCAD}}} hinzugefügt werden. (wobei %APPDATA% der benutzerspezifische Anwendungsordner von FreeCAD des Betriebssystems ist). Lege dort eine Datei namens {{FileName|splash_image.png}}} an und starte FreeCAD neu, um den geänderten Startbildschirm zu sehen.
+
Das Begrüßungsbildschirmbild kann geändert werden, indem die Ordner {{FileName|Gui/Images}}} im Ordner {{FileName|%APPDATA%/FreeCAD}}} hinzugefügt werden. (wobei %APPDATA% der benutzerspezifische Anwendungsordner von FreeCAD des Betriebssystems ist). Lege dort eine Datei namens {{FileName|splash_image.png}}} an und starte FreeCAD neu, um den geänderten Startbildschirm zu sehen.
 
|-
 
|-
 
| {{MenuCommand|Enable word wrap}}
 
| {{MenuCommand|Enable word wrap}}
Line 67: Line 78:
 
===Dokument===
 
===Dokument===
  
In the ''Document'' tab you can specify the following:
+
<div class="mw-translate-fuzzy">
 +
Im Reiter ''Document'' kann man folgendes festlegen:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
 
|-
 
|-
| {{MenuCommand|Create new document at start up}}
+
</div>
| If checked, FreeCAD will create a new document when started
 
|-
 
| {{MenuCommand|Document save compression level}}
 
|  Specification of the compression level for {{FileName|FCStd}} files. {{FileName|FCStd}} files are ZIP-compressed files. Therefore you can rename their suffix {{FileName|.FCStd}} to {{FileName|.zip}} and open them with a ZIP archive program.
 
|-
 
| {{MenuCommand|Using Undo/Redo on documents}}
 
|  If checked, all changes in documents are stored so that they can be undone/redone
 
|-
 
| {{MenuCommand|Maximum Undo/Redo steps}}
 
|  Specification how many Undo/Redo steps should be recorded
 
|-
 
| {{MenuCommand|Run AutoRecovery at startup}}
 
|  If there is a recovery file available FreeCAD will automatically run a file recovery when it is started. This way files can be restored if a crash occurred.
 
|-
 
| {{MenuCommand|Save AutoRecovery information every}}
 
|  Specification how often a recovery file is written.
 
|-
 
| {{MenuCommand|Save thumbnail into project file when saving document}}
 
|  If checked, also a thumbnail will be stored when the document is saved. The thumbnail will for example be shown in the list of recent files in the [[Start_Workbench|Start workbench]].
 
|-
 
| {{MenuCommand|Add the program logo to the generated thumbnail}}
 
|  If checked, the FreeCAD program logo [[image:FreeCAD-logo.svg|24px]] will be added to the thumbnail. This option only has an effect if {{MenuCommand|Save thumbnail into project file when saving document}} is used.
 
|-
 
| {{MenuCommand|Maximum number of backup files to keep when resaving document}}
 
|  If checked, backup files will be kept when saving the document. You can specify how many backup files will be kept. They contain the previously saved document version. The first backup file will have the file suffix {{FileName|.FCStd1}}, the second {{FileName|.FCStd2}} and so on.
 
|-
 
| {{MenuCommand|Disable partial loading of external linked objects}}
 
|  Enable partial loading of external linked document. When enabled, only the referenced objects and their dependencies will be loaded when a linked document is auto opened together with the main document. A partially loaded document cannot be edited. Double click the document icon in the tree view to reload it in full. A more detailed explanation of the feature can be found on the [https://github.com/realthunder/FreeCAD_assembly3/wiki/Core-Changes#partial-document-loading Assembly3 documentation page]
 
|-
 
| {{MenuCommand|Allow duplicate object labels in one document}}
 
|  If checked, objects can have the same label/name. For example different parts or features can then have the same name in the same document.
 
|-
 
| {{MenuCommand|Author name}}
 
|  All documents that will be created will get the specified author name. Keep the author field blank for an anonymous author. If the option {{MenuCommand|Set on save}} is checked, the field ''Last modified by'' will be set to the specified author when saving the file. This field can be viewed using the menu {{MenuCommand|File → Project information}}.
 
|-
 
| {{MenuCommand|Company}}
 
|  All documents that will be created will get the specified company name
 
|-
 
| {{MenuCommand|Default license}}
 
|  Selection of a default license for new documents. For predefined license the {{MenuCommand|License URL}} will automatically be set accordingly. Select 'Other' for an own or special license.
 
|-
 
| {{MenuCommand|License URL}}
 
|  Specification of an URL describing the license selected in {{MenuCommand|Default license}}
 
|}
 
  
 
[[Image:Preference_General_Tab_02.png]]
 
[[Image:Preference_General_Tab_02.png]]
Line 126: Line 94:
 
Die Farb- und Schrifteinstellungen wirken sich auch auf die [[Python console/de|Python-Konsole]] aus. Diese Konsole wird über das Menü {{MenuCommand|View → Panels → Python console}} angezeigt.
 
Die Farb- und Schrifteinstellungen wirken sich auch auf die [[Python console/de|Python-Konsole]] aus. Diese Konsole wird über das Menü {{MenuCommand|View → Panels → Python console}} angezeigt.
  
In the ''Editor'' tab you can specify the following:
+
Im ''Editor'' Reiter kannst du Folgendes angeben:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
 +
|-
 +
| {{MenuCommand|Elemente anzeigen}}
 +
| Auswahl des Codetyps. Die Farb- und Schrifteinstellungen werden auf den ausgewählten Typ angewendet. Das Ergebnis ist im Feld '''Vorschau''' zu sehen.
 
|-
 
|-
| {{MenuCommand|Display Items}}
+
| {{MenuCommand|Familie}}
| Selection of the code type. The color and font settings will be applied to the selected type. The result can be seen in the '''Preview''' field.
+
| Angabe der Schriftfamilie, die für den gewählten Codetyp verwendet werden soll
 
|-
 
|-
| {{MenuCommand|Family}}
+
| {{MenuCommand|Größe}}
Specification of the font family that should be used for the selected code type
+
Angabe der Schriftgröße, die für den gewählten Codetyp verwendet werden soll
 
|-
 
|-
| {{MenuCommand|Size}}
+
| {{MenuCommand|Farbe}}
Specification of the font size that should be used for the selected code type
+
Angabe der Farbe, die für den gewählten Codetyp verwendet werden soll
 
|-
 
|-
| {{MenuCommand|Enable line numbers}}
+
| {{MenuCommand|Zeilennummern einschalten}}
| If checked, the code lines will be numbered
+
| Wenn markiert, werden die Codezeilen nummeriert
 
|-
 
|-
| {{MenuCommand|Tab size}}
+
| {{MenuCommand|Tabulator Größe}}
| Specification of the tabulator raster (how many spaces). If it is for example set to '6', pressing {{KEY|Tab}} will jump to character 7 or 13 or 19 etc., depending the current cursor position. This setting is only used if {{MenuCommand|Keep tabs}} is selected.
+
| Angabe des Tabulatorrasters (wie viele Leerzeichen). Wenn es z.B. auf '6' gesetzt ist, wird durch Drücken von {{KEY|Tab}} zum Zeichen 7 oder 13 oder 19 usw. gesprungen, abhängig von der aktuellen Cursorposition. Diese Einstellung wird nur verwendet, wenn {{MenuCommand|Tabulatoren behalten}} ausgewählt ist.
 
|-
 
|-
| {{MenuCommand|Indent size}}
+
| {{MenuCommand|Einrückungsgröße}}
| Specification of how many spaces will be inserted when pressing {{KEY|Tab}}. This setting is only used if {{MenuCommand|Insert spaces}} is selected.
+
| Angabe, wie viele Leerzeichen eingefügt werden, wenn {{KEY|Tab}} gedrückt wird. Diese Einstellung wird nur verwendet, wenn {{MenuCommand|Einfügen Leerzeichen}} ausgewählt ist.
 
|-
 
|-
| {{MenuCommand|Keep tabs}}
+
| {{MenuCommand|Tabulatoren behalten}}
If selected, pressing {{KEY|Tab}} will insert a tabulator with the raster defined by {{MenuCommand|Tab size}}
+
Falls ausgewählt, wird durch Drücken von {{KEY|Tab}} ein Tabulator mit dem durch {{MenuCommand|Tabulatorgröße}} definierten Raster eingefügt
 
|-
 
|-
| {{MenuCommand|Insert spaces}}
+
| {{MenuCommand|Leerzeichen einfügen}}
| If selected, pressing {{KEY|Tab}} will insert the amount of spaces defined by {{MenuCommand|Indent size}}
+
| Falls ausgewählt, wird durch Drücken von {{KEY|Tab}} die durch {{MenuCommand|Einrückungsgröße}} definierte Anzahl von Leerzeichen eingefügt
 
|}
 
|}
  
Line 162: Line 133:
 
Die Ausgabeeinstellungen beeinflussen das Verhalten der [[Report view/de|Berichtansicht]].
 
Die Ausgabeeinstellungen beeinflussen das Verhalten der [[Report view/de|Berichtansicht]].
  
In the ''Output'' tab you can specify the following:
+
<div class="mw-translate-fuzzy">
 +
Im ''Ausgabe'' Reiter kannst du Folgendes angeben:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
 
|-
 
|-
| {{MenuCommand|Record log messages}}
+
</div>
| If checked, also log messages will be recorded. They will be output in the Report view panel with the color set in {{MenuCommand|Log messages}}. This panel is shown using the menu  {{MenuCommand|View → Panels → Report view}}.
 
|-
 
| {{MenuCommand|Record warnings}}
 
|  If checked, warnings will be recorded. They will be output in the Report view panel with the color set in {{MenuCommand|Warnings}}.
 
|-
 
| {{MenuCommand|Record error messages}}
 
|  If checked, error messages will be recorded. They will be output in the Report view panel with the color set in {{MenuCommand|Errors}}
 
|-
 
| {{MenuCommand|Show report view on error or warning}}
 
|  If checked, report view panel will show up automatically as soon as an error or warning is logged.
 
|-
 
| {{MenuCommand|Normal messages}}
 
|  Specification of the font color for normal messages in the Report view panel.
 
|-
 
| {{MenuCommand|Log messages}}
 
|  Specification of the font color for log messages in the Report view panel.
 
|-
 
| {{MenuCommand|Warnings}}
 
|  Specification of the font color for warning messages in the Report view panel.
 
|-
 
| {{MenuCommand|Errors}}
 
|  Specification of the font color for error messages in the Report view panel.
 
|-
 
| {{MenuCommand|Redirect internal Python output to report view}}
 
|  If checked, internal Python output will be redirected from the Python console to the Report view panel. The Python console is shown using the menu  {{MenuCommand|View → Panels → Python console}}
 
|-
 
| {{MenuCommand|Redirect internal Python errors to report view}}
 
|  If checked, internal Python error messages will be redirected from the Python console to the Report view panel.
 
|}
 
  
 
[[Image:Preference_General_Tab_04.png]]
 
[[Image:Preference_General_Tab_04.png]]
Line 204: Line 147:
 
Diese Optionen steuern bestimmte Aspekte der Ausführung von [[macros|Makros]].
 
Diese Optionen steuern bestimmte Aspekte der Ausführung von [[macros|Makros]].
  
 +
<div class="mw-translate-fuzzy">
 
Auf der Registerkarte "Makro" kannst Du folgendes festlegen:
 
Auf der Registerkarte "Makro" kannst Du folgendes festlegen:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
 
|-
 
|-
| {{MenuCommand|Run macros in local environment}}
+
| {{MenuCommand|Makros in lokaler Umgebung ausführen}}
| If checked, variables defined by macros are created as local variables, otherwise as global Python variable
+
| Wenn angehakt, werden durch Makros definierte Variablen als lokale Variablen erstellt, andernfalls als globale Python Variable
 
|-
 
|-
| {{MenuCommand|Macro path}}
+
| {{MenuCommand|Makro Pfad}}
| Specification of a path to macro files
+
| Angabe eines Pfades zu Makro Dateien
 
|-
 
|-
| {{MenuCommand|Recording GUI commands}}
+
| {{MenuCommand|Aufzeichnung von GUI Befehlen}}
| If checked, [[Std_DlgMacroRecord|recorded macros]] will also contain user interface commands
+
| Wenn angehakt, enthält [[Std_DlgMacroRecord/de|Aufgezeichnete Makros]] auch Benutzeroberflächenbefehle
 
|-
 
|-
| {{MenuCommand|Record as comment}}
+
| {{MenuCommand|Aufzeichnung als Kommentar}}
| If checked, [[Std_DlgMacroRecord|recorded macros]] will also contain user interface commands but as comments. This is useful if you don't want to execute visible actions when running the macro but to see what could be done visibly.
+
| Wenn diese Option angehakt ist, enthält [[Std_DlgMacroRecord/de|Aufgezeichnete Makros]] auch Benutzeroberflächenbefehle, jedoch als Kommentare. Dies ist nützlich, wenn du beim Ausführen des Makros keine sichtbaren Aktionen ausführen willst, sondern sehen willst, was sichtbar getan werden könnte.
 
|-
 
|-
| {{MenuCommand|Show script commands in python console}}
+
| {{MenuCommand|Skriptbefehle in der Python Konsole anzeigen}}
| If checked, the commands executed by the macro scripts are shown in the Python console. This console is shown using the menu  {{MenuCommand|View Panels → Python console}}.  
+
| Wenn diese Option aktiviert ist, werden die von den Makroskripten ausgeführten Befehle in der Python Konsole angezeigt. Diese Konsole wird über das Menü {{MenuCommand|Ansicht Paneele → Python Konsole}} angezeigt.  
 
|}
 
|}
 +
</div>
  
 
[[Image:Preference_General_Tab_05.png]]
 
[[Image:Preference_General_Tab_05.png]]
Line 234: Line 179:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
 
|-
 
|-
| {{MenuCommand|User system}}
+
| {{MenuCommand|Benutzer System}}
| Selection of a unit system that should be used for all parts of FreeCAD
+
| Auswahl eines Einheitensystems, das für alle Teile von FreeCAD verwendet werden soll
 
|-
 
|-
| {{MenuCommand|Number of decimals}}
+
| {{MenuCommand|Anzahl der Dezimalstellen}}
| The number of decimals that should be shown for numbers and dimensions in FreeCAD
+
| Die Anzahl der Dezimalstellen, die für Zahlen und Abmessungen in FreeCAD angezeigt werden sollen
 
|-
 
|-
| {{MenuCommand|Minimum fractional inch}}
+
| {{MenuCommand|Minimaler Bruchteil eines Zolls}}
| Minimum fractional inch that should be displayed. This setting is only available if the unit system '''Building US (ft-in/sqft/cuft)''' is used.
+
| Minimaler Zoll Bruchteil , der angezeigt werden sollte. Diese Einstellung ist nur verfügbar, wenn das Einheitensystem '''Building US (ft-in/sqft/cuft)'''' verwendet wird.
 
|}
 
|}
  
Line 256: Line 201:
 
Diese Registerkarte ist immer verfügbar und steuert bestimmte Eigenschaften der [[3D view/de|3D Ansicht]].
 
Diese Registerkarte ist immer verfügbar und steuert bestimmte Eigenschaften der [[3D view/de|3D Ansicht]].
  
In the ''3D View'' tab you can specify the following:
+
Im ''3D Ansicht'' Reiter kannst du Folgendes angeben:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
|-
 
| {{MenuCommand|Show coordinate system in the corner}}
 
| If checked, the main coordinate system will always be shown at the lower right in opened files
 
|-
 
| {{MenuCommand|Show counter of frames per second}}
 
|  If checked, the time needed for the last operation and the resulting [https://en.wikipedia.org/wiki/Frame_rate frame rate] will always be shown at the lower left in opened files
 
|-
 
| {{MenuCommand|Show navigation cube}}
 
|  If checked, the [[Navigation_Cube|navigation cube]] will always be shown at the selected {{MenuCommand|Corner}} in opened files
 
|-
 
| {{MenuCommand|Use OpenGL Vertex Buffer Object}}
 
|  If checked, [https://en.wikipedia.org/wiki/Vertex_Buffer_Object Vertex Buffer Objects] (VBO) will be used. A VBO is an [https://en.wikipedia.org/wiki/OpenGL OpenGL] feature that provides methods for uploading vertex data (position, normal vector, color, etc.) to the graphics card. VBOs offer substantial performance gains because the data resides in the graphics memory rather than the system memory and so it can be rendered directly by GPU. For more background info see [https://www.haroldserrano.com/blog/understanding-opengl-objects this webpage].
 
|-
 
| {{MenuCommand|Render Cache}} {{Version|0.19}}
 
|  "Render Cache" or "Render Acceleration" is explained in more detail in [https://github.com/realthunder/FreeCAD_assembly3/wiki/Link#render-caching Link#render-caching]. There are 3 options:
 
* '''Auto''' (default), let Coin3D decide where to cache.
 
* '''Distributed''', manually turn on cache for all view provider root nodes.
 
* '''Centralized''', manually turn off cache in all nodes of all view providers, and only cache at the scene graph root node. This offers the fastest rendering speed, but slower response to any scene changes.
 
|-
 
| {{MenuCommand|Enable animation}}
 
|  If checked, rotations can be animated. If for example the {{MenuCommand|3D Navigation}} set ''CAD'' is used and the mouse is moved while the scroll wheel and the right mouse button is pressed, parts are rotated. If one keeps the mouse moving while releasing e.g. the right mouse button, the rotation will continue as animation. To end the animation left-click with the mouse.
 
|-
 
| {{MenuCommand|3D Navigation}}
 
|  Selection of a navigation settings set. To see what each set defines, select a set and press the button {{Button|Mouse...}}.
 
|-
 
| {{MenuCommand|Orbit style}}
 
|  Selection of the rotation orbit style. When viewing a part in the x-y plane an being in the rotation mode of the 3D navigation, the difference is: If '''Trackball''' is selected, moving the mouse horizontally will rotate the part around the y-axis, if '''Turntable''' is selected the part will be rotated around the z-axis.
 
|-
 
| {{MenuCommand|Anti-Aliasing}}
 
|  Selection if and what kind of [https://en.wikipedia.org/wiki/Multisample_anti-aliasing multisample anti-aliasing] is used
 
|-
 
| {{MenuCommand|New Document Camera Orientation}}
 
|  Selection of the camera orientation for new documents
 
|-
 
| {{MenuCommand|New Document Scale}}
 
|  Affects the initial "zoom level" of camera for new documents. The value you set is the diameter of a sphere that fits in 3D view. Default is 100 mm, convenient for objects like boxes for Arduino. It also sets initial size of origin features (base planes in a new PartDesign Body).
 
 
|-
 
|-
| {{MenuCommand|Zoom at cursor}}
 
|  If checked, zoom operations will be performed at the position of the mouse pointer. Otherwise zoom operations will be performed at the center of the current view. The {{MenuCommand|Zoom step}} defines how much will be zoomed. A zoom step of  '1' means a factor of 7.5 for every zoom step.
 
|-
 
| {{MenuCommand|Invert zoom}}
 
|  If checked, the direction of zoom operations will be inverted.
 
|-
 
| {{MenuCommand|Disable touchscreen tilt gesture}}
 
|  If checked, the tilting gesture will be disabled for pinch-zooming (two-finger zooming). This only affects the {{MenuCommand|3D Navigation}} set ''Gesture''.
 
|-
 
| {{MenuCommand|Drag at cursor}}
 
|  If checked, rotations in 3D will use the current cursor position as center for the rotation. Otherwise always the center of the screen will be used.
 
|-
 
| {{MenuCommand|Marker size}}
 
|  Selection of the size of [[Glossary#Vertex|vertices]] (points) in the [[Sketcher_Workbench|Sketcher workbench]]. The clickable area of points can be additionally enlarged by increasing {{MenuCommand|Pick radius}} (on Colors tab).
 
|-
 
| {{MenuCommand|Eye to eye distance for stereo modes}}
 
|  Specification of the eye-to-eye distance used for stereo projections. The specified value is a factor that will be multiplied with the [[Property_editor#View|bounding box]] size of the 3D object that is currently displayed.
 
|-
 
| {{MenuCommand|Enable backlight color}}
 
|  If checked, backlight is enabled with the defined color. Backlight is used for rendering back sides of faces (usually, you don't see them in solids, unless you slice one with a clipping plane, or if the faces aren't oriented correctly). It is only active for objects whose Lighting property (on View tab) is set to "One side". If disabled, back sides of faces of objects in "One side" lighting mode will be black.
 
|-
 
| {{MenuCommand|Intensity of backlight}}
 
|  Specification of the intensity of the backlight. This setting is only enabled if {{MenuCommand|Enable backlight color}} is checked.
 
|-
 
| {{MenuCommand|Camera type}}
 
|  Selection of the camera projection type.
 
  
* '''Perspective rendering''', objects will appear in a [https://en.wikipedia.org/wiki/Perspective_projection perspective projection].
+
* '''Perspektivisches Rendern''', Objekte werden in einer [https://de.wikipedia.org/wiki/Perspektive#Arten_perspektivischer_Darstellung] erscheinen.
* '''Orthographic rendering''', objects will be projected in [https://en.wikipedia.org/wiki/Orthographic_projection orthographic projection].
+
* '''Orthographisches Rendern''', Objekte werden in [https://en.wikipedia.org/wiki/Orthographic_projection orthographische Projektion] projiziert. Siehe auch [https://de.wikipedia.org/wiki/Projektionsmatrix_(Computer_Vision)]
 
|}
 
|}
 +
 +
 +
[[Image:Preference_Display_Tab_01.png]]
 +
 +
===Navigation===
 +
 +
 +
Dieser Reiter wird immer angezeigt und steuert das Verhalten des Navigationswerkzeugs.
 +
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
[[Image:Preference_Display_Tab_01.png|left]]
+
Im ''Navigation'' Reiter kannst du Folgendes angeben:
 +
{| class="wikitable float-right mw-collapsible mw-collapsed"
 +
!style="width: 33%;"|Name
 +
!style="width: 66%;"|Beschreibung
 +
|-
 
</div>
 
</div>
 +
 +
[[Image:Preference_Navigation_Tab.png]]
  
 
===Farben===
 
===Farben===
  
This tab is always available.
+
Dieser Reiter ist immer verfügbar.
  
In the ''Colors'' tab you can specify the following:
+
<div class="mw-translate-fuzzy">
 +
Im ''Farben'' Reiter kannst du Folgendes angeben:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
 
|-
 
|-
| {{MenuCommand|Enable preselection highlighting}}
+
</div>
| If checked, preselection is turned on and will be highlighted by the specified color. Preselection means that for example edges in parts will be highlighted while hovering with the mouse over them to indicate that they can be selected.
 
|-
 
| {{MenuCommand|Enable selection highlighting}}
 
|  If checked, selection highlighting is turned on and the specified color will be used for it
 
|-
 
| {{MenuCommand|Pick radius}}
 
|  Sets the area for picking elements in 3D view. Larger value makes it easier to pick things, but can make some small features impossible to select.
 
|-
 
| {{MenuCommand|Simple color}}
 
|  If selected, the background for parts will have the selected color
 
|-
 
| {{MenuCommand|Color gradient}}
 
|  If selected, the background for parts will have the selected color gradient
 
|-
 
| {{MenuCommand|Middle color}}
 
|  Is only enabled if {{MenuCommand|Color gradient}} is selected. If checked, the color gradient will get the selected color as middle color.
 
|-
 
| {{MenuCommand|Object being edited}}
 
|  Selection of the background color for objects in the tree view that are currently edited
 
|-
 
| {{MenuCommand|Active container}}
 
|  Selection of the background color for active containers in the tree view. For example if there are several parts in the tree view and one part is toggled as [[PartDesign_Body#Active_Status|active body]], it will get the selected background color in the tree view.
 
|}
 
  
<div class="mw-translate-fuzzy">
+
[[Image:Preference_Display_Tab_02.png]]
[[Image:Preference_Display_Tab_02.png|left]]
 
</div>
 
  
 
===Teilefarben===
 
===Teilefarben===
  
This tab is only shown if you are in the [[Part_Module|Part]] or [[PartDesign_Workbench|PartDesign Workbench]] or if you have been in these workbenches before.
+
Diese Registerkarte wird nur angezeigt, wenn Du Dich in der [[Part_Module/de|Arbeitsbereich Part]] oder [[PartDesign_Workbench/de|PartDesign Arbeitsbereich]] befindest oder wenn Du Dich schon einmal in diesen Arbeitsbereichen befunden hast.
  
In the ''Part colors'' tab you can specify the following:
+
Im ''Teilefarben'' Reiter kannst Du Folgendes angeben:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
|-
 
| {{MenuCommand|Default shape color}}
 
| Selection of the default color for new shapes. If the option {{MenuCommand|Random shape color}} is set, a random color is used instead.
 
|-
 
| {{MenuCommand|Default line color}}
 
|  Selection of the default line color for new shapes
 
|-
 
| {{MenuCommand|Default line width}}
 
|  Specification of the default line thickness for new shapes
 
|-
 
| {{MenuCommand|Default vertex color}}
 
|  Selection of the default color for new [[Glossary#Vertex|vertices]]
 
|-
 
| {{MenuCommand|Default vertex size}}
 
|  Specification of the default size for new [[Glossary#Vertex|vertices]]
 
|-
 
| {{MenuCommand|Bounding box color}}
 
|  Selection of the color of [[Property_editor#View|bounding boxes]] in the 3D view
 
 
|-
 
|-
| {{MenuCommand|Default text color}}
 
|  Selection of the default text color for document annotations. There is currently no dialog to add annotations to documents. Annotations can only be added using the Python console with this command:
 
  
 
<code>obj=App.ActiveDocument.addObject("App::Annotation", "Label")</code>
 
<code>obj=App.ActiveDocument.addObject("App::Annotation", "Label")</code>
  
This console is shown using the menu  {{MenuCommand|View Panels → Python console}}.
+
Diese Konsole wird angezeigt über das Menü {{MenuCommand/de|Ansicht Paneele → Python Konsole}}
 
|}
 
|}
  
Line 411: Line 265:
 
Diese Registerkarte wird nur angezeigt, wenn Du Dich in der [[Mesh_Workbench/de|Mesh Arbeitsbereich]] befindest oder wenn Du Dich schon einmal in diesem Arbeitsbereich befindest.
 
Diese Registerkarte wird nur angezeigt, wenn Du Dich in der [[Mesh_Workbench/de|Mesh Arbeitsbereich]] befindest oder wenn Du Dich schon einmal in diesem Arbeitsbereich befindest.
  
In the ''Mesh view'' tab you can specify the following:
+
<div class="mw-translate-fuzzy">
 +
Im ''Netzansicht'' Reiter kannst du Folgendes angeben:
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
{| class="wikitable float-right mw-collapsible mw-collapsed"
 
!style="width: 33%;"|Name
 
!style="width: 33%;"|Name
!style="width: 66%;"|Description
+
!style="width: 66%;"|Beschreibung
 
|-
 
|-
| {{MenuCommand|Default mesh color}}
+
</div>
| Selection of the default color for new meshes
 
|-
 
| {{MenuCommand|Default line color}}
 
|  Selection of the default line color for new meshes
 
|-
 
| {{MenuCommand|Mesh transparency}}
 
|  Specification of the default mesh transparency for new meshes
 
|-
 
| {{MenuCommand|Line transparency}}
 
|  Specification of the default line transparency for new meshes
 
|-
 
| {{MenuCommand|Two-side rendering}}
 
|  If checked, the bottom side of the surface will be rendered the same way than the top side. If not checked, it depends on the option {{MenuCommand|Enable backlight color}} (see section [[Preferences_Editor#3D_View|3D view]]). Either the backlight color will be used or black.
 
|-
 
| {{MenuCommand|Show bounding-box for highlighted or selected meshes}}
 
|  If checked, a yellow bounding box will be displayed for highlighted or selected meshes.
 
|-
 
| {{MenuCommand|Define normal per vertex}}
 
|  If checked,  [https://en.wikipedia.org/wiki/Phong_shading Phong shading] is used, otherwise flat shading. Shading defines the appearance of surfaces.
 
With flat shading the surface normals are not defined per vertex that leads to a unreal appearance for curved surfaces while using Phong shading leads to a smoother appearance.
 
|-
 
| {{MenuCommand|Crease angle}}
 
|  The crease angle is a threshold angle between two faces. It can only be set if the option {{MenuCommand|Define normal per vertex}} is used.
 
:If face angle ≥ crease angle, facet shading is used
 
:If face angle < crease angle, smooth shading  is used
 
|}
 
  
 
[[Image:Mesh View Preferences.png]]
 
[[Image:Mesh View Preferences.png]]
Line 448: Line 277:
 
==Import-Export Einstellungen==
 
==Import-Export Einstellungen==
  
Die Import-Export Einstellungen beeinflussen wie Dateien in und aus FreeCAD heraus importiert und exportiert werden. Sie sind auf der Seite [[Import Export Preference/de|Import Export Einstellungen]] beschrieben.
+
Die Import-Export Einstellungen beeinflussen wie Dateien in FreeCAD importiert und exportiert werden. Sie sind auf der Seite [[Import_Export_Preference/de|Import Export Einstellungen]] beschrieben.
  
 
==Arbeitsbereichseinstellungen==
 
==Arbeitsbereichseinstellungen==
 +
 +
 +
{{VeryImportantMessage|Dieser Abschnitt ist unvollständig und erfordert die Erwähnung der Präferenzseiten jedes Kern Arbeitsbereichs}}
 +
 
Einstellungen für die gebräuchlicheren Arbeitsbereiche findest Du nachfolgend verknüpft.  
 
Einstellungen für die gebräuchlicheren Arbeitsbereiche findest Du nachfolgend verknüpft.  
 
Einige Arbeitsbereiche haben keine Einstellungen.  
 
Einige Arbeitsbereiche haben keine Einstellungen.  
Andere optionale Arbeitsbereiche sind möglicherweise nicht aufgeführt.
+
Andere optionale Arbeitsbereiche sind möglicherweise nicht aufgeführt. Diese Verknüpfungen sind auch unter [[:Category:Preferences]] aufgezeigt.  
  
 
* [[Arch Preferences/de|Arch Einstellungen]]
 
* [[Arch Preferences/de|Arch Einstellungen]]
 
* [[Draft Preferences/de|Draft Einstellungen]]
 
* [[Draft Preferences/de|Draft Einstellungen]]
* Drawing Preferences (none)
+
* Drawing Preferences {{veraltet|0.16}}
* [[Fem Preference/des|Fem Einstellungen]]
+
* [[FEM Preference/des|FEM Einstellungen]]
 
* Image Preferences (none)
 
* Image Preferences (none)
 
* Inspection Preferences (none)
 
* Inspection Preferences (none)
 
* Mesh Design Preferences (none)
 
* Mesh Design Preferences (none)
 
* [[OpenSCAD_Preferences/de|OpenSCAD Einstellungen]]
 
* [[OpenSCAD_Preferences/de|OpenSCAD Einstellungen]]
* Part Preferences (none)
+
<!--The PartDesign preferences are defined in the Part workbench and both the PartDesign workbench and the Part workbench use them-->
 +
* Part Preferences: der Teile-Arbeitsbereich verwendet auch die [[PartDesign_Preferences/de|PartDesign Einstellungen]]
 +
 
 +
 
 
* [[PartDesign Preferences/de|PartDesign Einstellungen]]
 
* [[PartDesign Preferences/de|PartDesign Einstellungen]]
 
* [[Path_Preferences/de|Path Einstellungen]]
 
* [[Path_Preferences/de|Path Einstellungen]]
Line 481: Line 317:
  
 
===Externe Arbeitsbereiche===
 
===Externe Arbeitsbereiche===
 +
 +
 +
{{VeryImportantMessage|Dieser Abschnitt ist unvollständig und erfordert die Erwähnung der Seiten zu den Einstellungen jeder [[External Workbenches/de|Externe Arbeitsbereiche]]}}
  
 
* [[A2plus_Workbench#Preferences/de|A2plus Einstellungen]]
 
* [[A2plus_Workbench#Preferences/de|A2plus Einstellungen]]
 +
* Schiffseinstellungen (keine)
 +
 +
== Related ==
 +
 +
* [[Parameter editor]]
 +
* [[Fine-tuning]]
  
{{docnav/de|[[Document structure/de|Dokumentstruktur]]
+
{{Docnav/de
 +
|[[Document structure/de|Dokumentenstruktur]]
 
|[[Import Export Preference/de|Import Export Einstellungen]]
 
|[[Import Export Preference/de|Import Export Einstellungen]]
 
}}
 
}}
  
{{Userdocnavi/de}}
+
[[Category:Preferences{{#translation:}}]]
 +
{{Userdocnavi{{#translation:}}}}

Latest revision as of 11:07, 17 November 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Einführung

Die Einstellungssystem für FreeCAD befindet sich in den Bearbeiten → Einstellungen.... Im Mac OS erscheint die Einstellungen... Menüoption im FreeCAD Menü anstatt im Bearbeitungsmenü (dies ist der vorgegebene Ort für Einstellungen auf dem Mac).

Die FreeCAD Funktionalität sind in verschiedene Module unterteilt, jedes Modul ist für die Arbeit mit einem bestimmten Arbeitsbereich zuständig. FreeCAD verwendet auch das Konzept "late loading", d.h., dass Komponenten nur dann geladen werden, wenn sie benötigt werden. Man erkennt, dass bei der Auswahl eines Arbeitsbereichs in der FreeCAD Werkzeugleiste dieser Arbeitsbereich und all seine Komponenten in diesem Moment geladen werden. Dies schließt auch seine bevorzugten Einstellungen ein.

Ohne ein geladenes Modul hat man Zugriff auf zwei Konfigurationsabschnitte, die für die allgemeinen Anwendungs- und die Anzeigeeinstellungen zuständig sind. Befindet man sich in einem bestimmten Arbeitsbereich, erscheinen die Einstellungen dieses Arbeitsbereichs als neuer Abschnitt und die von diesem Arbeitsbereich unterstützten Dateiformate erscheinen als neue Registerkarte im Abschnitt Import-Export.

Klicken der Reset Schaltfläche in der unteren linken Ecke einer beliebigen Einstellungsanzeige, wird alle FreeCAD Einstellungen auf ihre Standardwerte setzen.

Note: for more fine-tuned control of preferences see Parameter editor and Fine-tuning

Allgemeine Einstellung

Dieser Einstellungsbereich hat 6 Reiter: Allgemein, Dokument, Editor, Ausgabefenster, Makro und Einheiten.

Allgemeines

Auf der Registerkarte "Allgemein" können Sie Folgendes festlegen:

Name Beschreibung
Sprache ändern Wähle die Sprache der Benutzeroberfläche von FreeCAD aus.
Größe der Liste der letzten Dateien Gib an, wie viele Dateien in der Liste der letzten Dateien aufgelistet werden sollen.
Aktivieren des gekachelten Hintergrunds Wenn diese Option aktiviert ist, besteht der Hintergrund des Hauptfensters von FreeCAD standardmäßig aus Kacheln dieses Bildes: Background.png

Diese Option hat nur dann einen Effekt, wenn in Style Sheet/No Style Sheet ausgewählt ist.

Das Bild kann geändert werden, indem die Ordner Gui/Images im Ordner hinzufügt werden.

%APPDATA%/FreeCAD (in Windows),

$HOME/.FreeCAD (auf Linux) oder

$HOME/Library/Preferences/FreeCAD (auf MacOS).

Dort eine Datei mit dem Namen background.png anlegen und diese Option abwählen/wählen, um die geänderte Datei anzuzeigen.

Formatvorlage Auswahl einer Formatvorlage. Die Formatvorlagen definieren, wie die Benutzeroberfläche von FreeCAD aussieht.
Größe der Werkzeugleistensymbole Auswahl der Größe für die Werkzeugleistensymbole
Baumansichtsmodus Anpassung, wie die Baumansicht im Paneel angezeigt wird (Neustart erforderlich). Die Optionen sind:
  • Combo Ansicht: Kombiniert die Baumansicht und die Eigenschaftsansicht in einem Paneel.
  • Baumansicht und Eigenschaftsansicht: teile die Baumansicht und die Eigenschaftsansicht in ein separates Paneel.
  • Beide': alle drei Paneele beibehalten, und du kannst zwei Sätze von Baumansicht und Eigenschaftsansicht haben.
Modul nach dem Start automatisch laden Auswahl, welcher Arbeitsbereich direkt nach dem Start von FreeCAD verwendet werden soll
Startbildschirm beim Start aktivieren Wenn diese Option angehakt ist, wird der Startbildschirm von FreeCAD beim Start angezeigt.

Das Begrüßungsbildschirmbild kann geändert werden, indem die Ordner Gui/Images} im Ordner %APPDATA%/FreeCAD} hinzugefügt werden. (wobei %APPDATA% der benutzerspezifische Anwendungsordner von FreeCAD des Betriebssystems ist). Lege dort eine Datei namens splash_image.png} an und starte FreeCAD neu, um den geänderten Startbildschirm zu sehen.

Enable word wrap Wörter werden umgebrochen, wenn sie den verfügbaren horizontalen Platz in der Python-Konsole überschreiten. Diese Konsole wird über das Menü Ansicht → Paneele → Python Konsole} angezeigt.

Preference General Tab 01.png

Dokument

Im Reiter Document kann man folgendes festlegen:

Preference General Tab 02.png

Editor

Die Einstellungen der Editor Einstellungen beeinflussen das Verhalten des Makroeditors. Dieser Editor kann über das Menü Makro → Makros..... → Bearbeiten/Erstellen geöffnet werden.

Die Farb- und Schrifteinstellungen wirken sich auch auf die Python-Konsole aus. Diese Konsole wird über das Menü View → Panels → Python console angezeigt.

Im Editor Reiter kannst du Folgendes angeben:

Name Beschreibung
Name Beschreibung
Elemente anzeigen Auswahl des Codetyps. Die Farb- und Schrifteinstellungen werden auf den ausgewählten Typ angewendet. Das Ergebnis ist im Feld Vorschau zu sehen.
Familie Angabe der Schriftfamilie, die für den gewählten Codetyp verwendet werden soll
Größe Angabe der Schriftgröße, die für den gewählten Codetyp verwendet werden soll
Farbe Angabe der Farbe, die für den gewählten Codetyp verwendet werden soll
Zeilennummern einschalten Wenn markiert, werden die Codezeilen nummeriert
Tabulator Größe Angabe des Tabulatorrasters (wie viele Leerzeichen). Wenn es z.B. auf '6' gesetzt ist, wird durch Drücken von Tab zum Zeichen 7 oder 13 oder 19 usw. gesprungen, abhängig von der aktuellen Cursorposition. Diese Einstellung wird nur verwendet, wenn Tabulatoren behalten ausgewählt ist.
Einrückungsgröße Angabe, wie viele Leerzeichen eingefügt werden, wenn Tab gedrückt wird. Diese Einstellung wird nur verwendet, wenn Einfügen Leerzeichen ausgewählt ist.
Tabulatoren behalten Falls ausgewählt, wird durch Drücken von Tab ein Tabulator mit dem durch Tabulatorgröße definierten Raster eingefügt
Leerzeichen einfügen Falls ausgewählt, wird durch Drücken von Tab die durch Einrückungsgröße definierte Anzahl von Leerzeichen eingefügt

Preference General Tab 03.png

Ausgabefenster

Die Ausgabeeinstellungen beeinflussen das Verhalten der Berichtansicht.

Im Ausgabe Reiter kannst du Folgendes angeben:

Preference General Tab 04.png

Makro

Diese Optionen steuern bestimmte Aspekte der Ausführung von Makros.

Auf der Registerkarte "Makro" kannst Du folgendes festlegen:

Name Beschreibung
Name Beschreibung
Makros in lokaler Umgebung ausführen Wenn angehakt, werden durch Makros definierte Variablen als lokale Variablen erstellt, andernfalls als globale Python Variable
Makro Pfad Angabe eines Pfades zu Makro Dateien
Aufzeichnung von GUI Befehlen Wenn angehakt, enthält Aufgezeichnete Makros auch Benutzeroberflächenbefehle
Aufzeichnung als Kommentar Wenn diese Option angehakt ist, enthält Aufgezeichnete Makros auch Benutzeroberflächenbefehle, jedoch als Kommentare. Dies ist nützlich, wenn du beim Ausführen des Makros keine sichtbaren Aktionen ausführen willst, sondern sehen willst, was sichtbar getan werden könnte.
Skriptbefehle in der Python Konsole anzeigen Wenn diese Option aktiviert ist, werden die von den Makroskripten ausgeführten Befehle in der Python Konsole angezeigt. Diese Konsole wird über das Menü Ansicht → Paneele → Python Konsole angezeigt.

Preference General Tab 05.png

Einheiten

In dieser Registerkarte wird konfiguriert, wie Einheiten angezeigt werden.

Auf der Registerkarte "Einheiten" kannst Du folgendes festlegen:

Name Beschreibung
Benutzer System Auswahl eines Einheitensystems, das für alle Teile von FreeCAD verwendet werden soll
Anzahl der Dezimalstellen Die Anzahl der Dezimalstellen, die für Zahlen und Abmessungen in FreeCAD angezeigt werden sollen
Minimaler Bruchteil eines Zolls Minimaler Zoll Bruchteil , der angezeigt werden sollte. Diese Einstellung ist nur verfügbar, wenn das Einheitensystem Building US (ft-in/sqft/cuft)' verwendet wird.

Preference General Tab 06.png

Anzeige Einstellungen

Dieser Einstellungsabschnitt enthält zwei allgemeine Registerkarten, 3D Ansicht und Farben, sowie weitere Registerkarten, die von den verwendeten Arbeitsbereichen abhängen.

3D Ansicht

Diese Registerkarte ist immer verfügbar und steuert bestimmte Eigenschaften der 3D Ansicht.

Im 3D Ansicht Reiter kannst du Folgendes angeben:

  • Perspektivisches Rendern, Objekte werden in einer [1] erscheinen.
  • Orthographisches Rendern, Objekte werden in orthographische Projektion projiziert. Siehe auch [2]
Name Beschreibung


Preference Display Tab 01.png

Navigation

Dieser Reiter wird immer angezeigt und steuert das Verhalten des Navigationswerkzeugs.


Im Navigation Reiter kannst du Folgendes angeben:

Preference Navigation Tab.png

Farben

Dieser Reiter ist immer verfügbar.

Im Farben Reiter kannst du Folgendes angeben:

Name Beschreibung

Preference Display Tab 02.png

Teilefarben

Diese Registerkarte wird nur angezeigt, wenn Du Dich in der Arbeitsbereich Part oder PartDesign Arbeitsbereich befindest oder wenn Du Dich schon einmal in diesen Arbeitsbereichen befunden hast.

Im Teilefarben Reiter kannst Du Folgendes angeben:

Name Beschreibung
obj=App.ActiveDocument.addObject("App::Annotation", "Label") Diese Konsole wird angezeigt über das Menü Ansicht → Paneele → Python Konsole
Name Beschreibung

Preference Display Tab 03.png

Netzansicht

Diese Registerkarte wird nur angezeigt, wenn Du Dich in der Mesh Arbeitsbereich befindest oder wenn Du Dich schon einmal in diesem Arbeitsbereich befindest.

Im Netzansicht Reiter kannst du Folgendes angeben:

Mesh View Preferences.png

Import-Export Einstellungen

Die Import-Export Einstellungen beeinflussen wie Dateien in FreeCAD importiert und exportiert werden. Sie sind auf der Seite Import Export Einstellungen beschrieben.

Arbeitsbereichseinstellungen

Dieser Abschnitt ist unvollständig und erfordert die Erwähnung der Präferenzseiten jedes Kern Arbeitsbereichs


Einstellungen für die gebräuchlicheren Arbeitsbereiche findest Du nachfolgend verknüpft. Einige Arbeitsbereiche haben keine Einstellungen. Andere optionale Arbeitsbereiche sind möglicherweise nicht aufgeführt. Diese Verknüpfungen sind auch unter Category:Preferences aufgezeigt.


Externe Arbeitsbereiche

Dieser Abschnitt ist unvollständig und erfordert die Erwähnung der Seiten zu den Einstellungen jeder Externe Arbeitsbereiche


Related

Name Beschreibung