Difference between revisions of "Path Workbench/de"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "* 32px Adaptive: Erstellt eine adaptive Clearing- und Profilerstellung.")
(Updating to match new version of source page)
 
(70 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{docnav|[[PartDesign Workbench|PartDesign Workbench]]|[[Plot Workbench|Plot Workbench]]|IconL=Workbench_PartDesign.svg|IconR=Workbench_Plot.svg}}
+
<div class="mw-translate-fuzzy">
 +
{{docnav/de
 +
|[[PartDesign Workbench/de|PartDesign Arbeitsbereich]]
 +
|[[Plot Workbench/de|Plot Arbeitsbereich]]
 +
|IconL=Workbench_PartDesign.svg
 +
|IconR=Workbench_Plot.svg
 +
}}
 +
</div>
  
[[Image:Path-Workbench.svg|64px]]
+
[[Image:Workbench_Path.svg|thumb|128px|Path workbench icon]]
  
 
==Einleitung==
 
==Einleitung==
  
Mit dem Path Arbeitsbereich können zum Betrieb von CNC Maschinen benötigte Befehlssätze erstellt werden. Unterstützt werden, Stand März 2018, Fräsen, Lasercutter, Graviermaschinen und ähnliche, 3 achsige CNC Maschinen deren Steuerung auf G-Code basiert.
+
<div class="mw-translate-fuzzy">
Die Path Postprozessoren erstellen G-Code in vielen verbreiteten Varianten, z.B. für Centroid-, grbl-, LinuCNC-, Philips- gestützte Maschinencontroller.
+
Die Pfad Arbeitsbereich wird verwendet, um aus einem FreeCAD 3D Modell Maschinenanweisungen für [https://en.wikipedia.org/wiki/CNC_router CNC Maschinen] zu erstellen. Diese erzeugen reale 3D Objekte auf CNC Maschinen wie Fräsen, Drehbänken, Laserschneidmaschinen oder ähnlichem. Typischerweise handelt es sich bei den Anweisungen um einen [https://en.wikipedia.org/wiki/G-Code G-Code] Dialekt.
 +
</div>
  
 
{{TOCright}}
 
{{TOCright}}
 
[[Image:pathwb.png|none|600px]]
 
[[Image:pathwb.png|none|600px]]
  
<div class="mw-translate-fuzzy">
+
Der FreeCAD Pfad Arbeitsbereich Arbeitsablauf erstellt diese Maschinenanweisungen wie folgt:
Der FreeCAD Arbeitsbereich Path erstellt diese Befehlssätze mit folgendem Arbeitsablauf:
+
* Ein 3D Modell ist das Basisobjekt, das typischerweise mit einer oder mehreren der Arbeitsbereiche [[PartDesign Workbench/de|Part Design]], [[Part Workbench/de|Part]] oder [[Draft Workbench/de|Entwurf]] erstellt wird.
* Ein 3D Modell, erstellt mit einer der FreeCAD Arbeitsbereiche [[PartDesign Workbench/de|Part Design]], [[Part Workbench/de|Part]] oder [[Draft Workbench/de|Draft]], ist das Basis Objekt.
+
* Ein [[Path_Job|Arbeitsauftrag]] wird im Pfad Arbeitsbereich erstellt. Dieser enthält alle Informationen, die zur Erzeugung des notwendigen G-Codes für die Bearbeitung des Arbeitsauftrags auf einer CNC Fräse erforderlich sind: es gibt Rohmaterial, die Fräse hat einen bestimmten [[Path_EditToolsTable/de|Werkzeugsatz]] und es folgen bestimmte Befehle, die die Geschwindigkeit und die Bewegungen steuern (normalerweise G-Code).
* Ein [[Path_Job/de|Job]] wird im Path Arbeitsbereich erzeugt. Der Job enthält alle zur Erzeugung eines auf einer CNC Fräse ausführbaren g-codes nötigen Informationen:
+
* Die Werkzeuge werden entsprechend den Anforderungen der Arbeitsauftragsabläufe ausgewählt.
Enthalten sind die Abmessungen des Rohmaterials, die zur Verfügung stehenden [[Path_EditToolsTable/de|Werkzeuge]] und die zur Steuerung von Verfahrgeschwindigeit und Spindeldrehzahl benötigten Parameter.
+
* Fräsbahnen werden z.B. mit [[Path_Profile/de|Kontur]] und [[Path_Pocket_3D/de|Tasche]] Abläufen erzeugt. Diese [[Path objects/de|Bahnobjekte]] verwenden den internen FreeCAD G-Code Dialekt, unabhängig von der CNC Maschine.
* Werkzeuge werden passend zum Fräsvorgang ausgewählt.
+
* Exportiere den Job mit einem G-Code, der zu Ihrer Maschine passt. Dieser Schritt wird ''Nachbearbeitung'' genannt; es sind unterschiedliche Nachbearbeitungsprozessoren verfügbar.
* Der Fräspfad wird erstellt durch die Auswahl der benötigten Operation, z.B. [[Path_Profile/de|Contour]] oder [[Path_Pocket_3D/de|Pocket]]. Diese [[Path objects/de|Path Objekte]] werden primär in einem, von der CNC Maschine unabhängigen, FreeCAD G-Code Dialekt erstellt.
 
* Der Job wird in einem zur Maschine passendem G-Code exportiert.
 
</div>
 
  
=== Links für den schnellen Einstieg ===
+
=== Verweise für die Ungeduldigen ===
Abhängig von Ihrem Interesse am Path-Arbeitsbereich gibt es Lesestoff zu verschiedene Themen:
+
Abhängig von deinem Interesse am Pfad Arbeitsbereich gibt es unterschiedliche Themen zur weiteren Lektüre:
  
* Wenn Sie sich als neuer Anwender schnell in "Path" einarbeiten möchten: [[Path Walkthrough for the Impatient/de|hier ein schneller Einstieg]].
+
* Wenn du ein neuer Anwender bist, der versucht, sich mit Pfad vertraut zu machen, könntest du an einem schnellen  [[Path Walkthrough for the Impatient/de|Durchgang]] Tutorium interessiert sein.
* Wenn Sie eine Maschine besitzen welche nicht von enem der in FreeCAD integrierten postprozessoren unterstützt wird möchten Sie eventuell wissen wie Sie einen [[Path_Postprocessor_Customization|personalisierten postprozessor]] erstellen können.
+
* Wenn Du eine spezielle Maschine hast, die keinen der verfügbaren Postprozessoren verwenden kann, möchtest Du vielleicht etwas über [[Path_Postprocessor_Customization/de|post-processor Anpassung]] erfahren.
* Als erfahrener FreeCAD Nutzer möchten Sie ein Makro erstellen oder einen Prozess automatisieren und möchten wissen wie das [[Path_scripting|Skript]] dazu erstellt werden muss.
+
* Als erfahrener Anwender möchtest Du vielleicht ein Makro schreiben oder einen Prozess automatisieren, musst Du vielleicht [[Path_scripting/de|skripten]] lernen
* Als ergahrener FreeCAD Nutzer möchten sie ihren Arbeitsablauf beschleunigen und wissen wie die FreeCAD Oberfläche ihren Wünschen [[Path_Customization|angepasst]] werden kann.
+
* Erfahrene Anwender, die ihren Arbeitsablauf optimieren wollen, können sich über [[Path_Customization/de|Anpassung]] informieren.
* Als Entwickler möchten Sie zu "Path" beitragen und sich über die  [[Path_Core_Concepts|core concepts]] informieren.
+
* Neue Entwickler, die zu path beitragen möchten, sollten [[Path_Core_Concepts/de|Kernkonzepte]] verstehen.
  
 
== Allgemeine Konzepte ==
 
== Allgemeine Konzepte ==
Die Path Workbench generiert G-Code (Maschinensprache), welcher die Pfade vorgibt, die zum Fräsen des durch das 3D Modell dargestellten Projekts auf der Fräsmaschine erforderlich sind in [https://www.freecadweb.org/wiki/Path_scripting#FreeCAD.27s_internal_GCode_format the Path Job Operations FreeCAD G-Code dialect]. Der Programmablauf kann später durch Auswahl eines entsprechenden Postprocessors in Maschinensprache für die entsprechende CNC Steuerung übersetzt werden.
+
Der Pfad Arbeitsbereich erzeugt einen G-Code, der die Pfade definiert, die zum Fräsen des durch das 3D Modell auf der Zielfräse in [https://www.freecadweb.org/wiki/Path_scripting#FreeCAD.27s_internal_GCode_format dem Dialekt für Pfad-Job-Operationen FreeCAD G-Code] dargestellten Projekts erforderlich sind, der später durch Auswahl des entsprechenden Postprozessors in den entsprechenden Dialekt für die Ziel-CNC-Steuerung übersetzt wird.
 +
 +
Der G-Code wird aus den in einem Bahnauftrag enthaltenen Anweisungen und Operationen generiert. Der Auftrags Arbeitsablauf listet diese in der Reihenfolge ihrer Ausführung auf.  Die Liste wird durch Hinzufügen von Bahnoperationen, Bahnabbildern, Bahnteilbefehlen und Bahnmodifikationen aus dem Bahnmenü oder den GUI-Schaltflächen aufgefüllt.
 +
 
 +
Der Path Arbeitsbereich enthält einen Werkzeugverwalter (Bibliothek, Werkzeugtabelle), eine G-Code Überprüfung und Simulationswerkzeuge. Es verknüpft den Postprozessor und erlaubt den Im- und Export von Auftragsvorlagen.
  
Der G-Code wird durch Vorgaben und Operationen, die im Path-Job enthalten sind, generiert. Die Jobs werden in der Reihenfolge gelistet, in welcher sie abgearbeitet werden. Jobs können durch hinzufügen von Path Operations, Path Dressups, Path Partial Command und Path Modifications im Path Menü oder GUI-Schaltflächen erzeugt werden.
+
# Die Einheiten des FreeCAD 3D-Modells werden im {{MenuCommand/de|Bearbeiten → Einstellungen → Allgemein → Einheiten Register Einheiten Einstellungen}} definiert.  Die Postprozessor Konfiguration definiert die endgültigen G-Code Einheiten.
 +
# Der Pfad der Makrodatei und die geometrischen Toleranzen werden im {{MenuCommand/de|Bearbeiten → Einstellungen →  Pfad → Arbeitsauftag Einstellungen}} definiert.
 +
# Die Farben werden im Register {{MenuCommand/de|Bearbeiten → Einstellungen →Pfad → Pfad  Farben}} definiert.
 +
# Die Parameter der Halte Tags werden in der Registerkarte {{MenuCommand/de|Bearbeiten → Einstellungen → Pfad → Dressups}} definiert.
 +
# Dass die Qualität des Basis 3D Modells die Anforderungen an die Pfad Arbeitsbereich unterstützt, wird durch Prüfe Geometrie bestätigt.
  
Der Path Arbeitsbereich enthält einen Werkzeug Manager (Bibliothek, Verzeichnis, Werkzeugtabelle), eine G-Code Überprüfung und ein Simulationswerkzeug. Path verlinkt zum Postprozessor und erlaubt den Im- und Export von Job Vorlagen. 
+
== Begrenzungen ==
  
Die Path Workbench hat folgende externe Abhängigkeiten:
+
Die meisten Pfad Werkzeuge sind keine echten 3D Werkzeuge, sondern nur 2,5D fähig. Das bedeutet, dass sie eine feste 2D Form annehmen und diese bis zu einer bestimmten Tiefe schneiden können. Es gibt zwei Werkzeuge, die echte 3D Bahnen erzeugen, von denen eines noch experimentell ist ( Dezember 2019 ).  
# Die FreeCAD 3D Modelleinheiten werden definiert in: {{MenuCommand|Edit → Preference → General → Units tab's Units settings}}. Die Postprocessor-Konfiguration definiert die finalen G-Code Einheiten.
+
Es gibt derzeit keine Werkzeuge zum Planfräsen einer vertikalen Fläche oder zum Schneiden von vertikalen, nicht planaren Flächen eines Modells.
# Der Macro-Dateipfad und die geometrischen Toleranzen werden definiert in: {{MenuCommand|Edit → Preferences → Path → Job Preferences}} tab.
 
# Farben werden definiert in: {{MenuCommand|Edit → Preferences → Path → Path colors}} tab.
 
# Haltesteg-Parameter werden definiert in: {{MenuCommand|Edit → Preferences → Path → Dressups}} tab.  
 
# That the Base 3D model quality supports the Path WB requirements, passes Check Geometry.
 
  
 
== Einheiten ==
 
== Einheiten ==
  
Die Handhabung von Einheiten kann in der Path Workbench verwirrend sein. Es gibt mehrere Punkte, die verstanden werden müssen:
+
Die Handhabung von Einheiten kann im Pfad Arbeitsbereich verwirrend sein. Es gibt mehrere Punkte, die verstanden werden müssen:
# FreeCAD Basiseinheiten für Länge und Zeit sind 'mm' and 's'. Geschwindigkeit ist 'mm/s'. Diese Einheiten speichert FreeCAD intern unabhängig von allem anderem.
+
# FreeCAD Basiseinheiten für Länge und Zeit sind 'mm' und 's' bzw. Geschwindigkeit ist 'mm/s'. Diese Einheiten speichert FreeCAD intern unabhängig von allem anderem.
# Das standardmäßige Einheitensystem nutzt diese Basiseinheiten. Wenn du das Standard Einheitensystem benutzt und eine Vorschubgeschwindigkeit ohne Einheit eingibst, wird es als 'mm/s' interpretiert.
+
# Das standardmäßige Einheitensystem nutzt diese Basiseinheiten. Wenn du das Standard Einheitensystem benutzt und eine Vorschubgeschwindigkeit ohne eine Einheitenfolge eingibst, wird es als 'mm/s' interpretiert.
# Die meisten CNC Maschinen erwarten aber Einheiten in der Form 'mm/min'. Die meisten Postprozessoren konvertieren die Einheiten automatisch, wenn der Maschinencode generiert wird.
+
# Die meisten CNC Maschinen erwarten aber Einheiten in der Form 'mm/min'oder 'Zoll/min'. Die meisten Postprozessoren konvertieren die Einheiten automatisch, wenn der Maschinencode generiert wird.
  
Einheitensystem:
+
Schemata:
# Das Ändern des Einheitensystems in den Einstellungen verändert die Einheiten in den Eingabefeldern. Wenn du ein Path Workbench Benutzer bist und das metrische System bevorzugst, solltest du das Einheitensystem "Metrische Kleinteile & CNC" benutzen. Wenn du das imperiale System bevorzugst, solltest du "US-üblich" benutzen.
+
# Schemaänderungen in den Einstellungen ändert die Standardeinheitszeichenkette für die Eingabefelder. Wenn Du ein Pfad Anwender bist und es vorziehst, metrisch zu konstruieren, wird dringend empfohlen, das Schema "Metrische Kleinteile & CNC" zu verwenden. Wenn du in US Einheiten konstruierst, funktionieren entweder die Einheiten Britisches Dezimal und US Bauwesen
# Eine Änderung des Einheitensystems hat keinen Einfluss auf die Ausgabewerte. Aber es hilft Eingabefehler zu vermeiden.
+
# Ändern des bevorzugten Einheitenschemas hat keine Auswirkung auf die Ausgabe, hilft aber, Eingabefehler zu vermeiden
  
 
Ausgabe:
 
Ausgabe:
Line 67: Line 76:
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
==Path Kommandos==
+
==Pfad Befehle==
 +
Viele der Befehle haben unterschiedliche Höhen und Tiefen:
 +
[[File:Path-DepthsAndHeights.gif|center]]
 +
{{Caption|Sichtreferenz für Tiefeneigenschaften (Einstellungen)}}
 
</div>
 
</div>
  
  
Mit diesen Kommandos werden CNC Projekte und Vorlagen erstellt und verwaltet.
+
Diese Befehle dienen zum Einrichten eines CNC-Projekts und zur Verwaltung deiner Vorlagen.
  
* [[Image:Path-Job.png|32px]] [[Path_Job|Job]]: Erstellt einen neuen CNC Job
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path-Job.png|32px]] [[Path_Job/de|Auftrag]]: Erstellt einen neuen CNC Arbeitsauftrag
 +
</div>
  
* [[Image:Path_PostProcess.png|32px]] [[Path_Post|Post Process]]: Erstellt aus einem Job eine G-code Datei
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path_PostProcess.png|32px]] [[Path_Post/de|Nach Prozess]]: Exportiert ein Projekt in G-code
 +
</div>
  
* [[Image:Path-ExportTemplate.png|32px]] [[Path_ExportTemplate|Export Template]]: Speichert den ausgewählten Job als Vorlage
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path-ExportTemplate.png|32px]] [[Path_ExportTemplate/de|Export Vorlage]]: Den aktuellen Job als Vorlage exportieren
 +
</div>
  
* [[File:Path_Inspect.png|32px]] [[Path_Inspect|G-Code Inspector]]: Zeigt den G-code zur Überprüfung
+
<div class="mw-translate-fuzzy">
 +
* [[File:Path_Inspect.png|32px]] [[Path_Inspect/de|G-Code Inspector]]: Zeigt den G-code zur Überprüfung
 +
</div>
  
* [[File:Path_Simulator.png|32px]] [[Path_Simulator|Simulator]]: Zeigt eine Simulation des Fräsvorgangs wie er auf der Maschine ausgeführt wird.
+
* [[File:Path_Simulator.png|32px]] [[Path_Simulator/de|Simulator]]: Zeigt die Fräsbearbeitung wie sie auf der Maschine durchgeführt wird
  
* [[Image:Path_ToolLibraryEdit.png|32px]] [[Path_ToolLibraryEdit|Tool Manager]]: Aufruf der Werkzeugtabelle
+
* [[Image:Path_ToolLibraryEdit.png|32px]] [[Path_ToolLibraryEdit/de|Werkzeugverwalter]]: Den Werkzeugverwalter bearbeiten
  
* [[File:Path-CompleteLoop.png|32px]] [[Path_SelectLoop|Complete Loop]]: Erstellt aus 2 ausgewählten Kanten einen geschlossenen Ring
+
<div class="mw-translate-fuzzy">
 +
* [[File:Path-CompleteLoop.png|32px]] [[Path_SelectLoop/de|SChleife vervollständigen]]: Vervollständigt eine Schleife aus zwei ausgewählten Kanten
 +
</div>
  
* [[File:Path_Contour.png|32px]] [[Path_Contour|Contour]]: Erzeugt einen Fräspfad aus der Kontur des Basisobjekts
+
<div class="mw-translate-fuzzy">
 +
* [[File:Path_Contour.png|32px]] [[Path_Contour/de|Kontur]]: Erzeugt einen Pfad aus der Kontur des Basisobjekts
 +
</div>
  
* [[Image:Path-Profile-Face.png|32px]] [[Path_ProfileFace|Profile from Face]]: Erzeugt einen Kontur- Fräspfad um eine ausgewälte Fläche
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path-Profile-Face.png|32px]] [[Path_ProfileFace/de|Profil aus Fläche]]: Erzeugt einen Profilierungspfad aus einer ausgewählten Fläche
 +
</div>
  
* [[Image:Path-Profile-Edges.png|32px]] [[Path_ProfileEdges|Profile from Edges]]: Erzeugt einen Kontur- Fräspfad von ausgewählten Kanten
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path-Profile-Edges.png|32px]] [[Path_ProfileEdges/de|Profile aus Kanten]]: Erzeugt einen Profilierungspfad aus ausgewählten Kanten
 +
</div>
  
* [[Image:Path_Pocket.png|32px]] [[Path_Pocket_Shape|Pocket]]: Erzeugt einen Fräspfad für eine Tasche aus einer oder mehreren ausgewählten Taschen
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path_Pocket.png|32px]] [[Path_Pocket_Shape/de|Tasche]]: Erzeugt eine Taschenbearbeitung aus einer oder mehreren ausgewählten Taschen
 +
</div>
  
* [[Image:Path_Drilling.png|32px]] [[Path_Drilling|Drilling]]: Erzeugt den Pfad für eine oder mehrere Bohrungen
+
<div class="mw-translate-fuzzy">
 
+
* [[Image:Path_Drilling.png|32px]] [[Path_Drilling/de|Bohren]]: Führt einen Bohrzyklus durch
* [[Image:Path-Adaptive.svg|32px]] [[Path_Adaptive|Adaptive]]: Erstellt eine adaptive Clearing- und Profilerstellung.
+
</div>
 
 
* [[Image:Path-Engrave.png|32px]] [[Path_Engrave|Engrave]]: Erzeugt einen Pfad für Gravuren
 
 
 
* [[Image:Path-Face.png|32px]] [[Path_MillFace|Mill Face]]: Erzeugt einen Pfad zum Planen von Oberflächen
 
 
 
* [[Image:Path-Helix.png|32px]] [[Path_Helix|Helix]]: Erzeugt einen Helixförmigen Fräspfad
 
 
 
* [[Image:Path-3DPocket.png|32px]] [[Path_Pocket_3D|3D Pocket]]:  Erzeugt einen Fräspfad für eine 3D Tasche
 
 
 
===Path Fräspfad Erweiterungen===
 
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
* [[Image:Path_Dressup.png|32px]] [[Path_DressupDogbone|Dogbone Dressup]]: Fügt dem ausgewählten Pfad eine "dogbone" Erweiterung zu
+
* [[Image:Path-Adaptive.svg|32px]] [[Path_Adaptive/de|Adaptiv]]: Erstellt eine adaptive Räum- und Profilierungsoperation
 
</div>
 
</div>
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
* [[Image:Path_Dressup.png|32px]] [[Path_DressupDragKnife|Dragknife Dressup]]: Ändert den ausgewählten Pfad für den Einsatz eines Zugmessers
+
* [[Image:Path-Engrave.png|32px]] [[Path_Engrave/de|Gravieren]]: Erstellt einen Gravurpfad
 
</div>
 
</div>
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
* [[Image:Path_Dressup.png|32px]] [[Path_DressupLeadInOut|Lead In Dressup]]: Fügt dem ausgewählten Pfad eine horizontale Anfahrrampe zu
+
* [[Image:Path-Face.png|32px]] [[Path_MillFace/de|Fläche fräsen]]: Erzeugt einen Oberflächenpfad
 
</div>
 
</div>
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
* [[Image:Path_Dressup.png|32px]] [[Path_DressupRampEntry|Ramp Entry Dressup]]: Fügt dem ausgewählten Pfad eine vertikale Anfahrrampe zu
+
* [[Image:Path-Helix.png|32px]] [[Path_Helix/de|Helix]]: Erzeugt eine helixförmige Bahn
 
</div>
 
</div>
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
* [[Image:Path_Dressup.png|32px]] [[Path_DressupTag|Tag Dressup]]: Fügt dem ausgewählten Pfad eine Erweiterung für Haltestege zu
+
* [[Image:Path-3DPocket.png|32px]] [[Path_Pocket_3D/de|3D Tasche]]: Erzeugt einen Pfad für eine 3D Tasche
 
</div>
 
</div>
  
===Zusätzliche Kommandos===
+
===Pfad Abrichten===
 +
 
 +
 
 +
* [[Image:Path_DressupDogbone.png|32px]] [[Path_DressupBoundary/de|Randaufbereitung]]: Fügt eine Änderung der Randaufbereitung zu einem ausgewählten Pfad hinzu
 +
 
 +
* [[Image:Path_DressupDogbone.png|32px]] [[Path_DressupDogbone/de|Dogbone Aufbereitung]]: Fügt eine Dogbone Aufbereitungsmodifikation zu einem ausgewählten Pfad hinzu
 +
 
 +
* [[Image:Path_DressupDragKnife.png|32px]] [[Path_DressupDragKnife/de|Dragknife Dressup]]: Fügt ein dragknife dressup modification to a selected path
 +
 
 +
* [[Image:Path_DressupLeadInOut.png|32px]] [[Path_DressupLeadInOut/de|Lead In Dressup]]: Fügt einen Einführungs- und/oder Ausführungspunkt zu einem ausgewählten Pfad hinzu
  
* [[Image:Path_Fixture.png|32px]] [[Path_Fixture|Fixture]]: Verschiebt den Nullpunkt der Maschine.
+
* [[Image:Path_DressupRampEntry.png|32px]] [[Path_DressupRampEntry/de|Ramp Entry Dressup]]: Fügt dem ausgewählten Pfad eine vertikale Anfahrrampe zu
  
* [[Image:Path_Comment.png|32px]] [[Path_Comment|Comment]]: Fügt einen Kommentar in den G-Code eines Pfades ein.
+
* [[Image:Path_DressupTag.png|32px]] [[Path_DressupTag|Tag Dressup]]: Fügt dem ausgewählten Pfad eine Erweiterung für Haltestege zu
  
* [[Image:Path_Stop.png|32px]] [[Path_Stop|Stop]]: Fügt einen Maschinen Stop ein.
+
====Teilbefehle====
  
* [[Image:Path_Custom.png|32px]] [[Path_Custom|Custom]]: Fügt manuell erstellen G-Code ein
+
* [[Image:Path_Fixture.png|32px]] [[Path_Fixture/de|Vorrichtung]]: Ändert die Position der Vorrichtung
 +
 
 +
<div class="mw-translate-fuzzy">
 +
* [[Image:Path_Comment.png|32px]] [[Path_Comment/de|Kommentar]]: Fügt einen Kommentar in den G-Code eines Pfades ein.
 +
</div>
 +
 
 +
<div class="mw-translate-fuzzy">
 +
* [[Image:Path_Stop.png|32px]] [[Path_Stop/de|Stop]]: Fügt einen Maschinen Stop ein.
 +
</div>
 +
 
 +
<div class="mw-translate-fuzzy">
 +
* [[Image:Path_Custom.png|32px]] [[Path_Custom/de|Custom]]: Fügt benutzerdefinierten G-Code ein
 +
</div>
  
 
* [[Image:Path_GcodeFromShape.png|32px]] [[Path_FromShapes|Gcode From a Shape]]: Erstellt einen Fräspfad entlang einer oder mehrerer Linien
 
* [[Image:Path_GcodeFromShape.png|32px]] [[Path_FromShapes|Gcode From a Shape]]: Erstellt einen Fräspfad entlang einer oder mehrerer Linien
  
* [[Image:Path_OpActive.svg|32px]] [[Path_OpActive|Op Active]]: Used to activate or de-activate a path operation
+
* [[Image:Path_OpActive.svg|32px]] [[Path_OpActive/de|OP Aktiv]]: Wird zum Aktivieren oder Deaktivieren einer Pfadoperation verwendet
  
===Path Modifikationen===
+
===Pfad Modifikation===
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
* [[Image:Path_Copy.png|32px]] [[Path_Copy|Eine Operation des Jobs Kopieren]]: Erstellt eine parametrische Kopie der ausgewählten Operation.
+
* [[Image:Path_Copy.png|32px]] [[Path_Copy/de|Kopieren]]: Erstellt eine parametrische Kopie eines gewählten Pfadobjekts
 
</div>
 
</div>
  
* [[Image:Path_Array.png|32px]] [[Path_Array|Anordnung]]: Erstellt ein Array aus dem ausgewählten Pfad.
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path_Array.png|32px]] [[Path_Array|Anordnung]]: Erstellt eine Anordnung durch Duplizieren eines ausgewählten Pfades
 +
</div>
  
* [[Image:Path_SimpleCopy.png|32px]] [[Path_SimpleCopy|Simple Copy]]: Erstellt eine einfache Kopie des gewählten Pfades.
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path_SimpleCopy.png|32px]] [[Path_SimpleCopy/de|Einfache Kopie]]: Erstellt eine nichtparametrische Kopie eines ausgewählten Pfadobjekts
 +
</div>
  
==Weitere==
+
===Sonstiges===
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
* [[Image:Path-3DSurface.png|32px]] [[Path_Surface|3D Surface]]: Erstellt den Fräspfad für eine 3D Oberfläche
+
* [[Image:Path-3DSurface.png|32px]] [[Path_Surface/de|3D Surface]]: Erstellt einen Pfad für eine 3D Oberfläche ( experimentell , Dezember 2019 )
 
</div>
 
</div>
  
* [[Image:Path-Area.png|32px]] [[Path_Area|Featurebereich]]: Erstellt einen Featurebereich des selektierten Objekts
+
<div class="mw-translate-fuzzy">
 +
* [[Image:Path-Area.png|32px]] [[Path_Area/de|Funktionsbereich]]: Erstellt einen Funktionsbereich aus gewählten Objekten
 +
</div>
  
* [[Image:Path-Area-Workplane.png|32px]] [[Path_Area_Workplane|Feature area workplane]]: Creates a feature area workplane
+
<div class="mw-translate-fuzzy">
 +
[[Image:Path-Area-Workplane.png|32px]] [[Path_Area_Workplane/de|Funktionsbereich Arbeitsebene]]: Erstellt eine Funktionsbereich Arbeitsebene.
 +
</div>
  
* [[File:Path_Sanity.png|32px]] [[Path_Sanity|Path Errors]]: Überprüft den ausgewählten Job auf fehlende Angaben
+
<div class="mw-translate-fuzzy">
 +
* [[File:Path_Sanity.png|32px]] [[Path_Sanity|Path Errors]]: Überprüft den gewählten Job auf fehlende Werte
 +
</div>
  
* [[Fourth Axis]]: Developmental four axis milling
+
* [[Fourth Axis]]: Entwicklungsorientiertes Vier-Achsen Fräsen
  
 
===Einstellungen===
 
===Einstellungen===
  
 +
<div class="mw-translate-fuzzy">
 
* [[Image:Std_DlgParameter.png|32px]] [[Path_Preferences|Einstellungen...]]: Einstellungen in den Pfadwerkzeugen verfügbar.
 
* [[Image:Std_DlgParameter.png|32px]] [[Path_Preferences|Einstellungen...]]: Einstellungen in den Pfadwerkzeugen verfügbar.
 +
</div>
  
== Skriptsprache==
+
== Skripten==
  
Siehe [[Path scripting]] Seite.
+
Siehe [[Path scripting/de]] Seite.
  
Die Path Workbench bietet eine umfangreiche [[Python]] Skripting API. Damit können Sie Pfade aus Python-Skripten erstellen und ändern oder die verfügbare Funktionalität der Workbench erweitern.
+
Der Path Arbeitsbereich bietet eine umfangreiche [[Python/de]] Skripting API. Damit kannst Du Pfade aus Python Skripten erstellen und ändern oder die verfügbare Funktionalität des Arbeitsbereichs erweitern.
  
== FAQ ==
+
== Häufig gestellte Fragen ==
  
Siehe [[Path FAQ]]
+
Siehe [[Path FAQ/de]]
  
Die Path Workbench teilt viele Konzepte mit anderen CAM-Softwarepaketen, hat aber ihre eigenen Besonderheiten. Wenn etwas nicht stimmt, ist dies vielleicht ein guter Anfang.
+
Der Pfad Arbeitsbereich teilt viele Konzepte mit anderen CAM Softwarepaketen, hat aber ihre eigenen Besonderheiten. Wenn etwas nicht stimmt, ist dies vielleicht ein guter Anfang.
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
{{Userdocnavi}}
+
{{docnav/de
[[Category:Path/de]]
+
|[[PartDesign Workbench/de|PartDesign Arbeitsbereich]]
[[Category:Workbenches/de]]
+
|[[Plot Workbench|Plot Arbeitsbereich]]
 +
|IconL=Workbench_PartDesign.svg
 +
|IconR=Workbench_Plot.svg}}
 
</div>
 
</div>
  
{{Userdocnavi}}
+
{{clear}}
[[Category:Path]]
 
[[Category:Workbenches]]
 
  
 +
{{Path Tools navi{{#translation:}}}}
  
 +
{{Userdocnavi{{#translation:}}}}
  
{{clear}}
+
[[Category:Workbenches{{#translation:}}]]

Latest revision as of 21:52, 20 March 2020

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文 • ‎中文(中国大陆)‎ • ‎中文(台灣)‎
Path workbench icon

Einleitung

Die Pfad Arbeitsbereich wird verwendet, um aus einem FreeCAD 3D Modell Maschinenanweisungen für CNC Maschinen zu erstellen. Diese erzeugen reale 3D Objekte auf CNC Maschinen wie Fräsen, Drehbänken, Laserschneidmaschinen oder ähnlichem. Typischerweise handelt es sich bei den Anweisungen um einen G-Code Dialekt.

Pathwb.png

Der FreeCAD Pfad Arbeitsbereich Arbeitsablauf erstellt diese Maschinenanweisungen wie folgt:

  • Ein 3D Modell ist das Basisobjekt, das typischerweise mit einer oder mehreren der Arbeitsbereiche Part Design, Part oder Entwurf erstellt wird.
  • Ein Arbeitsauftrag wird im Pfad Arbeitsbereich erstellt. Dieser enthält alle Informationen, die zur Erzeugung des notwendigen G-Codes für die Bearbeitung des Arbeitsauftrags auf einer CNC Fräse erforderlich sind: es gibt Rohmaterial, die Fräse hat einen bestimmten Werkzeugsatz und es folgen bestimmte Befehle, die die Geschwindigkeit und die Bewegungen steuern (normalerweise G-Code).
  • Die Werkzeuge werden entsprechend den Anforderungen der Arbeitsauftragsabläufe ausgewählt.
  • Fräsbahnen werden z.B. mit Kontur und Tasche Abläufen erzeugt. Diese Bahnobjekte verwenden den internen FreeCAD G-Code Dialekt, unabhängig von der CNC Maschine.
  • Exportiere den Job mit einem G-Code, der zu Ihrer Maschine passt. Dieser Schritt wird Nachbearbeitung genannt; es sind unterschiedliche Nachbearbeitungsprozessoren verfügbar.

Verweise für die Ungeduldigen

Abhängig von deinem Interesse am Pfad Arbeitsbereich gibt es unterschiedliche Themen zur weiteren Lektüre:

  • Wenn du ein neuer Anwender bist, der versucht, sich mit Pfad vertraut zu machen, könntest du an einem schnellen Durchgang Tutorium interessiert sein.
  • Wenn Du eine spezielle Maschine hast, die keinen der verfügbaren Postprozessoren verwenden kann, möchtest Du vielleicht etwas über post-processor Anpassung erfahren.
  • Als erfahrener Anwender möchtest Du vielleicht ein Makro schreiben oder einen Prozess automatisieren, musst Du vielleicht skripten lernen
  • Erfahrene Anwender, die ihren Arbeitsablauf optimieren wollen, können sich über Anpassung informieren.
  • Neue Entwickler, die zu path beitragen möchten, sollten Kernkonzepte verstehen.

Allgemeine Konzepte

Der Pfad Arbeitsbereich erzeugt einen G-Code, der die Pfade definiert, die zum Fräsen des durch das 3D Modell auf der Zielfräse in dem Dialekt für Pfad-Job-Operationen FreeCAD G-Code dargestellten Projekts erforderlich sind, der später durch Auswahl des entsprechenden Postprozessors in den entsprechenden Dialekt für die Ziel-CNC-Steuerung übersetzt wird.

Der G-Code wird aus den in einem Bahnauftrag enthaltenen Anweisungen und Operationen generiert. Der Auftrags Arbeitsablauf listet diese in der Reihenfolge ihrer Ausführung auf. Die Liste wird durch Hinzufügen von Bahnoperationen, Bahnabbildern, Bahnteilbefehlen und Bahnmodifikationen aus dem Bahnmenü oder den GUI-Schaltflächen aufgefüllt.

Der Path Arbeitsbereich enthält einen Werkzeugverwalter (Bibliothek, Werkzeugtabelle), eine G-Code Überprüfung und Simulationswerkzeuge. Es verknüpft den Postprozessor und erlaubt den Im- und Export von Auftragsvorlagen.

  1. Die Einheiten des FreeCAD 3D-Modells werden im Bearbeiten → Einstellungen → Allgemein → Einheiten Register Einheiten Einstellungen definiert. Die Postprozessor Konfiguration definiert die endgültigen G-Code Einheiten.
  2. Der Pfad der Makrodatei und die geometrischen Toleranzen werden im Bearbeiten → Einstellungen → Pfad → Arbeitsauftag Einstellungen definiert.
  3. Die Farben werden im Register Bearbeiten → Einstellungen →Pfad → Pfad Farben definiert.
  4. Die Parameter der Halte Tags werden in der Registerkarte Bearbeiten → Einstellungen → Pfad → Dressups definiert.
  5. Dass die Qualität des Basis 3D Modells die Anforderungen an die Pfad Arbeitsbereich unterstützt, wird durch Prüfe Geometrie bestätigt.

Begrenzungen

Die meisten Pfad Werkzeuge sind keine echten 3D Werkzeuge, sondern nur 2,5D fähig. Das bedeutet, dass sie eine feste 2D Form annehmen und diese bis zu einer bestimmten Tiefe schneiden können. Es gibt zwei Werkzeuge, die echte 3D Bahnen erzeugen, von denen eines noch experimentell ist ( Dezember 2019 ). Es gibt derzeit keine Werkzeuge zum Planfräsen einer vertikalen Fläche oder zum Schneiden von vertikalen, nicht planaren Flächen eines Modells.

Einheiten

Die Handhabung von Einheiten kann im Pfad Arbeitsbereich verwirrend sein. Es gibt mehrere Punkte, die verstanden werden müssen:

  1. FreeCAD Basiseinheiten für Länge und Zeit sind 'mm' und 's' bzw. Geschwindigkeit ist 'mm/s'. Diese Einheiten speichert FreeCAD intern unabhängig von allem anderem.
  2. Das standardmäßige Einheitensystem nutzt diese Basiseinheiten. Wenn du das Standard Einheitensystem benutzt und eine Vorschubgeschwindigkeit ohne eine Einheitenfolge eingibst, wird es als 'mm/s' interpretiert.
  3. Die meisten CNC Maschinen erwarten aber Einheiten in der Form 'mm/min'oder 'Zoll/min'. Die meisten Postprozessoren konvertieren die Einheiten automatisch, wenn der Maschinencode generiert wird.

Schemata:

  1. Schemaänderungen in den Einstellungen ändert die Standardeinheitszeichenkette für die Eingabefelder. Wenn Du ein Pfad Anwender bist und es vorziehst, metrisch zu konstruieren, wird dringend empfohlen, das Schema "Metrische Kleinteile & CNC" zu verwenden. Wenn du in US Einheiten konstruierst, funktionieren entweder die Einheiten Britisches Dezimal und US Bauwesen
  2. Ändern des bevorzugten Einheitenschemas hat keine Auswirkung auf die Ausgabe, hilft aber, Eingabefehler zu vermeiden

Ausgabe:

  1. Die Generierung der korrekten Einheiten in der Ausgabe liegt in der Verantwortung des Postprozessors und geschieht nur bei diesem Vorgang.
  2. Die Einheiten für die Maschine bei der Ausgabe sind komplett unabhängig von der gewählten Einheitendarstellung.
  3. Postprozessoren erzeugen entweder metrische Einheiten (G21), imperiale Einheiten (G20) oder sind konfigurierbar.
  4. Konfigurierbare Postprozessoren generieren standardmäßig metrische Einheiten (G21).
  5. Wenn bei konfigurierbaren Postprozessoren imperiale Einheiten ausgegeben werden sollen, muss dies über Argumente in der Job-Output Konfiguration eingestellt werden (z.B.: --inches für linuxcnc). Die Einstellungen können in einem Job Template gespeichert werden und als Standard Template benutzt werden, um es in Zukunft automatisch zu verwenden.

Pfad Untersuchen:

  1. Wenn du das Werkzeug zum Untersuchen des Pfades benutzt, wird als Einheit 'mm/s' benutzt, da der Postprozessor noch nicht angewendet wurde.

Pfad Befehle

Viele der Befehle haben unterschiedliche Höhen und Tiefen:

Path-DepthsAndHeights.gif

Sichtreferenz für Tiefeneigenschaften (Einstellungen)


Diese Befehle dienen zum Einrichten eines CNC-Projekts und zur Verwaltung deiner Vorlagen.

  • Path-Job.png Auftrag: Erstellt einen neuen CNC Arbeitsauftrag
  • Path Simulator.png Simulator: Zeigt die Fräsbearbeitung wie sie auf der Maschine durchgeführt wird
  • Path Contour.png Kontur: Erzeugt einen Pfad aus der Kontur des Basisobjekts
  • Path Pocket.png Tasche: Erzeugt eine Taschenbearbeitung aus einer oder mehreren ausgewählten Taschen
  • Path Drilling.png Bohren: Führt einen Bohrzyklus durch
  • Path-Adaptive.svg Adaptiv: Erstellt eine adaptive Räum- und Profilierungsoperation
  • Path-Helix.png Helix: Erzeugt eine helixförmige Bahn
  • Path-3DPocket.png 3D Tasche: Erzeugt einen Pfad für eine 3D Tasche

Pfad Abrichten

  • Path DressupDogbone.png Randaufbereitung: Fügt eine Änderung der Randaufbereitung zu einem ausgewählten Pfad hinzu
  • Path DressupDogbone.png Dogbone Aufbereitung: Fügt eine Dogbone Aufbereitungsmodifikation zu einem ausgewählten Pfad hinzu
  • Path DressupLeadInOut.png Lead In Dressup: Fügt einen Einführungs- und/oder Ausführungspunkt zu einem ausgewählten Pfad hinzu
  • Path DressupTag.png Tag Dressup: Fügt dem ausgewählten Pfad eine Erweiterung für Haltestege zu

Teilbefehle

  • Path Comment.png Kommentar: Fügt einen Kommentar in den G-Code eines Pfades ein.
  • Path Stop.png Stop: Fügt einen Maschinen Stop ein.
  • Path Custom.png Custom: Fügt benutzerdefinierten G-Code ein
  • Path OpActive.svg OP Aktiv: Wird zum Aktivieren oder Deaktivieren einer Pfadoperation verwendet

Pfad Modifikation

  • Path Copy.png Kopieren: Erstellt eine parametrische Kopie eines gewählten Pfadobjekts
  • Path Array.png Anordnung: Erstellt eine Anordnung durch Duplizieren eines ausgewählten Pfades
  • Path SimpleCopy.png Einfache Kopie: Erstellt eine nichtparametrische Kopie eines ausgewählten Pfadobjekts

Sonstiges

  • Path-3DSurface.png 3D Surface: Erstellt einen Pfad für eine 3D Oberfläche ( experimentell , Dezember 2019 )
Path-Area-Workplane.png Funktionsbereich Arbeitsebene: Erstellt eine Funktionsbereich Arbeitsebene.
  • Path Sanity.png Path Errors: Überprüft den gewählten Job auf fehlende Werte
  • Fourth Axis: Entwicklungsorientiertes Vier-Achsen Fräsen

Einstellungen

Skripten

Siehe Path scripting/de Seite.

Der Path Arbeitsbereich bietet eine umfangreiche Python/de Skripting API. Damit kannst Du Pfade aus Python Skripten erstellen und ändern oder die verfügbare Funktionalität des Arbeitsbereichs erweitern.

Häufig gestellte Fragen

Siehe Path FAQ/de

Der Pfad Arbeitsbereich teilt viele Konzepte mit anderen CAM Softwarepaketen, hat aber ihre eigenen Besonderheiten. Wenn etwas nicht stimmt, ist dies vielleicht ein guter Anfang.