Difference between revisions of "Navigation Cube/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "=== Options avancées ===")
 
(9 intermediate revisions by the same user not shown)
Line 16: Line 16:
 
[[File:Navigation_Cube_Example.png]]
 
[[File:Navigation_Cube_Example.png]]
  
<div class="mw-translate-fuzzy">
+
Le cube de navigation se compose de plusieurs parties :
Le cube de navigation est composé de plusieurs parties:
+
* Le [[#Cube_principal|cube principal]]
* Flèches directionnelles
+
* Six [[#Fl.C3.A8ches_directionnelles|flèches directionnelles]].
* Cube de navigation principal
+
* Le [[#Bouton_de_vue_invers.C3.A9e|bouton de vue inversée]]. (en haut à droite) {{Version/fr|0.20}}
* Menu mini-cube
+
* Le [[#Menu_du_mini-cube|menu du mini-cube]] (en bas à droite)
</div>
+
* Les indicateurs des axes X, Y et Z
  
All parts, except the axis indicators, can be clicked.
+
Toutes les composantes, à l'exception des indicateurs d'axe, peuvent être cliquées.
  
== Usage ==
+
== Utilisation ==
  
 
===Cube principal===
 
===Cube principal===
  
The main cube has 26 faces: 6 square main faces, 12 rectangular edge faces ({{Version|0.20}}), and 8 triangular corner faces. Clicking any of them will reorient the camera so that its direction is perpendicular to the selected face.
+
Le cube principal comporte 26 faces : 6 faces principales carrées, 12 faces de bord rectangulaires ({{Version/fr|0.20}}) et 8 faces d'angle triangulaires. En cliquant sur l'une d'entre elles, la caméra sera réorientée de façon à ce que sa direction soit perpendiculaire à la face sélectionnée.
  
 
=== Flèches directionnelles ===  
 
=== Flèches directionnelles ===  
  
<div class="mw-translate-fuzzy">
+
Il existe six flèches directionnelles : quatre flèches triangulaires et deux flèches courbes. En cliquant sur l'une des flèches triangulaires, vous ferez pivoter la [[3D_view/fr|vue 3D]] autour d'une ligne perpendiculaire à la direction de la flèche. Si vous cliquez sur une flèche courbe, la [[3D_view/fr|vue 3D]] tournera autour de la direction de la flèche.
Six flèches directionnelles: quatre pointes de flèche triangulaires, une en haut, une en bas, une à gauche et une à droite; et deux flèches courbées, une de chaque côté de la flèche du haut.
 
</div>
 
  
 
=== Bouton de vue inversée ===
 
=== Bouton de vue inversée ===
  
Clicking the round button in the top right corner of the Navigation Cube will rotate the [[3D_view|3D view]] 180 degrees around the vertical axis of the view.
+
En cliquant sur le bouton rond dans le coin supérieur droit du cube de navigation, vous ferez pivoter la [[3D_view/fr|vue 3D]] de 180 degrés autour de l'axe vertical de la vue.
  
 
=== Menu du mini-cube ===
 
=== Menu du mini-cube ===
  
<div class="mw-translate-fuzzy">
+
En cliquant sur le petit cube dans le coin inférieur droit du cube de navigation, un menu s'affiche avec les options suivantes :
Dans le coin inférieur droit du cube de navigation se trouve un petit cube. En cliquant sur ce cube, vous obtiendrez un menu que vous pourrez utiliser pour changer le type de vue (Orthographique, Perspective, Isométrique) et de faire un "Ajuster le zoom".
+
* {{MenuCommand|[[Std_OrthographicCamera/fr|Orthographique]]}} : passe à une vue orthographique.
</div>
+
* {{MenuCommand|[[Std_PerspectiveCamera/fr|Perspective]]}} : permet d'obtenir une vue en perspective.
 +
* {{MenuCommand|[[Std_ViewIsometric/fr|Isometrique]]}} : permet de passer à une vue isométrique.
 +
* {{MenuCommand|[[Std_ViewFitAll/fr|Ajuster le zoom]]}} : effectue un zoom et un panoramique de la caméra de façon à ce que tous les objets visibles tiennent dans la vue.
  
 
==Personnalisation==
 
==Personnalisation==
Line 51: Line 51:
 
=== Déplacement du cube de navigation ===
 
=== Déplacement du cube de navigation ===
  
<div class="mw-translate-fuzzy">
+
L'ensemble du cube de navigation peut être déplacé en appuyant sur la souris n'importe où sur le cube principal et en la faisant glisser. La structure ne commencera à se déplacer que lorsque le curseur aura dépassé l'un des bords du cube principal.
Vous pouvez déplacer l'ensemble de la structure de contrôle du cube de navigation vers un autre endroit de l'affichage 3D en appuyant sur la souris n'importe où dans le cube de navigation principal et en la faisant glisser. La structure ne commencera à se déplacer que lorsque le pointeur de la souris aura dépassé le bord du cube de navigation principal.
 
</div>
 
  
 
=== Préférences ===
 
=== Préférences ===
  
<div class="mw-translate-fuzzy">
+
Le cube de navigation est contrôlé par plusieurs préférences : {{MenuCommand|Édition → Préférences... → Affichage → Navigation → Cube de navigation}}. Voir [[Preferences_Editor/fr#Navigation|Réglage des préférences]].
Le cube de navigation est configurable, notamment en ajustant sa taille : {{MenuCommand|Edition → Préférences... → Affichage → Navigation → Cube de navigation}} {{Version/fr|0.19}}.
 
</div>
 
  
 
=== Options avancées ===
 
=== Options avancées ===
  
<div class="mw-translate-fuzzy">
+
L'atelier externe [[Interface_Customization/fr#Menu_Cube|Cube Menu]] permet d'accéder plus facilement à plusieurs options de personnalisation plus avancées.
Pour une configuration plus avancée, consultez [[Interface_Customization/fr#Menu_Cube|Cube Menu]] à partir des [[External_workbenches/fr|ateliers externes]]
 
</div>
 
  
  

Latest revision as of 11:25, 9 January 2022

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어
Arrow-left.svg Page précédente : Méthodes de sélection
Page suivante : Structure d'un document Arrow-right.svg

Introduction

Le cube de navigation donne des informations visuelles sur l'orientation de la caméra dans la vue 3D en cours et peut être utilisé pour la modifier. Par défaut, il est visible et se trouve dans le coin supérieur droit de la vue.

Le cube de navigation a été mis à jour dans la version 0.20 de FreeCAD et le reste de cette page décrit cette version. Dans la version 0.19 de FreeCAD, le comportement principal est identique mais certaines fonctionnalités sont manquantes.

Navigation Cube Example.png

Le cube de navigation se compose de plusieurs parties :

Toutes les composantes, à l'exception des indicateurs d'axe, peuvent être cliquées.

Utilisation

Cube principal

Le cube principal comporte 26 faces : 6 faces principales carrées, 12 faces de bord rectangulaires (Introduit dans la version 0.20) et 8 faces d'angle triangulaires. En cliquant sur l'une d'entre elles, la caméra sera réorientée de façon à ce que sa direction soit perpendiculaire à la face sélectionnée.

Flèches directionnelles

Il existe six flèches directionnelles : quatre flèches triangulaires et deux flèches courbes. En cliquant sur l'une des flèches triangulaires, vous ferez pivoter la vue 3D autour d'une ligne perpendiculaire à la direction de la flèche. Si vous cliquez sur une flèche courbe, la vue 3D tournera autour de la direction de la flèche.

Bouton de vue inversée

En cliquant sur le bouton rond dans le coin supérieur droit du cube de navigation, vous ferez pivoter la vue 3D de 180 degrés autour de l'axe vertical de la vue.

Menu du mini-cube

En cliquant sur le petit cube dans le coin inférieur droit du cube de navigation, un menu s'affiche avec les options suivantes :

  • Orthographique : passe à une vue orthographique.
  • Perspective : permet d'obtenir une vue en perspective.
  • Isometrique : permet de passer à une vue isométrique.
  • Ajuster le zoom : effectue un zoom et un panoramique de la caméra de façon à ce que tous les objets visibles tiennent dans la vue.

Personnalisation

Déplacement du cube de navigation

L'ensemble du cube de navigation peut être déplacé en appuyant sur la souris n'importe où sur le cube principal et en la faisant glisser. La structure ne commencera à se déplacer que lorsque le curseur aura dépassé l'un des bords du cube principal.

Préférences

Le cube de navigation est contrôlé par plusieurs préférences : Édition → Préférences... → Affichage → Navigation → Cube de navigation. Voir Réglage des préférences.

Options avancées

L'atelier externe Cube Menu permet d'accéder plus facilement à plusieurs options de personnalisation plus avancées.


Arrow-left.svg Page précédente : Méthodes de sélection
Page suivante : Structure d'un document Arrow-right.svg