Difference between revisions of "Navigation Cube/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
 
(24 intermediate revisions by 2 users not shown)
Line 8: Line 8:
 
{{TOCright}}
 
{{TOCright}}
  
Le contrôle du '''cube de navigation''' est une aide graphique de l'interface utilisateur permettant de réorienter la vue 3D.
+
== Introduction ==
Par défaut, il est visible et réside dans le coin supérieur droit de l’affichage 3D. Si vous regardez la [[3D_view/fr|vue 3D]] standard, cela ressemble à ce qui suit :
 
  
[[File:FreeCAD-v0-18-NavCube_Axonometric.png]]
+
Le '''cube de navigation''' donne des informations visuelles sur l'orientation de la caméra dans la [[3D_view/fr|vue 3D]] en cours et peut être utilisé pour la modifier. Par défaut, il est visible et se trouve dans le coin supérieur droit de la vue.
  
Le cube de navigation est composé de plusieurs parties:
+
Le cube de navigation a été mis à jour dans la version 0.20 de FreeCAD et le reste de cette page décrit cette version. Dans la version 0.19 de FreeCAD, le comportement principal est identique mais certaines fonctionnalités sont manquantes.
* Flèches directionnelles
 
* Cube de navigation principal
 
* Menu mini-cube
 
  
Si vous placez le pointeur de la souris sur une entité du cube de navigation, elle devient bleu clair. En cliquant, vous réorienterez la vue 3D comme il est indiqué par la fonction. Dans l'exemple ci-dessous, la vue 3D a été pivotée par un [[Mouse_navigation/fr|mouvement à la souris]] vers une orientation "non standard". Le pointeur se trouve sur un coin (indiqué par la couleur bleue). En cliquant, vous réorienterez la vue 3D sur une vue axonométrique standard avec ce coin en face de vous.
+
[[File:Navigation_Cube_Example.png]]
  
[[File:FreeCAD-v0-18-NavCube_SelectCorner.png]]
+
Le cube de navigation se compose de plusieurs parties :
 +
* Le [[#Cube_principal|cube principal]]
 +
* Six [[#Fl.C3.A8ches_directionnelles|flèches directionnelles]].
 +
* Le [[#Bouton_de_vue_invers.C3.A9e|bouton de vue inversée]]. (en haut à droite) {{Version/fr|0.20}}
 +
* Le [[#Menu_du_mini-cube|menu du mini-cube]] (en bas à droite)
 +
* Les indicateurs des axes X, Y et Z
  
== Flèches directionnelles. ==
+
Toutes les composantes, à l'exception des indicateurs d'axe, peuvent être cliquées.
  
Six flèches directionnelles: quatre pointes de flèche triangulaires, une en haut, une en bas, une à gauche et une à droite; et deux flèches courbées, une de chaque côté de la flèche du haut.
+
== Utilisation ==
  
* En cliquant sur les flèches triangulaires, la vue 3D pivote de 45 degrés autour d'une ligne perpendiculaire à la direction de la flèche.
+
===Cube principal===
* En cliquant sur les flèches incurvées, la vue 3D pivote autour d'une ligne pointant vers vous.
 
  
<!-- Remarque: les axes de rotation ne sont pas correctement définis. Chacun est l'intersection de deux plans, mais je n'arrive pas à trouver comment les décrire -->
+
Le cube principal comporte 26 faces : 6 faces principales carrées, 12 faces de bord rectangulaires ({{Version/fr|0.20}}) et 8 faces d'angle triangulaires. En cliquant sur l'une d'entre elles, la caméra sera réorientée de façon à ce que sa direction soit perpendiculaire à la face sélectionnée.
  
== Cube de navigation principal ==
+
=== Flèches directionnelles ===  
  
Le cube de navigation principal ("cube de navigation" dans le reste de cette section) suit l'orientation de l'objet dans la partie principale de la vue 3D. Toute opération qui réoriente la vue 3D principale réorientera également le cube de navigation.
+
Il existe six flèches directionnelles : quatre flèches triangulaires et deux flèches courbes. En cliquant sur l'une des flèches triangulaires, vous ferez pivoter la [[3D_view/fr|vue 3D]] autour d'une ligne perpendiculaire à la direction de la flèche. Si vous cliquez sur une flèche courbe, la [[3D_view/fr|vue 3D]] tournera autour de la direction de la flèche.
  
Le cube de navigation est essentiellement une vue 3D d'un cube avec ses trois principaux types de composants (facettes, arêtes et angles) améliorés de sorte qu'ils puissent être facilement cliqués avec le pointeur. En cliquant sur un composant particulier, la vue 3D sera centrée et orientée vers vous. Le cube de navigation est un peu "écrasé", comme si la caractéristique la plus éloignée de vous était plus grande que celle qui se trouvait directement en face de vous. Cela permet de voir les éléments adjacents à celui qui vous fait face et par conséquent de les sélectionner.
+
=== Bouton de vue inversée ===
  
Par exemple, dans une vue "normale" d'un cube normal, lorsqu'une face vous fait face, vous pouvez également voir les quatre bords et les quatre coins de cette facette. Dans le cube de navigation "écrasé", vous pouvez également voir des entités représentant chacune des facettes adjacentes, les quatre arêtes reliant les coins de la face face à vous avec la face opposée et les angles de la face opposée. Cela vous permet de sélectionner n'importe quelle vue standard possible, à l'exception de la facette opposée et de ses bords (21 vues possibles sur 26):
+
En cliquant sur le bouton rond dans le coin supérieur droit du cube de navigation, vous ferez pivoter la [[3D_view/fr|vue 3D]] de 180 degrés autour de l'axe vertical de la vue.
* La facette qui vous fait face (ne fait rien car c'est la vue en cours)
 
* Les quatre arêtes de la facette courante
 
* Les quatre coins du facette actuel
 
* Les quatre facettes adjacentes
 
* Les quatre arêtes menant à la facette opposée
 
* Les quatre coins de la facette opposée
 
Pas possible:
 
* La facette opposée
 
* Les bords de la facette opposée
 
  
Remarque: Au moment de la rédaction de cet article (v 0.18), le cube de navigation pose quelques problèmes. toutes les fonctionnalités ne sont pas actuellement sélectionnables. En particulier, les arêtes ne peuvent pas être sélectionnées, ni les quatre coins de la face immédiatement en regard.
+
=== Menu du mini-cube ===
  
=== Sélection d'une facette ===
+
En cliquant sur le petit cube dans le coin inférieur droit du cube de navigation, un menu s'affiche avec les options suivantes :
 +
* {{MenuCommand|[[Std_OrthographicCamera/fr|Orthographique]]}} : passe à une vue orthographique.
 +
* {{MenuCommand|[[Std_PerspectiveCamera/fr|Perspective]]}} : permet d'obtenir une vue en perspective.
 +
* {{MenuCommand|[[Std_ViewIsometric/fr|Isometrique]]}} : permet de passer à une vue isométrique.
 +
* {{MenuCommand|[[Std_ViewFitAll/fr|Ajuster le zoom]]}} : effectue un zoom et un panoramique de la caméra de façon à ce que tous les objets visibles tiennent dans la vue.
  
En cliquant sur une facette, vous orienterez la vue 3D avec cete facette particulier qui vous fait face. Comme indiqué ci-dessus, d'autres points de sélection sont disponibles dans la vue de face. Il y a quatre "barres" minces sur chacun des bords extérieurs, représentant les quatre facettes adjacentes; en cliquant dessus, vous sélectionnez la vue correspondant à la facette adjacente. Quatre angles arrondis peuvent être utilisés pour définir la vue axonométrique correspondante. Il existe également un ensemble intérieur d'arêtes et de coins, actuellement non fonctionnels.
+
==Personnalisation==
  
=== Sélection du bord ===
+
=== Déplacement du cube de navigation ===
  
Malheureusement, la sélection des bords est actuellement interrompue. Tenter de sélectionner une arête sélectionnera le visage qui se trouve derrière celle-ci. En cliquant sur un bord, vous devez le centrer pour qu'il soit face à vous.
+
L'ensemble du cube de navigation peut être déplacé en appuyant sur la souris n'importe où sur le cube principal et en la faisant glisser. La structure ne commencera à se déplacer que lorsque le curseur aura dépassé l'un des bords du cube principal.
  
=== Sélection du coin ===
+
=== Préférences ===
  
En cliquant sur l'un des coins, vous obtiendrez une vue axonométrique vue depuis ce coin. Comme indiqué ci-dessus, actuellement, lorsqu'une face vous fait directement face, les coins de cette face ne sont pas sélectionnables.
+
Le cube de navigation est contrôlé par plusieurs préférences : {{MenuCommand|Édition → Préférences... → Affichage → Navigation → Cube de navigation}}. Voir [[Preferences_Editor/fr#Navigation|Réglage des préférences]].
  
== Menu du mini-cube ==
+
=== Options avancées ===
  
Dans le coin inférieur droit du cube de navigation se trouve un petit cube. En cliquant sur ce cube, vous obtiendrez un menu que vous pourrez utiliser pour changer le type de vue (Orthographique, Perspective, Isométrique) et de faire un "Ajuster le zoom".
+
L'atelier externe [[Interface_Customization/fr#Menu_Cube|Cube Menu]] permet d'accéder plus facilement à plusieurs options de personnalisation plus avancées.
 
 
== Déplacement de l’affichage du cube de navigation ==
 
 
 
Vous pouvez déplacer l'ensemble de la structure de contrôle du cube de navigation vers un autre endroit de l'affichage 3D en appuyant sur la souris n'importe où dans le cube de navigation principal et en la faisant glisser. La structure ne commencera à se déplacer que lorsque le pointeur de la souris aura dépassé le bord du cube de navigation principal.
 
 
 
== Configuration ==
 
 
 
Le cube de navigation est configurable, notamment en ajustant sa taille : {{MenuCommand|Edition → Préférences... → Affichage → Navigation → Cube de navigation}} {{Version/fr|0.19}}.
 
 
 
<div class="mw-translate-fuzzy">
 
Pour une configuration plus avancée, consultez l'[[External_workbenches/fr|atelier externe]] [[Interface_Customization/fr#Menu_Cube|Cube Menu]].
 
</div>
 
  
  

Latest revision as of 11:25, 9 January 2022

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어
Arrow-left.svg Page précédente : Méthodes de sélection
Page suivante : Structure d'un document Arrow-right.svg

Introduction

Le cube de navigation donne des informations visuelles sur l'orientation de la caméra dans la vue 3D en cours et peut être utilisé pour la modifier. Par défaut, il est visible et se trouve dans le coin supérieur droit de la vue.

Le cube de navigation a été mis à jour dans la version 0.20 de FreeCAD et le reste de cette page décrit cette version. Dans la version 0.19 de FreeCAD, le comportement principal est identique mais certaines fonctionnalités sont manquantes.

Navigation Cube Example.png

Le cube de navigation se compose de plusieurs parties :

Toutes les composantes, à l'exception des indicateurs d'axe, peuvent être cliquées.

Utilisation

Cube principal

Le cube principal comporte 26 faces : 6 faces principales carrées, 12 faces de bord rectangulaires (Introduit dans la version 0.20) et 8 faces d'angle triangulaires. En cliquant sur l'une d'entre elles, la caméra sera réorientée de façon à ce que sa direction soit perpendiculaire à la face sélectionnée.

Flèches directionnelles

Il existe six flèches directionnelles : quatre flèches triangulaires et deux flèches courbes. En cliquant sur l'une des flèches triangulaires, vous ferez pivoter la vue 3D autour d'une ligne perpendiculaire à la direction de la flèche. Si vous cliquez sur une flèche courbe, la vue 3D tournera autour de la direction de la flèche.

Bouton de vue inversée

En cliquant sur le bouton rond dans le coin supérieur droit du cube de navigation, vous ferez pivoter la vue 3D de 180 degrés autour de l'axe vertical de la vue.

Menu du mini-cube

En cliquant sur le petit cube dans le coin inférieur droit du cube de navigation, un menu s'affiche avec les options suivantes :

  • Orthographique : passe à une vue orthographique.
  • Perspective : permet d'obtenir une vue en perspective.
  • Isometrique : permet de passer à une vue isométrique.
  • Ajuster le zoom : effectue un zoom et un panoramique de la caméra de façon à ce que tous les objets visibles tiennent dans la vue.

Personnalisation

Déplacement du cube de navigation

L'ensemble du cube de navigation peut être déplacé en appuyant sur la souris n'importe où sur le cube principal et en la faisant glisser. La structure ne commencera à se déplacer que lorsque le curseur aura dépassé l'un des bords du cube principal.

Préférences

Le cube de navigation est contrôlé par plusieurs préférences : Édition → Préférences... → Affichage → Navigation → Cube de navigation. Voir Réglage des préférences.

Options avancées

L'atelier externe Cube Menu permet d'accéder plus facilement à plusieurs options de personnalisation plus avancées.


Arrow-left.svg Page précédente : Méthodes de sélection
Page suivante : Structure d'un document Arrow-right.svg