Navigare col mouse

From FreeCAD Documentation
Revision as of 15:31, 11 April 2019 by Renatorivo (talk | contribs)
Jump to navigation Jump to search
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎

La funzione Navigazione 3D - Tipo di mouse di FreeCAD comprende i comandi utilizzati per navigare visivamente lo spazio 3D e per interagire con gli oggetti visualizzati. Attualmente FreeCAD offre diversi stili di navigazione con il mouse. Lo stile di navigazione predefinito, denominato "Navigazione CAD​​", è molto semplice e pratico, ma si può anche usare uno stile alternativo, secondo le proprie preferenze.

Navigazione

I gesti del mouse utilizzati per la manipolazione dell'oggetto variano in base allo stile di navigazione selezionato; lo stile attivo, attualmente selezionato, viene utilizzato in tutti gli ambienti.

Ci sono due modi per modificare lo stile di navigazione:

  • In Preferenze, Modifica → Preferenze → Visualizzazione → Vista 3D → Navigazione 3D.
  • Cliccare col tasto destro nello spazio vuoto dell'area di visualizzazione 3D, quindi selezionare Stile di navigazione →... nel menu contestuale.

Navigazione CAD

Questo è lo stile di navigazione predefinito. Permette all'utente un semplice controllo della vista. Richiede l'uso della tastiera solo per eseguire multi-selezioni.

Template:CAD Navigation/it

Navigazione OpenInventor

La Navigazione OpenInventor (formalmente Inventor), si basa sul modello Open Inventor. Per selezionare gli oggetti, è necessario tenere premuto il tasto Ctrl.

Questa modalità non è basata su Autodesk Inventor.

Template:OpenInventor Navigation/it

Navigazione Blender

Lo stile di navigazione Blender segue il modello di Blender. In precedenza non c'era la traslazione con il solo mouse, ed era richiesto l'uso del tasto Shift per spostare la vista. Questo è cambiato nel 2016 con l'introduzione di una funzione aggiuntiva. Per eseguire una panoramica della vista, ora è possibile premere i pulsanti sinistro e destro del mouse per spostare la vista.

Selezione Traslazione Zoom Rotazione
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Shift+Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Mouse MMB hold.svg
Premere il tasto sinistro del mouse su un oggetto che si desidera selezionare. Tenere premuto Shift e il pulsante centrale del mouse, quindi spostare il puntatore.

In alternativa, tenere premuti i pulsanti sinistro e destro del mouse, quindi spostare il puntatore.

Usare la rotellina del mouse per zoommare avanti e indietro. Tenere premuto il pulsante centrale del mouse, quindi spostare il puntatore.


Navigazione Touchpad

Nella navigazione Touchpad, traslazione, zoom e rotazione della vista richiedono un tasto modificatore insieme al touchpad. Template:Touchpad Navigation/it

Navigazione Gesture

Questo stile di navigazione è fatto su misura per essere usato con il touchscreen o con la penna, ma è usabile anche con il mouse. Template:Gesture Navigation/it

Alternatively, tap and hold, then drag. This simulates the pan with the right mouse button. |Zoom_text=Use the mouse wheel to zoom in and out. |Zoom_gesture_text=Drag two fingers (pinch) closer or farther apart. |Rotate_view_text=Hold the left mouse button, then move the pointer. In Sketcher and other edit modes, this behavior is disabled. Hold Alt when pressing the mouse button to enter rotation mode.

To set the camera's focus point for rotation, click a point with the middle mouse button. Alternatively, aim the cursor at a point and press H on the keyboard. |Rotate_view_gesture_text=Drag with one finger to rotate.

Hold Alt when in the Sketcher. |Tilt_view_text=Hold both left and right mouse buttons, then move the pointer sideways. |Tilt_view_gesture_text=Rotate the imaginary line formed by two touch points.

On v0.18 this method is disabled by default. To enable, go to Edit → Preferences → Display, and untick "Disable touchscreen tilt gesture" checkbox. }}

Navigazione Maya-Gesture

Nella navigazione Maya-Gesture tutti i movimenti vista sono ottenuti premendo ALT e un pulsante del mouse, quindi per utilizzare correttamente questa modalità di navigazione è necessario disporre di un mouse con 3 pulsanti. In alternativa, dato che questo modo è stato sviluppato per essere normalmente usato come modalità di navigazione gestuale, è possibile utilizzare i gesti. Template:MayaGesture Navigation/it

Alternatively, use the mouse wheel to zoom in and out. |Rotate_view_text=Hold Alt and the left mouse button, then move the pointer. }}


Revit Navigation

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Mouse MMB hold.svg Mouse LMB+RMB hold.svg Mouse MMB rotate.svg Shift+Mouse MMB hold.svg Mouse MMB+RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer.

Alternatively, hold both left and right mouse buttons, then move the pointer.

Use the mouse wheel to zoom in and out. Hold Shift and the middle mouse button, then move the pointer.

Alternatively, hold the middle mouse button, then press and hold the right mouse button, then move the pointer.


OpenCascade

This style was introduced in version 0.18.

Select Pan Zoom Rotate view
Hand cursor.png Pan cursor.png Zoom cursor.png Rotate cursor.png
Mouse LMB.svg Ctrl+Mouse MMB hold.svg Mouse MMB hold.svg Mouse MMB rotate.svg Ctrl+Mouse LMB hold.svg Ctrl+Mouse RMB hold.svg


Press the left mouse button over an object you want to select. Hold the middle mouse button, then move the pointer. Use the mouse wheel to zoom in and out.

Alternatively, hold Ctrl and the left mouse button, then move the pointer.

Hold Ctrl and the right mouse button, then move the pointer.


La selezione degli oggetti

Selezione semplice

Gli oggetti si possono selezionare con un click del tasto sinistro del mouse o facendo clic sull'oggetto nella vista 3D o selezionandoli nella vista ad albero.

Preselezione

Passando con il mouse sugli oggetti, una funzione di Preselezione li evidenzia e visualizza le relative informazioni prima della loro selezione. Se questo comportamento non è gradito o si dispone di una macchina lenta, è possibile disattivare la funzione nel dialogo delle preferenze.

La manipolazione degli oggetti

FreeCAD offre strumenti Manipolatori utilizzabili per modificare un oggetto o il suo aspetto visivo.

Un esempio semplice è dato dal Piano di taglio attivabile con il menu Visualizza → Piano di taglio.

Supporto Hardware

FreeCAD supporta anche i dispositivi di input 3D.

Problemi con Mac OS X

Recentemente abbiamo ricevuto segnalazioni nel forum da utenti Mac che questi pulsanti del mouse e le combinazioni di tasti non funzionano come previsto. Purtroppo, nessuno degli sviluppatori possiede un Mac e neppure gli altri collaboratori regolari. Abbiamo bisogno del vostro aiuto per determinare quali pulsanti del mouse e quali combinazioni di tasti funzionano e poter aggiornare questo wiki.

Arrow-left.svg Pagina precedente: Per iniziare
Pagina successiva: Struttura dei documenti Arrow-right.svg