Mesh: Importa mesh

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Mesh Import and the translation is 100% complete.
Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎magyar • ‎română • ‎русский
FreeCAD.png
Pagina successiva: Esporta mesh Mesh Export.svg Arrow-right.svg

Mesh Import.svg Importa mesh

Nome nel codice
Mesh_Import
Posizione nel menu
Mesh → Importa mesh...
Ambiente
Mesh
Avvio veloce
Nessuno
Introdotto nella versione
-
Vedere anche
Importa, Apri, Importazione e Esportazione


Descrizione

Il comando Importa mesh importa la geometria da un formato file mesh nel documento attivo. Sono supportati diversi formati di file. Il comando crea un oggetto mesh non parametrico, una Mesh Feature.

Utilizzo

  1. Esistono diversi modi per invocare il comando:
    • Premere il pulsante Mesh Import.svg Importa mesh.
    • Selezionare l'opzione Mesh → Mesh Import.svg Importa mesh... dal menu.
    • Selezionare l'opzione Mesh Import.svg Importa mesh... dal menu contestuale della vista ad albero o della vista 3D. Questa opzione è disponibile solo se è stato selezionato un oggetto mesh esistente. Notare che l'oggetto selezionato non viene effettivamente utilizzato o modificato dal comando.
  2. Facoltativamente, selezionare il formato file corretto nella finestra di dialogo.
  3. Selezionare un file.
  4. Premere il pulsante Apri.

Preferenze

  • L'ultima posizione del file utilizzato viene memorizzata in: Strumenti → Modifica parametri... → BaseApp → Preferences → General → FileOpenSavePath.

Proprietà

Vedere: Mesh Feature.

Script

Vedere anche: Script di base per FreeCAD

Per importare un file mesh utilizzare il metodo insert del modulo Mesh.

import Mesh
Mesh.insert('D:/testfiles/cylinder.stl')


FreeCAD.png
Pagina successiva: Esporta mesh Mesh Export.svg Arrow-right.svg