Difference between revisions of "Interface Customization/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
Line 20: Line 20:
  
 
[[Image:CustomizeWorkbenches.png]]
 
[[Image:CustomizeWorkbenches.png]]
 +
 +
For an example workflow lets suppose we want to have the "Measure Linear" tool also show up in a custom toolbar in draft workbench.
 +
* in FreeCAD choose "Tools -> Customize" from the top menu
 +
* select the "Toolbars" tab
 +
* on the left side choose "Part" in the pull down menu
 +
* on the left side in the lower window scroll down to the "Measure Linear" entry and select it
 +
* on the right side choose "Draft" in the pull down menu
 +
* click on "New..." to create a new toolbar and choose a name for it
 +
* now select your destination toolbar in the right lower window (only needed if you have more than one toolbar)
 +
* by clicking on the blue "Arrow right" (top icon in the middle row) you will add your selected entry to the selected toolbar
 +
 +
'''Remarks:'''
 +
* when selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches
 +
* for adding an installed macro to a toolbar you must
 +
** select "Macros" in the pull down menu on the left side
 +
** have assigned menu text, icon (Pixmap) and so on using the "Tools -> Customize -> Macros" menu
  
  

Revision as of 19:47, 19 February 2017

Dato che l'interfaccia di FreeCAD è basata sul moderno toolkit Qt, essa dispone di una organizzazione ottimale. Si possono modificare, spostare, condividere tra i vari ambienti di lavoro widget, menu, barre e altri strumenti. Si possono creare e modificare le scorciatoie da tastiera. Si possono registrare e riprodurre le macro.

La finestra di personalizzazione è accessibile dal menu Strumenti → Std DlgCustomize.png Personalizza:

MenuPersonalizza.png

La scheda Comandi consente di esplorare tutti i comandi disponibili in FreeCAD, organizzati per categorie.

In Tastiera, è possibile vedere le scorciatoie da tastiera associate a ogni comando di FreeCAD, e volendo, si può modificare o assegnare un nuovo collegamento a qualsiasi comando. Quando si usa sovente uno specifico ambiente di lavoro, questo permette di velocizzare il suo utilizzo tramite la tastiera.

La scheda Barre degli strumenti consente di modificare le barre degli strumenti esistenti, o di creare nuove barre degli strumenti personalizzate.

La scheda Macro consente di gestire le Macro salvate in precedenza.

Le schede successive permettono di impostare le azioni di Spaceball (se installato)

Vedere anche il tutorial per creare la Barra personalizzata degli strumenti macro

Nella versione 0.16 è disponibile un nuovo strumento che permette di gestire gli ambienti di lavoro.

CustomizeWorkbenches.png

For an example workflow lets suppose we want to have the "Measure Linear" tool also show up in a custom toolbar in draft workbench.

  • in FreeCAD choose "Tools -> Customize" from the top menu
  • select the "Toolbars" tab
  • on the left side choose "Part" in the pull down menu
  • on the left side in the lower window scroll down to the "Measure Linear" entry and select it
  • on the right side choose "Draft" in the pull down menu
  • click on "New..." to create a new toolbar and choose a name for it
  • now select your destination toolbar in the right lower window (only needed if you have more than one toolbar)
  • by clicking on the blue "Arrow right" (top icon in the middle row) you will add your selected entry to the selected toolbar

Remarks:

  • when selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches
  • for adding an installed macro to a toolbar you must
    • select "Macros" in the pull down menu on the left side
    • have assigned menu text, icon (Pixmap) and so on using the "Tools -> Customize -> Macros" menu


Arrow-left.svg Impostare le preferenze Pagina precedente:
Pagina successiva: Editore delle proprietà Arrow-right.svg
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어