Difference between revisions of "Interface Customization/it"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
 
(96 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{Docnav/it|[[Import Export Preference/it|Preferenze di Importa/Esporta]]|[[Property editor/it|Editore delle proprietà]]}}
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/it|[[Import_Export_Preference/it|Preferenze di Importa/Esporta]]|[[Property_editor/it|Editore delle proprietà]]}}
 +
</div>
 +
 
 +
{{TOCright}}
 +
 
 +
==Introduzione==
 +
 
 +
L'interfaccia di FreeCAD è basata sul moderno toolkit [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt], e dispone di una organizzazione ottimale. Alcuni aspetti dell'interfaccia possono essere personalizzati. Ad esempio, è possibile aggiungere barre degli strumenti personalizzate, con strumenti di diversi ambienti di lavoro o strumenti definiti nelle macro e creare le proprie scorciatoie da tastiera. Ma i menu e le barre degli strumenti predefinite fornite con FreeCAD e i suoi ambienti di lavoro non possono essere modificati.
 +
 
 +
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
{{Caption|La finestra di dialogo Personalizza}}
 +
 
 +
==Utilizzo==
 +
 
 +
# The commands available in the Customize dialog box depend on the workbenches that have been loaded in the current FreeCAD session.  So you should first load all workbenches whose commands you want to have access to.
 +
# There are several ways to invoke the [[Image:Std_DlgCustomize.svg|16px]] [[Std_DlgCustomize|Std DlgCustomize]] command:
 +
#* Select the {{MenuCommand|Tools → [[Image:Std_DlgCustomize.svg|16px]] Customize...}} option from the menu.
 +
#* Right-click a toolbar area and choose {{MenuCommand|[[Image:Std_DlgCustomize.svg|16px]] Customize...}} from the context menu.
 +
# The Customize dialog box opens. For more information see [[#Options|Options]].
 +
# The {{Button|Help}} button does not work at this time.
 +
# Press the {{Button|Close}} button to close the dialog box.
 +
 
 +
==Opzioni==
 +
 
 +
Nella finestra di dialogo Personalizza sono disponibili le seguenti schede:
 +
 
 +
===Comandi===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Commands.png]]
 +
{{Caption|La scheda Comandi}}
 +
 
 +
In questa scheda è possibile sfogliare i comandi disponibili.
 +
 
 +
====Sfogliare i comandi====
 +
 
 +
# Selezionare una categoria di comandi nel pannello '''Categoria''' a sinistra. Alcune categorie corrispondono alle voci del menu.
 +
# Gli strumenti disponibili nella categoria selezionata sono mostrati nel pannello a destra.
 +
# Passa il mouse su un comando: appare la descrizione del comando.
 +
# Selezionare un comando: il testo della sua barra di stato viene visualizzato sotto i due pannelli.
 +
 
 +
[[#top|Torna all'inizio]]
 +
 
 +
===Tastiera===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Keyboard.png]]
 +
{{Caption|La scheda Tastiera}}
 +
 
 +
In questa scheda è possibile definire le scorciatoie da tastiera personalizzate. I collegamenti per i comandi delle macro possono essere definiti nella scheda [[#Macros|Macro]].
 +
 
 +
====Aggiungere una scorciatoia personalizzata====
 +
 
 +
# Selezionare una categoria di comando dall'elenco a discesa '''Categoria'''.
 +
# Selezionare un comando dal pannello '''Comandi'''.
 +
# La casella '''Scorciatoia corrente''' visualizza la scorciatoia corrente, se disponibile.
 +
# Inserire una nuova scorciatoia nella casella di input '''Digita la nuova scorciatoia'''. La scorciatoia accetta fino a 4 input. Ogni input è un singolo carattere, una combinazione di uno o più tasti speciali o una combinazione di uno o più tasti speciali e un carattere. Usare {{KEY|Backspace}} per correggere gli errori.
 +
# Se la scorciatoia è già in uso, una finestra di dialogo chiede se si desidera sostituirla e il comando a cui è assegnata la scorciatoia viene visualizzato nel pannello '''Attualmente assegnata a'''.
 +
# Premere il pulsante {{Button|Assegna}} per assegnare la nuova scorciatoia.
 +
# Premere il pulsante {{Button|Cancella}} per rimuovere il collegamento immesso. Questo rimuove anche il contenuto della casella '''Collegamento corrente'''. Notare che i collegamenti predefiniti non vengono rimossi in modo permanente. Sono ripristinati al riavvio di FreeCAD.
 +
 
 +
====Rimuovere una scorciatoia personalizzata====
 +
 
 +
# Selezionare una categoria di comando dall'elenco a discesa '''Categoria'''.
 +
# Selezionare un comando dal pannello '''Comandi'''.
 +
# Premere il pulsante {{Button|Ripristina}}.
 +
 
 +
====Rimuovere tutte le scorciatoie personalizzate====
 +
 
 +
# Premere il pulsante {{Button|Ripristina tutto}}.
 +
 
 +
====Note (Tastiera)====
 +
 
 +
* Le scorciatoie funzionano solo se i loro comandi vengono visualizzati nel menu standard o nel menu di un ambiente di lavoro che è stato caricato nella sessione corrente di FreeCAD o se i loro comandi vengono visualizzati su una barra degli strumenti "visibile".
 +
<!--Description of problem below: https://forum.freecadweb.org/viewtopic.php?f=23&t=45826-->
 +
* In V0.19 c'è un problema con alcuni comandi Draft. Le loro scorciatoie predefinite non funzionano e/o le scorciatoie personalizzate non possono essere assegnate.
 +
 
 +
[[#top|Torna all'inizio]]
 +
 
 +
===Ambienti di lavoro===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Workbenches.png]]
 +
{{Caption|La scheda Ambienti}}
 +
 
 +
In questa scheda si può modificare l'ordine dell'elenco del [[Std_Workbench/it|selettore degli ambienti]]. L'elenco '''Ambienti abilitati''' mostra gli ambienti così come appaiono nel selettore.
 +
 
 +
====Disabilitare un ambiente====
 +
 
 +
# Selezionare un ambiente nell'elenco '''Ambienti di lavoro abilitati'''.
 +
# Premere il pulsante {{Button|[[Image:Button_left.svg|16px]]}}.
 +
# L'ambiente viene spostato nell'elenco '''Ambienti di lavoro disabilitati'''
 +
 
 +
====Riabilitare un ambiente====
 +
 
 +
# Selezionare un ambiente nell'elenco '''Ambienti di lavoro disabilitati'''.
 +
# Premere il pulsante {{Button|[[Image:Button_right.svg|16px]]}}.
 +
# L'ambiente viene spostato nell'elenco '''Ambienti di lavoro abilitati'''
 +
 
 +
====Riabilitare tutti gli ambienti====
 +
 
 +
# Premere il pulsante {{Button|[[Image:Button_add_all.svg|16px]]}}.
 +
 
 +
====Cambiare la posizione di un ambiente====
 +
 
 +
# Selezionare un ambiente nell'elenco '''Ambienti di lavoro abilitati'''.
 +
# Premere il pulsante {{Button|[[Image:Button_up.svg|16px]]}} o il pulsante {{Button|[[Image:Button_down.svg|16px]]}}.
 +
# Ripetere fino a quando l'ambiente non si trova nella posizione desiderata.
 +
 
 +
====Ambienti in ordine alfabetico====
 +
 
 +
# Premere il pulsante {{Button|[[Image:Button_sort.svg|16px]]}}.
 +
 
 +
[[#top|Torna all'inizio]]
 +
 
 +
===Barre degli strumenti===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
{{Caption|La scheda Barre degli strumenti}}
 +
 
 +
In questa scheda è possibile creare e modificare barre degli strumenti personalizzate.
 +
 
 +
====Selezionare l'ambiente====
 +
 
 +
# Nell'elenco a discesa a destra selezionare l'ambiente di cui si desidera modificare le barre degli strumenti personalizzate. L'opzione {{Value|Global}} è disponibile per le barre degli strumenti personalizzate che dovrebbero essere disponibili in tutti gli ambienti.
 +
 
 +
====Creare una barra degli strumenti====
 +
 
 +
# Premere il pulsante {{Button|Nuovo ...}}.
 +
# Inserire un nome nella finestra di dialogo che si apre.
 +
# Premere il pulsante {{Button|OK}}.
 +
# La nuova barra degli strumenti appare nel pannello a destra.
 +
 
 +
====Rinominare una barra degli strumenti====
 +
 
 +
# Selezionare una barra degli strumenti nel pannello a destra.
 +
# Premere il pulsante {{Button|Rinomina...}}.
 +
# Inserire un nuovo nome nella finestra di dialogo che si apre.
 +
# Premere il pulsante {{Button|OK}}.
 +
 
 +
====Eliminare una barra degli strumenti====
 +
 
 +
# Selezionare una barra degli strumenti nel pannello a destra.
 +
# Premere il pulsante {{Button|Elimina}}.
 +
 
 +
====Disabilitare una barra degli strumenti====
 +
 
 +
# Deselezionare la casella di controllo davanti al nome della barra degli strumenti nel pannello a destra.
 +
# Una barra degli strumenti disabilitata è invisibile nell'interfaccia di FreeCAD.
 +
 
 +
====Aggiungere un comando====
 +
 
 +
# Selezionare la barra degli strumenti corretta nel pannello a destra. Se non viene selezionata alcuna barra degli strumenti, il comando viene aggiunto alla prima barra degli strumenti nell'elenco.
 +
# Selezionare una categoria dall'elenco a discesa a sinistra. I comandi delle macro che sono stati impostati nella scheda [[#Macros|Macro]] vengono visualizzati nella categoria "Macro".
 +
# Selezionare un comando dal pannello a sinistra.
 +
# Oppure selezionare '<Separatore>' per aggiungere un separatore (una linea tra due pulsanti della barra degli strumenti).
 +
# Premere il pulsante {{Button|[[Image:Button_right.svg|16px]]}}.
 +
 
 +
====Rimuovere un comando====
 +
 
 +
# Se necessario, espandere la barra degli strumenti nel riquadro a destra.
 +
# Selezionare un comando.
 +
# Premere il pulsante {{Button|[[Image:Button_left.svg|16px]]}}.
 +
 
 +
====Cambiare la posizione di un comando====
 +
 
 +
# Se necessario, espandere la barra degli strumenti nel riquadro a destra.
 +
# Selezionare un comando.
 +
# Premere il pulsante {{Button|[[Image:Button_up.svg|16px]]}} o il pulsante {{Button|[[Image:Button_down.svg|16px]]}}.
 +
# Ripetere fino a quando l'ambiente non si trova nella posizione desiderata.
 +
 
 +
====Note (Barre degli strumenti)====
 +
 
 +
* Le barre degli strumenti appartenenti all'ambiente corrente vengono aggiornate immediatamente, ma dopo aver disabilitato o riattivato una barra degli strumenti è necessario cambiare ambiente (passare a un ambiente diverso e quindi tornare indietro).
 +
* Per aggiornare le barre degli strumenti globali è necessario cambiare ambiente (se i comandi sono stati aggiunti o rimossi) o riavviare (se l'ordine di una barra degli strumenti è cambiato o una barra degli strumenti è stata rinominata).
 +
<!--Description of problem below: https://forum.freecadweb.org/viewtopic.php?f=23&t=45757-->
 +
* In V0.19 c'è un problema con alcuni comandi di Draft. Dopo averli aggiunti a una barra degli strumenti personalizzata ed essere usciti dall'applicazione FreeCAD, il file {{FileName|user.cfg}} deve essere modificato manualmente per questi comandi. Cercare il nome della barra degli strumenti personalizzata e in quella sezione modificare il contenuto degli elementi {{incode|FCText}} che iniziano con {{incode|gui_}} in {{incode|DraftTools}}.
 +
 
 +
[[#top|Torna all'inizio]]
 +
 
 +
===Macro===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Macros.png]]
 +
{{Caption|La scheda Macro}}
 +
 
 +
On this tab user macro commands can be set up. Once set up, they can be added to custom toolbars. FreeCAD uses a dedicated folder for user macros and only macros in that folder can be set up. Use the [[Image:Std_DlgMacroExecute.svg|16px]] [[Std_DlgMacroExecute|Std DlgMacroExecute]] command to find this folder on your system.
 +
 
 +
If you download a macro with the [[Image:Std_AddonMgr.svg|16px]] [[Std_AddonMgr|Addon Manager]] then make sure that you also download its icon image file. Most macros have an image link on the information page that appears in the Addon Manager. You can for example put this image file in the user macros folder.
 +
 
 +
If you want to use a macro downloaded from a different source you will have to install it manually. See [[How_to_install_macros|How to install macros]] for more information.
 +
 
 +
====Add a macro command====
 +
 
 +
# In the '''Macro''' dropdown list select a macro.
 +
# Enter a '''Menu text'''. This will be the name used to identify the macro command and will also appear in the toolbar if there is no icon.
 +
# Optionally enter a '''Tool tip'''. This text will appear near the location of the mouse when you hover the toolbar icon.
 +
# Optionally enter a '''Status text'''. This text will appear in the [[Status_bar|status bar]] when you hover the toolbar icon.
 +
# Optionally enter the wiki page for the macro, if available, in the '''What's this''' input box. Enter the page name, not the full URL.
 +
# Optionally enter a shortcut in the '''Accelerator''' input box. See [[#Keyboard|Keyboard]] for more information.
 +
# To add an icon:
 +
## Press the '''Pixmap''' {{Button|...}} button.
 +
## The Choose Icon dialog box opens.
 +
## If required press the {{Button|Icon folders...}} button to add an icon folder.
 +
## Select an icon from the panel. The Choose Icon dialog box closes automatically.
 +
# Press the {{Button|Add}} button.
 +
# The macro command appears in the panel on the left.
 +
# The macro command can now be selected on the [[#Toolbars|Toolbars]] tab.
 +
 
 +
====Remove a macro command====
 +
 
 +
# Select the macro command in the panel on the left.
 +
# Press the {{Button|Remove}} button.
 +
 
 +
====Change a macro command====
 +
 
 +
# Double-click the macro command in the panel on the left.
 +
# Make the required changes. Note that you cannot remove the icon, you can only replace it.
 +
# Press the {{Button|Replace}} button.
 +
 
 +
[[#top|Torna all'inizio]]
 +
 
 +
===Spaceball Motion===
 +
 
 +
This is tab is blank if no Spaceball is detected. See: [[3Dconnexion_input_devices|3Dconnexion input devices]].
 +
 
 +
[[#top|Torna all'inizio]]
 +
 
 +
===Spaceball Buttons===
 +
 
 +
This is tab is blank if no Spaceball is detected. See: [[3Dconnexion_input_devices|3Dconnexion input devices]].
 +
 
 +
[[#top|Torna all'inizio]]
 +
 
 +
==Componenti aggiuntivi==
 +
 
 +
I componenti aggiuntivi offrono ancora un altro modo per personalizzare l'interfaccia utente. Di seguito sono riportati alcuni componenti aggiuntivi creati dagli utenti nella comunità di FreeCAD. Possono essere scaricati tramite [[Image: Std_AddonMgr.svg|16px]] [[Std_AddonMgr/it|Addon Manager]] (nota: essi sono elencati nella scheda Ambienti).
  
Dato che l'interfaccia di FreeCAD è basata sul moderno toolkit [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt], essa dispone di una organizzazione ottimale. Si possono modificare, spostare, condividere tra i vari ambienti di lavoro widget, menu, barre e altri strumenti. Si possono creare e modificare le scorciatoie da tastiera. Si possono registrare e riprodurre le macro.
+
===CubeMenu===
  
La finestra di personalizzazione è accessibile dal menu {{MenuCommand|Strumenti → {{KEY/it|[[File:Std DlgCustomize.png|16px]]}} [[Std_DlgCustomize/it|Personalizza]]}}''':
+
* Github repository: https://github.com/triplus/CubeMenu
  
[[Image:MenuPersonalizza.png]]
+
===Glass===
  
==La scheda Personalizza==
+
* Github repository: https://github.com/triplus/Glass.
La scheda  '''Comandi''' consente di esplorare tutti i comandi disponibili in FreeCAD, organizzati per categorie.  
 
  
In '''Tastiera''', è possibile vedere le scorciatoie da tastiera associate a ogni comando di FreeCAD, e volendo, si può modificare o assegnare un nuovo collegamento a qualsiasi comando. Quando si usa sovente uno specifico ambiente di lavoro, questo permette di velocizzare il suo utilizzo tramite la tastiera.
+
===IconThemes===
  
La scheda '''Barre degli strumenti''' consente di modificare le barre degli strumenti esistenti, o di creare nuove barre degli strumenti personalizzate.
+
* Github repository: https://github.com/triplus/IconThemes
  
La scheda '''Macro''' consente di gestire le [[Macros/it|Macro]] salvate in precedenza.
+
===Launcher===
  
Le schede successive permettono di impostare le azioni di [[3Dconnexion_input_devices/it|Spaceball]] (se installato)
+
* Github repository: https://github.com/triplus/Launcher
  
Vedere anche il tutorial per creare la [[Customize_Toolbars/it|Barra personalizzata]] degli strumenti macro
+
===PieMenu===
  
Dalla versione 0.16 è disponibile un nuovo strumento che permette di gestire gli ambienti di lavoro.
+
* Github repository: https://github.com/triplus/PieMenu
  
[[Image:CustomizeWorkbenches.png]]
+
===RemBench===
  
==Esempio==
+
* Github repository: https://github.com/triplus/RemBench
Come esempio del flusso di lavoro, supponiamo di voler avere la funzione "Misura Lineare" mostrata anche in una barra degli strumenti personalizzata nell'ambiente [[Draft Workbench/it|Draft]].
 
* dal menu principale di FreeCAD scegliere {{MenuCommand|Strumenti → Personalizza}}
 
* selezionare la tabella "Barre degli strumenti"
 
* sul lato sinistro scegliere "Part" nel menu a discesa
 
* sul lato sinistro della finestra scorrere in basso fino alla voce "Misura Lineare" e selezionarla
 
* sul lato destro scegliere "Draft" nel menu a discesa
 
* cliccare su {{button|Nuova...}} per creare una nuova barra degli strumenti e definire il suo nome
 
* ora selezionare la barra degli strumenti di destinazione nella finestra in basso a destra (è necessario solo se si dispone di più di una barra degli strumenti)
 
* cliccando sulla "Freccia destra" di colore blu (l'icona in alto nella fila centrale) si aggiunge la voce selezionata alla barra degli strumenti selezionata
 
  
===Osservazioni:===
+
===ShortCut===
* quando si seleziona "Global" nel menu a tendina sulla parte di destra si crea una barra degli strumenti che sarà visibile in tutti gli ambienti
 
  
Per aggiungere ad una barra degli strumenti una macro installata è necessario
+
* Github repository: https://github.com/triplus/ShortCuts
* selezionare "Macro" nel menu a discesa sul lato sinistro
 
* aver assegnato il testo del menu, l'icona (Pixmap) e così via utilizzando il menu {{MenuCommand|Strumenti → Personalizza → Macro}}
 
  
 +
[[#top|Torna all'inizio]]
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
{{Docnav/it|[[Preferences Editor/it|Impostare le preferenze]]|[[Property editor/it|Editore delle proprietà]]}}
+
{{Docnav/it|[[Import_Export_Preference/it|Preferenze di Importa/Esporta]]|[[Property_editor/it|Editore delle proprietà]]}}
 
</div>
 
</div>
  
[[Category:User Documentation/it]]
+
{{Std Base navi{{#translation:}}}}
 +
{{Interface navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}

Latest revision as of 19:22, 17 October 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어
Arrow-left.svg Preferenze di Importa/Esporta Pagina precedente:
Pagina successiva: Editore delle proprietà Arrow-right.svg

Introduzione

L'interfaccia di FreeCAD è basata sul moderno toolkit Qt, e dispone di una organizzazione ottimale. Alcuni aspetti dell'interfaccia possono essere personalizzati. Ad esempio, è possibile aggiungere barre degli strumenti personalizzate, con strumenti di diversi ambienti di lavoro o strumenti definiti nelle macro e creare le proprie scorciatoie da tastiera. Ma i menu e le barre degli strumenti predefinite fornite con FreeCAD e i suoi ambienti di lavoro non possono essere modificati.

Std DlgCustomize tab Toolbars.png

La finestra di dialogo Personalizza


Utilizzo

  1. The commands available in the Customize dialog box depend on the workbenches that have been loaded in the current FreeCAD session. So you should first load all workbenches whose commands you want to have access to.
  2. There are several ways to invoke the Std DlgCustomize.svg Std DlgCustomize command:
    • Select the Tools → Std DlgCustomize.svg Customize... option from the menu.
    • Right-click a toolbar area and choose Std DlgCustomize.svg Customize... from the context menu.
  3. The Customize dialog box opens. For more information see Options.
  4. The Help button does not work at this time.
  5. Press the Close button to close the dialog box.

Opzioni

Nella finestra di dialogo Personalizza sono disponibili le seguenti schede:

Comandi

Std DlgCustomize tab Commands.png

La scheda Comandi


In questa scheda è possibile sfogliare i comandi disponibili.

Sfogliare i comandi

  1. Selezionare una categoria di comandi nel pannello Categoria a sinistra. Alcune categorie corrispondono alle voci del menu.
  2. Gli strumenti disponibili nella categoria selezionata sono mostrati nel pannello a destra.
  3. Passa il mouse su un comando: appare la descrizione del comando.
  4. Selezionare un comando: il testo della sua barra di stato viene visualizzato sotto i due pannelli.

Torna all'inizio

Tastiera

Std DlgCustomize tab Keyboard.png

La scheda Tastiera


In questa scheda è possibile definire le scorciatoie da tastiera personalizzate. I collegamenti per i comandi delle macro possono essere definiti nella scheda Macro.

Aggiungere una scorciatoia personalizzata

  1. Selezionare una categoria di comando dall'elenco a discesa Categoria.
  2. Selezionare un comando dal pannello Comandi.
  3. La casella Scorciatoia corrente visualizza la scorciatoia corrente, se disponibile.
  4. Inserire una nuova scorciatoia nella casella di input Digita la nuova scorciatoia. La scorciatoia accetta fino a 4 input. Ogni input è un singolo carattere, una combinazione di uno o più tasti speciali o una combinazione di uno o più tasti speciali e un carattere. Usare Backspace per correggere gli errori.
  5. Se la scorciatoia è già in uso, una finestra di dialogo chiede se si desidera sostituirla e il comando a cui è assegnata la scorciatoia viene visualizzato nel pannello Attualmente assegnata a.
  6. Premere il pulsante Assegna per assegnare la nuova scorciatoia.
  7. Premere il pulsante Cancella per rimuovere il collegamento immesso. Questo rimuove anche il contenuto della casella Collegamento corrente. Notare che i collegamenti predefiniti non vengono rimossi in modo permanente. Sono ripristinati al riavvio di FreeCAD.

Rimuovere una scorciatoia personalizzata

  1. Selezionare una categoria di comando dall'elenco a discesa Categoria.
  2. Selezionare un comando dal pannello Comandi.
  3. Premere il pulsante Ripristina.

Rimuovere tutte le scorciatoie personalizzate

  1. Premere il pulsante Ripristina tutto.

Note (Tastiera)

  • Le scorciatoie funzionano solo se i loro comandi vengono visualizzati nel menu standard o nel menu di un ambiente di lavoro che è stato caricato nella sessione corrente di FreeCAD o se i loro comandi vengono visualizzati su una barra degli strumenti "visibile".
  • In V0.19 c'è un problema con alcuni comandi Draft. Le loro scorciatoie predefinite non funzionano e/o le scorciatoie personalizzate non possono essere assegnate.

Torna all'inizio

Ambienti di lavoro

Std DlgCustomize tab Workbenches.png

La scheda Ambienti


In questa scheda si può modificare l'ordine dell'elenco del selettore degli ambienti. L'elenco Ambienti abilitati mostra gli ambienti così come appaiono nel selettore.

Disabilitare un ambiente

  1. Selezionare un ambiente nell'elenco Ambienti di lavoro abilitati.
  2. Premere il pulsante Button left.svg.
  3. L'ambiente viene spostato nell'elenco Ambienti di lavoro disabilitati

Riabilitare un ambiente

  1. Selezionare un ambiente nell'elenco Ambienti di lavoro disabilitati.
  2. Premere il pulsante Button right.svg.
  3. L'ambiente viene spostato nell'elenco Ambienti di lavoro abilitati

Riabilitare tutti gli ambienti

  1. Premere il pulsante Button add all.svg.

Cambiare la posizione di un ambiente

  1. Selezionare un ambiente nell'elenco Ambienti di lavoro abilitati.
  2. Premere il pulsante Button up.svg o il pulsante Button down.svg.
  3. Ripetere fino a quando l'ambiente non si trova nella posizione desiderata.

Ambienti in ordine alfabetico

  1. Premere il pulsante Button sort.svg.

Torna all'inizio

Barre degli strumenti

Std DlgCustomize tab Toolbars.png

La scheda Barre degli strumenti


In questa scheda è possibile creare e modificare barre degli strumenti personalizzate.

Selezionare l'ambiente

  1. Nell'elenco a discesa a destra selezionare l'ambiente di cui si desidera modificare le barre degli strumenti personalizzate. L'opzione Global è disponibile per le barre degli strumenti personalizzate che dovrebbero essere disponibili in tutti gli ambienti.

Creare una barra degli strumenti

  1. Premere il pulsante Nuovo ....
  2. Inserire un nome nella finestra di dialogo che si apre.
  3. Premere il pulsante OK.
  4. La nuova barra degli strumenti appare nel pannello a destra.

Rinominare una barra degli strumenti

  1. Selezionare una barra degli strumenti nel pannello a destra.
  2. Premere il pulsante Rinomina....
  3. Inserire un nuovo nome nella finestra di dialogo che si apre.
  4. Premere il pulsante OK.

Eliminare una barra degli strumenti

  1. Selezionare una barra degli strumenti nel pannello a destra.
  2. Premere il pulsante Elimina.

Disabilitare una barra degli strumenti

  1. Deselezionare la casella di controllo davanti al nome della barra degli strumenti nel pannello a destra.
  2. Una barra degli strumenti disabilitata è invisibile nell'interfaccia di FreeCAD.

Aggiungere un comando

  1. Selezionare la barra degli strumenti corretta nel pannello a destra. Se non viene selezionata alcuna barra degli strumenti, il comando viene aggiunto alla prima barra degli strumenti nell'elenco.
  2. Selezionare una categoria dall'elenco a discesa a sinistra. I comandi delle macro che sono stati impostati nella scheda Macro vengono visualizzati nella categoria "Macro".
  3. Selezionare un comando dal pannello a sinistra.
  4. Oppure selezionare '<Separatore>' per aggiungere un separatore (una linea tra due pulsanti della barra degli strumenti).
  5. Premere il pulsante Button right.svg.

Rimuovere un comando

  1. Se necessario, espandere la barra degli strumenti nel riquadro a destra.
  2. Selezionare un comando.
  3. Premere il pulsante Button left.svg.

Cambiare la posizione di un comando

  1. Se necessario, espandere la barra degli strumenti nel riquadro a destra.
  2. Selezionare un comando.
  3. Premere il pulsante Button up.svg o il pulsante Button down.svg.
  4. Ripetere fino a quando l'ambiente non si trova nella posizione desiderata.

Note (Barre degli strumenti)

  • Le barre degli strumenti appartenenti all'ambiente corrente vengono aggiornate immediatamente, ma dopo aver disabilitato o riattivato una barra degli strumenti è necessario cambiare ambiente (passare a un ambiente diverso e quindi tornare indietro).
  • Per aggiornare le barre degli strumenti globali è necessario cambiare ambiente (se i comandi sono stati aggiunti o rimossi) o riavviare (se l'ordine di una barra degli strumenti è cambiato o una barra degli strumenti è stata rinominata).
  • In V0.19 c'è un problema con alcuni comandi di Draft. Dopo averli aggiunti a una barra degli strumenti personalizzata ed essere usciti dall'applicazione FreeCAD, il file user.cfg deve essere modificato manualmente per questi comandi. Cercare il nome della barra degli strumenti personalizzata e in quella sezione modificare il contenuto degli elementi FCText che iniziano con gui_ in DraftTools.

Torna all'inizio

Macro

Std DlgCustomize tab Macros.png

La scheda Macro


On this tab user macro commands can be set up. Once set up, they can be added to custom toolbars. FreeCAD uses a dedicated folder for user macros and only macros in that folder can be set up. Use the Std DlgMacroExecute.svg Std DlgMacroExecute command to find this folder on your system.

If you download a macro with the Std AddonMgr.svg Addon Manager then make sure that you also download its icon image file. Most macros have an image link on the information page that appears in the Addon Manager. You can for example put this image file in the user macros folder.

If you want to use a macro downloaded from a different source you will have to install it manually. See How to install macros for more information.

Add a macro command

  1. In the Macro dropdown list select a macro.
  2. Enter a Menu text. This will be the name used to identify the macro command and will also appear in the toolbar if there is no icon.
  3. Optionally enter a Tool tip. This text will appear near the location of the mouse when you hover the toolbar icon.
  4. Optionally enter a Status text. This text will appear in the status bar when you hover the toolbar icon.
  5. Optionally enter the wiki page for the macro, if available, in the What's this input box. Enter the page name, not the full URL.
  6. Optionally enter a shortcut in the Accelerator input box. See Keyboard for more information.
  7. To add an icon:
    1. Press the Pixmap ... button.
    2. The Choose Icon dialog box opens.
    3. If required press the Icon folders... button to add an icon folder.
    4. Select an icon from the panel. The Choose Icon dialog box closes automatically.
  8. Press the Add button.
  9. The macro command appears in the panel on the left.
  10. The macro command can now be selected on the Toolbars tab.

Remove a macro command

  1. Select the macro command in the panel on the left.
  2. Press the Remove button.

Change a macro command

  1. Double-click the macro command in the panel on the left.
  2. Make the required changes. Note that you cannot remove the icon, you can only replace it.
  3. Press the Replace button.

Torna all'inizio

Spaceball Motion

This is tab is blank if no Spaceball is detected. See: 3Dconnexion input devices.

Torna all'inizio

Spaceball Buttons

This is tab is blank if no Spaceball is detected. See: 3Dconnexion input devices.

Torna all'inizio

Componenti aggiuntivi

I componenti aggiuntivi offrono ancora un altro modo per personalizzare l'interfaccia utente. Di seguito sono riportati alcuni componenti aggiuntivi creati dagli utenti nella comunità di FreeCAD. Possono essere scaricati tramite Std AddonMgr.svg Addon Manager (nota: essi sono elencati nella scheda Ambienti).

CubeMenu

Glass

IconThemes

Launcher

PieMenu

RemBench

ShortCut

Torna all'inizio

Arrow-left.svg Preferenze di Importa/Esporta Pagina precedente:
Pagina successiva: Editore delle proprietà Arrow-right.svg