Difference between revisions of "Interface Customization/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "{{Interface/fr}}")
(Updating to match new version of source page)
 
(21 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 +
{{UnfinishedDocu{{#translation:}}}}
 
{{Docnav/fr
 
{{Docnav/fr
 
|[[Import Export Preference/fr|Import et Export préférences]]
 
|[[Import Export Preference/fr|Import et Export préférences]]
Line 7: Line 8:
 
== Introduction ==
 
== Introduction ==
  
Puisque l'interface de FreeCAD est basée sur le très moderne ''toolkit'' [http://fr.wikipedia.org/wiki/Qt Qt], elle dispose d'une organisation de pointe. Les widgets, menus, barres d'outils et autres outils peuvent être modifiés, déplacés, partagés entre ateliers ; des raccourcis-clavier peuvent être créés et modifiés, et des macros peuvent être enregistrées et jouées. La fenêtre de personnalisation est accessible depuis le menu {{MenuCommand|Outils → Personnaliser}}
+
Puisque l'interface de FreeCAD est basée sur le très moderne ''toolkit'' [http://fr.wikipedia.org/wiki/Qt Qt], elle dispose d'une organisation de pointe. Les widgets, menus, barres d'outils et autres outils peuvent être modifiés, déplacés, partagés entre ateliers ; des raccourcis-clavier peuvent être créés et modifiés, et des macros peuvent être enregistrées et jouées.
 
{{TOCright}}
 
{{TOCright}}
  
 
[[Image:Screenshot-customize.jpg|La fenêtre Personnaliser...]]
 
[[Image:Screenshot-customize.jpg|La fenêtre Personnaliser...]]
 +
 +
{{Caption|La boite de dialogue de personnalisation d'interface}}
 +
 +
==Usage==
 +
 +
La fenêtre de personnalisation est accessible depuis le menu {{MenuCommand|{{StdMenu|[[Std Tools Menu|Tools]]}} → Customize}}.
  
 
== Onglets de personnalisation ==
 
== Onglets de personnalisation ==
Line 47: Line 54:
 
* en cliquant sur la "Flèche vers la droite" bleue (icône du haut de la rangée du milieu), vous ajouterez l’entrée sélectionnée à la barre d’outils sélectionnée
 
* en cliquant sur la "Flèche vers la droite" bleue (icône du haut de la rangée du milieu), vous ajouterez l’entrée sélectionnée à la barre d’outils sélectionnée
  
===Remarques:===
+
=== Remarques ===
Lorsque vous sélectionnez "Global" dans le menu déroulant sur le côté droit, vous allez créer une barre d’outils qui sera visible dans tous les ateliers
+
Lorsque vous sélectionnez "Global" dans le menu déroulant sur le côté droit, vous allez créer une barre d’outils qui sera visible dans tous les ateliers.
  
 
Pour ajouter une macro déjà enregistrée à une barre d’outils, vous devez
 
Pour ajouter une macro déjà enregistrée à une barre d’outils, vous devez
Line 54: Line 61:
 
* sinon au préalable il faut avoir une macro correctement définie en ayant utilisé l’onglet {{MenuCommand|Outils → Personnaliser → Macros}} et qu’elle soit présente dans la fenêtre "Installer des macros personnalisées"
 
* sinon au préalable il faut avoir une macro correctement définie en ayant utilisé l’onglet {{MenuCommand|Outils → Personnaliser → Macros}} et qu’elle soit présente dans la fenêtre "Installer des macros personnalisées"
  
<div class="mw-translate-fuzzy">
+
== Addons ==
{{docnav/fr
+
{{Page en cours}}
 +
 
 +
Il existe d'autres façons de personnaliser l'interface FreeCAD en utilisant son référentiel modulaire robuste via le [[Image:AddonManager.svg|24px]] [[Addon Manager/fr|Std Addon manager (gestionnaire d'extensions)]]. Il existe plusieurs Addons qui permettent d'améliorer l'interface utilisateur/expérience utilisateur. Voici quelques options créées par les utilisateurs de la communauté FreeCAD.
 +
 
 +
=== Transparence ===
 +
 
 +
https://www.youtube.com/watch?v=ny31diN1ZhM
 +
 
 +
* Dépôt Github: ([https://github.com/triplus/Glass lien])
 +
* Discussion du forum : ([https://forum.freecadweb.org/viewtopic.php?t=32397 fil])
 +
 +
=== Menu camembert===
 +
 
 +
* Dépôt Github:
 +
 +
=== Lanceur ===
 +
 
 +
* Dépôt Github: https://github.com/triplus/Launcher
 +
 
 +
=== Raccourci ===
 +
 
 +
* Dépôt Github: https://github.com/triplus/ShortCuts
 +
 
 +
=== RemBench ===
 +
 
 +
* Dépôt Github: https://github.com/triplus/RemBench
 +
 
 +
=== Thèmes des icônes===
 +
 
 +
* Dépôt Github: https://github.com/triplus/IconThemes
 +
 
 +
=== Menu en cube===
 +
 
 +
* Dépôt Github: https://github.com/triplus/CubeMenu
 +
 
 +
{{Docnav/fr
 
|[[Import Export Preference/fr|Import et Export préférences]]
 
|[[Import Export Preference/fr|Import et Export préférences]]
 
|[[Property editor/fr|Propriétés des objets]]
 
|[[Property editor/fr|Propriétés des objets]]
 
}}
 
}}
</div>
 
 
<div class="mw-translate-fuzzy">
 
{{Std Base navi/fr}}
 
{{Interface/fr}}
 
{{Userdocnavi/fr}}
 
</div>
 
 
{{Interface/fr}}
 
  
{{Userdocnavi/fr}}
+
{{Std Base navi{{#translation:}}}}
 +
{{Interface navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}

Latest revision as of 22:48, 18 March 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Cette documentation n'est pas terminée. SVP contribuez en traduisant la documentation.

Allez voir Draft ShapeString pour un modèle de documentation. Gui Command donne un aperçu des commandes. Et, pour voir d'autres commandes Liste des Commandes.

Allez sur Help FreeCAD ou comment faire pour contribuer.

Introduction

Puisque l'interface de FreeCAD est basée sur le très moderne toolkit Qt, elle dispose d'une organisation de pointe. Les widgets, menus, barres d'outils et autres outils peuvent être modifiés, déplacés, partagés entre ateliers ; des raccourcis-clavier peuvent être créés et modifiés, et des macros peuvent être enregistrées et jouées.

La fenêtre Personnaliser...

La boite de dialogue de personnalisation d'interface


Usage

La fenêtre de personnalisation est accessible depuis le menu Tools → Customize.

Onglets de personnalisation

L'onglet Commandes permet de naviguer à travers les commandes disponibles de FreeCAD, classées par leur catégorie.

L'onglet Clavier affiche les raccourcis associés avec chaque commande de FreeCAD, et vous permet de modifier ou d'assigner un nouveau raccourci à n'importe quelle commande. Ceci peut être utile si vous utiliser couramment un atelier en particulier : vous pouvez augmenter votre rapidité en utilisant le clavier.

Les onglets Barre d'outils et Barre de boîte d'outils vous permet de modifier des barres d'outils existantes, ou de créer vos propres barres d'outils personnalisées.

Sous l'onglet Ateliers (Workbenches), les ateliers existants dans FreeCAD sont répertoriés, à gauche ceux à l'état passif, à droite ceux à l'état actif. Le statut peut être changé avec les flèches horizontales.

File:UserdefSymbstrip.jpg

Sous l'onglet Barres d'outils (Toolbars) à gauche se trouvent les mêmes catégories de commandes que sous la carte Commandes. Après avoir cliqué sur une catégorie, les commandes correspondantes apparaissent et peuvent être copiées à droite. Avant cela, sélectionnez un espace de travail actif auquel vous souhaitez ajouter une barre d'outils individuelle. Commencez par sélectionner un nom pour cette barre d’outils avec Nouveau (New...) avant de copier les commandes. Lorsque cet espace de travail est appelé ultérieurement, cette barre doit être activée: Affichage → Barres d'outils.

Remarque: si "Global" (au lieu d'un espace de travail) est sélectionné à droite, la barre d'outils ajoutée peut être activée dans chaque espace de travail.


L'onglet Macros permet de gérer vos Macros enregistrées.

Tutoriel pour créer vos Barres d'Outils pour vos macro Personnaliser la barre d'outils

Depuis FreeCAD 0.16, un nouvel outil est disponible pour vous permettre de gérer vos ateliers.

CustomizeWorkbenches.png

Exemple

Par exemple lors d’une session de travail, supposons que nous voulions que l’outil "Mesure de longueur" apparaisse également dans une barre d'outils personnalisée dans l’atelier Draft.

  • dans FreeCAD choisissez Outils → Personnaliser... dans le menu tout en haut
  • sélectionnez l’onglet "Barre d'outils"
  • sur le côté gauche, choisissez "Pièce" dans le menu déroulant
  • sur le côté gauche de la fenêtre inférieure, descendez jusqu’à l’entrée "Mesure de longueur" et sélectionnez-la
  • sur le côté droit, choisissez "Draft" dans le menu déroulant
  • cliquez sur "Nouveau ..." pour créer une nouvelle barre d’outils et choisissez un nom pour celle-ci
  • sélectionnez maintenant votre barre d’outils de destination dans la fenêtre inférieure droite (uniquement nécessaire si vous avez plus d’une barre d’outils)
  • en cliquant sur la "Flèche vers la droite" bleue (icône du haut de la rangée du milieu), vous ajouterez l’entrée sélectionnée à la barre d’outils sélectionnée

Remarques

Lorsque vous sélectionnez "Global" dans le menu déroulant sur le côté droit, vous allez créer une barre d’outils qui sera visible dans tous les ateliers.

Pour ajouter une macro déjà enregistrée à une barre d’outils, vous devez

  • sélectionnez "Macros" dans le menu déroulant sur le côté gauche en haut
  • sinon au préalable il faut avoir une macro correctement définie en ayant utilisé l’onglet Outils → Personnaliser → Macros et qu’elle soit présente dans la fenêtre "Installer des macros personnalisées"

Addons

Template:Page en cours

Il existe d'autres façons de personnaliser l'interface FreeCAD en utilisant son référentiel modulaire robuste via le AddonManager.svg Std Addon manager (gestionnaire d'extensions). Il existe plusieurs Addons qui permettent d'améliorer l'interface utilisateur/expérience utilisateur. Voici quelques options créées par les utilisateurs de la communauté FreeCAD.

Transparence

https://www.youtube.com/watch?v=ny31diN1ZhM

  • Dépôt Github: (lien)
  • Discussion du forum : (fil)

Menu camembert

  • Dépôt Github:

Lanceur

Raccourci

RemBench

Thèmes des icônes

Menu en cube