Difference between revisions of "Interface Customization/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "Sous l'onglet '''Ateliers''' ('''Workbenches'''), les ateliers existants dans FreeCAD sont répertoriés, à gauche ceux à l'état passif, à droite ceux à l'état actif. Le...")
 
(143 intermediate revisions by 4 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{docnav/fr
+
{{Docnav/fr
|[[Import Export Preference/fr|Import et Export préférences]]
+
|[[Import_Export_Preferences/fr|Préférences d'Import Export]]
|[[Property editor/fr|Propriétés des objets]]
+
|[[Property_editor/fr|Propriétés des objets]]
 
}}
 
}}
  
Puisque l'interface de FreeCAD est basée sur le très moderne ''toolkit'' [http://fr.wikipedia.org/wiki/Qt Qt], elle dispose d'une organisation de pointe. Les widgets, menus, barres d'outils et autres outils peuvent être modifiés, déplacés, partagés entre ateliers ; des raccourcis-clavier peuvent être créés et modifiés, et des macros peuvent être enregistrées et jouées. La fenêtre de personnalisation est accessible depuis le menu {{MenuCommand|Outils → Personnaliser}}
+
{{TOCright}}
  
[[Image:Screenshot-customize.jpg|La fenêtre Personnaliser...]]
+
== Introduction ==
  
== Onglets de personnalisation ==
+
L'interface FreeCAD est basée sur la boîte à outils [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] et possède une organisation de pointe. Certains aspects de l'interface peuvent être personnalisés. Vous pouvez, par exemple, ajouter des barres d'outils personnalisées avec des outils de plusieurs ateliers ou des outils définis dans des macros et vous pouvez créer vos propres raccourcis clavier. Mais les menus et barres d'outils par défaut fournis avec FreeCAD et ses ateliers ne peuvent pas être modifiés.
L'onglet '''Commandes''' permet de naviguer à travers les commandes disponibles de FreeCAD, classées par leur catégorie.  
 
  
L'onglet '''Clavier''' affiche les raccourcis associés avec chaque commande de FreeCAD, et vous permet de modifier ou d'assigner un nouveau raccourci à n'importe quelle commande. Ceci peut être utile si vous utiliser couramment un atelier en particulier : vous pouvez augmenter votre rapidité en utilisant le clavier.
+
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
{{Caption|La boite de dialogue de personnalisation de l'interface}}
  
Les onglets '''Barre d'outils''' et '''Barre de boîte d'outils''' vous permet de modifier des barres d'outils existantes, ou de créer vos propres barres d'outils personnalisées.
+
==Utilisation==
  
Sous l'onglet '''Ateliers''' ('''Workbenches'''), les ateliers existants dans FreeCAD sont répertoriés, à gauche ceux à l'état passif, à droite ceux à l'état actif. Le statut peut être changé avec les flèches horizontales.
+
# Les commandes disponibles dans la boite de dialogue de personnalisation d'interface dépendent des ateliers qui ont été chargés dans la session FreeCAD en cours. Vous devez donc d'abord charger tous les établis dont vous souhaitez avoir accès aux commandes.
 +
# Il existe plusieurs façons d'appeler la commande [[Image:Std_DlgCustomize.svg|16px]] [[Std_DlgCustomize/fr|Std Personnalisation]]:
 +
#* Sélectionnez l'option {{MenuCommand|Outils → [[Image:Std_DlgCustomize.svg|16px]] Personnaliser...}} dans le menu.
 +
#* Cliquez avec le bouton droit sur une zone de barre d'outils et choisissez {{MenuCommand|[[Image:Std_DlgCustomize.svg|16px]] Personnaliser...}} dans le menu contextuel.
 +
# La boîte de dialogue Personnaliser s'ouvre. Pour plus d'informations, voir [[#Options|Options]].
 +
# Le bouton {{Button|Aide}} ne fonctionne pas pour le moment.
 +
# Appuyez sur le bouton {{Button|Fermer}} pour fermer la boîte de dialogue.
  
[[Image:UserdefSymbstrip.jpg]]
+
== Options ==
  
Under the tab '''Toolbars''' ('''Toolbars''') on the left are the same command categories as under the map '''Commands'''. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with '''New''' ('''New...''') before copying commands over to it. When this workspace is called later, this bar must be activated: '''View → Toolbars'''.
+
Dans la boîte de dialogue Personnaliser, les onglets suivants sont disponibles:
  
Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.
+
=== Commandes ===
  
 +
[[Image:Std_DlgCustomize_tab_Commands.png]]
 +
{{Caption|L'onglet Commandes}}
  
<div class="mw-translate-fuzzy">
+
Avec cet onglet, vous pouvez parcourir les commandes disponibles.
L'onglet '''Macros''' permet de gérer vos [[Macros/fr|Macros]] enregistrées.
 
</div>
 
  
Tutoriel pour créer vos Barres d'Outils pour vos macro [[Customize_Toolbars/fr|Customize Toolbars]]
+
==== Parcourir les commandes ====
  
Depuis FreeCAD 0.16, un nouvel outil est disponible pour vous permettre de gérer vos ateliers.
+
# Sélectionnez une catégorie de commandes dans le panneau '''Catégorie''' à gauche. Certaines catégories correspondent aux entrées de menu.
 +
# Les outils disponibles dans la catégorie sélectionnée sont affichés dans le panneau de droite.
 +
# Survolez une commande: son info-bulle apparaît.
 +
# Sélectionnez une commande: son texte dans la barre d'état s'affiche sous les deux panneaux.
  
[[Image:CustomizeWorkbenches.png]]
+
[[#top|En haut]]
  
<div class="mw-translate-fuzzy">
+
===Clavier===
==Exemple==
 
Par exemple lors d’une session de travail, supposons que nous voulions que l’outil "Mesure de longueur" apparaisse également dans une barre d'outils personnalisée dans l’atelier Draft.
 
* dans FreeCAD choisissez {{MenuCommand|Outils → Personnaliser...}} dans le menu tout en haut
 
* sélectionnez l’onglet "Barre d'outils"
 
* sur le côté gauche, choisissez "Pièce" dans le menu déroulant
 
* sur le côté gauche de la fenêtre inférieure, descendez jusqu’à l’entrée "Mesure de longueur" et sélectionnez-la
 
* sur le côté droit, choisissez "Draft" dans le menu déroulant
 
* cliquez sur "Nouveau ..." pour créer une nouvelle barre d’outils et choisissez un nom pour celle-ci
 
* sélectionnez maintenant votre barre d’outils de destination dans la fenêtre inférieure droite (uniquement nécessaire si vous avez plus d’une barre d’outils)
 
* en cliquant sur la "Flèche vers la droite" bleue (icône du haut de la rangée du milieu), vous ajouterez l’entrée sélectionnée à la barre d’outils sélectionnée
 
</div>
 
  
===Remarques:===
+
[[Image:Std_DlgCustomize_tab_Keyboard.png]]
Lorsque vous sélectionnez "Global" dans le menu déroulant sur le côté droit, vous allez créer une barre d’outils qui sera visible dans tous les ateliers
+
{{Caption|L'onglet Clavier}}
  
Pour ajouter une macro déjà enregistrée à une barre d’outils, vous devez
+
Dans cet onglet, des raccourcis clavier personnalisés peuvent être définis. Les raccourcis des macro-commandes peuvent être définis dans l'onglet [[#Macros|Macros]].
* sélectionnez "Macros" dans le menu déroulant sur le côté gauche en haut
 
* sinon au préalable il faut avoir une macro correctement définie en ayant utilisé l’onglet {{MenuCommand|Outils → Personnaliser → Macros}} et qu’elle soit présente dans la fenêtre "Installer des macros personnalisées"
 
  
{{docnav/fr
+
==== Ajouter un raccourci personnalisé ====
|[[Import Export Preference/fr|Import et Export préférences]]
+
 
|[[Property editor/fr|Propriétés des objets]]
+
# Sélectionnez une catégorie de commandes dans la liste déroulante '''Catégorie'''.
 +
# Sélectionnez une commande dans le panneau '''Commandes'''.
 +
# La case '''Raccourci actuel''' affiche le raccourci actuel, si disponible.
 +
# Entrez un nouveau raccourci dans la zone de saisie '''Appuyez sur nouveau raccourci'''. Les raccourcis peuvent comporter jusqu'à 4 entrées. Chaque entrée est soit un seul caractère, une combinaison d'une ou plusieurs touches spéciales ou une combinaison d'une ou plusieurs touches spéciales et un caractère. Utilisez {{KEY|Retour Arrière}} pour corriger les erreurs.
 +
# Si le raccourci est déjà utilisé, une boîte de dialogue vous demandera si vous souhaitez le remplacer, et la commande à laquelle le raccourci est affecté apparaîtra dans le panneau '''Actuellement assigné à'''.
 +
# Appuyez sur le bouton {{Button|Attribuer}} pour attribuer le nouveau raccourci.
 +
# Appuyez sur le bouton {{Button|Effacer}} pour supprimer le raccourci entré. Cela supprimera également le contenu de la boîte '''Raccourci actuel'''. Notez que les raccourcis par défaut ne sont pas supprimés définitivement. Ils seront restaurés au redémarrage de FreeCAD.
 +
 
 +
==== Supprimer un raccourci personnalisé ====
 +
 
 +
# Sélectionnez une catégorie de commandes dans la liste déroulante '''Catégorie'''.
 +
# Sélectionnez une commande dans le panneau '''Commandes'''.
 +
# Appuyez sur le bouton {{Button|Réinitialiser}}.
 +
 
 +
==== Supprimer tous les raccourcis personnalisés ====
 +
 
 +
# Appuyez sur le bouton {{Button|Tout réinitialiser}}.
 +
 
 +
==== Remarques (clavier) ====
 +
 
 +
* Les raccourcis ne fonctionnent que si leurs commandes apparaissent dans le menu standard ou dans le menu d'un plan de travail qui a été chargé dans la session FreeCAD en cours, ou si leurs commandes apparaissent sur une barre d'outils ''visible'' .
 +
<!-- Description du problème ci-dessous: https://forum.freecadweb.org/viewtopic.php?f=23&t=45826-->
 +
* Dans V0.19 il y a un problème avec certaines commandes Draft. Leurs raccourcis par défaut ne fonctionnent pas et/ou des raccourcis personnalisés ne peuvent pas leur être attribués.
 +
 
 +
[[#top|En haut]]
 +
 
 +
===Ateliers===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Workbenches.png]]
 +
{{Caption|L'onglet Ateliers}}
 +
 
 +
Dans cet onglet, la liste des [[Std_Workbench/fr|Ateliers]] peut être modifiée. La liste '''Ateliers activés''' affiche les Ateliers tels qu'ils apparaîtront dans le sélecteur d'Ateliers.
 +
 
 +
==== Désactiver un atelier ====
 +
 
 +
# Sélectionnez un établi dans la liste des '''ateliers activés'''.
 +
# Appuyez sur le bouton {{Button|[[Image:Button_left.svg|16px]]}}.
 +
# L'atelier sera déplacé vers la liste des '''ateliers désactivés'''
 +
 
 +
==== Réactiver un atelier ====
 +
 
 +
# Sélectionnez un établi dans la liste des '''ateliers désactivés'''.
 +
# Appuyez sur le bouton {{Button|[[Image:Button_right.svg|16px]]}}.
 +
# L'atelier sera déplacé vers la liste des '''ateliers désactivés'''.
 +
 
 +
==== Réactiver tous les ateliers ====
 +
 
 +
# Appuyez sur le bouton {{Button|[[Image:Button_add_all.svg|16px]]}}.
 +
 
 +
==== Modifier une position d'un atelier ====
 +
 
 +
# Sélectionnez un établi dans la liste des '''Ateliers activés'''.
 +
# Appuyez sur le bouton {{Button|[[Image:Button_up.svg|16px]]}} ou sur le bouton {{Button|[[Image:Button_down.svg|16px]]}}.
 +
# Répétez éventuellement cette opération jusqu'à ce que l'atelier soit à la bonne position.
 +
 
 +
==== Trier les ateliers par ordre alphabétique ====
 +
 
 +
# Appuyez sur le bouton {{Button|[[Image:Button_sort.svg|16px]]}}.
 +
 
 +
[[#top|En haut]]
 +
 
 +
=== Barre d'outils ===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
{{Caption|L'onglet Barres d'outils}}
 +
 
 +
Dans cet onglet, des barres d'outils personnalisées peuvent être créées et modifiées.
 +
 
 +
==== Sélectionnez l'atelier ====
 +
 
 +
# Dans la liste déroulante à droite, sélectionnez l'atelier dont vous souhaitez modifier les barres d'outils personnalisées. L'option {{Value|Global}} est disponible pour les barres d'outils personnalisées qui devraient être disponibles dans tous les ateliers.
 +
 
 +
==== Créer une barre d'outils ====
 +
 
 +
# Appuyez sur le bouton {{Button|Nouveau...}}.
 +
# Saisissez un nom dans la boîte de dialogue qui s'ouvre.
 +
# Appuyez sur le bouton {{Button|OK}}.
 +
# La nouvelle barre d'outils apparaîtra dans le panneau de droite.
 +
 
 +
==== Renommer une barre d'outils ====
 +
 
 +
# Sélectionnez une barre d'outils dans le panneau de droite.
 +
# Appuyez sur le bouton {{Button|Renommer...}}.
 +
# Saisissez un nouveau nom dans la boîte de dialogue qui s'ouvre.
 +
# Appuyez sur le bouton {{Button|OK}}.
 +
 
 +
==== Supprimer une barre d'outils ====
 +
 
 +
# Sélectionnez une barre d'outils dans le panneau de droite.
 +
# Appuyez sur le bouton {{Button|Supprimer}}.
 +
 
 +
==== Désactiver une barre d'outils ====
 +
 
 +
# Décochez la case devant le nom de la barre d'outils dans le panneau de droite.
 +
# Une barre d'outils désactivée sera invisible dans l'interface FreeCAD.
 +
 
 +
==== Ajouter une commande ====
 +
 
 +
# Sélectionnez la barre d'outils appropriée dans le panneau de droite. Si aucune barre d'outils n'est sélectionnée, la commande sera ajoutée à la première barre d'outils de la liste.
 +
# Sélectionnez une catégorie dans la liste déroulante de gauche. Les macros commandes qui ont été configurées dans l'onglet [[#Macros|Macros]] apparaissent dans la catégorie 'Macros'.
 +
# Sélectionnez une commande dans le panneau de gauche.
 +
# Ou sélectionnez  '<Separator>' pour ajouter un séparateur (une ligne entre deux boutons de la barre d'outils).
 +
# Appuyez sur le bouton {{Button|[[Image:Button_right.svg|16px]]}}.
 +
 
 +
==== Supprimer une commande ====
 +
 
 +
# Si nécessaire, développez la barre d'outils dans le panneau de droite.
 +
# Sélectionnez une commande.
 +
# Appuyez sur le bouton {{Button|[[Image:Button_left.svg|16px]]}}.
 +
 
 +
==== Modifier une position de commande ====
 +
 
 +
# Si nécessaire, développez la barre d'outils dans le panneau de droite.
 +
# Sélectionnez une commande.
 +
# Appuyez sur le bouton {{Button|[[Image:Button_up.svg|16px]]}} ou sur le bouton {{Button|[[Image:Button_down.svg|16px]]}}.
 +
# Répétez éventuellement cette opération jusqu'à ce que la commande soit dans la bonne position.
 +
 
 +
==== Remarques (Barres d'outils) ====
 +
 
 +
* Les barres d'outils appartenant à l'atelier en cours sont mises à jour immédiatement, mais après avoir désactivé/réactivé une barre d'outils, un changement d'atelier est requis (basculer vers un atelier puis revenir en arrière).
 +
* Pour mettre à jour les barres d'outils globales, un changement d'atelier (si des commandes ont été ajoutées ou supprimées) ou un redémarrage (si l'ordre d'une barre d'outils a changé ou une barre d'outils a été renommée) est requis.
 +
<!-- Description du problème ci-dessous: https://forum.freecadweb.org/viewtopic.php?f=23&t=45757-->
 +
* Dans V0.19 il y a un problème avec certaines commandes Draft. Après les avoir ajoutés à une barre d'outils personnalisée et quitté l'application FreeCAD, le fichier {{FileName|user.cfg}} doit être modifié manuellement pour ces commandes. Recherchez le nom de la barre d'outils personnalisée et dans cette section, changez le contenu des éléments {{incode|FCText}} qui commencent par {{incode|gui_}} en {{incode|DraftTools}}.
 +
 
 +
[[#top|En haut]]
 +
 
 +
===Macros===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Macros.png]]
 +
{{Caption|L'onglet Macros}}
 +
 
 +
Avec cet onglet, les commandes de macro utilisateur peuvent être configurées. Une fois configurés, ils peuvent être ajoutés à des barres d'outils personnalisées. FreeCAD utilise un dossier dédié pour les macros dutilisateurs et seules les macros de ce dossier peuvent être configurées. Utilisez la commande [[Image:Std_DlgMacroExecute.svg|16px]] [[Std_DlgMacroExecute/fr|Std Lancer la macro]] pour rechercher ce dossier sur votre système.
 +
 
 +
Si vous téléchargez une macro avec le [[Image:Std_AddonMgr.svg|16px]] [[Std_AddonMgr/fr|Gestionnaire d'extensions]], assurez-vous de télécharger également son fichier image d'icône. La plupart des macros ont un lien d'image sur la page d'informations qui apparaît dans le gestionnaire d'extensions. Vous pouvez par exemple placer ce fichier image dans le dossier des macros utilisateur.
 +
 
 +
Si vous souhaitez utiliser une macro téléchargée à partir d'une autre source, vous devrez l'installer manuellement. Voir [[How_to_install_macros/fr|Comment installer les macros]] pour plus d'informations.
 +
 
 +
==== Ajouter une commande macro====
 +
 
 +
# Dans la liste déroulante '''Macro''', sélectionnez une macro.
 +
# Saisissez un '''Texte de menu'''. Ce sera le nom utilisé pour identifier la macro-commande et apparaîtra également dans la barre d'outils s'il n'y a pas d'icône.
 +
# Saisissez éventuellement une '''Info-bulle'''. Ce texte apparaîtra près de l'emplacement de la souris lorsque vous survolez l'icône de la barre d'outils.
 +
# Saisissez éventuellement un '''Texte d'état'''. Ce texte apparaîtra dans la [[Status_bar/fr|barre d'état]] lorsque vous survolez l'icône de la barre d'outils.
 +
# Facultativement, entrez la page wiki de la macro, si elle est disponible, dans la zone de saisie '''Qu'est-ce que c'est'''. Saisissez le nom de la page, pas l'URL complète.
 +
# Saisissez éventuellement un raccourci dans la zone de saisie '''Accélérateur'''. Voir [[#Clavier|Clavier]] pour plus d'informations.
 +
# Pour ajouter une icône:
 +
## Appuyez sur le bouton '''Pixmap''' {{Button|...}}.
 +
## La boîte de dialogue Choisir une icône s'ouvre.
 +
## Si nécessaire, appuyez sur le bouton {{Button|Dossiers d'icônes...}} pour ajouter un dossier d'icônes.
 +
## Sélectionnez une icône dans le panneau. La boîte de dialogue Choisir une icône se ferme automatiquement.
 +
# Appuyez sur le bouton {{Button|Ajouter}}.
 +
# La macro-commande apparaît dans le panneau de gauche.
 +
# La macro-commande peut maintenant être sélectionnée dans l'onglet [[#Barre d'outils|Barre d'outils]].
 +
 
 +
==== Supprimer une commande macro====
 +
 
 +
# Sélectionnez une commande macro dans le panneau de gauche.
 +
# Appuyez sur le bouton {{Button|Supprimer}}.
 +
 
 +
==== Modifier une commande macro====
 +
 
 +
# Double-cliquez sur la commande macro dans le panneau de gauche.
 +
# Apportez les modifications requises. Notez que vous ne pouvez pas supprimer l'icône, vous pouvez uniquement la remplacer.
 +
# Appuyez sur le bouton {{Button|Remplacer}}.
 +
 
 +
[[#top|En haut]]
 +
 
 +
===Mouvement de la Spaceball===
 +
 
 +
Cet onglet est vide si aucune souris 3D n'est détecté. Voir: [[3Dconnexion_input_devices/fr|Périphériques d'entrée de connexion 3D]].
 +
 
 +
[[#top|En haut]]
 +
 
 +
===Boutons de la souris 3D===
 +
 
 +
Cet onglet est vide si aucune souris 3D n'est détecté. Voir: [[3Dconnexion_input_devices/fr|Périphériques d'entrée de connexion 3D]].
 +
 
 +
[[#top|En haut]]
 +
 
 +
==Thèmes==
 +
 
 +
FreeCAD prend en charge la thématisation complète de l'interface, via des feuilles de style .qss. Le [https://doc.qt.io/qt-5/stylesheet-syntax.html format qss] est très similaire au [https://en.wikipedia.org/wiki/CSS format css] utilisé dans les pages Web. Il ajoute essentiellement plus de méthodes pour référencer les différents widgets et éléments de l'interface Qt. Vous pouvez changer le thème par défaut actuel (qui prend simplement le style défini par votre système de bureau) en l'un des thèmes intégrés fournis avec FreeCAD, ou créer le vôtre, par exemple à partir de l'un des [https://github.com/FreeCAD/FreeCAD/tree/master/src/Gui/Stylesheets intégrés dans les feuilles de style] et l'éditer. Votre nouveau style doit être placé dans un dossier nommé $USERAPPDATA/Gui/Stylesheets pour être connu de FreeCAD ($USERAPPDATA s'obtient en tapant App.getUserAppDataDir() dans la console FreeCAD).
 +
 
 +
[[#top|En haut]]
 +
 
 +
== Addons ==
 +
 
 +
Les modules complémentaires offrent une autre façon de personnaliser l'interface d'utilisation. Vous trouverez ci-dessous quelques addons créés par les utilisateurs de la communauté FreeCAD. Ils peuvent être téléchargés via le [[Image:Std_AddonMgr.svg|16px]] [[Std_AddonMgr/fr|gestionnaire d'Addons]] (remarque: ils sont répertoriés dans l'onglet Ateliers).
 +
 
 +
=== Menu Cube===
 +
 
 +
* Dépôt Github: https://github.com/triplus/CubeMenu
 +
 
 +
=== Transparence ===
 +
 
 +
* Dépôt Github: https://github.com/triplus/Glass.
 +
 
 +
=== Thèmes des icônes===
 +
 
 +
* Dépôt Github: https://github.com/triplus/IconThemes
 +
 
 +
=== Lanceur ===
 +
 
 +
* Dépôt Github: https://github.com/triplus/Launcher
 +
 
 +
=== Menu Camembert===
 +
 
 +
* Dépôt Github: https://github.com/triplus/PieMenu
 +
 
 +
===RemBench===
 +
 
 +
* Dépôt Github: https://github.com/triplus/RemBench
 +
 
 +
=== Raccourci ===
 +
 
 +
* Dépôt Github: https://github.com/triplus/ShortCuts
 +
 
 +
[[#top|En haut]]
 +
 
 +
{{Docnav/fr
 +
|[[Import_Export_Preferences/fr|Préférences d'Import Export]]
 +
|[[Property_editor/fr|Propriétés des objets]]
 
}}
 
}}
  
{{Std Base/fr}}
+
{{Std Base navi{{#translation:}}}}
{{Interface/fr}}
+
{{Interface navi{{#translation:}}}}
{{Userdocnavi/fr}}
+
{{Userdocnavi{{#translation:}}}}

Latest revision as of 19:12, 20 October 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어
Arrow-left.svg Page précédente : Préférences d'Import Export
Page suivante : Propriétés des objets Arrow-right.svg

Introduction

L'interface FreeCAD est basée sur la boîte à outils Qt et possède une organisation de pointe. Certains aspects de l'interface peuvent être personnalisés. Vous pouvez, par exemple, ajouter des barres d'outils personnalisées avec des outils de plusieurs ateliers ou des outils définis dans des macros et vous pouvez créer vos propres raccourcis clavier. Mais les menus et barres d'outils par défaut fournis avec FreeCAD et ses ateliers ne peuvent pas être modifiés.

Std DlgCustomize tab Toolbars.png

La boite de dialogue de personnalisation de l'interface


Utilisation

  1. Les commandes disponibles dans la boite de dialogue de personnalisation d'interface dépendent des ateliers qui ont été chargés dans la session FreeCAD en cours. Vous devez donc d'abord charger tous les établis dont vous souhaitez avoir accès aux commandes.
  2. Il existe plusieurs façons d'appeler la commande Std DlgCustomize.svg Std Personnalisation:
    • Sélectionnez l'option Outils → Std DlgCustomize.svg Personnaliser... dans le menu.
    • Cliquez avec le bouton droit sur une zone de barre d'outils et choisissez Std DlgCustomize.svg Personnaliser... dans le menu contextuel.
  3. La boîte de dialogue Personnaliser s'ouvre. Pour plus d'informations, voir Options.
  4. Le bouton Aide ne fonctionne pas pour le moment.
  5. Appuyez sur le bouton Fermer pour fermer la boîte de dialogue.

Options

Dans la boîte de dialogue Personnaliser, les onglets suivants sont disponibles:

Commandes

Std DlgCustomize tab Commands.png

L'onglet Commandes


Avec cet onglet, vous pouvez parcourir les commandes disponibles.

Parcourir les commandes

  1. Sélectionnez une catégorie de commandes dans le panneau Catégorie à gauche. Certaines catégories correspondent aux entrées de menu.
  2. Les outils disponibles dans la catégorie sélectionnée sont affichés dans le panneau de droite.
  3. Survolez une commande: son info-bulle apparaît.
  4. Sélectionnez une commande: son texte dans la barre d'état s'affiche sous les deux panneaux.

En haut

Clavier

Std DlgCustomize tab Keyboard.png

L'onglet Clavier


Dans cet onglet, des raccourcis clavier personnalisés peuvent être définis. Les raccourcis des macro-commandes peuvent être définis dans l'onglet Macros.

Ajouter un raccourci personnalisé

  1. Sélectionnez une catégorie de commandes dans la liste déroulante Catégorie.
  2. Sélectionnez une commande dans le panneau Commandes.
  3. La case Raccourci actuel affiche le raccourci actuel, si disponible.
  4. Entrez un nouveau raccourci dans la zone de saisie Appuyez sur nouveau raccourci. Les raccourcis peuvent comporter jusqu'à 4 entrées. Chaque entrée est soit un seul caractère, une combinaison d'une ou plusieurs touches spéciales ou une combinaison d'une ou plusieurs touches spéciales et un caractère. Utilisez Retour Arrière pour corriger les erreurs.
  5. Si le raccourci est déjà utilisé, une boîte de dialogue vous demandera si vous souhaitez le remplacer, et la commande à laquelle le raccourci est affecté apparaîtra dans le panneau Actuellement assigné à.
  6. Appuyez sur le bouton Attribuer pour attribuer le nouveau raccourci.
  7. Appuyez sur le bouton Effacer pour supprimer le raccourci entré. Cela supprimera également le contenu de la boîte Raccourci actuel. Notez que les raccourcis par défaut ne sont pas supprimés définitivement. Ils seront restaurés au redémarrage de FreeCAD.

Supprimer un raccourci personnalisé

  1. Sélectionnez une catégorie de commandes dans la liste déroulante Catégorie.
  2. Sélectionnez une commande dans le panneau Commandes.
  3. Appuyez sur le bouton Réinitialiser.

Supprimer tous les raccourcis personnalisés

  1. Appuyez sur le bouton Tout réinitialiser.

Remarques (clavier)

  • Les raccourcis ne fonctionnent que si leurs commandes apparaissent dans le menu standard ou dans le menu d'un plan de travail qui a été chargé dans la session FreeCAD en cours, ou si leurs commandes apparaissent sur une barre d'outils visible .
  • Dans V0.19 il y a un problème avec certaines commandes Draft. Leurs raccourcis par défaut ne fonctionnent pas et/ou des raccourcis personnalisés ne peuvent pas leur être attribués.

En haut

Ateliers

Std DlgCustomize tab Workbenches.png

L'onglet Ateliers


Dans cet onglet, la liste des Ateliers peut être modifiée. La liste Ateliers activés affiche les Ateliers tels qu'ils apparaîtront dans le sélecteur d'Ateliers.

Désactiver un atelier

  1. Sélectionnez un établi dans la liste des ateliers activés.
  2. Appuyez sur le bouton Button left.svg.
  3. L'atelier sera déplacé vers la liste des ateliers désactivés

Réactiver un atelier

  1. Sélectionnez un établi dans la liste des ateliers désactivés.
  2. Appuyez sur le bouton Button right.svg.
  3. L'atelier sera déplacé vers la liste des ateliers désactivés.

Réactiver tous les ateliers

  1. Appuyez sur le bouton Button add all.svg.

Modifier une position d'un atelier

  1. Sélectionnez un établi dans la liste des Ateliers activés.
  2. Appuyez sur le bouton Button up.svg ou sur le bouton Button down.svg.
  3. Répétez éventuellement cette opération jusqu'à ce que l'atelier soit à la bonne position.

Trier les ateliers par ordre alphabétique

  1. Appuyez sur le bouton Button sort.svg.

En haut

Barre d'outils

Std DlgCustomize tab Toolbars.png

L'onglet Barres d'outils


Dans cet onglet, des barres d'outils personnalisées peuvent être créées et modifiées.

Sélectionnez l'atelier

  1. Dans la liste déroulante à droite, sélectionnez l'atelier dont vous souhaitez modifier les barres d'outils personnalisées. L'option Global est disponible pour les barres d'outils personnalisées qui devraient être disponibles dans tous les ateliers.

Créer une barre d'outils

  1. Appuyez sur le bouton Nouveau....
  2. Saisissez un nom dans la boîte de dialogue qui s'ouvre.
  3. Appuyez sur le bouton OK.
  4. La nouvelle barre d'outils apparaîtra dans le panneau de droite.

Renommer une barre d'outils

  1. Sélectionnez une barre d'outils dans le panneau de droite.
  2. Appuyez sur le bouton Renommer....
  3. Saisissez un nouveau nom dans la boîte de dialogue qui s'ouvre.
  4. Appuyez sur le bouton OK.

Supprimer une barre d'outils

  1. Sélectionnez une barre d'outils dans le panneau de droite.
  2. Appuyez sur le bouton Supprimer.

Désactiver une barre d'outils

  1. Décochez la case devant le nom de la barre d'outils dans le panneau de droite.
  2. Une barre d'outils désactivée sera invisible dans l'interface FreeCAD.

Ajouter une commande

  1. Sélectionnez la barre d'outils appropriée dans le panneau de droite. Si aucune barre d'outils n'est sélectionnée, la commande sera ajoutée à la première barre d'outils de la liste.
  2. Sélectionnez une catégorie dans la liste déroulante de gauche. Les macros commandes qui ont été configurées dans l'onglet Macros apparaissent dans la catégorie 'Macros'.
  3. Sélectionnez une commande dans le panneau de gauche.
  4. Ou sélectionnez '<Separator>' pour ajouter un séparateur (une ligne entre deux boutons de la barre d'outils).
  5. Appuyez sur le bouton Button right.svg.

Supprimer une commande

  1. Si nécessaire, développez la barre d'outils dans le panneau de droite.
  2. Sélectionnez une commande.
  3. Appuyez sur le bouton Button left.svg.

Modifier une position de commande

  1. Si nécessaire, développez la barre d'outils dans le panneau de droite.
  2. Sélectionnez une commande.
  3. Appuyez sur le bouton Button up.svg ou sur le bouton Button down.svg.
  4. Répétez éventuellement cette opération jusqu'à ce que la commande soit dans la bonne position.

Remarques (Barres d'outils)

  • Les barres d'outils appartenant à l'atelier en cours sont mises à jour immédiatement, mais après avoir désactivé/réactivé une barre d'outils, un changement d'atelier est requis (basculer vers un atelier puis revenir en arrière).
  • Pour mettre à jour les barres d'outils globales, un changement d'atelier (si des commandes ont été ajoutées ou supprimées) ou un redémarrage (si l'ordre d'une barre d'outils a changé ou une barre d'outils a été renommée) est requis.
  • Dans V0.19 il y a un problème avec certaines commandes Draft. Après les avoir ajoutés à une barre d'outils personnalisée et quitté l'application FreeCAD, le fichier user.cfg doit être modifié manuellement pour ces commandes. Recherchez le nom de la barre d'outils personnalisée et dans cette section, changez le contenu des éléments FCText qui commencent par gui_ en DraftTools.

En haut

Macros

Std DlgCustomize tab Macros.png

L'onglet Macros


Avec cet onglet, les commandes de macro utilisateur peuvent être configurées. Une fois configurés, ils peuvent être ajoutés à des barres d'outils personnalisées. FreeCAD utilise un dossier dédié pour les macros dutilisateurs et seules les macros de ce dossier peuvent être configurées. Utilisez la commande Std DlgMacroExecute.svg Std Lancer la macro pour rechercher ce dossier sur votre système.

Si vous téléchargez une macro avec le Std AddonMgr.svg Gestionnaire d'extensions, assurez-vous de télécharger également son fichier image d'icône. La plupart des macros ont un lien d'image sur la page d'informations qui apparaît dans le gestionnaire d'extensions. Vous pouvez par exemple placer ce fichier image dans le dossier des macros utilisateur.

Si vous souhaitez utiliser une macro téléchargée à partir d'une autre source, vous devrez l'installer manuellement. Voir Comment installer les macros pour plus d'informations.

Ajouter une commande macro

  1. Dans la liste déroulante Macro, sélectionnez une macro.
  2. Saisissez un Texte de menu. Ce sera le nom utilisé pour identifier la macro-commande et apparaîtra également dans la barre d'outils s'il n'y a pas d'icône.
  3. Saisissez éventuellement une Info-bulle. Ce texte apparaîtra près de l'emplacement de la souris lorsque vous survolez l'icône de la barre d'outils.
  4. Saisissez éventuellement un Texte d'état. Ce texte apparaîtra dans la barre d'état lorsque vous survolez l'icône de la barre d'outils.
  5. Facultativement, entrez la page wiki de la macro, si elle est disponible, dans la zone de saisie Qu'est-ce que c'est. Saisissez le nom de la page, pas l'URL complète.
  6. Saisissez éventuellement un raccourci dans la zone de saisie Accélérateur. Voir Clavier pour plus d'informations.
  7. Pour ajouter une icône:
    1. Appuyez sur le bouton Pixmap ....
    2. La boîte de dialogue Choisir une icône s'ouvre.
    3. Si nécessaire, appuyez sur le bouton Dossiers d'icônes... pour ajouter un dossier d'icônes.
    4. Sélectionnez une icône dans le panneau. La boîte de dialogue Choisir une icône se ferme automatiquement.
  8. Appuyez sur le bouton Ajouter.
  9. La macro-commande apparaît dans le panneau de gauche.
  10. La macro-commande peut maintenant être sélectionnée dans l'onglet Barre d'outils.

Supprimer une commande macro

  1. Sélectionnez une commande macro dans le panneau de gauche.
  2. Appuyez sur le bouton Supprimer.

Modifier une commande macro

  1. Double-cliquez sur la commande macro dans le panneau de gauche.
  2. Apportez les modifications requises. Notez que vous ne pouvez pas supprimer l'icône, vous pouvez uniquement la remplacer.
  3. Appuyez sur le bouton Remplacer.

En haut

Mouvement de la Spaceball

Cet onglet est vide si aucune souris 3D n'est détecté. Voir: Périphériques d'entrée de connexion 3D.

En haut

Boutons de la souris 3D

Cet onglet est vide si aucune souris 3D n'est détecté. Voir: Périphériques d'entrée de connexion 3D.

En haut

Thèmes

FreeCAD prend en charge la thématisation complète de l'interface, via des feuilles de style .qss. Le format qss est très similaire au format css utilisé dans les pages Web. Il ajoute essentiellement plus de méthodes pour référencer les différents widgets et éléments de l'interface Qt. Vous pouvez changer le thème par défaut actuel (qui prend simplement le style défini par votre système de bureau) en l'un des thèmes intégrés fournis avec FreeCAD, ou créer le vôtre, par exemple à partir de l'un des intégrés dans les feuilles de style et l'éditer. Votre nouveau style doit être placé dans un dossier nommé $USERAPPDATA/Gui/Stylesheets pour être connu de FreeCAD ($USERAPPDATA s'obtient en tapant App.getUserAppDataDir() dans la console FreeCAD).

En haut

Addons

Les modules complémentaires offrent une autre façon de personnaliser l'interface d'utilisation. Vous trouverez ci-dessous quelques addons créés par les utilisateurs de la communauté FreeCAD. Ils peuvent être téléchargés via le Std AddonMgr.svg gestionnaire d'Addons (remarque: ils sont répertoriés dans l'onglet Ateliers).

Menu Cube

Transparence

Thèmes des icônes

Lanceur

Menu Camembert

RemBench

Raccourci

En haut

Arrow-left.svg Page précédente : Préférences d'Import Export
Page suivante : Propriétés des objets Arrow-right.svg