Difference between revisions of "Interface Customization/de"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
 
(41 intermediate revisions by 4 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{docnav/de|Import Export Preference/de|Property editor/de}}
+
<div class="mw-translate-fuzzy">
 +
{{Docnav/de
 +
|[[Import Export Preference/de|Import Export Einstellung]]
 +
|[[Property editor/de|Eigenschaftseditor]]
 +
}}
 +
</div>
 +
 
 +
{{TOCright}}
 +
 
 +
==Einleitung==
 +
 
 +
Die FreeCAD Oberfläche basiert auf dem modernen [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] Qt Werkzeugsatz und verfügt über eine moderne Struktur. Einige Aspekte der Oberfläche können angepasst werden. Sie können z.B. benutzerdefinierte Werkzeugleisten hinzufügen, mit Werkzeugen von mehreren Arbeitsbereichen oder in Makros definierten Werkzeugen, und du kannst eigene Tastaturkürzel erstellen. Die Menüs und Standardwerkzeugleisten, die mit FreeCAD und seinen Arbeitsbereichen geliefert werden, können jedoch nicht geändert werden.
 +
 
 +
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
{{Caption|Das Anpassungs Dialogfeld}}
 +
 
 +
==Anwendung==
 +
 
 +
# Die im Dialogfeld Anpassen verfügbaren Befehle hängen von den Arbeitsbereichen ab, die in der aktuellen FreeCAD Sitzung geladen wurden.  Du solltest also zunächst alle Arbeitsbereiche laden, auf deren Befehle du Zugriff haben möchtest.
 +
# Es gibt mehrere Wege, das Dialogfeld [[Image:Std_DlgCustomize.svg|16px]] [[Std_DlgCustomize/de|Std DlgAnpassen]]:
 +
#* Wähle die  {{MenuCommand/de|Werkzeuge → [[Image:Std_DlgCustomize.svg|16px]] Anpassen...}} Option aus dem Menü.
 +
#* Klicke mit der rechten Maustaste auf einen Werkzeugleistenbereich und wähle {{MenuCommand/de|[[Image:Std_DlgCustomize.svg|16px]] Anpassen...}} über das Kontextmenü.
 +
# Das Anpassen Dialogfeld öffnet sich. Für weitere Informationen siehe [[#Options/de|Optionen]].
 +
# Die {{Button|Help}} Schaltfläche funktioniert zur Zeit nicht.
 +
# Drücke die  {{Button|Close}} Schaltfläche um das Dialogfeld zu schließen.
 +
 
 +
==Optionen==
 +
 
 +
Im Dialogfeld Anpassen stehen die folgenden Reiter zur Verfügung:
 +
 
 +
===Befehle===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Commands.png]]
 +
{{Caption|Der Befehlsreiter}}
 +
 
 +
Auf diesem Reiter kannst Du die verfügbaren Befehle durchsuchen.
 +
 
 +
====Befehle durchsuchen====
 +
 
 +
# Select a command category in the '''Category''' panel on the left. Some categories match menu entries.
 +
# The tools available in the selected category are shown in the panel on the right.
 +
# Hover a command: its tooltip appears.
 +
# Select a command: its status bar text is displayed below the two panels.
 +
 
 +
[[#top|top]]
 +
 
 +
===Keyboard===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Keyboard.png]]
 +
{{Caption|The Keyboard tab}}
 +
 
 +
On this tab custom keyboard shortcuts can be defined. Shortcuts for macro commands can be defined on the [[#Macros|Macros]] tab.
 +
 
 +
====Add a custom shortcut====
 +
 
 +
# Select a command category from the '''Category''' dropdown list.
 +
# Select a command from the '''Commands''' panel.
 +
# The '''Current shortcut''' box displays the current short cut, if available.
 +
# Enter a new shortcut in the '''Press new shortcut''' input box. Shortcuts can be up to 4 inputs long. Each input is either a single character, a combination of one or more special keys or a combination of one or more special keys and a character. Use {{KEY|Backspace}} to correct mistakes.
 +
# If the shortcut is already in use, a dialog box will ask you if you want to override it, and the command the shortcut is assigned to will appear in the '''Currently assigned to''' panel.
 +
# Press the {{Button|Assign}} button to assign the new shortcut.
 +
# Press the {{Button|Clear}} button to remove the entered shortcut. This will also remove the content of the '''Current shortcut''' box. Note that default shortcuts are not permanently removed. They will be restored upon restarting FreeCAD.
 +
 
 +
====Remove a custom shortcut====
 +
 
 +
# Select a command category from the '''Category''' dropdown list.
 +
# Select a command from the '''Commands''' panel.
 +
# Press the {{Button|Reset}} button.
 +
 
 +
====Remove all custom shortcuts====
 +
 
 +
# Press the {{Button|Reset All}} button.
 +
 
 +
====Notes (Keyboard)====
 +
 
 +
* Shortcuts only work if their commands appear in the standard menu or in the menu of a workbench that has been loaded in the current FreeCAD session, or if their commands appear on a ''visible'' toolbar.
 +
<!--Description of problem below: https://forum.freecadweb.org/viewtopic.php?f=23&t=45826-->
 +
* In V0.19 there is an issue with some Draft commands. Their default shortcuts do not work and/or custom shortcuts cannot be assigned to them.
 +
 
 +
[[#top|top]]
 +
 
 +
===Workbenches===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Workbenches.png]]
 +
{{Caption|The Workbenches tab}}
 +
 
 +
On this tab the [[Std_Workbench|Workbench selector]] list can be changed. The '''Enabled workbenches''' list shows the workbenches as they will appear in the Workbench selector.
 +
 
 +
====Disable a workbench====
 +
 
 +
# Select a workbench in the '''Enabled workbenches''' list.
 +
# Press the {{Button|[[Image:Button_left.svg|16px]]}} button.
 +
# The workbench will be moved to the '''Disabled workbenches''' list
 +
 
 +
====Re-enable a workbench====
 +
 
 +
# Select a workbench in the '''Disabled workbenches''' list.
 +
# Press the {{Button|[[Image:Button_right.svg|16px]]}} button.
 +
# The workbench will be moved to the '''Enabled workbenches''' list
 +
 
 +
====Re-enable all workbenches====
 +
 
 +
# Press the {{Button|[[Image:Button_add_all.svg|16px]]}} button.
 +
 
 +
====Change a workbench position====
 +
 
 +
# Select a workbench in the '''Enabled workbenches''' list.
 +
# Press the {{Button|[[Image:Button_up.svg|16px]]}} button or the {{Button|[[Image:Button_down.svg|16px]]}} button.
 +
# Optionally repeat this until the workbench is in the correct position.
 +
 
 +
====Sort workbenches alphabetically====
 +
 
 +
# Press the {{Button|[[Image:Button_sort.svg|16px]]}} button.
 +
 
 +
[[#top|top]]
 +
 
 +
===Toolbars===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
{{Caption|The Toolbars tab}}
 +
 
 +
On this tab custom toolbars can be created and modified.
  
Seit die FreeCAD Oberfläche auf dem modernen [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] Werkzeugkasten basiert, verfügt sie über eine zeitgemäße Struktur. Widgets, Menüs, Symbolleisten und andere Werkzeuge können geändert, verschoben, zwischen den Arbeitsbereichen geteilt, Tastenkombinationen festgelegt, geändert und Makros aufgezeichnet und abgespielt werden. Das Anpassungsfenster wird über das Menü {{MenuCommand/de|Werkzeuge → Anpassen}} aufgerufen:
+
====Select the workbench====
  
[[Image:BenutzerdefBefehle.jpg]]
+
# In the dropdown list on the right select the workbench whose custom toolbars you want to modify. The {{Value|Global}} option is there for custom toolbars that should be available in all workbenches.
  
==Anpassung Reiter==
+
====Create a toolbar====
Auf der Registerkarte "Befehle" kannst Du alle verfügbaren FreeCAD Befehle durchsuchen, geordnet nach ihrer Kategorie.
 
  
Unter der Registerkarte '''Tastatur''' ('''Keybord''') sind die zum Aufruf eines Befehls verwendeten Tastenkombinationen eingetragen oder können eingetragen und/oder geändert werden.  
+
# Press the {{Button|New...}} button.
 +
# Enter a name in the dialog box that opens.
 +
# Press the {{Button|OK}} button.
 +
# The new toolbar will appear in the panel on the right.
  
 +
====Rename a toolbar====
  
[[Image:BenutzerdefSymbLeisten.jpg]]
+
# Select a toolbar in the panel on the right.
 +
# Press the {{Button|Rename...}} button.
 +
# Enter a new name in the dialog box that opens.
 +
# Press the {{Button|OK}} button.
  
Unter der Registerkarte  '''Symbolleisten'''  ('''Toolbars''') stehen links die gleichen Befehls-Kategorien wie unter der Karte '''Befehle'''. Nach Anklicken einer Kategorie erscheinen die dazugehörenden Befehle, die auf die rechte Seite hinüber kopiert werden können. Vorher wählt man dort einen aktiven Arbeitsbereich, dem man eine individuelle Symbolleiste zufügen möchte. Für diese Leiste ist zuerst mit '''Neu''' ('''New...''') ein Name  zu wählen, bevor man in sie  Befehle herüber kopiert. Beim späteren Aufruf dieses Arbeitsbereichs ist diese Leiste zu aktivieren:  '''Ansicht -> Symbolleisten'''.
+
====Delete a toolbar====
  
Anmerkung: Wenn rechts "Global" (anstatt eines Arbeitsbereiches) gewählt wird, kann die zugefügte Symbolleiste in jedem Arbeitsbereich aktiviert werden.
+
# Select a toolbar in the panel on the right.
 +
# Press the {{Button|Delete}} button.
  
Under the tab '''Worksbenches''' ('''Workbenches''') the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.
+
====Disable a toolbar====
  
[[Image:UserdefSymbstrip.jpg]]
+
# Uncheck the checkbox in front of the toolbar name in the panel on the right.
 +
# A disabled toolbar will be invisible in the FreeCAD interface.
  
Under the tab '''Toolbars''' ('''Toolbars''') on the left are the same command categories as under the map '''Commands'''. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with '''New''' ('''New...''') before copying commands over to it. When this workspace is called later, this bar must be activated: '''View → Toolbars'''.
+
====Add a command====
  
Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.
+
# Select the correct toolbar in the panel on the right. If no toolbar is selected, the command will be added to the first toolbar in the list.
 +
# Select a category from the dropdown list on the left. Macro commands that have been set up on the [[#Macros|Macros]] tab appear in the 'Macros' category.
 +
# Select a command from the panel on the left.
 +
# Or select '<Separator>' to add a separator (a line between two toolbar buttons).
 +
# Press {{Button|[[Image:Button_right.svg|16px]]}} button.
  
 +
====Remove a command====
  
<div class="mw-translate-fuzzy">
+
# If required, expand the toolbar in the panel on the right.
Unter der Registerkarte '''Makros''' ('''Macros''') werden den von extern beschafften Programmteilen (Makros) Worte und Icons zugefügt, die für ihren Aufruf als Makro-Werkzeuge erforderlich sind.
+
# Select a command.
</div>
+
# Press {{Button|[[Image:Button_left.svg|16px]]}} button.
 +
 
 +
====Change a command position====
 +
 
 +
# If required, expand the toolbar in the panel on the right.
 +
# Select a command.
 +
# Press the {{Button|[[Image:Button_up.svg|16px]]}} button or the {{Button|[[Image:Button_down.svg|16px]]}} button.
 +
# Optionally repeat this until the command is in the correct position.
 +
 
 +
====Notes (Toolbars)====
 +
 
 +
* Toolbars belonging to the current workbench are updated immediately, but after disabling/re-enabling a toolbar a workbench change is required (switch to a different workbench and then switch back).
 +
* To update global toolbars a workbench change (if commands have been added or removed) or a restart (if the order of a toolbar has changed or a toolbar was renamed) is required.
 +
<!--Description of problem below: https://forum.freecadweb.org/viewtopic.php?f=23&t=45757-->
 +
* In V0.19 there is an issue with some Draft commands. After adding them to a custom toolbar and exiting the FreeCAD application the {{FileName|user.cfg}} file must be manually edited for these commands. Search for the name of the custom toolbar and in that section change the content of the {{incode|FCText}} items that start with {{incode|gui_}} to {{incode|DraftTools}}.
 +
 
 +
[[#top|top]]
 +
 
 +
===Macros===
 +
 
 +
[[Image:Std_DlgCustomize_tab_Macros.png]]
 +
{{Caption|The Macros tab}}
 +
 
 +
On this tab user macro commands can be set up. Once set up, they can be added to custom toolbars. FreeCAD uses a dedicated folder for user macros and only macros in that folder can be set up. Use the [[Image:Std_DlgMacroExecute.svg|16px]] [[Std_DlgMacroExecute|Std DlgMacroExecute]] command to find this folder on your system.
 +
 
 +
If you download a macro with the [[Image:Std_AddonMgr.svg|16px]] [[Std_AddonMgr|Addon Manager]] then make sure that you also download its icon image file. Most macros have an image link on the information page that appears in the Addon Manager. You can for example put this image file in the user macros folder.
 +
 
 +
====Add a macro command====
 +
 
 +
# In the '''Macro''' dropdown list select a macro.
 +
# Enter a '''Menu text'''. This will be the name used to identify the macro command and will also appear in the toolbar if there is no icon.
 +
# Optionally enter a '''Tool tip'''. This text will appear near the location of the mouse when you hover the toolbar icon.
 +
# Optionally enter a '''Status text'''. This text will appear in the [[Status_bar|status bar]] when you hover the toolbar icon.
 +
# Optionally enter the wiki page for the macro, if available, in the '''What's this''' input box. Enter the page name, not the full URL.
 +
# Optionally enter a shortcut in the '''Accelerator''' input box. See [[#Keyboard|Keyboard]] for more information.
 +
# To add an icon:
 +
## Press the '''Pixmap''' {{Button|...}} button.
 +
## The Choose Icon dialog box opens.
 +
## If required press the {{Button|Icon folders...}} button to add an icon folder.
 +
## Select an icon from the panel. The Choose Icon dialog box closes automatically.
 +
# Press the {{Button|Add}} button.
 +
# The macro command appears in the panel on the left.
 +
# The macro command can now be selected on the [[#Toolbars|Toolbars]] tab.
 +
 
 +
====Remove a macro command====
 +
 
 +
# Select the macro command in the panel on the left.
 +
# Press the {{Button|Remove}} button.
 +
 
 +
====Change a macro command====
 +
 
 +
# Double-click the macro command in the panel on the left.
 +
# Make the required changes. Note that you cannot remove the icon, you can only replace it.
 +
# Press the {{Button|Replace}} button.
 +
 
 +
[[#top|top]]
 +
 
 +
===Spaceball Motion===
 +
 
 +
This is tab is blank if no Spaceball is detected. See: [[3Dconnexion_input_devices|3Dconnexion input devices]].
 +
 
 +
[[#top|top]]
 +
 
 +
===Spaceball Buttons===
 +
 
 +
This is tab is blank if no Spaceball is detected. See: [[3Dconnexion_input_devices|3Dconnexion input devices]].
 +
 
 +
[[#top|top]]
 +
 
 +
==Addons==
 +
 
 +
Addons offer yet another way to customize the use interface. Below are some addons created by users in the FreeCAD community. They can be downloaded through the [[Image:Std_AddonMgr.svg|16px]] [[Std_AddonMgr|Addon Manager]] (note: they are listed on the Workbenches tab).
 +
 
 +
===CubeMenu===
 +
 
 +
* Github repository: https://github.com/triplus/CubeMenu
 +
 
 +
===Glass===
 +
 
 +
* Github repository: https://github.com/triplus/Glass.
 +
 
 +
===IconThemes===
 +
 
 +
* Github repository: https://github.com/triplus/IconThemes
 +
 
 +
===Launcher===
 +
 
 +
* Github repository: https://github.com/triplus/Launcher
 +
 
 +
===PieMenu===
  
Siehe auch
+
* Github repository: https://github.com/triplus/PieMenu
[https://www.freecadweb.org/wiki/Customize_Toolbars/de dieses Tutorial]
 
  
Seit FreeCAD v0.16 ist ein neues Werkzeug verfügbar, mit dem die Arbeitsbereiche verwaltet werden können.
+
===RemBench===
  
.
+
* Github repository: https://github.com/triplus/RemBench
  
<div class="mw-translate-fuzzy">
+
===ShortCut===
==Beispiel=====
 
Angenommen, wir wollen das Werkzeug "Linear messen" auch in einer benutzerdefinierten Symbolleiste in der [[Draft Workbench]] anzeigen lassen.
 
* in FreeCAD wähle {{MenuCommand/de|Werkzeuge → Anpassung}} aus dem oberen Menü.
 
* Wähle die Registerkarte "Symbolleisten".
 
* auf der linken Seite wähle "Part" im Auswahlmenü.
 
* auf der linken Seite im unteren Fenster scrolle nach unten zum Eintrag " Lineare Messung" und wähle ihn aus.
 
* auf der rechten Seite wähle "Draft" im Auswahlmenü.
 
* Klicke auf {{button|New....}}, um eine neue Symbolleiste zu erstellen und einen Namen dafür zu wählen.
 
* Wähle nun Deine Ziel Symbolleiste im rechten unteren Fenster (nur erforderlich, wenn Du mehr als eine Symbolleiste hast).
 
* durch Anklicken des blauen "Pfeils rechts" (oberes Symbol in der mittleren Zeile) füge Deinen ausgewählten Eintrag der ausgewählten Symbolleiste hinzu.
 
</div>
 
  
===Anmerkungen===
+
* Github repository: https://github.com/triplus/ShortCuts
Wenn Du im Auswahlmenü auf der rechten Seite "Global" auswählst, erstellst Du eine Symbolleiste, die auf allen Arbeitsbereichen sichtbar ist.
 
  
Um ein installiertes Makro zu einer Symbolleiste hinzuzufügen, musst Du folgendes tun
+
[[#top|top]]
* Wähle "Makros" im Pulldown-Menü auf der linken Seite.
 
* haben Menütext, Symbol (Pixmap) und so weiter mit dem {{MenuCommand/de|Werkzeuge → Anpassen → Makros}} Menü zugewiesen.
 
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
{{docnav/de|[[Preferences Editor/de|Benutzereinstellungen vornehmen]]|[[Property editor/de|Eigenschafteneditor]]}}
+
{{docnav/de
 +
|[[Preferences Editor/de|Voreinstellungseditor]]
 +
|[[Property editor/de|Eigenschaftseditor]]
 +
}}
 
</div>
 
</div>
  
{{Std Base/de}}
+
{{Std Base navi{{#translation:}}}}
{{Interface/de}}
+
{{Interface navi{{#translation:}}}}
{{Userdocnavi/de}}
+
{{Userdocnavi{{#translation:}}}}

Latest revision as of 20:07, 15 May 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Einleitung

Die FreeCAD Oberfläche basiert auf dem modernen Qt Qt Werkzeugsatz und verfügt über eine moderne Struktur. Einige Aspekte der Oberfläche können angepasst werden. Sie können z.B. benutzerdefinierte Werkzeugleisten hinzufügen, mit Werkzeugen von mehreren Arbeitsbereichen oder in Makros definierten Werkzeugen, und du kannst eigene Tastaturkürzel erstellen. Die Menüs und Standardwerkzeugleisten, die mit FreeCAD und seinen Arbeitsbereichen geliefert werden, können jedoch nicht geändert werden.

Std DlgCustomize tab Toolbars.png

Das Anpassungs Dialogfeld


Anwendung

  1. Die im Dialogfeld Anpassen verfügbaren Befehle hängen von den Arbeitsbereichen ab, die in der aktuellen FreeCAD Sitzung geladen wurden. Du solltest also zunächst alle Arbeitsbereiche laden, auf deren Befehle du Zugriff haben möchtest.
  2. Es gibt mehrere Wege, das Dialogfeld Std DlgCustomize.svg Std DlgAnpassen:
    • Wähle die Werkzeuge → Std DlgCustomize.svg Anpassen... Option aus dem Menü.
    • Klicke mit der rechten Maustaste auf einen Werkzeugleistenbereich und wähle Std DlgCustomize.svg Anpassen... über das Kontextmenü.
  3. Das Anpassen Dialogfeld öffnet sich. Für weitere Informationen siehe Optionen.
  4. Die Help Schaltfläche funktioniert zur Zeit nicht.
  5. Drücke die Close Schaltfläche um das Dialogfeld zu schließen.

Optionen

Im Dialogfeld Anpassen stehen die folgenden Reiter zur Verfügung:

Befehle

Std DlgCustomize tab Commands.png

Der Befehlsreiter


Auf diesem Reiter kannst Du die verfügbaren Befehle durchsuchen.

Befehle durchsuchen

  1. Select a command category in the Category panel on the left. Some categories match menu entries.
  2. The tools available in the selected category are shown in the panel on the right.
  3. Hover a command: its tooltip appears.
  4. Select a command: its status bar text is displayed below the two panels.

top

Keyboard

Std DlgCustomize tab Keyboard.png

The Keyboard tab


On this tab custom keyboard shortcuts can be defined. Shortcuts for macro commands can be defined on the Macros tab.

Add a custom shortcut

  1. Select a command category from the Category dropdown list.
  2. Select a command from the Commands panel.
  3. The Current shortcut box displays the current short cut, if available.
  4. Enter a new shortcut in the Press new shortcut input box. Shortcuts can be up to 4 inputs long. Each input is either a single character, a combination of one or more special keys or a combination of one or more special keys and a character. Use Backspace to correct mistakes.
  5. If the shortcut is already in use, a dialog box will ask you if you want to override it, and the command the shortcut is assigned to will appear in the Currently assigned to panel.
  6. Press the Assign button to assign the new shortcut.
  7. Press the Clear button to remove the entered shortcut. This will also remove the content of the Current shortcut box. Note that default shortcuts are not permanently removed. They will be restored upon restarting FreeCAD.

Remove a custom shortcut

  1. Select a command category from the Category dropdown list.
  2. Select a command from the Commands panel.
  3. Press the Reset button.

Remove all custom shortcuts

  1. Press the Reset All button.

Notes (Keyboard)

  • Shortcuts only work if their commands appear in the standard menu or in the menu of a workbench that has been loaded in the current FreeCAD session, or if their commands appear on a visible toolbar.
  • In V0.19 there is an issue with some Draft commands. Their default shortcuts do not work and/or custom shortcuts cannot be assigned to them.

top

Workbenches

Std DlgCustomize tab Workbenches.png

The Workbenches tab


On this tab the Workbench selector list can be changed. The Enabled workbenches list shows the workbenches as they will appear in the Workbench selector.

Disable a workbench

  1. Select a workbench in the Enabled workbenches list.
  2. Press the Button left.svg button.
  3. The workbench will be moved to the Disabled workbenches list

Re-enable a workbench

  1. Select a workbench in the Disabled workbenches list.
  2. Press the Button right.svg button.
  3. The workbench will be moved to the Enabled workbenches list

Re-enable all workbenches

  1. Press the Button add all.svg button.

Change a workbench position

  1. Select a workbench in the Enabled workbenches list.
  2. Press the Button up.svg button or the Button down.svg button.
  3. Optionally repeat this until the workbench is in the correct position.

Sort workbenches alphabetically

  1. Press the Button sort.svg button.

top

Toolbars

Std DlgCustomize tab Toolbars.png

The Toolbars tab


On this tab custom toolbars can be created and modified.

Select the workbench

  1. In the dropdown list on the right select the workbench whose custom toolbars you want to modify. The Global option is there for custom toolbars that should be available in all workbenches.

Create a toolbar

  1. Press the New... button.
  2. Enter a name in the dialog box that opens.
  3. Press the OK button.
  4. The new toolbar will appear in the panel on the right.

Rename a toolbar

  1. Select a toolbar in the panel on the right.
  2. Press the Rename... button.
  3. Enter a new name in the dialog box that opens.
  4. Press the OK button.

Delete a toolbar

  1. Select a toolbar in the panel on the right.
  2. Press the Delete button.

Disable a toolbar

  1. Uncheck the checkbox in front of the toolbar name in the panel on the right.
  2. A disabled toolbar will be invisible in the FreeCAD interface.

Add a command

  1. Select the correct toolbar in the panel on the right. If no toolbar is selected, the command will be added to the first toolbar in the list.
  2. Select a category from the dropdown list on the left. Macro commands that have been set up on the Macros tab appear in the 'Macros' category.
  3. Select a command from the panel on the left.
  4. Or select '<Separator>' to add a separator (a line between two toolbar buttons).
  5. Press Button right.svg button.

Remove a command

  1. If required, expand the toolbar in the panel on the right.
  2. Select a command.
  3. Press Button left.svg button.

Change a command position

  1. If required, expand the toolbar in the panel on the right.
  2. Select a command.
  3. Press the Button up.svg button or the Button down.svg button.
  4. Optionally repeat this until the command is in the correct position.

Notes (Toolbars)

  • Toolbars belonging to the current workbench are updated immediately, but after disabling/re-enabling a toolbar a workbench change is required (switch to a different workbench and then switch back).
  • To update global toolbars a workbench change (if commands have been added or removed) or a restart (if the order of a toolbar has changed or a toolbar was renamed) is required.
  • In V0.19 there is an issue with some Draft commands. After adding them to a custom toolbar and exiting the FreeCAD application the user.cfg file must be manually edited for these commands. Search for the name of the custom toolbar and in that section change the content of the FCText items that start with gui_ to DraftTools.

top

Macros

Std DlgCustomize tab Macros.png

The Macros tab


On this tab user macro commands can be set up. Once set up, they can be added to custom toolbars. FreeCAD uses a dedicated folder for user macros and only macros in that folder can be set up. Use the Std DlgMacroExecute.svg Std DlgMacroExecute command to find this folder on your system.

If you download a macro with the Std AddonMgr.svg Addon Manager then make sure that you also download its icon image file. Most macros have an image link on the information page that appears in the Addon Manager. You can for example put this image file in the user macros folder.

Add a macro command

  1. In the Macro dropdown list select a macro.
  2. Enter a Menu text. This will be the name used to identify the macro command and will also appear in the toolbar if there is no icon.
  3. Optionally enter a Tool tip. This text will appear near the location of the mouse when you hover the toolbar icon.
  4. Optionally enter a Status text. This text will appear in the status bar when you hover the toolbar icon.
  5. Optionally enter the wiki page for the macro, if available, in the What's this input box. Enter the page name, not the full URL.
  6. Optionally enter a shortcut in the Accelerator input box. See Keyboard for more information.
  7. To add an icon:
    1. Press the Pixmap ... button.
    2. The Choose Icon dialog box opens.
    3. If required press the Icon folders... button to add an icon folder.
    4. Select an icon from the panel. The Choose Icon dialog box closes automatically.
  8. Press the Add button.
  9. The macro command appears in the panel on the left.
  10. The macro command can now be selected on the Toolbars tab.

Remove a macro command

  1. Select the macro command in the panel on the left.
  2. Press the Remove button.

Change a macro command

  1. Double-click the macro command in the panel on the left.
  2. Make the required changes. Note that you cannot remove the icon, you can only replace it.
  3. Press the Replace button.

top

Spaceball Motion

This is tab is blank if no Spaceball is detected. See: 3Dconnexion input devices.

top

Spaceball Buttons

This is tab is blank if no Spaceball is detected. See: 3Dconnexion input devices.

top

Addons

Addons offer yet another way to customize the use interface. Below are some addons created by users in the FreeCAD community. They can be downloaded through the Std AddonMgr.svg Addon Manager (note: they are listed on the Workbenches tab).

CubeMenu

Glass

IconThemes

Launcher

PieMenu

RemBench

ShortCut

top

Template:Std Base navi/de