Difference between revisions of "Interface Customization/cs"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
(Updating to match new version of source page)
Line 13: Line 13:
  
 
[[Image:Screenshot-customize.jpg]]
 
[[Image:Screenshot-customize.jpg]]
 +
 +
{{Caption|The Interface Customization dialog}}
 +
 +
==Usage==
 +
 +
The customization window is accessed from the {{MenuCommand|{{StdMenu|[[Std Tools Menu|Tools]]}} → Customize}} menu.
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 63: Line 69:
 
</div>
 
</div>
  
<div class="mw-translate-fuzzy">
 
[[Category:User Documentation/cs]]
 
</div>
 
  
{{Interface}}
+
{{Std Base navi{{#translation:}}}}
 +
 
 +
{{Interface{{#translation:}}}}
  
{{Userdocnavi}}
+
{{Userdocnavi{{#translation:}}}}

Revision as of 05:29, 19 February 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Introduction

Protože grafické rozhraní FreeCADu je založeno na moderním toolkitu Qt, má nejvyšší úroveň organizace. Widgety, menu, nástrojové pruhy a další nástroje mohou být modifikovány, přesunovány, sdíleny mezi pracovními plochami, mohou být nastavovány a modifikovány klávesové zkratky a mohou být zaznamenávána a přehrávána makra. Okno pro nastavení je přístupné z menu Nástroje -> Nastavení

Screenshot-customize.jpg

The Interface Customization dialog


Usage

The customization window is accessed from the Tools → Customize menu.

Záložka Commands (Příkazy) vám umožní prohlédnout všechny dostupné příkazy FreeCADu, organizované podle kategorií.

V záložce Keyboard (Klávesnice) najdete klávesové zkratku spojené s příkazy FreeCADu a budte-li chtít můžete si modifikovat nebo přiřazovat novou klávesovou zkratku k libovolnému příkazu. Toto je místo kam jít pokud budete chtít často používat některou pracovní plochu a budete chtít pro přechod na ni používat nějakou klávesovou zkratku.

Záložky Toolbars (Nástrojové pruhy) a Toolbox bars (Nástrojové boxy) Vám umožní modifikovat existující nástrojové pruhy nebo vytvářet Vaše vlastní uživatelské nástrojové pruhy.

Under the tab Worksbenches (Workbenches) the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.

File:UserdefSymbstrip.jpg

Under the tab Toolbars (Toolbars) on the left are the same command categories as under the map Commands. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with New (New...) before copying commands over to it. When this workspace is called later, this bar must be activated: View → Toolbars.

Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.


Záložka Macros (Makra) slouží ke správě uložených maker.

Create your Toolbars for your macro Customize Toolbars

Since FreeCAD 0.16 a new tool is available that lets you manage your workbenches.

CustomizeWorkbenches.png

Example

For an example workflow lets suppose we want to have the "Measure Linear" tool also show up in a custom toolbar in the Draft Workbench.

  • in FreeCAD choose Tools → Customize from the top menu
  • select the "Toolbars" tab
  • on the left side choose "Part" in the pull down menu
  • on the left side in the lower window scroll down to the "Measure Linear" entry and select it
  • on the right side choose "Draft" in the pull down menu
  • click on New... to create a new toolbar and choose a name for it
  • now select your destination toolbar in the right lower window (only needed if you have more than one toolbar)
  • by clicking on the blue "Arrow right" (top icon in the middle row) you will add your selected entry to the selected toolbar

Remarks

When selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches.

For adding an installed macro to a toolbar you must

  • select "Macros" in the pull down menu on the left side
  • have assigned menu text, icon (Pixmap) and so on using the Tools → Customize → Macros menu


Template:Std Base navi/cs

Template:Interface/cs