Difference between revisions of "Interface Customization"

From FreeCAD Documentation
Jump to navigation Jump to search
({{Std Base navi}} to categorize page)
m (Added {{TOCright}} outside of translation tags + Linted templates)
Line 2: Line 2:
 
<translate>
 
<translate>
 
<!--T:15-->
 
<!--T:15-->
{{docnav
+
{{Docnav
 
|[[Import Export Preference|Import Export Preference]]
 
|[[Import Export Preference|Import Export Preference]]
 
|[[Property editor|Property editor]]
 
|[[Property editor|Property editor]]
 
}}
 
}}
  
<!--T:1-->
+
==Introduction== <!--T:1-->
 
Since FreeCAD interface is based on the modern [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] toolkit, it has a state-of-the-art organization. Widgets, menus, toolbars and other tools can be modified, moved, shared between workbenches, keyboard shortcuts can be set, modified, and macros can be recorded and played. The customization window is accessed from the {{MenuCommand|Tools → Customize}} menu:
 
Since FreeCAD interface is based on the modern [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] toolkit, it has a state-of-the-art organization. Widgets, menus, toolbars and other tools can be modified, moved, shared between workbenches, keyboard shortcuts can be set, modified, and macros can be recorded and played. The customization window is accessed from the {{MenuCommand|Tools → Customize}} menu:
 +
</translate>
 +
{{TOCright}}
 +
<translate>
  
 
<!--T:2-->
 
<!--T:2-->
Line 67: Line 70:
  
 
<!--T:7-->
 
<!--T:7-->
{{docnav
+
{{Docnav
 
|[[Import Export Preference|Import Export Preference]]
 
|[[Import Export Preference|Import Export Preference]]
 
|[[Property editor|Property editor]]
 
|[[Property editor|Property editor]]
Line 74: Line 77:
 
<!--T:8-->
 
<!--T:8-->
 
{{Std Base navi}}
 
{{Std Base navi}}
 +
 
{{Interface}}
 
{{Interface}}
 +
 
{{Userdocnavi}}
 
{{Userdocnavi}}
 
</translate>
 
</translate>

Revision as of 10:28, 16 February 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Introduction

Since FreeCAD interface is based on the modern Qt toolkit, it has a state-of-the-art organization. Widgets, menus, toolbars and other tools can be modified, moved, shared between workbenches, keyboard shortcuts can be set, modified, and macros can be recorded and played. The customization window is accessed from the Tools → Customize menu:

Screenshot-customize.jpg

Customization tabs

The Commands tab lets you browse all available FreeCAD commands, organized by their category.

In Keyboard, you can see the keyboard shortcuts associated with every FreeCAD command, and if you want, modify or assign new shortcut to any command. This is where to come if you use a particular workbench often, and would like to speed up its use by using the keyboard.

The Toolbars and Toolbox bars tabs let you modify existing toolbars, or create your own custom toolbars.

Under the tab Worksbenches (Workbenches) the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.

File:UserdefSymbstrip.jpg

Under the tab Toolbars (Toolbars) on the left are the same command categories as under the map Commands. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with New (New...) before copying commands over to it. When this workspace is called later, this bar must be activated: View → Toolbars.

Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.


The Macros tab lets you manage your saved Macros.

Create your Toolbars for your macro Customize Toolbars

Since FreeCAD 0.16 a new tool is available that lets you manage your workbenches.

CustomizeWorkbenches.png

Example

For an example workflow lets suppose we want to have the "Measure Linear" tool also show up in a custom toolbar in the Draft Workbench.

  • in FreeCAD choose Tools → Customize from the top menu
  • select the "Toolbars" tab
  • on the left side choose "Part" in the pull down menu
  • on the left side in the lower window scroll down to the "Measure Linear" entry and select it
  • on the right side choose "Draft" in the pull down menu
  • click on New... to create a new toolbar and choose a name for it
  • now select your destination toolbar in the right lower window (only needed if you have more than one toolbar)
  • by clicking on the blue "Arrow right" (top icon in the middle row) you will add your selected entry to the selected toolbar

Remarks

When selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches.

For adding an installed macro to a toolbar you must

  • select "Macros" in the pull down menu on the left side
  • have assigned menu text, icon (Pixmap) and so on using the Tools → Customize → Macros menu