Difference between revisions of "Interface Customization"

From FreeCAD Documentation
Jump to navigation Jump to search
(Fixed docnav links)
 
(65 intermediate revisions by 7 users not shown)
Line 2: Line 2:
 
<translate>
 
<translate>
 
<!--T:15-->
 
<!--T:15-->
{{docnav|Import Export Preference|Property editor}}
+
{{Docnav
 +
|[[Import_Export_Preferences|Import Export Preferences]]
 +
|[[Property_editor|Property editor]]
 +
}}
 +
 
 +
</translate>
 +
{{TOCright}}
 +
<translate>
 +
 
 +
==Introduction== <!--T:20-->
  
 
<!--T:1-->
 
<!--T:1-->
Since FreeCAD interface is based on the modern [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] toolkit, it has a state-of-the-art organization. Widgets, menus, toolbars and other tools can be modified, moved, shared between workbenches, keyboard shortcuts can be set, modified, and macros can be recorded and played. The customization window is accessed from the {{MenuCommand|Tools → Customize}} menu:
+
The FreeCAD interface is based on the modern [http://en.wikipedia.org/wiki/Qt_(toolkit) Qt] toolkit and has a state-of-the-art organization. Some aspects of the interface can be customized. You can, for example, add custom toolbars, with tools from several workbenches or tools defined in macros, and you can create you own keyboard shortcuts. But the menus and default toolbars that come with FreeCAD and its workbenches cannot be changed.
  
 +
</translate>
 +
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
<translate>
 
<!--T:2-->
 
<!--T:2-->
[[Image:Screenshot-customize.jpg]]
+
{{Caption|The Customize dialog box}}
 +
 
 +
==Usage== <!--T:23-->
 +
 
 +
<!--T:24-->
 +
# The commands available in the Customize dialog box depend on the workbenches that have been loaded in the current FreeCAD session.  So you should first load all workbenches whose commands you want to have access to.
 +
# There are several ways to invoke the [[Image:Std_DlgCustomize.svg|16px]] [[Std_DlgCustomize|Std DlgCustomize]] command:
 +
#* Select the {{MenuCommand|Tools → [[Image:Std_DlgCustomize.svg|16px]] Customize...}} option from the menu.
 +
#* Right-click a toolbar area and choose {{MenuCommand|[[Image:Std_DlgCustomize.svg|16px]] Customize...}} from the context menu.
 +
# The Customize dialog box opens. For more information see [[#Options|Options]].
 +
# The {{Button|Help}} button does not work at this time.
 +
# Press the {{Button|Close}} button to close the dialog box.
 +
 
 +
==Options== <!--T:40-->
 +
 
 +
<!--T:41-->
 +
In the Customize dialog box the following tabs are available:
 +
 
 +
===Commands=== <!--T:42-->
 +
 
 +
</translate>
 +
[[Image:Std_DlgCustomize_tab_Commands.png]]
 +
<translate>
 +
<!--T:43-->
 +
{{Caption|The Commands tab}}
 +
 
 +
<!--T:44-->
 +
On this tab you can browse the available commands.
 +
 
 +
====Browse commands==== <!--T:45-->
 +
 
 +
<!--T:46-->
 +
# Select a command category in the '''Category''' panel on the left. Some categories match menu entries.
 +
# The tools available in the selected category are shown in the panel on the right.
 +
# Hover a command: its tooltip appears.
 +
# Select a command: its status bar text is displayed below the two panels.
 +
 
 +
<!--T:47-->
 +
[[#top|top]]
  
==Customization tabs== <!--T:3-->
+
===Keyboard=== <!--T:48-->
The '''Commands''' tab lets you browse all available FreeCAD commands, organized by their category.
 
  
<!--T:4-->
+
</translate>
In '''Keyboard''', you can see the keyboard shortcuts associated with every FreeCAD command, and if you want, modify or assign new shortcut to any command. This is where to come if you use a particular workbench often, and would like to speed up its use by using the keyboard.
+
[[Image:Std_DlgCustomize_tab_Keyboard.png]]
 +
<translate>
 +
<!--T:49-->
 +
{{Caption|The Keyboard tab}}
  
<!--T:5-->
+
<!--T:50-->
The '''Toolbars''' and '''Toolbox bars''' tabs let you modify existing toolbars, or create your own custom toolbars.
+
On this tab custom keyboard shortcuts can be defined. Shortcuts for macro commands can be defined on the [[#Macros|Macros]] tab.
  
<!--T:7-->
+
====Add a custom shortcut==== <!--T:51-->
Under the tab '''Worksbenches''' ('''Workbenches''') the workbenches existing in FreeCAD are listed, on the left the currently passive, on the right the currently active workspaces. The status can be changed with the horizontal arrows.
+
 
 +
<!--T:52-->
 +
# Select a command category from the '''Category''' dropdown list.
 +
# Select a command from the '''Commands''' panel.
 +
# The '''Current shortcut''' box displays the current short cut, if available.
 +
# Enter a new shortcut in the '''Press new shortcut''' input box. Shortcuts can be up to 4 inputs long. Each input is either a single character, a combination of one or more special keys or a combination of one or more special keys and a character. Use {{KEY|Backspace}} to correct mistakes.
 +
# If the shortcut is already in use, a dialog box will ask you if you want to override it, and the command the shortcut is assigned to will appear in the '''Currently assigned to''' panel.
 +
# Press the {{Button|Assign}} button to assign the new shortcut.
 +
# Press the {{Button|Clear}} button to remove the entered shortcut. This will also remove the content of the '''Current shortcut''' box. Note that default shortcuts are not permanently removed. They will be restored upon restarting FreeCAD.
 +
 
 +
====Remove a custom shortcut==== <!--T:53-->
 +
 
 +
<!--T:54-->
 +
# Select a command category from the '''Category''' dropdown list.
 +
# Select a command from the '''Commands''' panel.
 +
# Press the {{Button|Reset}} button.
 +
 
 +
====Remove all custom shortcuts==== <!--T:55-->
 +
 
 +
<!--T:56-->
 +
# Press the {{Button|Reset All}} button.
 +
 
 +
====Notes (Keyboard)==== <!--T:57-->
 +
 
 +
<!--T:58-->
 +
* Shortcuts only work if their commands appear in the standard menu or in the menu of a workbench that has been loaded in the current FreeCAD session, or if their commands appear on a ''visible'' toolbar.
 +
<!--Description of problem below: https://forum.freecadweb.org/viewtopic.php?f=23&t=45826-->
 +
* In V0.19 there is an issue with some Draft commands. Their default shortcuts do not work and/or custom shortcuts cannot be assigned to them.
 +
 
 +
<!--T:59-->
 +
[[#top|top]]
 +
 
 +
===Workbenches=== <!--T:60-->
 +
 
 +
</translate>
 +
[[Image:Std_DlgCustomize_tab_Workbenches.png]]
 +
<translate>
 +
<!--T:61-->
 +
{{Caption|The Workbenches tab}}
 +
 
 +
<!--T:62-->
 +
On this tab the [[Std_Workbench|Workbench selector]] list can be changed. The '''Enabled workbenches''' list shows the workbenches as they will appear in the Workbench selector.
 +
 
 +
====Disable a workbench==== <!--T:63-->
 +
 
 +
<!--T:64-->
 +
# Select a workbench in the '''Enabled workbenches''' list.
 +
# Press the {{Button|[[Image:Button_left.svg|16px]]}} button.
 +
# The workbench will be moved to the '''Disabled workbenches''' list
 +
 
 +
====Re-enable a workbench==== <!--T:65-->
 +
 
 +
<!--T:66-->
 +
# Select a workbench in the '''Disabled workbenches''' list.
 +
# Press the {{Button|[[Image:Button_right.svg|16px]]}} button.
 +
# The workbench will be moved to the '''Enabled workbenches''' list
 +
 
 +
====Re-enable all workbenches==== <!--T:67-->
 +
 
 +
<!--T:68-->
 +
# Press the {{Button|[[Image:Button_add_all.svg|16px]]}} button.
 +
 
 +
====Change a workbench position==== <!--T:69-->
 +
 
 +
<!--T:70-->
 +
# Select a workbench in the '''Enabled workbenches''' list.
 +
# Press the {{Button|[[Image:Button_up.svg|16px]]}} button or the {{Button|[[Image:Button_down.svg|16px]]}} button.
 +
# Optionally repeat this until the workbench is in the correct position.
 +
 
 +
====Sort workbenches alphabetically==== <!--T:71-->
 +
 
 +
<!--T:72-->
 +
# Press the {{Button|[[Image:Button_sort.svg|16px]]}} button.
 +
 
 +
<!--T:73-->
 +
[[#top|top]]
 +
 
 +
===Toolbars=== <!--T:74-->
 +
 
 +
</translate>
 +
[[Image:Std_DlgCustomize_tab_Toolbars.png]]
 +
<translate>
 +
<!--T:75-->
 +
{{Caption|The Toolbars tab}}
 +
 
 +
<!--T:76-->
 +
On this tab custom toolbars can be created and modified.
 +
 
 +
====Select the workbench==== <!--T:77-->
 +
 
 +
<!--T:78-->
 +
# In the dropdown list on the right select the workbench whose custom toolbars you want to modify. The {{Value|Global}} option is there for custom toolbars that should be available in all workbenches.
 +
 
 +
====Create a toolbar==== <!--T:79-->
 +
 
 +
<!--T:80-->
 +
# Press the {{Button|New...}} button.
 +
# Enter a name in the dialog box that opens.
 +
# Press the {{Button|OK}} button.
 +
# The new toolbar will appear in the panel on the right.
 +
 
 +
====Rename a toolbar==== <!--T:81-->
 +
 
 +
<!--T:82-->
 +
# Select a toolbar in the panel on the right.
 +
# Press the {{Button|Rename...}} button.
 +
# Enter a new name in the dialog box that opens.
 +
# Press the {{Button|OK}} button.
 +
 
 +
====Delete a toolbar==== <!--T:83-->
 +
 
 +
<!--T:84-->
 +
# Select a toolbar in the panel on the right.
 +
# Press the {{Button|Delete}} button.
 +
 
 +
====Disable a toolbar==== <!--T:85-->
 +
 
 +
<!--T:86-->
 +
# Uncheck the checkbox in front of the toolbar name in the panel on the right.
 +
# A disabled toolbar will be invisible in the FreeCAD interface.
 +
 
 +
====Add a command==== <!--T:87-->
 +
 
 +
<!--T:88-->
 +
# Select the correct toolbar in the panel on the right. If no toolbar is selected, the command will be added to the first toolbar in the list.
 +
# Select a category from the dropdown list on the left. Macro commands that have been set up on the [[#Macros|Macros]] tab appear in the 'Macros' category.
 +
# Select a command from the panel on the left.
 +
# Or select '<Separator>' to add a separator (a line between two toolbar buttons).
 +
# Press {{Button|[[Image:Button_right.svg|16px]]}} button.
 +
 
 +
====Remove a command==== <!--T:89-->
 +
 
 +
<!--T:90-->
 +
# If required, expand the toolbar in the panel on the right.
 +
# Select a command.
 +
# Press {{Button|[[Image:Button_left.svg|16px]]}} button.
 +
 
 +
====Change a command position==== <!--T:91-->
 +
 
 +
<!--T:92-->
 +
# If required, expand the toolbar in the panel on the right.
 +
# Select a command.
 +
# Press the {{Button|[[Image:Button_up.svg|16px]]}} button or the {{Button|[[Image:Button_down.svg|16px]]}} button.
 +
# Optionally repeat this until the command is in the correct position.
 +
 
 +
====Notes (Toolbars)==== <!--T:93-->
 +
 
 +
<!--T:94-->
 +
* Toolbars belonging to the current workbench are updated immediately, but after disabling/re-enabling a toolbar a workbench change is required (switch to a different workbench and then switch back).
 +
* To update global toolbars a workbench change (if commands have been added or removed) or a restart (if the order of a toolbar has changed or a toolbar was renamed) is required.
 +
<!--Description of problem below: https://forum.freecadweb.org/viewtopic.php?f=23&t=45757-->
 +
* In V0.19 there is an issue with some Draft commands. After adding them to a custom toolbar and exiting the FreeCAD application the {{FileName|user.cfg}} file must be manually edited for these commands. Search for the name of the custom toolbar and in that section change the content of the {{incode|FCText}} items that start with {{incode|gui_}} to {{incode|DraftTools}}.
 +
 
 +
<!--T:95-->
 +
[[#top|top]]
 +
 
 +
===Macros=== <!--T:96-->
 +
 
 +
</translate>
 +
[[Image:Std_DlgCustomize_tab_Macros.png]]
 +
<translate>
 +
<!--T:97-->
 +
{{Caption|The Macros tab}}
 +
 
 +
<!--T:98-->
 +
On this tab user macro commands can be set up. Once set up, they can be added to custom toolbars. FreeCAD uses a dedicated folder for user macros and only macros in that folder can be set up. Use the [[Image:Std_DlgMacroExecute.svg|16px]] [[Std_DlgMacroExecute|Std DlgMacroExecute]] command to find this folder on your system.
 +
 
 +
<!--T:99-->
 +
If you download a macro with the [[Image:Std_AddonMgr.svg|16px]] [[Std_AddonMgr|Addon Manager]] then make sure that you also download its icon image file. Most macros have an image link on the information page that appears in the Addon Manager. You can for example put this image file in the user macros folder.
 +
 
 +
====Add a macro command==== <!--T:100-->
 +
 
 +
<!--T:101-->
 +
# In the '''Macro''' dropdown list select a macro.
 +
# Enter a '''Menu text'''. This will be the name used to identify the macro command and will also appear in the toolbar if there is no icon.
 +
# Optionally enter a '''Tool tip'''. This text will appear near the location of the mouse when you hover the toolbar icon.
 +
# Optionally enter a '''Status text'''. This text will appear in the [[Status_bar|status bar]] when you hover the toolbar icon.
 +
# Optionally enter the wiki page for the macro, if available, in the '''What's this''' input box. Enter the page name, not the full URL.
 +
# Optionally enter a shortcut in the '''Accelerator''' input box. See [[#Keyboard|Keyboard]] for more information.
 +
# To add an icon:
 +
## Press the '''Pixmap''' {{Button|...}} button.
 +
## The Choose Icon dialog box opens.
 +
## If required press the {{Button|Icon folders...}} button to add an icon folder.
 +
## Select an icon from the panel. The Choose Icon dialog box closes automatically.
 +
# Press the {{Button|Add}} button.
 +
# The macro command appears in the panel on the left.
 +
# The macro command can now be selected on the [[#Toolbars|Toolbars]] tab.
 +
 
 +
====Remove a macro command==== <!--T:102-->
 +
 
 +
<!--T:103-->
 +
# Select the macro command in the panel on the left.
 +
# Press the {{Button|Remove}} button.
 +
 
 +
====Change a macro command==== <!--T:104-->
 +
 
 +
<!--T:105-->
 +
# Double-click the macro command in the panel on the left.
 +
# Make the required changes. Note that you cannot remove the icon, you can only replace it.
 +
# Press the {{Button|Replace}} button.
 +
 
 +
<!--T:106-->
 +
[[#top|top]]
 +
 
 +
===Spaceball Motion=== <!--T:107-->
 +
 
 +
<!--T:108-->
 +
This is tab is blank if no Spaceball is detected. See: [[3Dconnexion_input_devices|3Dconnexion input devices]].
 +
 
 +
<!--T:109-->
 +
[[#top|top]]
 +
 
 +
===Spaceball Buttons=== <!--T:110-->
 +
 
 +
<!--T:111-->
 +
This is tab is blank if no Spaceball is detected. See: [[3Dconnexion_input_devices|3Dconnexion input devices]].
 +
 
 +
<!--T:112-->
 +
[[#top|top]]
 +
 
 +
==Addons== <!--T:25-->
 +
 
 +
<!--T:26-->
 +
Addons offer yet another way to customize the use interface. Below are some addons created by users in the FreeCAD community. They can be downloaded through the [[Image:Std_AddonMgr.svg|16px]] [[Std_AddonMgr|Addon Manager]] (note: they are listed on the Workbenches tab).
 +
 
 +
===CubeMenu=== <!--T:38-->
 +
 
 +
<!--T:39-->
 +
* Github repository: https://github.com/triplus/CubeMenu
  
[[Image:UserdefSymbLeisten.jpg]]]
+
===Glass=== <!--T:27-->
  
Under the tab '''Toolbars''' ('''Toolbars''') on the left are the same command categories as under the map '''Commands'''. After clicking on a category the corresponding commands appear, which can be copied to the right side. Before you do this, select an active workspace to which you want to add an individual toolbar. First select a name for this toolbar with '''New''' ('''New...''') before copying commands over to it. When this workspace is called later, this bar must be activated: '''View -> Toolbars'''.
+
<!--T:28-->
 +
* Github repository: https://github.com/triplus/Glass.
  
Remark: If "Global" (instead of a workspace) is selected on the right, the added toolbar can be activated in each workspace.
+
===IconThemes=== <!--T:36-->
  
 +
<!--T:37-->
 +
* Github repository: https://github.com/triplus/IconThemes
  
 +
===Launcher=== <!--T:30-->
  
 +
<!--T:31-->
 +
* Github repository: https://github.com/triplus/Launcher
  
<!--T:6-->
+
===PieMenu=== <!--T:29-->
The '''Macros''' tab lets you manage your saved [[Macros]].
 
  
<!--T:9-->
+
<!--T:113-->
Create your Toolbars for your macro [[Customize_Toolbars|Customize Toolbars]]
+
* Github repository: https://github.com/triplus/PieMenu
  
<!--T:10-->
+
===RemBench=== <!--T:34-->
Since FreeCAD 0.16 a new tool is available that lets you manage your workbenches.
 
  
<!--T:11-->
+
<!--T:35-->
[[Image:CustomizeWorkbenches.png]]
+
* Github repository: https://github.com/triplus/RemBench
  
==Example== <!--T:12-->
+
===ShortCut=== <!--T:32-->
For an example workflow lets suppose we want to have the "Measure Linear" tool also show up in a custom toolbar in the [[Draft Workbench]].
 
* in FreeCAD choose {{MenuCommand|Tools → Customize}} from the top menu
 
* select the "Toolbars" tab
 
* on the left side choose "Part" in the pull down menu
 
* on the left side in the lower window scroll down to the "Measure Linear" entry and select it
 
* on the right side choose "Draft" in the pull down menu
 
* click on {{button|New...}} to create a new toolbar and choose a name for it
 
* now select your destination toolbar in the right lower window (only needed if you have more than one toolbar)
 
* by clicking on the blue "Arrow right" (top icon in the middle row) you will add your selected entry to the selected toolbar
 
  
===Remarks=== <!--T:13-->
+
<!--T:33-->
When selecting "Global" in the pull down menu on the right side you will create a toolbar which will be visible in all workbenches.
+
* Github repository: https://github.com/triplus/ShortCuts
  
<!--T:14-->
+
<!--T:114-->
For adding an installed macro to a toolbar you must
+
[[#top|top]]
* select "Macros" in the pull down menu on the left side
 
* have assigned menu text, icon (Pixmap) and so on using the {{MenuCommand|Tools → Customize → Macros}} menu
 
  
 
<!--T:7-->
 
<!--T:7-->
{{docnav|Import Export Preference|Property editor}}
+
{{Docnav
 +
|[[Import_Export_Preferences|Import Export Preferences]]
 +
|[[Property_editor|Property editor]]
 +
}}
  
<!--T:8-->
 
{{Std Base}}
 
{{Interface}}
 
{{Userdocnavi}}
 
 
</translate>
 
</translate>
 +
{{Std Base navi{{#translation:}}}}
 +
{{Interface navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}

Latest revision as of 14:25, 6 August 2020

Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎български • ‎русский • ‎українська • ‎中文 • ‎中文(中国大陆)‎ • ‎日本語 • ‎한국어

Introduction

The FreeCAD interface is based on the modern Qt toolkit and has a state-of-the-art organization. Some aspects of the interface can be customized. You can, for example, add custom toolbars, with tools from several workbenches or tools defined in macros, and you can create you own keyboard shortcuts. But the menus and default toolbars that come with FreeCAD and its workbenches cannot be changed.

Std DlgCustomize tab Toolbars.png

The Customize dialog box


Usage

  1. The commands available in the Customize dialog box depend on the workbenches that have been loaded in the current FreeCAD session. So you should first load all workbenches whose commands you want to have access to.
  2. There are several ways to invoke the Std DlgCustomize.svg Std DlgCustomize command:
    • Select the Tools → Std DlgCustomize.svg Customize... option from the menu.
    • Right-click a toolbar area and choose Std DlgCustomize.svg Customize... from the context menu.
  3. The Customize dialog box opens. For more information see Options.
  4. The Help button does not work at this time.
  5. Press the Close button to close the dialog box.

Options

In the Customize dialog box the following tabs are available:

Commands

Std DlgCustomize tab Commands.png

The Commands tab


On this tab you can browse the available commands.

Browse commands

  1. Select a command category in the Category panel on the left. Some categories match menu entries.
  2. The tools available in the selected category are shown in the panel on the right.
  3. Hover a command: its tooltip appears.
  4. Select a command: its status bar text is displayed below the two panels.

top

Keyboard

Std DlgCustomize tab Keyboard.png

The Keyboard tab


On this tab custom keyboard shortcuts can be defined. Shortcuts for macro commands can be defined on the Macros tab.

Add a custom shortcut

  1. Select a command category from the Category dropdown list.
  2. Select a command from the Commands panel.
  3. The Current shortcut box displays the current short cut, if available.
  4. Enter a new shortcut in the Press new shortcut input box. Shortcuts can be up to 4 inputs long. Each input is either a single character, a combination of one or more special keys or a combination of one or more special keys and a character. Use Backspace to correct mistakes.
  5. If the shortcut is already in use, a dialog box will ask you if you want to override it, and the command the shortcut is assigned to will appear in the Currently assigned to panel.
  6. Press the Assign button to assign the new shortcut.
  7. Press the Clear button to remove the entered shortcut. This will also remove the content of the Current shortcut box. Note that default shortcuts are not permanently removed. They will be restored upon restarting FreeCAD.

Remove a custom shortcut

  1. Select a command category from the Category dropdown list.
  2. Select a command from the Commands panel.
  3. Press the Reset button.

Remove all custom shortcuts

  1. Press the Reset All button.

Notes (Keyboard)

  • Shortcuts only work if their commands appear in the standard menu or in the menu of a workbench that has been loaded in the current FreeCAD session, or if their commands appear on a visible toolbar.
  • In V0.19 there is an issue with some Draft commands. Their default shortcuts do not work and/or custom shortcuts cannot be assigned to them.

top

Workbenches

Std DlgCustomize tab Workbenches.png

The Workbenches tab


On this tab the Workbench selector list can be changed. The Enabled workbenches list shows the workbenches as they will appear in the Workbench selector.

Disable a workbench

  1. Select a workbench in the Enabled workbenches list.
  2. Press the Button left.svg button.
  3. The workbench will be moved to the Disabled workbenches list

Re-enable a workbench

  1. Select a workbench in the Disabled workbenches list.
  2. Press the Button right.svg button.
  3. The workbench will be moved to the Enabled workbenches list

Re-enable all workbenches

  1. Press the Button add all.svg button.

Change a workbench position

  1. Select a workbench in the Enabled workbenches list.
  2. Press the Button up.svg button or the Button down.svg button.
  3. Optionally repeat this until the workbench is in the correct position.

Sort workbenches alphabetically

  1. Press the Button sort.svg button.

top

Toolbars

Std DlgCustomize tab Toolbars.png

The Toolbars tab


On this tab custom toolbars can be created and modified.

Select the workbench

  1. In the dropdown list on the right select the workbench whose custom toolbars you want to modify. The Global option is there for custom toolbars that should be available in all workbenches.

Create a toolbar

  1. Press the New... button.
  2. Enter a name in the dialog box that opens.
  3. Press the OK button.
  4. The new toolbar will appear in the panel on the right.

Rename a toolbar

  1. Select a toolbar in the panel on the right.
  2. Press the Rename... button.
  3. Enter a new name in the dialog box that opens.
  4. Press the OK button.

Delete a toolbar

  1. Select a toolbar in the panel on the right.
  2. Press the Delete button.

Disable a toolbar

  1. Uncheck the checkbox in front of the toolbar name in the panel on the right.
  2. A disabled toolbar will be invisible in the FreeCAD interface.

Add a command

  1. Select the correct toolbar in the panel on the right. If no toolbar is selected, the command will be added to the first toolbar in the list.
  2. Select a category from the dropdown list on the left. Macro commands that have been set up on the Macros tab appear in the 'Macros' category.
  3. Select a command from the panel on the left.
  4. Or select '<Separator>' to add a separator (a line between two toolbar buttons).
  5. Press Button right.svg button.

Remove a command

  1. If required, expand the toolbar in the panel on the right.
  2. Select a command.
  3. Press Button left.svg button.

Change a command position

  1. If required, expand the toolbar in the panel on the right.
  2. Select a command.
  3. Press the Button up.svg button or the Button down.svg button.
  4. Optionally repeat this until the command is in the correct position.

Notes (Toolbars)

  • Toolbars belonging to the current workbench are updated immediately, but after disabling/re-enabling a toolbar a workbench change is required (switch to a different workbench and then switch back).
  • To update global toolbars a workbench change (if commands have been added or removed) or a restart (if the order of a toolbar has changed or a toolbar was renamed) is required.
  • In V0.19 there is an issue with some Draft commands. After adding them to a custom toolbar and exiting the FreeCAD application the user.cfg file must be manually edited for these commands. Search for the name of the custom toolbar and in that section change the content of the FCText items that start with gui_ to DraftTools.

top

Macros

Std DlgCustomize tab Macros.png

The Macros tab


On this tab user macro commands can be set up. Once set up, they can be added to custom toolbars. FreeCAD uses a dedicated folder for user macros and only macros in that folder can be set up. Use the Std DlgMacroExecute.svg Std DlgMacroExecute command to find this folder on your system.

If you download a macro with the Std AddonMgr.svg Addon Manager then make sure that you also download its icon image file. Most macros have an image link on the information page that appears in the Addon Manager. You can for example put this image file in the user macros folder.

Add a macro command

  1. In the Macro dropdown list select a macro.
  2. Enter a Menu text. This will be the name used to identify the macro command and will also appear in the toolbar if there is no icon.
  3. Optionally enter a Tool tip. This text will appear near the location of the mouse when you hover the toolbar icon.
  4. Optionally enter a Status text. This text will appear in the status bar when you hover the toolbar icon.
  5. Optionally enter the wiki page for the macro, if available, in the What's this input box. Enter the page name, not the full URL.
  6. Optionally enter a shortcut in the Accelerator input box. See Keyboard for more information.
  7. To add an icon:
    1. Press the Pixmap ... button.
    2. The Choose Icon dialog box opens.
    3. If required press the Icon folders... button to add an icon folder.
    4. Select an icon from the panel. The Choose Icon dialog box closes automatically.
  8. Press the Add button.
  9. The macro command appears in the panel on the left.
  10. The macro command can now be selected on the Toolbars tab.

Remove a macro command

  1. Select the macro command in the panel on the left.
  2. Press the Remove button.

Change a macro command

  1. Double-click the macro command in the panel on the left.
  2. Make the required changes. Note that you cannot remove the icon, you can only replace it.
  3. Press the Replace button.

top

Spaceball Motion

This is tab is blank if no Spaceball is detected. See: 3Dconnexion input devices.

top

Spaceball Buttons

This is tab is blank if no Spaceball is detected. See: 3Dconnexion input devices.

top

Addons

Addons offer yet another way to customize the use interface. Below are some addons created by users in the FreeCAD community. They can be downloaded through the Std AddonMgr.svg Addon Manager (note: they are listed on the Workbenches tab).

CubeMenu

Glass

IconThemes

Launcher

PieMenu

RemBench

ShortCut

top