Interfaz

From FreeCAD Documentation
Revision as of 22:56, 25 September 2021 by Maker (talk | contribs) (Created page with "Los menús estándar son: {{StdMenu|{{MenuCommand|Archivo}}}}, {{StdMenu|{{MenuCommand|Editar}}}}, {{StdMenu|S...")
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎português do Brasil • ‎русский

Introducción

La interfaz de FreeCAD está basada en Qt, un conocido kit de herramientas de interfaz gráfica de usuario (GUI), particularmente utilizado en Linux, pero también disponible en Windows y MacOS.

FreeCAD interface base divisions.svg

Interfaz estándar en la v0.19.

La ventana principal de la aplicación puede dividirse a grandes rasgos en 11 secciones:

  1. El área de vista principal, que puede contener diferentes ventanas con pestañas.
  2. La vista 3D, normalmente incrustada en el área de vista principal
  3. La parte superior de la vista_combo, que incluye la vista_árbol y el panel_tarea
  4. La parte inferior de la vista_combo, que incluye el editor de propiedades
  5. La vista de selección
  6. La vista de informe
  7. La consola de Python
  8. La barra_de_estado
  9. El área de la barra de herramientas, ver la siguiente información sobre las barras de herramientas
  10. El Selector de ambientes de trabajo, que es una barra de herramientas
  11. El menú estándar

Componentes de la interfaz

Como muchas piezas de software, FreeCAD incluye una barra de menú estándar, y luego una serie de barras de herramientas y paneles donde se encuentran las herramientas del usuario.

Menús

Los menús estándar son: Archivo, Editar, Vista, Herramientas, Macro, Windows, Ayuda.

Barras de herramientas

The standard toolbars that appear in the interface are:

  • File toolbar: tools to work with files, open documents, copy, paste, undo and redo actions.
  • Workbench toolbar: it contains a single widget to select the active workbench.
  • Macro toolbar: tools to record, edit, and execute macros.
  • View toolbar: tools to control how objects appear in the 3D view.
  • Structure toolbar: tools to organize objects in the document, and create links to additional documents.

These can be turned on and off by right clicking on an empty space on one of the toolbars and choosing the desired element, or from the menu, View → Toolbars.

Paneles

The main panels that allow working with objects are:

  • 3D view: the area where 2D and 3D geometry is drawn.
  • Combo view: the panel that contains the tree view, the task panel, and the property editor.
  • Tree view: the element that shows all objects in the document and their parametric history.
  • Task panel: the panel that shows different actions and options depending on the drawing tool selected.
  • Property editor: the place where object properties are modified.
  • Selection view: the panel that shows elements that are currently selected.
  • Report view: the text box that shows different messages from the application and its tools.
  • Python console: the editor that allows running Python code interactively to see results in the 3D view.
  • Status bar: the bar that shows certain messages from the application, and that has the mouse navigation selector.
  • DAG view: an alternative to the tree view, which shows the relationships between different objects through a graph.

With the exception of the 3D view, all can be turned on and off by right clicking on an empty space on one of the top toolbars and choosing the desired element, or from the menu, View → Panels.

To activate and deactivate the status bar use the menu, View → Status bar.

Otros

Other useful interfaces and windows include:

  • Scene inspector: a panel that shows the Coin3D nodes that make up the scenegraph. For power users and developers, it may be useful to troubleshoot operations that manipulate the scene directly, and the objects created in the 3D view.
  • Dependency graph: a window showing the dependency graph of all the objects in the document, created with the auxiliary program Graphviz. It is helpful to recognize problems in the creation of objects, such as circular dependencies, which may not be entirely evident from the tree view or the DAG view.

Personalización

Toolbars can have more or fewer buttons, and custom toolbars can be created with a mix of different tools, and to store developed macros.

These options are in the menu, Tools → Customize. See interface customization.