Difference between revisions of "Interface/en"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
(Updating to match new version of source page)
 
(One intermediate revision by the same user not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 +
{{TOCright}}
  
 
== Introduction ==
 
== Introduction ==
Line 5: Line 6:
 
The FreeCAD [[interface|interface]] is based on Qt, a well known graphical user interface (GUI) toolkit, particularly used in Linux, but also available in Windows and MacOS.
 
The FreeCAD [[interface|interface]] is based on Qt, a well known graphical user interface (GUI) toolkit, particularly used in Linux, but also available in Windows and MacOS.
  
[[File:FreeCAD_interface_base_divisions.png|1024px]]
+
[[File:FreeCAD_interface_base_divisions.svg|1024px]]
  
 
{{Caption|Standard interface in v0.19.}}
 
{{Caption|Standard interface in v0.19.}}
  
The main window of the application can be roughly divided into 10 sections:
+
The main window of the application can be roughly divided into 11 sections:
# [[3D view|3D view]]
+
# The [[main_view_area|main view area]], which can contain different tabbed windows
# Upper part of the [[combo view|combo view]], which includes the [[Tree view|tree view]] and [[task panel|task panel]]
+
# The [[3D_view|3D view]], normally embedded in the [[main_view_area|main view area]]
# Lower part of the [[combo view|combo view]], which includes the [[property editor|property editor]]
+
# The upper part of the [[combo_view|combo view]], which includes the [[tree_view|tree view]] and [[task_panel|task panel]]
# [[Selection view|Selection view]]
+
# The lower part of the [[combo_view|combo view]], which includes the [[property_editor|property editor]]
# [[Report view|Report view]]
+
# The [[selection_view|selection view]]
# [[Python console|Python console]]
+
# The [[report_view|report view]]
# [[Status bar|Status bar]]
+
# The [[Python_console|Python console]]
# Toolbar area, see the following information on the toolbars
+
# The [[status_bar|status bar]]
# [[Std_Workbench|Workbench selector]], which itself is a toolbar
+
# The toolbar area, see the following information on the toolbars
# [[Standard Menu|Standard menu]]
+
# The [[Std_Workbench|Workbench selector]], which itself is a toolbar
 +
# The [[Standard_Menu|standard menu]]
  
 
== Components of the interface ==
 
== Components of the interface ==
Line 27: Line 29:
 
=== Menus ===
 
=== Menus ===
  
The [[Standard_Menu|standard menus]] are: [[Std_File_Menu|{{MenuCommand|File}}]], [[Std_Edit_Menu|{{MenuCommand|Edit}}]], [[Std_View_Menu|{{MenuCommand|View}}]], [[Std_Tools_Menu|{{MenuCommand|Tools}}]], [[Std_Macro_Menu|{{MenuCommand|Macro}}]], [[Std_Windows_Menu|{{MenuCommand|Windows}}]], [[Std_Help_Menu|{{MenuCommand|Help}}]].
+
The [[Standard_Menu|standard menus]] are: {{StdMenu|[[Std_File_Menu|{{MenuCommand|File}}]]}}, {{StdMenu|[[Std_Edit_Menu|{{MenuCommand|Edit}}]]}}, {{StdMenu|[[Std_View_Menu|{{MenuCommand|View}}]]}}, {{StdMenu|[[Std_Tools_Menu|{{MenuCommand|Tools}}]]}}, {{StdMenu|[[Std_Macro_Menu|{{MenuCommand|Macro}}]]}}, {{StdMenu|[[Std_Windows_Menu|{{MenuCommand|Windows}}]]}}, {{StdMenu|[[Std_Help_Menu|{{MenuCommand|Help}}]]}}.
  
 
=== Toolbars ===
 
=== Toolbars ===
Line 70: Line 72:
 
These options are in the menu, {{MenuCommand|Tools → Customize}}. See [[Interface Customization|interface customization]].
 
These options are in the menu, {{MenuCommand|Tools → Customize}}. See [[Interface Customization|interface customization]].
  
{{Interface}}
+
{{Interface navi{{#translation:}}}}
{{Userdocnavi}}
+
{{Userdocnavi{{#translation:}}}}

Latest revision as of 22:47, 18 March 2020

Other languages:
Deutsch • ‎English • ‎français • ‎italiano • ‎polski

Introduction

The FreeCAD interface is based on Qt, a well known graphical user interface (GUI) toolkit, particularly used in Linux, but also available in Windows and MacOS.

FreeCAD interface base divisions.svg

Standard interface in v0.19.


The main window of the application can be roughly divided into 11 sections:

  1. The main view area, which can contain different tabbed windows
  2. The 3D view, normally embedded in the main view area
  3. The upper part of the combo view, which includes the tree view and task panel
  4. The lower part of the combo view, which includes the property editor
  5. The selection view
  6. The report view
  7. The Python console
  8. The status bar
  9. The toolbar area, see the following information on the toolbars
  10. The Workbench selector, which itself is a toolbar
  11. The standard menu

Components of the interface

Like many pieces of software, FreeCAD includes a standard menu bar, and then a series of toolbars and panels where the user tools are found.

Menus

The standard menus are: File, Edit, View, Tools, Macro, Windows, Help.

Toolbars

The standard toolbars that appear in the interface are:

  • File toolbar: tools to work with files, open documents, copy, paste, undo and redo actions.
  • Workbench toolbar: it contains a single widget to select the active workbench.
  • Macro toolbar: tools to record, edit, and execute macros.
  • View toolbar: tools to control how objects appear in the 3D view.
  • Structure toolbar: tools to organize objects in the document, and create links to additional documents.

These can be turned on and off by right clicking on an empty space on one of the toolbars and choosing the desired element, or from the menu, View → Toolbars.

Panels

The main panels that allow working with objects are:

  • 3D view: the area where 2D and 3D geometry is drawn.
  • Combo view: the panel that contains the tree view, the task panel, and the property editor.
  • Tree view: the element that shows all objects in the document and their parametric history.
  • Task panel: the panel that shows different actions and options depending on the drawing tool selected.
  • Property editor: the place where object properties are modified.
  • Selection view: the panel that shows elements that are currently selected.
  • Report view: the text box that shows different messages from the application and its tools.
  • Python console: the editor that allows running Python code interactively to see results in the 3D view.
  • Status bar: the bar that shows certain messages from the application, and that has the mouse navigation selector.
  • DAG view: an alternative to the tree view, which shows the relationships between different objects through a graph.

With the exception of the 3D view, all can be turned on and off by right clicking on an empty space on one of the top toolbars and choosing the desired element, or from the menu, View → Panels.

To activate and deactivate the status bar use the menu, View → Status bar.

Other

Other useful interfaces and windows include:

  • Scene inspector: a panel that shows the Coin3D nodes that make up the scenegraph. For power users and developers, it may be useful to troubleshoot operations that manipulate the scene directly, and the objects created in the 3D view.
  • Dependency graph: a window showing the dependency graph of all the objects in the document, created with the auxiliary program Graphviz. It is helpful to recognize problems in the creation of objects, such as circular dependencies, which may not be entirely evident from the tree view or the DAG view.

Customization

Toolbars can have more or fewer buttons, and custom toolbars can be created with a mix of different tools, and to store developed macros.

These options are in the menu, Tools → Customize. See interface customization.

Template:Interface navi/en Template:Userdocnavi/en