Difference between revisions of "Installing Helpfile"

From FreeCAD Documentation
Jump to navigation Jump to search
(Marked this version for translation)
Line 19: Line 19:
  
 
<!--T:7-->
 
<!--T:7-->
A working offline documentation consist of at least two files: "freecad.qhc" the Qt-helpfile-configuration and "freecad.qch" the compressed Qt-helpfile. They have always the same name. In order to have different version of the helpfiles, these need to be installed in different directories. In case of a manual download, just store the zip-file locally and extract the archive into the wanted directory.
+
The help files do always have the same names: "freecad.qhc" and "freecad.qch". In order to have different version of the helpfiles, these need to be installed in different directories. In case of a manual download, just store the zip-file locally and extract the archive into the wanted directory.
  
 
==Register the Documentation== <!--T:8-->
 
==Register the Documentation== <!--T:8-->
Line 28: Line 28:
  
 
<!--T:10-->
 
<!--T:10-->
* Click inside FreeCAD in the Help menu on the Help item. The program Qt-assistant should be open.
+
* Click inside FreeCAD in the Help menu on the Help item. The program Qt-assistant should open.
 
* In Qt-assistant click in the menu Edit on preferences.
 
* In Qt-assistant click in the menu Edit on preferences.
 
* In the preferences dialog click on the tab Documentation.  
 
* In the preferences dialog click on the tab Documentation.  
* In the documentation dialog select org.freecad.usermanual and click on "Remove"
+
* In the list registered documentation select org.freecad.usermanual and click on the button "Remove".
 
* Close the dialog with ok, but do not close the Qt-assistant. This is important as otherwise another helpfile will not be registered.
 
* Close the dialog with ok, but do not close the Qt-assistant. This is important as otherwise another helpfile will not be registered.
 
* Open again the preferences dialog via the menu Edit/Preferences.
 
* Open again the preferences dialog via the menu Edit/Preferences.
Line 38: Line 38:
 
* close the filedialog by confirming your selection. The Documentation tab in the preferences should now have again a line with org.freecad.usermanual.
 
* close the filedialog by confirming your selection. The Documentation tab in the preferences should now have again a line with org.freecad.usermanual.
 
* Close the Preferences with Ok.  
 
* Close the Preferences with Ok.  
* You should now have the new documentation available in the Qt-assistant, that are accessible from within FreeCAD.
+
* You should now have the new documentation available in the Qt-assistant, which is accessible from within FreeCAD.
  
 
==Additional Notes== <!--T:11-->
 
==Additional Notes== <!--T:11-->

Revision as of 19:03, 16 June 2018

FreeCAD Helpfiles

The FreeCAD offline documentation is created with scripts from the FreeCAD-Wiki. It has actual grown to a file size of more than 100 megabyte. These big files are not part of development installers and executables of FreeCAD. But the offline documentation can be installed separately, which is explained here.

The offline documentation has now also made been available in French and Italian. (Check for other languages.) These files are not part of the official installers of FreeCAD but available as separate packages.


Download Helpfiles

A working offline documentation consist of at least two files: "freecad.qhc" the Qt-helpfile-configuration and "freecad.qch" the compressed Qt-helpfile. They are put together in a ZIP-archive.

The helpfiles can be downloaded here: https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre

As a future option they can be installed from within FreeCAD with the Addon manager.

The help files do always have the same names: "freecad.qhc" and "freecad.qch". In order to have different version of the helpfiles, these need to be installed in different directories. In case of a manual download, just store the zip-file locally and extract the archive into the wanted directory.

Register the Documentation

The actual organization of the offline help does allow only one helpfile to be active. It is therefore not possible to have helpfiles in different languages accessible from FreeCAD at the same time.

In order to make another FreeCAD documentation active the following steps have to be applied:

  • Click inside FreeCAD in the Help menu on the Help item. The program Qt-assistant should open.
  • In Qt-assistant click in the menu Edit on preferences.
  • In the preferences dialog click on the tab Documentation.
  • In the list registered documentation select org.freecad.usermanual and click on the button "Remove".
  • Close the dialog with ok, but do not close the Qt-assistant. This is important as otherwise another helpfile will not be registered.
  • Open again the preferences dialog via the menu Edit/Preferences.
  • Select the tab documentation and click the button Add...
  • In the filedialog navigate to your new helpfile and select freecad.qch
  • close the filedialog by confirming your selection. The Documentation tab in the preferences should now have again a line with org.freecad.usermanual.
  • Close the Preferences with Ok.
  • You should now have the new documentation available in the Qt-assistant, which is accessible from within FreeCAD.

Additional Notes

In case your operation system has no Qt-Assistant and it is not delivered with FreeCAD, it will be necessary to install one.


Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎русский