Import Export Preferences

From FreeCAD Documentation
Revision as of 15:50, 25 October 2021 by Roy 043 (talk | contribs) (Marked this version for translation)
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎русский • ‎한국어

Introduction

FreeCAD can import and export many file formats. For some formats dedicated preferences exist. These can be found in the Preferences editor, in the menu Edit → Preferences → Import-Export.

Not all import and export preferences tabs are available by default. For some a workbench has to be loaded first.

Notes

TechDraw pages

The DXF and SVG preferences listed here are not used by the TechDraw ExportPageSVG.svg Export Page as SVG and TechDraw ExportPageDXF.svg Export Page as DXF commands of the Workbench TechDraw.svg TechDraw Workbench, or by the TechDraw export option: File → Export → Technical Drawing (*.svg *.dxf *.pdf).

OpenSCAD files

The import and export preferences for OpenSCAD files are listed in a different part of the Preferences editor. See the OpenSCAD Preferences.

Related

See the following pages for additional information:

Available preferences

DAE

The Collada DAE (Digital Asset Exchange) format is a standard file format for exchange of Mesh data. FreeCAD can import meshes from .dae files, and export Shape-based objects to the .dae format.

Note for Linux users: To handle this file format FreeCAD requires the pyCollada module.

For the DAE format you can specify the following:

Name Description
Scaling factor All dimensions in the file will be scaled with the specified factor.
Mesher Sets the meshing program that should be used. If using Netgen, make sure that it is available. This can be checked by using the Workbench Mesh.svg Mesh Workbench and creating a mesh using Netgen. If it is not available another version of FreeCAD, compiled with Netgen, must be installed.
Tessellation The tessellation value to use with the Builtin and the Mefisto meshing program.
Grading The grading value to use for meshing using Netgen. This value describes how fast the mesh size decreases. The gradient of the local mesh size h(x) is bound by abs(Δh(x)) ≤ 1/value.
Segments per edge The maximum number of segments per edge.
Segments per radius The number of segments per radius.
Second order Allow a second order mesh.
Optimize Allow optimization.
Allow quads Allow quadrilateral faces.

Preferences Import Export Tab DAE.png

DWG

DWG (from drawing) is a proprietary, closed source, binary file format for storing 2D and 3D design data and metadata. FreeCAD requires external converters to process DWG files.

Note: All settings for the DXF file format also apply to DWG.

For the DWG format you can specify the following:

Name Description
Conversion method Select the DWG converter to use:
  • Automatic: FreeCAD will try to find a converter automatically following the order of the rest of this list.
  • LibreDWG: LibreDWG is an open-source DWG reading and writing library. It lacks support for several DWG entities, and may not always give faithful results.
  • ODA Converter: The ODA File Converter is a free utility provided by the Open Design Alliance. It gives very good and reliable results.
  • QCAD pro: QCAD pro is the paid version of the open-source QCAD DXF-based 2D CAD platform. Its DWG converter uses the Teigha libraries from the OpenDesign Alliance and therefore gives the same good results as the ODA File Converter.

introduced in version 0.20

Path to file converter FreeCAD will try to find the path to the selected DWG converter automatically. If FreeCAD is unable to find it you can specify the path to the executable here:
  • dwg2dxf.exe (LibreDWG)
  • ODAFileConverter.exe (ODA File Converter)
  • dwg2dwg.exe (QCAD pro).

introduced in version 0.20

Preferences Import Export Tab DWG.png

DXF

AutoCAD DXF (Drawing eXchange Format) is a proprietary format to exchange CAD data between AutoCAD and other programs.

For the DXF format you can specify the following:

Name Description
Show this dialog when importing and exporting If checked, this preferences dialog will be shown when importing or exporting DXF files.
Use legacy python importer If checked, the Python importer is used, otherwise the newer C++ one. The C++ importer is faster, but has not as many features yet.

The Python importer uses the Edit → Preferences... → Draft → General settings → Internal precision level preference. For an accurate import result set this value to 8 or higher.

Use legacy python exporter If checked, the Python exporter is used, otherwise the newer C++ one. The C++ exporter is faster, but has not as many features yet. introduced in version 0.19
Allow FreeCAD to automatically download and update the DXF libraries By checking this, you will allow FreeCAD to download the Python converter for DXF import and export. This converter cannot be bundled with FreeCAD because it has a different software license.
Import Select what will be imported.

If texts and dimensions is unchecked, texts and mtexts won't be imported.

If points is unchecked, points won't be imported.

If layouts is checked, paper space objects will be imported too.

Check *blocks if you want anonymous blocks (which have names beginning with a *) to be imported too.

Create Select what will be created.

If simple Part shapes is selected, only standard Part objects will be created. This is the fastest.

If Draft objects is selected, parametric Draft objects will be created whenever possible.

If Sketches is selected, sketches will be created whenever possible.

Scale factor to apply to imported files Scale factor to apply to DXF files on import. The factor is the conversion between the units of your DXF file and millimeters. Example: for files in millimeters: 1, in centimeters: 10, in meters: 1000, in inches: 25.4, in feet: 304.8.
Get original colors from the DXF file If checked, colors will be retrieved from the DXF objects whenever possible. Otherwise default colors will be applied.
Join geometry If checked, FreeCAD will try to join coincident objects into wires. Note that this can take a while!
Group layers into blocks If checked, objects from the same layers will be joined into Draft Blocks, which display faster, but are less easily editable.
Use standard font size for texts If checked, imported texts will get the standard Draft Text size, instead of the size they have in the DXF document.
Use Layers If checked, DXF layers will be imported as Draft Layers. (introduced in version 0.19)
Import hatch boundaries as wires If checked, hatches will be converted to simple wires.
Render polylines with width If checked, if polylines have a width defined, they will be rendered as closed wires with the correct width.
Treat ellipses and splines as polylines The export of ellipses and splines is poorly supported. Use this option to export them as polylines instead.

The setting Max Spline Segment is then the maximum length of each of the polyline segments. If it is set to 0 the whole spline is treated as a straight segment.

Export 3D objects as polyface meshes If checked, all objects containing faces will be exported as 3D polyfaces.
Export Drawing Views as blocks If this is checked, Drawing Views will be exported as blocks. This might fail for post DXF R12 templates.
Project exported objects along current view direction If checked, the exported objects will be projected to reflect the current view direction.

Preferences Import Export Tab DXF.png

IGES

The Initial Graphics Exchange Specification (IGES) file format is a file format that allows the digital exchange of information among CAD systems. After publication of the STEP file format, IGES development was stopped in 1996, but it is still supported by many CAD programs. IGES files have the .iges or .igs extension.

The tab IGES is only shown in the preferences if the Workbench Part.svg Part Workbench, Workbench PartDesign.svg PartDesign Workbench, or Workbench OpenSCAD.svg OpenSCAD Workbench has been loaded in the current FreeCAD session.

For the IGES format you can specify the following:

Name Description
Units for export of IGES Select what unit will be used when exporting IGES files.
Write solids and shells as Select how solids and shells should be output.

If Groups of Trimmed Surfaces (type 144) is selected, they will be exported as trimmed surfaces.

If Solids (type 186) and Shells (type 514) / B-REP mode is selected, solids will be exported as manifold solid B-Rep objects, shells as shells.

Skip blank entities If checked, blank entities will not be imported.
Company If not empty, the entered text will be used in the IGES file header for the company.
Author If not empty, the entered text will be used in the IGES file header for the author.
Product If not empty, the entered text will be used in the IGES file header for the product.

Preferences Import Export Tab IGES.png

IFC

Industry Foundation Classes (IFC) is a wide spread format to exchange data between BIM applications. It is used in architecture and engineering.

Note for Linux users: To handle this file format FreeCAD requires the IfcOpenShell module.

IFC import

For import of the IFC format you can specify the following:

Name Description
Show this dialog when importing If checked, this preferences dialog will be shown when importing IFC files.
Show debug messages Shows verbose debug messages during import and export of IFC files in the Report view.
Create clones when objects have shared geometry IFC objects can share a same geometry definition between several objects, only their placement is different. When this option is enabled, clones are used to achieve the same result in FreeCAD. One object is the base object, the others are clones.
Number of cores to use (experimental) Specify the number of CPU cores to use for IFC import. The maximum number should be smaller than the number of actually available cores. Use 0 to disable this feature. introduced in version 0.19
Import arch IFC objects as What will be created in FreeCAD for arch IFC objects.
Import struct IFC objects as What will be created in FreeCAD for struct IFC objects.
Root element Only subtypes of the specified element will be imported. Keep the predefined element IfcProduct to import all building elements.
Separate openings If checked, openings will be imported as subtractions, otherwise wall shapes will already have their openings subtracted.
Detect extrusions If checked, the importer will try to detect extrusions. Note that this might slow things down.
Split multilayer walls Split walls made of multiple layers.
Prefix names with ID number If checked, object names will be prefixed with the IFC ID number.
Merge materials with same name and same color If several materials with the same name are found in the IFC file, they will be treated as one.
Import Ifc Properties in spreadsheet If checked, each object will have their IFC properties stored in a spreadsheet object.
Allow invalid shapes If unchecked invalid shapes are not imported. introduced in version 0.19
Exclude list A comma-separated list of IFC entities to be excluded from imports.
Fit view while importing Fit view during import on the imported objects. This will slow down the import, but one can watch the import.
Import full FreeCAD parametric definitions if available Creates a full parametric model on import using stored FreeCAD object properties.

To get the FreeCAD properties, the model must have been exported using the option Export full FreeCAD parametric model. introduced in version 0.19

Replace 'Project', 'Site', 'Building' and 'Storey' with 'Group' If checked, groups will be used to replace the mentioned objects. introduced in version 0.19

Preferences Import Export Tab IFC import.png

IFC export

For export of the IFC format you can specify the following:

Name Description
Show this dialog when exporting If checked, this preferences dialog will be shown when exporting IFC files.
Export type Select how the model should be exported: as Standard model, Structural Analysis, or Standard + structural. introduced in version 0.19
Force export as Brep Some IFC viewers don't like objects exported as extrusions. Use this to force all objects to be exported as BREP geometry. But avoid exporting as Brep if possible as this makes objects non-parametric.
Use DAE triangulation options Use triangulation options set in the DAE options page.
Join coplanar facets when triangulating Curved shapes that cannot be represented as curves in IFC are decomposed into flat facets. If this is checked, some additional calculation is done to join coplanar facets.
Store IFC unique ID in FreeCAD objects When exporting objects without a unique ID (UID), the generated UID will be stored inside the FreeCAD object for reuse the next time the object is exported. This leads to smaller differences between file versions.
Use IfcOpenShell serializer if available IFCOpenShell is a library for IFC files. Its serializer functionality can produce valid IFC geometry from OCC shapes.

Note that this is still an experimental feature.

Export 2D objects as IfcAnnotations If checked, 2D objects will be exported as IfcAnnotation.
Export full FreeCAD parametric model If checked, all FreeCAD object properties will be stored inside the exported objects, allowing to recreate a full parametric model on reimport using the option Import full FreeCAD parametric definitions if available.
Reuse similar entities If checked, similar entities will be used only once in the file if possible. This can reduce the file size a lot, but will make it less easily readable.
Disable IfcRectangleProfileDef Whenever possible, IFC objects that are extruded rectangles will be exported as IfcRectangleProfileDef. For applications that have problems importing these entities, select this option to ensure that all profiles are exported as IfcArbitraryClosedProfileDef instead.
Auto-detect and export as standard cases when applicable Some IFC types such as IfcWall or IfcBeam have special standard versions like IfcWallStandardCase or IfcBeamStandardCase. If this option is selected, FreeCAD will automatically export such objects as standard cases when the necessary conditions are met. introduced in version 0.19
Add default site if one is not found in the document When exporting an IFC file, if no site is found in the FreeCAD document, a default one is added. A site is not mandatory according to the IFC standard, but it is common practice to have at least one in the file. introduced in version 0.19
Add default building if one is not found in the document (no standard) When exporting an IFC file, if no building is found in the FreeCAD document, a default one is added.

Warning: The IFC standard asks for at least one building in each file. By turning this option off, you will produce a non-standard IFC file.

However, at FreeCAD we believe having a building should not be mandatory, and this option is there to have a chance to demonstrate our point of view. introduced in version 0.19

Add default building storey if one is not found in the document When exporting an IFC file, if no building storey is found in the FreeCAD document, a default one is added. A building storey is not mandatory according to the IFC standard, but it is common practice to have at least one in the file. introduced in version 0.19
IFC file units Select which units will be used when exporting IFC files. introduced in version 0.19

Preferences Import Export Tab IFC export.png

INP

INP is the input file format for the FEM software Abaqus. It is used for the CalculiX solver in the Workbench FEM.svg FEM Workbench.

The tab INP is only shown in the preferences if the Workbench FEM.svg FEM Workbench has been loaded in the current FreeCAD session.

For the INP format you can specify the following:

Name Description
Which mesh elements to export Select which mesh elements should be exported.

If All is selected, all elements will be exported.

If Highest is selected, only the highest elements will be exported. This means volumes for a volume mesh and faces for a shell mesh.

If FEM is selected, only FEM elements will be exported. This means only edges not belonging to faces and faces not belonging to volumes.

Export group data If checked, mesh groups are exported too. Every constraint and, if there are different materials, material consists of two mesh groups, faces and nodes where the constraint or material is applied.

Preferences Import Export Tab INP.png

Mesh Formats

Meshes are a special type of 3D object, composed of triangular faces connected by their vertices and edges. They are widely used for additive manufacturing. FreeCAD provides the Workbench Mesh.svg Mesh Workbench to create and handle meshes. FreeCAD supports several mesh file formats.

The tab Mesh Formats is only shown in the preferences if the Workbench Mesh.svg Mesh Workbench has been loaded in the current FreeCAD session.

For the Mesh formats you can specify the following:

Name Description
Maximum mesh deviation Specification of the maximal deviation between the mesh and the object.
Export AMF files using compression If checked, ZIP compression is used when writing a mesh file in AMF format.
Width Width of Asymptote page. introduced in version 0.19
Height Height of Asymptote page. introduced in version 0.19

Preferences Import Export Tab Mesh Formats.png

OCA

The OCA file format is a community project to create a free, simple and open CAD file format. OCA is largely based on the GCAD file format generated by gCAD3D. Both formats can be imported in FreeCAD and the OCA files exported by FreeCAD can be opened in gCAD3D.

For the OCA format you can specify the following:

Name Description
Import OCA areas If checked, the areas (3D faces) will be imported too.

Preferences Import Export Tab OCA.png

STEP

The Standard for The Exchange of Product model data (STEP) file format is an ISO standard for the computer-interpretable representation and exchange of product manufacturing information. STEP is commonly used to exchange 3D data between CAD software. STEP files have the .step or .stp extension. For compressed files the .stpz extension is used.

The tab STEP is only shown in the preferences if the Workbench Part.svg Part Workbench, Workbench PartDesign.svg PartDesign Workbench, or Workbench OpenSCAD.svg OpenSCAD Workbench has been loaded in the current FreeCAD session.

For the STEP format you can specify the following:

Name Description
Units for export of STEP Select which units will be used when exporting STEP files.
Write out curves in parametric space of surface If checked, parametric curves (curves in parametric space of surfaces) will be written into the STEP file. Unchecking the option can be helpful to minimize the size of the resulting STEP file.
Export invisible objects Uncheck this to skip invisible object when exporting, which is useful for CAD applications that do not support invisibility STEP styling. introduced in version 0.19
Export single object placement Check this option to keep the placement information when exporting a single object. Please note that when re-importing the STEP file, the placement will be encoded into the shape geometry, instead of keeping it inside the Placement property. introduced in version 0.19
Use legacy exporter Use the legacy exporter. introduced in version 0.19
Scheme Select the STEP application protocol (AP) to be used for the export.

AP 203 is the protocol for configuration controlled 3D designs of mechanical parts and assemblies.

AP 214 is the protocol for core data for automotive mechanical design processes.

Enable STEP Compound merge If checked, a compound merge will be done during file reading. This is slower but results in higher details.
Use LinkGroup Select this to use App::LinkGroup group containers instead of App::Part group containers. introduced in version 0.19
Import invisible objects Select this to import invisible objects. introduced in version 0.19
Reduce number of objects Reduce the number of objects using Link arrays. introduced in version 0.19
Expand compound shape Expand compound shapes with multiple solids. introduced in version 0.19
Show progress bar when importing Show a progress bar when importing. introduced in version 0.19
Ignore instance names Do not use instance names. Useful for some legacy STEP files with non-meaningful auto-generated instance names. introduced in version 0.19
Mode Select the required document structure. introduced in version 0.19

Single document

Assembly per document

Assembly per document in sub-directory

Object per document

Object per document in sub-directory

Company If not empty, the entered text will be used in the STEP file header for the company.
Author If not empty, the entered text will be used in the STEP file header for the author.
Product If not empty, the entered text will be used in the STEP file header for the product.

Preferences Import Export Tab STEP.png

SVG

Scalable Vector Graphics (SVG) is a vector image format for two-dimensional graphics. A vector image can be scaled to any size without losing its shape or details. An SVG image can be converted to bitmap formats like PNG or JPEG for printing.

For the SVG format you can specify the following:

Name Description
Import style Select how SVG object colors and line widths will be imported.

If None (fastest) is selected no color or line width settings will be imported.

If Use default color and linewidth is selected FreeCAD will use its default color and line width.

If Original color and linewidth is selected FreeCAD will use the color and linewidth from the SVG objects.

Disable units scaling If checked, no unit conversion will occur. One unit in the SVG file will translate as one millimeter.
Export style Select how Sketches are exported to SVG.

If Translated (for print & display) is selected, SVG objects are encapsulated in a group that is scaled and moved to the correct place in the SVG document to fit into a printable area.

If Raw (for CAM) is selected, SVG objects are placed as they are - at the same coordinates as in the FreeCAD model (1:1 export).

Translate white line color to black If checked, all white lines will appear in black in the SVG for better readability against white backgrounds.
Max segment length for discretized arcs Versions of Open CASCADE older than version 6.8 don't support arc projection. In this case arcs will be discretized into small line segments. This value is the maximum segment length.

Preferences Import Export Tab SVG.png

VTK

The Visualization Toolkit (VTK) is an open-source, freely available software system for 3D computer graphics, image processing and visualization. VTK files are used by the Workbench FEM.svg FEM Workbench for the post processing of simulation results.

The tab VTK is only shown in the preferences if the Workbench FEM.svg FEM Workbench has been loaded in the current FreeCAD session.

For the VTK format you can specify the following:

Name Description
Which object to import into Select what objects should be imported.

If VTK result object is selected, a FreeCAD FEM VTK result object will be imported (equals to the object which was exported).

If FEM mesh object is selected, the results in the VTK file will be omitted, only the mesh data will be imported and a FreeCAD FEM mesh object will be created.

If FreeCAD result object is selected, the imported data will be converted into a FreeCAD FEM Result object. Note: this setting needs the exact result component names and thus it only works properly with VTK files exported from FreeCAD.

Preferences Import Export Tab VTK.png