Difference between revisions of "FEM SolverElmer"

From FreeCAD Documentation
Jump to navigation Jump to search
(Marked this version for translation)
 
(22 intermediate revisions by 5 users not shown)
Line 24: Line 24:
 
==Description== <!--T:8-->
 
==Description== <!--T:8-->
  
 +
<!--T:10-->
 
Elmer is an open source multiphysical simulation software mainly developed by CSC - IT Center for Science (CSC). Elmer development was started 1995 in collaboration with Finnish Universities, research institutes and industry. After it's open source publication in 2005, the use and development of Elmer has become international.
 
Elmer is an open source multiphysical simulation software mainly developed by CSC - IT Center for Science (CSC). Elmer development was started 1995 in collaboration with Finnish Universities, research institutes and industry. After it's open source publication in 2005, the use and development of Elmer has become international.
  
 +
<!--T:11-->
 
Elmer includes physical models of fluid dynamics, structural mechanics, electromagnetics, heat transfer and acoustics, for example. These are described by partial differential equations which Elmer solves by the Finite Element Method (FEM).  https://www.csc.fi/web/elmer
 
Elmer includes physical models of fluid dynamics, structural mechanics, electromagnetics, heat transfer and acoustics, for example. These are described by partial differential equations which Elmer solves by the Finite Element Method (FEM).  https://www.csc.fi/web/elmer
  
Creating the ElmerSolver object in the Analysis container in FreeCAD, gives access to the Elmer Equations for simple or multiphysical analysis.
+
<!--T:12-->
 +
Creating the SolverElmer object in the Analysis container in FreeCAD, gives access to the Elmer Equations for simple or multiphysical analysis.
  
 +
<!--T:2-->
 
Since FreeCAD already has an extensive integration of Calculix and Z88 as solvers for mechanical and thermo-mechanical analysis, Elmer will be preferred for Computational Fluid Dynamics (CFD), Heat, Electrostatics, Magnetostatics and Electrical Forces. It can also be used for mechanical FEA through the Elasticity equation or any combination of the aforementioned equations.
 
Since FreeCAD already has an extensive integration of Calculix and Z88 as solvers for mechanical and thermo-mechanical analysis, Elmer will be preferred for Computational Fluid Dynamics (CFD), Heat, Electrostatics, Magnetostatics and Electrical Forces. It can also be used for mechanical FEA through the Elasticity equation or any combination of the aforementioned equations.
<!--T:2-->
 
  
==Installation==
+
==Installation== <!--T:13-->
  
Elmer requires two components to be interfaced with FreeCAD, ElmerGrid is the interface handling meshes and ElmerSolver is handling the computation.  
+
<!--T:14-->
 +
Elmer requires two components to be interfaced with FreeCAD:
 +
* ElmerGrid is the interface handling meshes
 +
* ElmerSolver is handling the computation.  
 
There are standalone programs for both of these applications but their installation and usage are beyond the scope of the FreeCAD integration.
 
There are standalone programs for both of these applications but their installation and usage are beyond the scope of the FreeCAD integration.
  
#Go to the CSC binaries resources for Elmer: https://www.nic.funet.fi/pub/sci/physics/elmer/bin/ OR https://www.csc.fi/web/elmer/binaries
+
<!--T:15-->
#Download and install the version best suited to your Operating System ([https://www.nic.funet.fi/pub/sci/physics/elmer/bin/windows/ Windows 64] bits or [https://www.nic.funet.fi/pub/sci/physics/elmer/bin/linux/Readme1st.txt Linux])
+
# Go to the CSC binaries resources for Elmer: https://www.nic.funet.fi/pub/sci/physics/elmer/bin/ OR https://www.csc.fi/web/elmer/binaries
#In FreeCAD go to '''Edit'''-->'''Preferences'''-->'''FEM'''-->'''Elmer'''
+
# Download and install the version best suited to your Operating System ([https://www.nic.funet.fi/pub/sci/physics/elmer/bin/windows/ Windows 64] bits or [https://www.nic.funet.fi/pub/sci/physics/elmer/bin/linux/Readme1st.txt Linux])
#Link the correct path for both ElmerGrid.exe and ElmerSolver.exe
+
# In FreeCAD go to {{MenuCommand|Edit Preferences FEM Elmer}}
[[Image:Preferences-ElmerPath.png|Elmer Tab in FEM Preferences]]
+
# Link the correct path for both {{incode|ElmerGrid}} and {{incode|ElmerSolver}} 
 +
#: [[Image:Preferences-ElmerPath.png|Elmer Tab in FEM Preferences]]
 +
#: {{Caption|Above: Elmer preferences dialog menu showing fields to locate important Elmer binaries on Windows OS}}
  
 +
<!--T:16-->
 
You are ready to use Elmer in FreeCAD.
 
You are ready to use Elmer in FreeCAD.
  
 
==Usage== <!--T:9-->
 
==Usage== <!--T:9-->
#In FreeCAD go to FEM workbench
 
#Create an [[FEM_Analysis|Analysis]] container
 
#Create a FEM Solver for Elmer [[Image:Fem-elmer.svg]]
 
A successful analysis will require at least a Model (2D or 3D), a Material ([[FEM_MaterialFluid|Fluid]] or [[FEM_MaterialSolid|Solid]], a [[FEM_MeshGmshFromShape|Mesh]], Equations and Boundary conditions
 
  
About Equations:
+
<!--T:17-->
* Each type of analysis in Elmer is called an Equation (Flow, Heat, Electrostatics...)
+
# Switch to the [[Image:Workbench_FEM.svg|24px]] [[FEM Workbench]]
* One or several equations can be used at once with elmer by simply adding equation under the ElmerSolver object:
+
# Create an [[FEM_Analysis|Analysis]] container by pressing the [[Image:Fem-analysis.svg|22px]] icon.
#Click on the ElmerSolver object
+
# Create a FEM Solver for Elmer, by pressing the [[Image:Fem-elmer.svg|22px]] icon.
#Select an equation:
+
#* Note: A successful analysis will require at least a Model (2D or 3D), a Material ([[FEM_MaterialFluid|Fluid]] or [[FEM_MaterialSolid|Solid]]), a [[FEM_MeshGmshFromShape|Mesh]], Equations and Boundary conditions
* [[Image:Fem-equation-elasticity.svg|32px]] [[FEM_EquationElasticity|Equation elasticity]]
+
#: [[Image:Elmer typical file tree.png]]
* [[Image:Fem-equation-flow.svg|32px]] [[FEM_EquationFlow|Equation flow]]
+
#: {{Caption|Above: Example of a [[tree view]] once a Solver for Elmer is activated}}
* [[Image:Fem-equation-heat.svg|32px]] [[FEM_EquationHeat|Equation heat]]
+
# Edit the parameters for the solver in the [[Property editor]] {{Button|Data}} tab of the SolverElmer object in the model [[tree view]]
* [[Image:Fem-equation-electrostatic.svg|32px]] [[FEM_EquationElectrostatic|Equation electrostatic]]
+
# Double-click on the {{KEY|[[Image:Fem-elmer.svg|22px]] SolverElmer}} object to prepare an analysis run
* [[Image:Fem-equation-fluxsolver.svg|32px]] [[FEM_EquationFluxsolver|Equation fluxsolver]]
+
#: [[Image:ElmerSolver TaskPanel.png]]
 +
#: {{Caption|Above: Dialog box to run an Elmer analysis}}
 +
# Select the path to write the analysis in by clicking {{Button|...}}
 +
# Click {{Button|Write}} to write the case files in the directory selected previously
 +
# Click {{Button|Run}} to start the analysis
  
  
 +
===About Equations=== <!--T:18-->
 +
* Each type of analysis in Elmer is called an Equation (Flow, Heat, Electrostatics...)
 +
* One or several equations can be used at once with Elmer by simply adding the Equation object under the SolverElmer object:
  
 +
<!--T:19-->
 +
# Click on the {{KEY|[[Image:Fem-elmer.svg|22px]] SolverElmer}} object in the model [[tree view]]
 +
# Select an equation:
 +
#* [[Image:Fem-equation-elasticity.svg|32px]] [[FEM_EquationElasticity|Equation elasticity]]
 +
#* [[Image:Fem-equation-flow.svg|32px]] [[FEM_EquationFlow|Equation flow]]
 +
#* [[Image:Fem-equation-heat.svg|32px]] [[FEM_EquationHeat|Equation heat]]
 +
#* [[Image:Fem-equation-electrostatic.svg|32px]] [[FEM_EquationElectrostatic|Equation electrostatic]]
 +
#* [[Image:Fem-equation-fluxsolver.svg|32px]] [[FEM_EquationFluxsolver|Equation fluxsolver]]
  
==Notes==
+
==Notes== <!--T:20-->
* Parameters for the Solver and for the Equations are independently set through the {{KEY|Data}} tab of their respective objects in the tree.
+
* Parameters for the Solver and for the Equations are independently set through the [[Property editor]] {{KEY|Data}} tab of their respective objects in the [[tree view]].
 
* Each equation will have a priority, for example, if trying see the effect of a convective flow of hot air, the equation for Flow should be solved with higher priority than Heat, otherwise the solver will first solve Heat through conduction and then Flow.
 
* Each equation will have a priority, for example, if trying see the effect of a convective flow of hot air, the equation for Flow should be solved with higher priority than Heat, otherwise the solver will first solve Heat through conduction and then Flow.
  
==Documentation==
+
==Documentation== <!--T:21-->
  
The following documentation may be of use to advanced users of Elmer in or out of FreeCAD:
+
<!--T:22-->
*
+
The following link gives access to the full documentation for Elmer https://www.nic.funet.fi/pub/sci/physics/elmer/doc/
 +
This includes the manuals as well as tutorials.
 +
Note that documentation and files appended with "gui" generally concern the usage of the Elmer GUI and not the FreeCAD implementation of Elmer.
  
 
<!--T:3-->
 
<!--T:3-->

Latest revision as of 07:41, 12 June 2020

Other languages:
English • ‎français • ‎italiano

This documentation is not finished. Please help and contribute documentation.

Gui Command explains how tools should be documented. See Draft ShapeString for an example of a well documented tool. Browse Category:UnfinishedDocu to see incomplete pages like this one. See Category:Command Reference for all commands.

See WikiPages to learn about editing the wiki pages, and go to Help FreeCAD to learn about other ways in which you can contribute.

Arrow-left.svg Previous: Fem Solver.svg Solver CalculiX
Next: Solver Z88 FEM SolverZ88.png Arrow-right.svg

Fem-elmer.svg FEM SolverElmer

Menu location
Solve → solver Elmer
Workbenches
FEM
Default shortcut
Introduced in version
-
See also
Solver CalculiX, Solver Z88, FEM tutorial


Description

Elmer is an open source multiphysical simulation software mainly developed by CSC - IT Center for Science (CSC). Elmer development was started 1995 in collaboration with Finnish Universities, research institutes and industry. After it's open source publication in 2005, the use and development of Elmer has become international.

Elmer includes physical models of fluid dynamics, structural mechanics, electromagnetics, heat transfer and acoustics, for example. These are described by partial differential equations which Elmer solves by the Finite Element Method (FEM). https://www.csc.fi/web/elmer

Creating the SolverElmer object in the Analysis container in FreeCAD, gives access to the Elmer Equations for simple or multiphysical analysis.

Since FreeCAD already has an extensive integration of Calculix and Z88 as solvers for mechanical and thermo-mechanical analysis, Elmer will be preferred for Computational Fluid Dynamics (CFD), Heat, Electrostatics, Magnetostatics and Electrical Forces. It can also be used for mechanical FEA through the Elasticity equation or any combination of the aforementioned equations.

Installation

Elmer requires two components to be interfaced with FreeCAD:

  • ElmerGrid is the interface handling meshes
  • ElmerSolver is handling the computation.

There are standalone programs for both of these applications but their installation and usage are beyond the scope of the FreeCAD integration.

  1. Go to the CSC binaries resources for Elmer: https://www.nic.funet.fi/pub/sci/physics/elmer/bin/ OR https://www.csc.fi/web/elmer/binaries
  2. Download and install the version best suited to your Operating System (Windows 64 bits or Linux)
  3. In FreeCAD go to Edit → Preferences → FEM → Elmer
  4. Link the correct path for both ElmerGrid and ElmerSolver
    Elmer Tab in FEM Preferences

    Above: Elmer preferences dialog menu showing fields to locate important Elmer binaries on Windows OS


You are ready to use Elmer in FreeCAD.

Usage

  1. Switch to the Workbench FEM.svg FEM Workbench
  2. Create an Analysis container by pressing the Fem-analysis.svg icon.
  3. Create a FEM Solver for Elmer, by pressing the Fem-elmer.svg icon.
    • Note: A successful analysis will require at least a Model (2D or 3D), a Material (Fluid or Solid), a Mesh, Equations and Boundary conditions
    Elmer typical file tree.png

    Above: Example of a tree view once a Solver for Elmer is activated

  1. Edit the parameters for the solver in the Property editor Data tab of the SolverElmer object in the model tree view
  2. Double-click on the Fem-elmer.svg SolverElmer object to prepare an analysis run
    ElmerSolver TaskPanel.png

    Above: Dialog box to run an Elmer analysis

  1. Select the path to write the analysis in by clicking ...
  2. Click Write to write the case files in the directory selected previously
  3. Click Run to start the analysis


About Equations

  • Each type of analysis in Elmer is called an Equation (Flow, Heat, Electrostatics...)
  • One or several equations can be used at once with Elmer by simply adding the Equation object under the SolverElmer object:
  1. Click on the Fem-elmer.svg SolverElmer object in the model tree view
  2. Select an equation:

Notes

  • Parameters for the Solver and for the Equations are independently set through the Property editor Data tab of their respective objects in the tree view.
  • Each equation will have a priority, for example, if trying see the effect of a convective flow of hot air, the equation for Flow should be solved with higher priority than Heat, otherwise the solver will first solve Heat through conduction and then Flow.

Documentation

The following link gives access to the full documentation for Elmer https://www.nic.funet.fi/pub/sci/physics/elmer/doc/ This includes the manuals as well as tutorials. Note that documentation and files appended with "gui" generally concern the usage of the Elmer GUI and not the FreeCAD implementation of Elmer.


Arrow-left.svg Previous: Fem Solver.svg Solver CalculiX
Next: Solver Z88 FEM SolverZ88.png Arrow-right.svg