Tutoriel Planche à Dessin

From FreeCAD Documentation
Revision as of 23:50, 24 February 2020 by Gnrc (talk | contribs) (Replaced content with "== Plans de travail ==")
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(繁體)‎
Base ExampleCommandModel.png Tutoriel
Thème
Drafting
Niveau
Débutant
Temps d'exécution estimé
30 minutes
Auteur(s)
Drei
Version de FreeCAD
0.16 or above
Fichier(s) exemple(s)


Introduction

Ce tutoriel est destiné à présenter au lecteur le flux de travail de base de l'Atelier Draft Workbench Draft.svg.

Le lecteur pratiquera :

  • la création de profils
  • l'utilisation de plans de travail
  • la création et le dimensionnement, de textes et d'annotations

Ce tutoriel utilise la notation (x, y, z) pour désigner les coordonnées nécessaires pour définir des points dans un objet

Draft tutorial result.png

installation

1. Ouvrez FreeCAD, créez un nouveau document vide avec Fichier → Std New.svg Nouveau.

1.1. Basculez vers l'atelier Draft Workbench depuis le sélecteur d'atelier ou le menu Affichage → Atelier → Draft.
1.2. Assurez-vous de comprendre comment utiliser l'éditeur de propriétés, en particulier les onglets Données et Affichage pour modifier les propriétés. :1.3. Comme les objets Draft sont des formes planes, ils sont mieux vus du dessus. Utilisez Std ViewTop.svg pour définir la vue 3D.

Verrouillage de la barre d'outils

  1. Démarrer FreeCAD
  2. Si vous n'avez pas ouvert un nouveau document FreeCAD (la plupart des fenêtres de FreeCAD sont grisées), dans le menu déroulant, cliquez sur Fichier → Nouveau ou cliquez sur l'outil Créer un nouveau document Document-new.svg.
  3. Activez l'Atelier Planche à Dessin
  4. Sélectionnez le menu Modifier
  5. Cliquez sur Préférences
  6. Aller à Planche à dessin et sélectionner l'onglet Grille et magnétisme
  7. Vérifiez que la barre d'outils Montrer la barre d'outils d'accrochage est activé

Vous pouvez aussi changer la visibilité et les propriétés de la grille dans ce même menu.

Plans de travail

Most Draft objects are planar shapes so they are naturally based on a working plane. A working plane can be one of the main XY, XZ, and YZ global coordinate planes, or it can be a plane that is parallel to them with a positive or negative offset, or it can be a plane defined by the face of a solid object.

  1. Sélectionnez Draft SelectPlane.png Plan de Travail, soit dans la barre d'outils atelier Dessin, soit dans le menu Draft sous-menu Utilitaire.
  2. Sélectionnez le plan XY.

Before pressing the button, you can also change the value of the offset in millimeters, as well as the grid spacing, the main lines and snapping radius.

Création de profils

La création de profils peut se faire de plusieurs façons. Bien qu'il soit possible d'utiliser des «arcs» et des lignes simples pour faire la plupart des travaux, FreeCAD comprend plusieurs outils pour accélérer le processus.

The creation of profiles can be done in several ways. Though it is possible to use simple arcs and lines to do most of the work, FreeCAD includes several tools to speed up the process.

Lignes et Arcs
  1. Sélectionnez Draft Arc.png Arc.
  2. Réglez le centre à (0, 0, 0)
  3. Définir le rayon à 30 mm
  4. L'angle de départ est de 60,0 °
  5. L'ouverture est de 60.0 °

Répétez la même procédure pour un deuxième arc avec un rayon de 25 mm, les autres propriétés restent inchangées.

  1. Sélectionnez Draft Line.png Ligne.
  2. Approchez la Terminaison de l'un ou l'autre des arcs. Un point blanc devrait apparaître, à côté de cette icône Snap Endpoint.png lorsque votre curseur s'approche du point de terminaison.
  3. Sélectionnez le point final de l'autre arc.
  4. Répétez pour l'autre côté des arcs

Fusing or upgrading

Nous avons maintenant plusieurs courbes qui détaillent un profil, mais celui-ci n'est toujours pas reconnu comme une entité unique. Il est possible de continuer à travailler avec des éléments entiers, mais dans ce cas, nous les fusionnerons dans un seul objet.

  1. Sélectionnez un arc et tout en appuyant sur la touche CTRL, sélectionnez les deux segments de ligne et l’autre arc.
  2. Avec ces quatre objets sélectionnés, cliquez sur Draft Upgrade.png Grouper.

6b. If you wish to maintain the parametric nature of the objects you may wish to create a compound instead.

6.1. Switch to the Part Workbench.
6.2. With these objects selected, click on Part Compound.svg Part Compound.
Plans, rectangles et cercles
  1. Cliquez sur Draft Rectangle.png Rectangle
  2. Définir le premier point sur (-100, -60, 0)
  3. Définir le deuxième point sur (140, 90, 0)

7. We will draw a rectangular frame.

7.1. Press Draft Rectangle.svg Rectangle.
7.2. Enter the values (-100, -60, 0), and press Enter.
7.3. Make sure the Relative option is unchecked, as we will use absolute units. You may press R in the keyboard to quickly toggle this option on and off.
7.4. Enter the values for the second point (140, 90, 0), and press Enter.

Le résultat est un Plan. Ses propriétés peuvent être modifiées pour supprimer le remplissage, en changeant son Style de Représentation en Filaire.

  1. Sélectionnez Draft Circle.png
  2. Réglez le centre sur (0, 0, 0)
  3. Réglez le rayon à 15 mm
Polygones
  1. Sélectionnez Draft Polygon.png Polygone
  2. Le point central est situé à (0, 0, 0)
  3. Réglez le rayon à 50 mm
  4. Réglez le nombre de côtés à 6

Again, you may change the DataMake Face and ViewDisplay Mode properties in the property editor if you want.

The rectangle, the circle, the polygon, and most other objects created with the Draft Workbench share many data and view properties because they are derived from the same base class, Part Part2DObject.

Tableaux

Les tableaux sont utilisés pour reproduire un objet plusieurs fois dans une direction, un axe de révolution ou le long d'un chemin.

  1. Sélectionnez le Filaire qui a été précédemment créé
  2. Cliquez sur Draft Array.png Tableau
  3. Dans l'onglet Donnéesde l'objet, modifiez le type de matrice de ortho à polar
  4. Change Number Polar de 1 à 4

Arrays are used to replicate an object several times in an orthogonal direction (X, Y, Z), around a revolution axis, or along a path.

10. We will create a polar array.

10.1. Select the Wire object that was previously created with the Draft Upgrade.svg Upgrade tool, or the Compound created with the Part Compound.svg Part Compound tool.
10.2. Press Draft PolarArray.svg PolarArray.
10.3. Adjust the polar angle to 360°, and press OK.

Old workflow

10.2. Press Draft Array.svg Array.
10.3. Go to the tree view, select the Array object, and then go to the property editor, and change the DataArray Type from ortho to polar.
10.4. Change DataNumber Polar to 4, and DataAngle to 360°.

An array object should be created replicating the object around the origin.

Ajout de dimensions

Les dimensions requièrent une utilisation constante de Restrictions d'Ancrage pour sélectionner correctement les points que l'on souhaite dimensionner. La barre d'outils Ancrage sert à modifier les points possibles qui peuvent être sélectionnés

Dimensions require a constant use of Snapping Constraints to properly select the points that one wishes to dimension. The Snapping toolbar is used to change the possible points that can be selected.

  1. Sélectionnez Draft Dimension.png Dimension
  2. Sélectionnez le premier point. Cela peut être soit un élément existant, soit spécifié par des coordonnées. Pour ce tutoriel, le premier point sera toujours (0, 0, 0)
  3. Sélectionnez le deuxième point. Approchez le point médian de la ligne supérieure du polygone. Un point blanc devrait apparaître à côté de cette icône Snap Midpoint.png
  4. Déplacez le curseur sur l'emplacement souhaité de la dimension et cliquez dessus.
  5. Change la taille de la police sur l'onglet Vue à 6 mm

Répéter le processus pour les arcs et les cercles.

Annotations et texte

Il y a une légère différence entre les deux: il est seulement possible d'utiliser le second comme profil pour effectuer des opérations 3D

Annotations
  1. Sélectionnez Draft Text.png Texte
  2. Sélectionnez le point de référence dans la Vue 3D. Dans ce cas, le point milieu de l'arc supérieur.
  3. Entrez votre texte et appuyez sur Entrée. Répétez pour autant de lignes de texte que vous souhaitez saisir.
  4. Appuyez sur Entrée
Texte
  1. Sélectionnez Draft ShapeString.png ShapeString
  2. Sélectionnez le point de référence dans la Vue 3D. Cela peut être un point existant ou l'emplacement actuel du curseur.
  3. Entrez votre texte et appuyez sur Entrée
  4. Définir la taille de police souhaitée
  5. Laisser le suivi à 0 mm
  6. Sélectionnez le chemin dans le fichier de police que vous souhaitez utilise

Création de plans

Pour créer des plans, il est nécessaire de créer un Dessin avec les éléments que vous souhaitez utiliser. Veuillez lire le Tutoriel de Dessin pour une description détaillée.

Important Note: Drawing WB was deprecated in FreeCAD v0.16 and replaced by the TechDraw Workbench. Although the author of this tutorial also created the Drawing Tutorial, it would be better for the reader to familiarize themselves with Basic tutorials of TechDraw, such as Basic_TechDraw_Tutorial.

Nous avons terminé le travail de base pour Module Table à Dessin.

Lectures recommandées