Difference between revisions of "Draft tutorial/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
 
(4 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
  
 +
<div class="mw-translate-fuzzy">
 
{{TutorialInfo/fr
 
{{TutorialInfo/fr
 
|Topic= Drafting
 
|Topic= Drafting
Line 9: Line 10:
 
|Files=
 
|Files=
 
}}
 
}}
 +
</div>
  
 
== Introduction ==
 
== Introduction ==
 +
 +
This tutorial was originally written by Drei, and it was rewritten and illustrated by vocx.
  
 
Ce tutoriel est destiné à présenter au lecteur le flux de travail de base de l'[[Draft_Module/fr|Atelier Draft]] [[File:Workbench_Draft.svg|24px]].
 
Ce tutoriel est destiné à présenter au lecteur le flux de travail de base de l'[[Draft_Module/fr|Atelier Draft]] [[File:Workbench_Draft.svg|24px]].
  
 +
<div class="mw-translate-fuzzy">
 
Le lecteur pratiquera :
 
Le lecteur pratiquera :
 
* la création de profils
 
* la création de profils
 
* l'utilisation de plans de travail
 
* l'utilisation de plans de travail
 
* la création et le dimensionnement, de textes et d'annotations
 
* la création et le dimensionnement, de textes et d'annotations
 +
</div>
  
 +
<div class="mw-translate-fuzzy">
 
Ce tutoriel utilise la notation {{Value|(x, y, z)}} pour désigner les coordonnées nécessaires pour définir des points dans un objet
 
Ce tutoriel utilise la notation {{Value|(x, y, z)}} pour désigner les coordonnées nécessaires pour définir des points dans un objet
 +
</div>
  
[[Image:Draft_tutorial_result.png|480px]]
+
[[File:00_Dr01_Draft_Tutorial_final.png|x400px]]
 +
{{Caption|Final drawing including various Draft objects.}}
  
== installation ==
+
== Installation ==
  
 +
<div class="mw-translate-fuzzy">
 
1. Ouvrez FreeCAD, créez un nouveau document vide avec {{MenuCommand|Fichier → [[File:Std_New.svg|16px]] [[Std_New|Nouveau]]}}.
 
1. Ouvrez FreeCAD, créez un nouveau document vide avec {{MenuCommand|Fichier → [[File:Std_New.svg|16px]] [[Std_New|Nouveau]]}}.
 
:1.1. Basculez vers l'[[Draft_Module/fr|atelier Draft Workbench]] depuis le [[Std_Workbench/fr|sélecteur d'atelier]] ou le menu {{MenuCommand|[[Std_View_Menu|Affichage]] → Atelier → Draft}}.
 
:1.1. Basculez vers l'[[Draft_Module/fr|atelier Draft Workbench]] depuis le [[Std_Workbench/fr|sélecteur d'atelier]] ou le menu {{MenuCommand|[[Std_View_Menu|Affichage]] → Atelier → Draft}}.
 
:1.2. Assurez-vous de comprendre comment utiliser l'[[property_editor/fr|éditeur de propriétés]], en particulier les onglets {{MenuCommand|Données}} et {{MenuCommand|Affichage}} pour modifier les propriétés. :1.3. Comme les objets Draft sont des formes planes, ils sont mieux vus du dessus. Utilisez {{Button| [[File:Std_ViewTop.svg|16px]] pour définir la [[Std_ViewTop/fr|vue 3D]]}}.
 
:1.2. Assurez-vous de comprendre comment utiliser l'[[property_editor/fr|éditeur de propriétés]], en particulier les onglets {{MenuCommand|Données}} et {{MenuCommand|Affichage}} pour modifier les propriétés. :1.3. Comme les objets Draft sont des formes planes, ils sont mieux vus du dessus. Utilisez {{Button| [[File:Std_ViewTop.svg|16px]] pour définir la [[Std_ViewTop/fr|vue 3D]]}}.
 +
</div>
  
 
== Verrouillage de la barre d'outils ==
 
== Verrouillage de la barre d'outils ==
Line 42: Line 53:
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Notez que vous pouvez changer la visibilité de la '''Grille''' dans ce menu, au cas où vous souhaitez le faire
+
Vous pouvez aussi changer la visibilité et les propriétés de la grille dans ce même menu.
 
</div>
 
</div>
  
<div class="mw-translate-fuzzy">
+
== Plans de travail ==
==== Utilisation des plans ====
 
Les plans sont utilisés pour restreindre le comportement des outils de Dessin à un plan spécifique, en évitant les problèmes d'emplacement des points et des courbes dans des pièces complexes.
 
Les plans peuvent faire référence aux axes du système de coordonnées '''(XY, YZ, ...)''' ou ils peuvent utiliser une surface plane dans le document comme référence.
 
</div>
 
  
 
Most Draft objects are planar shapes so they are naturally based on a {{Emphasis|working plane}}. A working plane can be one of the main XY, XZ, and YZ global coordinate planes, or it can be a plane that is parallel to them with a positive or negative offset, or it can be a plane defined by the face of a solid object.
 
Most Draft objects are planar shapes so they are naturally based on a {{Emphasis|working plane}}. A working plane can be one of the main XY, XZ, and YZ global coordinate planes, or it can be a plane that is parallel to them with a positive or negative offset, or it can be a plane defined by the face of a solid object.
Line 59: Line 66:
  
 
Before pressing the button, you can also change the value of the offset in millimeters, as well as the grid spacing, the main lines and snapping radius.
 
Before pressing the button, you can also change the value of the offset in millimeters, as well as the grid spacing, the main lines and snapping radius.
 
<div class="mw-translate-fuzzy">
 
==== Création de profils ====
 
La création de profils peut se faire de plusieurs façons. Bien qu'il soit possible d'utiliser des «arcs» et des lignes simples pour faire la plupart des travaux, FreeCAD comprend plusieurs outils pour accélérer le processus.
 
</div>
 
 
The creation of profiles can be done in several ways. Though it is possible to use simple '''arcs''' and '''lines''' to do most of the work, FreeCAD includes several tools to speed up the process.
 
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 87: Line 87:
 
</div>
 
</div>
  
== Fusing or upgrading ==
+
[[File:01_Dr01_Draft_Arc_profile.png|x400px]]
 +
{{Caption|Closed profile created by two arcs and two lines.}}
 +
 
 +
== Fusing or compounding ==
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 111: Line 114:
 
7. We will draw a rectangular frame.
 
7. We will draw a rectangular frame.
 
:7.1. Press {{Button|[[File:Draft_Rectangle.svg|16px]] [[Draft_Rectangle|Rectangle]]}}.
 
:7.1. Press {{Button|[[File:Draft_Rectangle.svg|16px]] [[Draft_Rectangle|Rectangle]]}}.
:7.2. Enter the values {{Value|(-100, -60, 0)}}, and press {{KEY|Enter}}.
+
:7.2. Enter the values of the first point {{Value|(-100, -60, 0)}}, and press {{KEY|Enter}}.
 
:7.3. Make sure the {{MenuCommand|Relative}} option is unchecked, as we will use absolute units. You may press {{KEY|R}} in the keyboard to quickly toggle this option on and off.
 
:7.3. Make sure the {{MenuCommand|Relative}} option is unchecked, as we will use absolute units. You may press {{KEY|R}} in the keyboard to quickly toggle this option on and off.
 
:7.4. Enter the values for the second point {{Value|(140, 90, 0)}}, and press {{KEY|Enter}}.
 
:7.4. Enter the values for the second point {{Value|(140, 90, 0)}}, and press {{KEY|Enter}}.
Line 136: Line 139:
  
 
The rectangle, the circle, the polygon, and most other objects created with the [[Draft_Module|Draft Workbench]] share many data and view properties because they are derived from the same base class, [[Part_Part2DObject|Part Part2DObject]].
 
The rectangle, the circle, the polygon, and most other objects created with the [[Draft_Module|Draft Workbench]] share many data and view properties because they are derived from the same base class, [[Part_Part2DObject|Part Part2DObject]].
 +
 +
[[File:02_Dr01_Draft_Rectangle_circle_polygon.png|x400px]]
 +
{{Caption|Rectangle, circle and polygon added.}}
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 159: Line 165:
 
:10.4. Change {{PropertyData|Number Polar}} to {{Value|4}}, and {{PropertyData|Angle}} to {{Value|360°}}.
 
:10.4. Change {{PropertyData|Number Polar}} to {{Value|4}}, and {{PropertyData|Angle}} to {{Value|360°}}.
  
An array object should be created replicating the object around the origin.
+
The array object shows copies of the object around the origin.
 +
 
 +
[[File:03_Dr01_Draft_PolarArray.png|x400px]]
 +
{{Caption|Polar array of the small profile centered around the origin.}}
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 166: Line 175:
 
</div>
 
</div>
  
Dimensions require a constant use of '''Snapping Constraints''' to properly select the points that one wishes to dimension. The '''Snapping toolbar''' is used to change the possible points that can be selected.
+
Linear dimensions work best when using the appropriate [[Draft_Snap|Draft Snap]] methods to select points and edges to measure. However, they can also be created by specifying absolute coordinates.
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 176: Line 185:
 
</div>
 
</div>
  
 +
<div class="mw-translate-fuzzy">
 
Répéter le processus pour les arcs et les cercles.
 
Répéter le processus pour les arcs et les cercles.
 +
</div>
 +
 +
13. Repeat the process for the circle located in the center. The first point of the measurement will still be the origin. To select the second point make sure {{Button|[[File:Draft_ToggleSnap.svg|16px]] [[Draft_ToggleSnap|Toggle snap]]}} is active, and only {{Button|[[File:Draft_Angle.svg|16px]] [[Draft_Angle|Angle]]}} as well. As you move the pointer to the top of the circle, the [[File:Draft_Angle.svg|24px]] [[Draft_Angle|Angle]] icon should appear; click to select this point. Then move the cursor to the right, and click to fix the dimension.
  
 +
Remember to adjust the {{PropertyView|Font Size}}, and other properties to see the dimension correctly.
 +
 +
[[File:04_Dr01_Draft_Dimension.png|x400px]]
 +
{{Caption|Dimensions that measure the vertical distance from the origin to the top of the circle, arcs, and polygon.}}
 +
 +
<div class="mw-translate-fuzzy">
 
==== Annotations et texte ====
 
==== Annotations et texte ====
 
Il y a une légère différence entre les deux: il est seulement possible d'utiliser le second comme profil pour effectuer des opérations 3D
 
Il y a une légère différence entre les deux: il est seulement possible d'utiliser le second comme profil pour effectuer des opérations 3D
 +
</div>
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 198: Line 218:
 
# Sélectionnez le '''chemin''' dans le fichier de police que vous souhaitez utilise
 
# Sélectionnez le '''chemin''' dans le fichier de police que vous souhaitez utilise
 
</div>
 
</div>
 +
 +
[[File:05_Dr01_Draft_Text_ShapeString.png|x400px]]
 +
{{Caption|Text and ShapeString objects added.}}
 +
 +
To extrude letters and engrave them on to solids, see the [[Draft_ShapeString_tutorial|Draft ShapeString tutorial]].
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
 
==== Création de plans ====
 
==== Création de plans ====
 
Pour créer des plans, il est nécessaire de créer un '''Dessin''' avec les éléments que vous souhaitez utiliser. Veuillez lire le [[Drawing tutorial/fr|Tutoriel de Dessin]] pour une description détaillée.
 
Pour créer des plans, il est nécessaire de créer un '''Dessin''' avec les éléments que vous souhaitez utiliser. Veuillez lire le [[Drawing tutorial/fr|Tutoriel de Dessin]] pour une description détaillée.
</div>  
+
</div>
 +
 
 +
As it is now, the objects that we have created can be saved, exported to other formats like [[SVG|SVG]] or [[DXF|DXF]], or printed.
 +
 
 +
If you wish, you may create a technical drawing to display these objects together with additional information like a frame.
 +
 
 +
Before doing anything, hide the Draft grid by pressing {{Button|[[File:Draft_ToggleGrid.svg|16px]] [[Draft_ToggleGrid|Toggle  grid]]}}.
 +
 
 +
16. Switch to the [[File:Workbench_TechDraw.svg|24px]] [[TechDraw_Workbench|TechDraw Workbench]].
 +
:16.1. Create a standard page by pressing {{Button|[[File:TechDraw_PageDefault.svg|16px]] [[TechDraw_PageDefault|TechDraw PageDefault]]}}.
 +
:16.2. In the [[tree_view|tree view]] select all objects created, except for the Page, and then press {{Button|[[File:TechDraw_ActiveView.svg|16px]] [[TechDraw_ActiveView|TechDraw ActiveView]]}}. Press {{Button|OK}} with the default options; it may take a few seconds to create the view in the page.
 +
:16.3. Selecting the Page object in the [[tree_view|tree view]] will automatically display the Page in the main window. With the Page selected, go to the [[Property_editor|property editor]], and change {{PropertyData|Scale}} to {{Value|0.75}}.
 +
:16.4. Expand the Page object in the [[tree_view|tree view]] to select the ActiveView object. With this view selected, go to the [[Property_editor|property editor]], and change {{PropertyData|Scale Type}} to {{Value|Page}}.
 +
:16.5. Recompute the model by using {{Button|[[File:Std_Refresh.svg|16px]] [[Std_Refresh|Refresh]]}} or pressing {{KEY|F5}}.
 +
:16.6. Hide the frames of the objects by pressing {{Button|[[File:TechDraw_ToggleFrame.svg|16px]] [[TechDraw_ToggleFrame|TechDraw ToggleFrame]]}}.
 +
 
 +
Learn more about the [[TechDraw_Workbench|TechDraw Workbench]] by reading the [[Basic_TechDraw_Tutorial|Basic TechDraw Tutorial]].
 +
 
 +
[[File:06_Dr01_Draft_TechDraw_page.png|x400px]]
 +
{{Caption|TechDraw page with a projection of the shapes created with the Draft Workbench.}}
 +
 
 +
TechDraw works best with objects that have a [[Part_TopoShape|Part TopoShape]]. Since some objects from Draft, like [[Draft_Text|Draft Texts]] and [[Draft_Dimension|Draft Dimensions]], don't have such "[[Shape|shapes]]", some operations of TechDraw don't work with these elements.
  
'''Important Note:''' Drawing WB was deprecated in FreeCAD v0.16 and replaced by the [[TechDraw Workbench]]. Although the author of this tutorial also created the Drawing Tutorial, it would be better for the reader to familiarize themselves with Basic tutorials of TechDraw, such as [[Basic_TechDraw_Tutorial]].
+
Tools like {{Button|[[File:TechDraw_ActiveView.svg|16px]] [[TechDraw_ActiveView|TechDraw ActiveView]]}}, {{Button|[[File:TechDraw_DraftView.svg|16px]] [[TechDraw_DraftView|TechDraw DraftView]]}}, and {{Button|[[File:TechDraw_ArchView.svg|16px]] [[TechDraw_ArchView|TechDraw ArchView]]}} work by receiving an internal SVG image that is generated by internal Draft functions; therefore, TechDraw doesn't have much control about how these views are displayed. More integration of Draft and TechDraw is a work in progress.
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">
Line 210: Line 256:
 
</div>
 
</div>
  
<div class="mw-translate-fuzzy">
+
The [[Draft_Module|Draft Workbench]] in many ways is similar to the [[Sketcher_Workbench|Sketcher Workbench]], as both are intended to produce 2D shapes. The main difference is in the way each workbench handles coordinate systems, and how the objects are positioned. In Draft, objects are freely positioned in the global coordinates system, usually snapping their points to a grid, or to other objects. In Sketcher, a "[[Sketch|sketch object]]" defines a local coordinate system which serves as the reference for all geometrical elements within that sketch. Moreover, the sketch relies on "constraints" to define the final position of its points.
== Lectures recommandées ==
+
 
* Pour une description détaillée de l'atelier, voir [[Draft Module/fr|Module Table à Dessin]]
+
* The [[Draft_Module|Draft Workbench]] is intended for 2D drawings which are suitable to be drawn on a grid. The [[Arch_Module|Arch Workbench]] mostly builds on top of the tools defined in the [[Draft_Module|Draft Workbench]].
* Pour en savoir plus sur les commandes '''Ancrage''', voir [[Draft Snap/fr|Ancrage Table à Dessin]]
+
 
</div>
+
* The [[Sketcher_Workbench|Sketcher Workbench]] is intended for 2D drawings that require precise relationships between its points. It does not rely on a grid, but on rules of positioning (constraints) to determine where the points and edges will be placed. The [[Sketcher_Workbench|Sketcher Workbench]] is mostly used together with the [[PartDesign_Workbench|PartDesign Workbench]] for the creation of solid [[Body|bodies]].
 +
 
 +
* It is possible to transform a Draft object into a [[Sketch|Sketch]], and the other way around, using the {{Button|[[File:Draft_Draft2Sketch.svg|16px]] [[Draft_Draft2Sketch|Draft Draft2Sketch]]}} tool.
  
 +
{{Tutorials navi{{#translation:}}}}
 
{{Draft Tools navi{{#translation:}}}}
 
{{Draft Tools navi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
{{clear}}
 

Latest revision as of 23:08, 29 February 2020

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(繁體)‎

Introduction

This tutorial was originally written by Drei, and it was rewritten and illustrated by vocx.

Ce tutoriel est destiné à présenter au lecteur le flux de travail de base de l'Atelier Draft Workbench Draft.svg.

Le lecteur pratiquera :

  • la création de profils
  • l'utilisation de plans de travail
  • la création et le dimensionnement, de textes et d'annotations

Ce tutoriel utilise la notation (x, y, z) pour désigner les coordonnées nécessaires pour définir des points dans un objet

00 Dr01 Draft Tutorial final.png

Final drawing including various Draft objects.


Installation

1. Ouvrez FreeCAD, créez un nouveau document vide avec Fichier → Std New.svg Nouveau.

1.1. Basculez vers l'atelier Draft Workbench depuis le sélecteur d'atelier ou le menu Affichage → Atelier → Draft.
1.2. Assurez-vous de comprendre comment utiliser l'éditeur de propriétés, en particulier les onglets Données et Affichage pour modifier les propriétés. :1.3. Comme les objets Draft sont des formes planes, ils sont mieux vus du dessus. Utilisez Std ViewTop.svg pour définir la vue 3D.

Verrouillage de la barre d'outils

  1. Démarrer FreeCAD
  2. Si vous n'avez pas ouvert un nouveau document FreeCAD (la plupart des fenêtres de FreeCAD sont grisées), dans le menu déroulant, cliquez sur Fichier → Nouveau ou cliquez sur l'outil Créer un nouveau document Document-new.svg.
  3. Activez l'Atelier Planche à Dessin
  4. Sélectionnez le menu Modifier
  5. Cliquez sur Préférences
  6. Aller à Planche à dessin et sélectionner l'onglet Grille et magnétisme
  7. Vérifiez que la barre d'outils Montrer la barre d'outils d'accrochage est activé

Vous pouvez aussi changer la visibilité et les propriétés de la grille dans ce même menu.

Plans de travail

Most Draft objects are planar shapes so they are naturally based on a working plane. A working plane can be one of the main XY, XZ, and YZ global coordinate planes, or it can be a plane that is parallel to them with a positive or negative offset, or it can be a plane defined by the face of a solid object.

  1. Sélectionnez Draft SelectPlane.png Plan de Travail, soit dans la barre d'outils atelier Dessin, soit dans le menu Draft sous-menu Utilitaire.
  2. Sélectionnez le plan XY.

Before pressing the button, you can also change the value of the offset in millimeters, as well as the grid spacing, the main lines and snapping radius.

Lignes et Arcs
  1. Sélectionnez Draft Arc.png Arc.
  2. Réglez le centre à (0, 0, 0)
  3. Définir le rayon à 30 mm
  4. L'angle de départ est de 60,0 °
  5. L'ouverture est de 60.0 °

Répétez la même procédure pour un deuxième arc avec un rayon de 25 mm, les autres propriétés restent inchangées.

  1. Sélectionnez Draft Line.png Ligne.
  2. Approchez la Terminaison de l'un ou l'autre des arcs. Un point blanc devrait apparaître, à côté de cette icône Snap Endpoint.png lorsque votre curseur s'approche du point de terminaison.
  3. Sélectionnez le point final de l'autre arc.
  4. Répétez pour l'autre côté des arcs

01 Dr01 Draft Arc profile.png

Closed profile created by two arcs and two lines.


Fusing or compounding

Nous avons maintenant plusieurs courbes qui détaillent un profil, mais celui-ci n'est toujours pas reconnu comme une entité unique. Il est possible de continuer à travailler avec des éléments entiers, mais dans ce cas, nous les fusionnerons dans un seul objet.

  1. Sélectionnez un arc et tout en appuyant sur la touche CTRL, sélectionnez les deux segments de ligne et l’autre arc.
  2. Avec ces quatre objets sélectionnés, cliquez sur Draft Upgrade.png Grouper.

6b. If you wish to maintain the parametric nature of the objects you may wish to create a compound instead.

6.1. Switch to the Part Workbench.
6.2. With these objects selected, click on Part Compound.svg Part Compound.
Plans, rectangles et cercles
  1. Cliquez sur Draft Rectangle.png Rectangle
  2. Définir le premier point sur (-100, -60, 0)
  3. Définir le deuxième point sur (140, 90, 0)

7. We will draw a rectangular frame.

7.1. Press Draft Rectangle.svg Rectangle.
7.2. Enter the values of the first point (-100, -60, 0), and press Enter.
7.3. Make sure the Relative option is unchecked, as we will use absolute units. You may press R in the keyboard to quickly toggle this option on and off.
7.4. Enter the values for the second point (140, 90, 0), and press Enter.

Le résultat est un Plan. Ses propriétés peuvent être modifiées pour supprimer le remplissage, en changeant son Style de Représentation en Filaire.

  1. Sélectionnez Draft Circle.png
  2. Réglez le centre sur (0, 0, 0)
  3. Réglez le rayon à 15 mm
Polygones
  1. Sélectionnez Draft Polygon.png Polygone
  2. Le point central est situé à (0, 0, 0)
  3. Réglez le rayon à 50 mm
  4. Réglez le nombre de côtés à 6

Again, you may change the DataMake Face and ViewDisplay Mode properties in the property editor if you want.

The rectangle, the circle, the polygon, and most other objects created with the Draft Workbench share many data and view properties because they are derived from the same base class, Part Part2DObject.

02 Dr01 Draft Rectangle circle polygon.png

Rectangle, circle and polygon added.


Tableaux

Les tableaux sont utilisés pour reproduire un objet plusieurs fois dans une direction, un axe de révolution ou le long d'un chemin.

  1. Sélectionnez le Filaire qui a été précédemment créé
  2. Cliquez sur Draft Array.png Tableau
  3. Dans l'onglet Donnéesde l'objet, modifiez le type de matrice de ortho à polar
  4. Change Number Polar de 1 à 4

Arrays are used to replicate an object several times in an orthogonal direction (X, Y, Z), around a revolution axis, or along a path.

10. We will create a polar array.

10.1. Select the Wire object that was previously created with the Draft Upgrade.svg Upgrade tool, or the Compound created with the Part Compound.svg Part Compound tool.
10.2. Press Draft PolarArray.svg PolarArray.
10.3. Adjust the polar angle to 360°, and press OK.

Old workflow

10.2. Press Draft Array.svg Array.
10.3. Go to the tree view, select the Array object, and then go to the property editor, and change the DataArray Type from ortho to polar.
10.4. Change DataNumber Polar to 4, and DataAngle to 360°.

The array object shows copies of the object around the origin.

03 Dr01 Draft PolarArray.png

Polar array of the small profile centered around the origin.


Ajout de dimensions

Les dimensions requièrent une utilisation constante de Restrictions d'Ancrage pour sélectionner correctement les points que l'on souhaite dimensionner. La barre d'outils Ancrage sert à modifier les points possibles qui peuvent être sélectionnés

Linear dimensions work best when using the appropriate Draft Snap methods to select points and edges to measure. However, they can also be created by specifying absolute coordinates.

  1. Sélectionnez Draft Dimension.png Dimension
  2. Sélectionnez le premier point. Cela peut être soit un élément existant, soit spécifié par des coordonnées. Pour ce tutoriel, le premier point sera toujours (0, 0, 0)
  3. Sélectionnez le deuxième point. Approchez le point médian de la ligne supérieure du polygone. Un point blanc devrait apparaître à côté de cette icône Snap Midpoint.png
  4. Déplacez le curseur sur l'emplacement souhaité de la dimension et cliquez dessus.
  5. Change la taille de la police sur l'onglet Vue à 6 mm

Répéter le processus pour les arcs et les cercles.

13. Repeat the process for the circle located in the center. The first point of the measurement will still be the origin. To select the second point make sure Draft ToggleSnap.svg Toggle snap is active, and only Draft Angle.svg Angle as well. As you move the pointer to the top of the circle, the Draft Angle.svg Angle icon should appear; click to select this point. Then move the cursor to the right, and click to fix the dimension.

Remember to adjust the ViewFont Size, and other properties to see the dimension correctly.

04 Dr01 Draft Dimension.png

Dimensions that measure the vertical distance from the origin to the top of the circle, arcs, and polygon.


Annotations et texte

Il y a une légère différence entre les deux: il est seulement possible d'utiliser le second comme profil pour effectuer des opérations 3D

Annotations
  1. Sélectionnez Draft Text.png Texte
  2. Sélectionnez le point de référence dans la Vue 3D. Dans ce cas, le point milieu de l'arc supérieur.
  3. Entrez votre texte et appuyez sur Entrée. Répétez pour autant de lignes de texte que vous souhaitez saisir.
  4. Appuyez sur Entrée
Texte
  1. Sélectionnez Draft ShapeString.png ShapeString
  2. Sélectionnez le point de référence dans la Vue 3D. Cela peut être un point existant ou l'emplacement actuel du curseur.
  3. Entrez votre texte et appuyez sur Entrée
  4. Définir la taille de police souhaitée
  5. Laisser le suivi à 0 mm
  6. Sélectionnez le chemin dans le fichier de police que vous souhaitez utilise

05 Dr01 Draft Text ShapeString.png

Text and ShapeString objects added.


To extrude letters and engrave them on to solids, see the Draft ShapeString tutorial.

Création de plans

Pour créer des plans, il est nécessaire de créer un Dessin avec les éléments que vous souhaitez utiliser. Veuillez lire le Tutoriel de Dessin pour une description détaillée.

As it is now, the objects that we have created can be saved, exported to other formats like SVG or DXF, or printed.

If you wish, you may create a technical drawing to display these objects together with additional information like a frame.

Before doing anything, hide the Draft grid by pressing Draft ToggleGrid.svg Toggle grid.

16. Switch to the Workbench TechDraw.svg TechDraw Workbench.

16.1. Create a standard page by pressing TechDraw PageDefault.svg TechDraw PageDefault.
16.2. In the tree view select all objects created, except for the Page, and then press TechDraw ActiveView.svg TechDraw ActiveView. Press OK with the default options; it may take a few seconds to create the view in the page.
16.3. Selecting the Page object in the tree view will automatically display the Page in the main window. With the Page selected, go to the property editor, and change DataScale to 0.75.
16.4. Expand the Page object in the tree view to select the ActiveView object. With this view selected, go to the property editor, and change DataScale Type to Page.
16.5. Recompute the model by using Std Refresh.svg Refresh or pressing F5.
16.6. Hide the frames of the objects by pressing TechDraw ToggleFrame.svg TechDraw ToggleFrame.

Learn more about the TechDraw Workbench by reading the Basic TechDraw Tutorial.

06 Dr01 Draft TechDraw page.png

TechDraw page with a projection of the shapes created with the Draft Workbench.


TechDraw works best with objects that have a Part TopoShape. Since some objects from Draft, like Draft Texts and Draft Dimensions, don't have such "shapes", some operations of TechDraw don't work with these elements.

Tools like TechDraw ActiveView.svg TechDraw ActiveView, TechDraw DraftView.svg TechDraw DraftView, and TechDraw ArchView.svg TechDraw ArchView work by receiving an internal SVG image that is generated by internal Draft functions; therefore, TechDraw doesn't have much control about how these views are displayed. More integration of Draft and TechDraw is a work in progress.

Nous avons terminé le travail de base pour Module Table à Dessin.

The Draft Workbench in many ways is similar to the Sketcher Workbench, as both are intended to produce 2D shapes. The main difference is in the way each workbench handles coordinate systems, and how the objects are positioned. In Draft, objects are freely positioned in the global coordinates system, usually snapping their points to a grid, or to other objects. In Sketcher, a "sketch object" defines a local coordinate system which serves as the reference for all geometrical elements within that sketch. Moreover, the sketch relies on "constraints" to define the final position of its points.

  • The Sketcher Workbench is intended for 2D drawings that require precise relationships between its points. It does not rely on a grid, but on rules of positioning (constraints) to determine where the points and edges will be placed. The Sketcher Workbench is mostly used together with the PartDesign Workbench for the creation of solid bodies.

Template:Tutorials navi/fr