Difference between revisions of "Draft Pattern/cs"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "==Popis== Všechny objekty Kreslení, které mohou být uzavřené, jako je obdélník, kružnice, elipsa, [[Dr...")
 
(Updating to match new version of source page)
 
(15 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 +
<languages/>
 +
 +
{{Docnav
 +
|[[Draft_Constrain|Constrain]]
 +
|[[Draft_Preferences|Preferences]]
 +
|[[Draft_Workbench|Draft]]
 +
|IconL=
 +
|IconR=
 +
|IconC=Workbench_Draft.svg
 +
}}
 +
 +
{{TOCright}}
 +
 +
==Description==
 +
 +
<div class="mw-translate-fuzzy">
 
==Popis==
 
==Popis==
Všechny objekty Kreslení, které mohou být uzavřené, jako je [[Draft Rectangle/cs|obdélník]], [[Draft Circle/cs|kružnice]], [[Draft Ellipse/cs|elipsa]], [[Draft Wire/cs|drát]] nebo [[Draft Polygon/cs|mnohoúhelník]], jsou-li uzavřeny a je nastaven zobrazovací mód na "Flat Lines", mohou zobrazovat šrafovací vzor, místo barevné plochy, pomocí nastavení vlastnosti "Vzor".  
+
Všechny objekty Kreslení, které mohou být uzavřené, jako je [[Draft Rectangle/cs|obdélník]], [[Draft Circle/cs|kružnice]], [[Draft Ellipse/cs|elipsa]], [[Draft Wire/cs|drát]] nebo [[Draft Polygon/cs|mnohoúhelník]], jsou-li uzavřeny a je nastaven zobrazovací mód na "Flat Lines", mohou zobrazovat šrafovací vzor, místo barevné plochy, pomocí nastavení vlastnosti "Vzor".
 +
</div>
  
 
[[Image:DraftPatternSample.png]]
 
[[Image:DraftPatternSample.png]]
 +
<div class="mw-translate-fuzzy">
 +
[[Image:DraftPatternSample.png]]
 +
</div>
 +
 +
==Usage==
 +
 +
<div class="mw-translate-fuzzy">
 +
==Použití==
 +
# Vyberte objekt
 +
# V rozbalovacím pohledu → Data: nastavte Vytvořit pochu na true abyste zajistili, že objekt bude mít plochy, kde bude vzor
 +
# V rozbalovacím pohledu → Pohled → Vzor: specifikujte šrafovací vzor pro vyplnění drátů
 +
# V rozbalovacím pohledu → Pohled → Velikost vzoru: specifikujte rozměr šrafovacího vzoru
 +
</div>
 +
 +
==Available patterns==
 +
 +
<gallery mode=nolines widths=96px heights=96px>
 +
Image:Aluminium.svg|aluminium
 +
Image:Brick01.svg|brick01
 +
Image:Concrete.svg|concrete
 +
Image:Cross.svg|cross
 +
Image:Cuprous.svg|cuprous
 +
Image:Diagonal1.svg|diagonal1
 +
Image:Diagonal2.svg|diagonal2
 +
Image:Earth.svg|earth
 +
Image:General_steel.svg|general_steel<!--Keep underscore in caption as this is the name in the GUI-->
 +
Image:Glass.svg|glass
 +
Image:Hatch45L.svg|hatch45L
 +
Image:Hatch45R.svg|hatch45R
 +
Image:Hbone.svg|hbone
 +
Image:Line.svg|line
 +
Image:Plastic.svg|plastic
 +
Image:Plus.svg|plus
 +
Image:Simple.svg|simple
 +
Image:Solid.svg|solid
 +
Image:Square.svg|square
 +
Image:Steel.svg|steel
 +
Image:Titanium.svg|titanium
 +
Image:Wood.svg|wood
 +
Image:Woodgrain.svg|woodgrain
 +
Image:Zinc.svg|zinc
 +
</gallery>
  
==How to use==
+
==Notes==
# Select the object
 
# In Combo View -> Data: set Make Face to true to make sure the object will have a face to set the pattern
 
# In Combo View -> View -> Pattern: specify a hatch pattern to fill the wire with
 
# In Combo View -> View -> Pattern Size: specify the size of the hatch pattern
 
  
Note:
+
* SVG patterns are stored in {{FileName|.SVG}} files. It is possible to use your own custom patterns. See [[#Preferences|Preferences]].
 +
* The patterns themselves are not saved in the FreeCAD document. Objects whose {{PropertyView|Pattern}} cannot be found are displayed with a solid face color instead.
  
* The pattern is not visible when the item is either selected or pre-selected.
+
==Preferences==
* If you create a face with upgrade, the resulting object is not a Draft object anymore, and so patterns are not available
 
* The [[Draft Wire]] can be closed and turned into a face directly when created, by checking the "Filled" checkbox.
 
  
[[Category:User Documentation]]
+
See also: [[Preferences_Editor|Preferences Editor]] and [[Draft_Preferences|Draft Preferences]].
  
{{clear}}
+
* To specify a directory with addition SVG patterns: {{MenuCommand|Edit → Preferences... → Draft → Visual settings → Alternate SVG patterns location}}. Select a file in the directory and then remove the filename in the preferences input box, leaving only the path. After changing this preference you must restart FreeCAD.
<languages/>
+
* The {{MenuCommand|Edit → Preferences... → Draft → Visual settings → SVG pattern resolution}} preference is not used.
 +
* To change the {{PropertyView|Pattern Size}} used for new objects: {{MenuCommand|Edit → Preferences... → Draft → Visual settings → SVG pattern default size}}.
 +
 
 +
 
 +
{{Docnav
 +
|[[Draft_Constrain|Constrain]]
 +
|[[Draft_Preferences|Preferences]]
 +
|[[Draft_Workbench|Draft]]
 +
|IconL=
 +
|IconR=
 +
|IconC=Workbench_Draft.svg
 +
}}
 +
 
 +
{{Draft Tools navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}

Latest revision as of 11:38, 29 September 2021

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎français • ‎italiano • ‎polski • ‎čeština • ‎русский • ‎中文(中国大陆)‎
Arrow-left.svg Previous: Constrain

Description

Popis

Všechny objekty Kreslení, které mohou být uzavřené, jako je obdélník, kružnice, elipsa, drát nebo mnohoúhelník, jsou-li uzavřeny a je nastaven zobrazovací mód na "Flat Lines", mohou zobrazovat šrafovací vzor, místo barevné plochy, pomocí nastavení vlastnosti "Vzor".

DraftPatternSample.png

DraftPatternSample.png

Usage

Použití

  1. Vyberte objekt
  2. V rozbalovacím pohledu → Data: nastavte Vytvořit pochu na true abyste zajistili, že objekt bude mít plochy, kde bude vzor
  3. V rozbalovacím pohledu → Pohled → Vzor: specifikujte šrafovací vzor pro vyplnění drátů
  4. V rozbalovacím pohledu → Pohled → Velikost vzoru: specifikujte rozměr šrafovacího vzoru

Available patterns

Notes

  • SVG patterns are stored in .SVG files. It is possible to use your own custom patterns. See Preferences.
  • The patterns themselves are not saved in the FreeCAD document. Objects whose PohledPattern cannot be found are displayed with a solid face color instead.

Preferences

See also: Preferences Editor and Draft Preferences.

  • To specify a directory with addition SVG patterns: Edit → Preferences... → Draft → Visual settings → Alternate SVG patterns location. Select a file in the directory and then remove the filename in the preferences input box, leaving only the path. After changing this preference you must restart FreeCAD.
  • The Edit → Preferences... → Draft → Visual settings → SVG pattern resolution preference is not used.
  • To change the PohledPattern Size used for new objects: Edit → Preferences... → Draft → Visual settings → SVG pattern default size.


Arrow-left.svg Previous: Constrain