Difference between revisions of "Draft DXF/tr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
(Updating to match new version of source page)
Line 6: Line 6:
 
|MenuLocation=File → Export → Autodesk DXF 2D (*.dxf)
 
|MenuLocation=File → Export → Autodesk DXF 2D (*.dxf)
 
|Workbenches=[[Draft Workbench|Draft]]
 
|Workbenches=[[Draft Workbench|Draft]]
|Shortcut=Ctrl+E
+
|Shortcut={{KEY|Ctrl}}+{{KEY|E}}
 
|SeeAlso=[[FreeCAD and DXF Import]], [[FreeCAD and DWG Import]]
 
|SeeAlso=[[FreeCAD and DXF Import]], [[FreeCAD and DWG Import]]
 
|Empty=1
 
|Empty=1
Line 12: Line 12:
  
 
== Description ==
 
== Description ==
{{Emphasis|See also:}} [[FreeCAD and DXF Import]] and [[FreeCAD and DWG Import]].
+
{{Emphasis|See also:}} [[FreeCAD and DXF Import|FreeCAD and DXF Import]] and [[FreeCAD and DWG Import|FreeCAD and DWG Import]].
  
This function opens a [[DXF]] file, any version from 12 to 2007, to a new document.
+
This function opens a [[DXF|DXF]] file, any version from 12 to 2007, to a new document.
  
 
[[Image:Screenshot qcad.jpg]]
 
[[Image:Screenshot qcad.jpg]]
Line 37: Line 37:
 
== Installing ==
 
== Installing ==
  
{{Emphasis|Note:}} for licensing reasons, the [[DXF]] import/export libraries are not part of the FreeCAD source code anymore. For that reason, they must be installed by you, the user, after you install FreeCAD. There is a way to allow FreeCAD to do that automatically, or you can do it manually.
+
{{Emphasis|Note:}} for licensing reasons, the [[DXF|DXF]] import/export libraries are not part of the FreeCAD source code anymore. For that reason, they must be installed by you, the user, after you install FreeCAD. There is a way to allow FreeCAD to do that automatically, or you can do it manually.
  
 
=== Automatically ===
 
=== Automatically ===
  
Starting from version 0.15, you only need to mark the Edit-> Preferences -> Import/Export -> DXF/DWG -> "Allow FreeCAD to automatically download the DXF libraries" option to have FreeCAD take automatically care of doenloading and installing these libraries. For older versions, you will need to do it manually.
+
Starting from version 0.15, you only need to mark the {{MenuCommand|Edit Preferences Import/Export DXF/DWG "Allow FreeCAD to automatically download the DXF libraries"}} option to have FreeCAD take automatically care of downloading and installing these libraries. For older versions, you will need to do it manually.
  
 
=== Manually ===
 
=== Manually ===
Line 49: Line 49:
  
 
== Importing ==
 
== Importing ==
This works the same way as opening, but it will add the contents of the dxf file in the active documento instead of creating a new document.
+
This works the same way as opening, but it will add the contents of the DXF file in the active document instead of creating a new document.
  
 
Tutorial: [[Dxf_Importer_Install|Dxf Importer Install]]
 
Tutorial: [[Dxf_Importer_Install|Dxf Importer Install]]
Line 64: Line 64:
  
 
== Preferences ==
 
== Preferences ==
The following parameters can be specified in the [[Preferences Editor]], in the menu {{MenuCommand|Edit → Preferences → Import-Export}}.
+
The following parameters can be specified in the [[Preferences Editor|Preferences Editor]], in the menu {{MenuCommand|Edit → Preferences → Import-Export}}.
 
* Import style: This lets you choose the way objects from the dxf file will be drawn in FreeCAD. You can choose between:
 
* Import style: This lets you choose the way objects from the dxf file will be drawn in FreeCAD. You can choose between:
 
** None: this is the faster way, there is no conversion, all objects will be black with 2px width (FreeCAD default)
 
** None: this is the faster way, there is no conversion, all objects will be black with 2px width (FreeCAD default)
Line 70: Line 70:
 
** Original color and linewidth: Objects will keep the color and linewidth (if specified) they have in the dxf file
 
** Original color and linewidth: Objects will keep the color and linewidth (if specified) they have in the dxf file
 
** Colors mapped to linewidth: If this option is selected, the mapping file option below is used.
 
** Colors mapped to linewidth: If this option is selected, the mapping file option below is used.
* Color mapping file: This allows you to specify a mapping file to be used for translating dxf colors to color and linewidth, the same way as a plot style works in Autocad. The mapping file must be a tab-separated text file. There is a nice free utility called [http://www.noliturbare.com/TablePrintGUI.php Plot style viewer] that can convert Autocad CTB or STB (plot styles) files to tab-separated mapping files ready to use in FreeCAD. Alternatively, we have a couple of [[Draft_mapping_files|home-made mapping files]] availables here.
+
* Color mapping file: This allows you to specify a mapping file to be used for translating dxf colors to color and linewidth, the same way as a plot style works in Autocad. The mapping file must be a tab-separated text file. There is a nice free utility called [http://www.noliturbare.com/TablePrintGUI.php Plot style viewer] that can convert Autocad CTB or STB (plot styles) files to tab-separated mapping files ready to use in FreeCAD. Alternatively, we have a couple of [[Draft_mapping_files|home-made mapping files]] available here.
* Import texts: This allows you to specify if you want to import dxf texts and dimensions or not. Many texts might make your work in FreeCAD very heavy, so you might want to use this option some time.
+
* Import texts: This allows you to specify whether you want to import dxf texts and dimensions. Many texts might make your work in FreeCAD very difficult, so you might want to use this option some time.
* Import layout objects: Turn this on if you want to import paper space object. They will be merged in the same document than model space objects.
+
* Import layout objects: Turn this on if you want to import paper space object. They will be merged in the same document as model space objects.
  
 
== Scripting ==
 
== Scripting ==

Revision as of 09:15, 25 February 2019

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский

Draft DXF

Menu location
File → Export → Autodesk DXF 2D (*.dxf)
Workbenches
Draft
Default shortcut
Ctrl+E
Introduced in version
-
See also
FreeCAD and DXF Import, FreeCAD and DWG Import

Description

See also: FreeCAD and DXF Import and FreeCAD and DWG Import.

This function opens a DXF file, any version from 12 to 2007, to a new document.

Screenshot qcad.jpg

Qcad drawing exported to DXF, which is subsequently opened in FreeCAD

Opening

The following DXF object types are currently supported:

  • lines
  • polylines and lwpolylines
  • circles
  • arcs
  • layers (layers containing objects are converted to FreeCAD Groups)
  • texts and mtexts
  • dimensions
  • blocks (only geometry. texts, dims and attributes inside blocks will be skipped)
  • points introduced in version 0.13
  • leaders introduced in version 0.13

Other DXF entities are currently not imported because there is no corresponding FreeCAD object. As new functionality gets implemented, it will be possible to import more entity types.

Installing

Note: for licensing reasons, the DXF import/export libraries are not part of the FreeCAD source code anymore. For that reason, they must be installed by you, the user, after you install FreeCAD. There is a way to allow FreeCAD to do that automatically, or you can do it manually.

Automatically

Starting from version 0.15, you only need to mark the Edit → Preferences → Import/Export → DXF/DWG → "Allow FreeCAD to automatically download the DXF libraries" option to have FreeCAD take automatically care of downloading and installing these libraries. For older versions, you will need to do it manually.

Manually

Libraries must be downloaded from https://github.com/yorikvanhavre/Draft-dxf-importer There is a very complete step-by-step tutorial that will explain you the necessary steps.

Importing

This works the same way as opening, but it will add the contents of the DXF file in the active document instead of creating a new document.

Tutorial: Dxf Importer Install

Exporting

The exported DXF is compatible with Autocad version 12 and up, so it should open in about any application that supports dxf format. Currently the following FreeCAD objects get exported:

  • lines and wires (polylines)
  • arcs and circles
  • texts
  • colors are mapped from objects RGB colors to autocad color index (ACI). Black will always be "by layer"
  • layers are mapped from group names. When groups are nested, the deepest group gives the layer name.
  • dimensions, which are exported with "Standard" dimstyle

Preferences

The following parameters can be specified in the Preferences Editor, in the menu Edit → Preferences → Import-Export.

  • Import style: This lets you choose the way objects from the dxf file will be drawn in FreeCAD. You can choose between:
    • None: this is the faster way, there is no conversion, all objects will be black with 2px width (FreeCAD default)
    • Use default color and linewidth: All imported dxf objects will take current linewidth/color from the draft command bar
    • Original color and linewidth: Objects will keep the color and linewidth (if specified) they have in the dxf file
    • Colors mapped to linewidth: If this option is selected, the mapping file option below is used.
  • Color mapping file: This allows you to specify a mapping file to be used for translating dxf colors to color and linewidth, the same way as a plot style works in Autocad. The mapping file must be a tab-separated text file. There is a nice free utility called Plot style viewer that can convert Autocad CTB or STB (plot styles) files to tab-separated mapping files ready to use in FreeCAD. Alternatively, we have a couple of home-made mapping files available here.
  • Import texts: This allows you to specify whether you want to import dxf texts and dimensions. Many texts might make your work in FreeCAD very difficult, so you might want to use this option some time.
  • Import layout objects: Turn this on if you want to import paper space object. They will be merged in the same document as model space objects.

Scripting

See also: Draft API and FreeCAD Scripting Basics.

You can export elements to DXF by using the following function:

importDXF.export(objectslist, filename, nospline=False, lwPoly=False)

Example:

import Draft, importDXF

Polygon1 = Draft.makePolygon(3, radius=500)
Polygon2 = Draft.makePolygon(5, radius=1500)

objects = [Polygon1, Polygon2]

importDXF.export(objects, "/home/user/Pictures/myfile.dxf")