Difference between revisions of "Draft DXF/tr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
(Updating to match new version of source page)
 
(8 intermediate revisions by the same user not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
 +
 
{{Docnav
 
{{Docnav
|
+
|[[Draft_Preferences|Preferences]]
|[[Draft_SVG|SVG]]
+
|[[Draft_SVG|Scalable Vector Graphics .SVG]]
|[[Draft_Module|Draft Module]]
+
|[[Draft_Module|Draft]]
 +
|IconL=
 +
|IconR=
 
|IconC=Workbench_Draft.svg
 
|IconC=Workbench_Draft.svg
 
}}
 
}}
  
{{GuiCommand
+
{{TOCright}}
|Name=Draft DXF
 
|MenuLocation={{StdMenu|[[Std File Menu|File]]}} → Export → Autodesk DXF 2D (*.dxf)
 
|Workbenches=[[Draft Workbench|Draft]]
 
|Shortcut={{KEY|Ctrl}}+{{KEY|E}}
 
|SeeAlso=[[FreeCAD and DXF Import]], [[FreeCAD and DWG Import]]
 
|Empty=1
 
}}
 
  
== Description ==
+
==Description==
{{Emphasis|See also:}} [[FreeCAD and DXF Import|FreeCAD and DXF Import]] and [[FreeCAD and DWG Import|FreeCAD and DWG Import]].
 
  
This function opens a [[DXF|DXF]] file, any version from 12 to 2007, to a new document.
+
Draft DXF is a software module used by the [[File:Std_Open.svg|24px]] [[Std_Open|Std Open]], [[File:Std_Import.svg|24px]] [[Std_Import|Std Import]] and [[File:Std_Export.svg|24px]] [[Std_Export|Std Export]] commands to handle the DXF file format.
  
 
[[Image:Screenshot qcad.jpg]]
 
[[Image:Screenshot qcad.jpg]]
 
{{Caption|Qcad drawing exported to DXF, which is subsequently opened in FreeCAD}}
 
{{Caption|Qcad drawing exported to DXF, which is subsequently opened in FreeCAD}}
  
== Opening ==
+
==Importing==
 +
 
 +
Two importers are available, which one is used can be specified under {{MenuCommand|Edit → Preferences... → Import-Export → DXF}}. One is built-in, C++-based and fast, the other is legacy, coded in Python, slower, and requires the installation of an add-on, but can handle some entities better and can create more refined FreeCAD objects. Both support all DXF versions starting from R12.
 +
 
 +
3D solids inside a DXF file are stored under a binary ACIS/SAT blob, which at the moment cannot be read by FreeCAD.
  
The following DXF object types are currently supported:
+
===C++ importer===
 +
 
 +
This importer can import the following DXF objects:
 
* lines
 
* lines
* polylines and lwpolylines
+
* polylines (and lwpolylines)
 +
* arcs
 
* circles
 
* circles
 +
* ellipses
 +
* splines
 +
* points
 +
* texts and mtexts
 +
* dimensions
 +
* leaders
 +
* blocks (only geometry, texts, dimensions and attributes inside blocks are skipped)
 +
* layers
 +
* paper space objects
 +
 +
===Legacy importer===
 +
 +
This importer can import the following DXF objects:
 +
* lines
 +
* polylines (and lwpolylines)
 
* arcs
 
* arcs
* layers (layers containing objects are converted to FreeCAD Groups)
+
* circles
 +
* ellipses
 +
* splines
 +
* 3D faces
 
* texts and mtexts
 
* texts and mtexts
* dimensions
+
* leaders
* blocks (only geometry. texts, dims and attributes inside blocks will be skipped)
+
* layers
* points {{Version|0.13}}
+
 
* leaders {{Version|0.13}}
+
==Exporting==
 +
 
 +
There are also two exporters. The legacy exporter exports to the R12 DXF format, the C++ exporter to the R14 DXF format. Both formats can be handled by many applications.
 +
 
 +
===C++ exporter===
 +
 
 +
Some of the features and limitations of this exporter are:
 +
* All FreeCAD 2D geometry is exported, except [[Draft_CubicBezCurve|Draft CubicBezCurves]], [[Draft_BezCurve|Draft BezCurves]] and [[Draft_Point|Draft Points]].
 +
* Straight edges from faces of 3D objects are exported, but curved edges only if they are on a plane parallel to the XY plane of the global coordinate system. Note that a DXF created from 3D objects will contain duplicate lines.
 +
* Texts and dimensions are not exported.
 +
* Colors are ignored.
 +
* Layers are mapped from object names.
 +
 
 +
===Legacy exporter===
  
Other DXF entities are currently not imported because there is no corresponding FreeCAD object. As new functionality gets implemented, it will be possible to import more entity types.
+
Some of the features and limitations of this exporter are:
 +
* All FreeCAD 2D geometry is exported, except [[Draft_Point|Draft Points]]. But ellipses, B-splines and Bézier curves are not exported properly.
 +
* 3D objects are exported as flattened 2D views.
 +
* Compound objects are exported as blocks.
 +
* Texts and dimensions are exported.
 +
* The colors in the DXF are based on the line color of objects. Black is mapped to "ByBlock", other colors are mapped using AutoCAD Color Index (ACI) colors.
 +
* Layers are mapped from layer and group names. When groups are nested, the deepest group gives the layer name.
  
== Installing ==
+
==Installing==
  
{{Emphasis|Note:}} for licensing reasons, the [[DXF|DXF]] import/export libraries are not part of the FreeCAD source code anymore. For that reason, they must be installed by you, the user, after you install FreeCAD. There is a way to allow FreeCAD to do that automatically, or you can do it manually.
+
For licensing reasons, the required [[DXF|DXF]] import/export libraries needed by the legacy version of the importer are not part of the FreeCAD source code.
 +
For more information see: [[FreeCAD_and_DXF_Import|FreeCAD and DXF Import]].
  
=== Automatically ===
+
==Preferences==  
  
Starting from version 0.15, you only need to mark the {{MenuCommand|Edit → Preferences → Import/Export → DXF/DWG → "Allow FreeCAD to automatically download the DXF libraries"}} option to have FreeCAD take automatically care of downloading and installing these libraries. For older versions, you will need to do it manually.
+
See [[Import_Export_Preferences|Import Export Preferences]].
  
=== Manually ===
+
== DWG ==
  
Libraries must be downloaded from https://github.com/yorikvanhavre/Draft-dxf-importer
+
Because the DWG format is a proprietary, closed and undocumented format it is hard for open-source projects like FreeCAD to support it. That is why FreeCAD relies on external converters to read and write DWG files. To import a DWG file a converter is used to create a DXF first, which can then be processed by the FreeCAD DXF importer. When exporting to DWG the opposite conversion happens: the DXF created by the FreeCAD DXF exporter is turned into a DWG.
There is a very complete step-by-step [[Dxf_Importer_Install|tutorial]] that will explain you the necessary steps.
 
  
== Importing ==
+
Note that the DXF format allows a 1:1 conversion of the DWG format. All applications that can read and write DWG files can do the same with DXF files, with no data loss. So asking for DXF files instead of DWG files, and supplying DXF files in turn, should not cause any problems.
This works the same way as opening, but it will add the contents of the DXF file in the active document instead of creating a new document.
 
  
Tutorial: [[Dxf_Importer_Install|Dxf Importer Install]]
+
There is built-in support for the following DWG converters:
 +
* [https://www.gnu.org/software/libredwg LibreDWG] (open-source, lacks support for some DWG entities).
 +
* [https://www.opendesign.com/guestfiles/oda_file_converter ODA File Converter] (free).
 +
* [https://qcad.org/en/qcad-command-line-tools#dwg2dwg QCAD pro] (commercial). {{Version|0.20}}
  
== Exporting ==
+
See [[Import_Export_Preferences#DWG|Import Export Preferences]] and [[FreeCAD_and_DWG_Import|FreeCAD and DWG Import]] for more information.
The exported DXF is compatible with Autocad version 12 and up, so it should open in about any application that supports dxf format.
 
Currently the following FreeCAD objects get exported:
 
* lines and wires (polylines)
 
* arcs and circles
 
* texts
 
* colors are mapped from objects RGB colors to autocad color index (ACI). Black will always be "by layer"
 
* layers are mapped from group names. When groups are nested, the deepest group gives the layer name.
 
* dimensions, which are exported with "Standard" dimstyle
 
  
== Preferences ==  
+
==Scripting==
  
The following parameters can be specified in the [[Preferences Editor|Preferences Editor]], in the menu {{MenuCommand|Edit → Preferences → Import-Export}}.
+
See also: [https://freecad.github.io/SourceDoc/ Autogenerated API documentation] and [[FreeCAD Scripting Basics|FreeCAD Scripting Basics]].
* Import style: This lets you choose the way objects from the dxf file will be drawn in FreeCAD. You can choose between:
 
** None: this is the faster way, there is no conversion, all objects will be black with 2px width (FreeCAD default)
 
** Use default color and linewidth: All imported dxf objects will take current linewidth/color from the draft command bar
 
** Original color and linewidth: Objects will keep the color and linewidth (if specified) they have in the dxf file
 
** Colors mapped to linewidth: If this option is selected, the mapping file option below is used.
 
* Color mapping file: This allows you to specify a mapping file to be used for translating dxf colors to color and linewidth, the same way as a plot style works in Autocad. The mapping file must be a tab-separated text file. There is a nice free utility called [http://www.noliturbare.com/TablePrintGUI.php Plot style viewer] that can convert Autocad CTB or STB (plot styles) files to tab-separated mapping files ready to use in FreeCAD. Alternatively, we have a couple of [[Draft_mapping_files|home-made mapping files]] available here.
 
* Import texts: This allows you to specify whether you want to import dxf texts and dimensions. Many texts might make your work in FreeCAD very difficult, so you might want to use this option some time.
 
* Import layout objects: Turn this on if you want to import paper space object. They will be merged in the same document as model space objects.
 
  
== Scripting ==
+
To export objects to DXF use the {{incode|export}} method of the importDXF module.
{{Emphasis|See also:}} [[Draft API]] and [[FreeCAD Scripting Basics]].
 
  
You can export elements to DXF by using the following function:
 
 
{{Code|code=
 
{{Code|code=
 
importDXF.export(objectslist, filename, nospline=False, lwPoly=False)
 
importDXF.export(objectslist, filename, nospline=False, lwPoly=False)
 
}}
 
}}
 +
 +
* For the Windows OS: use a {{FileName|/}} (forward slash) as the path separator in {{Incode|filename}}.
  
 
Example:
 
Example:
 +
 
{{Code|code=
 
{{Code|code=
import Draft, importDXF
+
import FreeCAD as App
 +
import Draft
 +
import importDXF
  
Polygon1 = Draft.makePolygon(3, radius=500)
+
doc = App.newDocument()
Polygon2 = Draft.makePolygon(5, radius=1500)
 
  
objects = [Polygon1, Polygon2]
+
polygon1 = Draft.make_polygon(3, radius=500)
 +
polygon2 = Draft.make_polygon(5, radius=1500)
  
 +
doc.recompute()
 +
 +
objects = [polygon1, polygon2]
 
importDXF.export(objects, "/home/user/Pictures/myfile.dxf")
 
importDXF.export(objects, "/home/user/Pictures/myfile.dxf")
 
}}
 
}}
 +
  
 
{{Docnav
 
{{Docnav
|
+
|[[Draft_Preferences|Preferences]]
|[[Draft_SVG|SVG]]
+
|[[Draft_SVG|Scalable Vector Graphics .SVG]]
|[[Draft_Module|Draft Module]]
+
|[[Draft_Module|Draft]]
 +
|IconL=
 +
|IconR=
 
|IconC=Workbench_Draft.svg
 
|IconC=Workbench_Draft.svg
 
}}
 
}}
Line 109: Line 143:
 
{{Draft Tools navi{{#translation:}}}}
 
{{Draft Tools navi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
{{Draft Tools navi{{#translation:}}}}
+
[[Category:File Formats{{#translation:}}]]
[[Category:Formats{{#translation:}}]]
 
{{clear}}
 

Latest revision as of 15:48, 25 October 2021

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский

Description

Draft DXF is a software module used by the Std Open.svg Std Open, Std Import.svg Std Import and Std Export.svg Std Export commands to handle the DXF file format.

Screenshot qcad.jpg

Qcad drawing exported to DXF, which is subsequently opened in FreeCAD

Importing

Two importers are available, which one is used can be specified under Edit → Preferences... → Import-Export → DXF. One is built-in, C++-based and fast, the other is legacy, coded in Python, slower, and requires the installation of an add-on, but can handle some entities better and can create more refined FreeCAD objects. Both support all DXF versions starting from R12.

3D solids inside a DXF file are stored under a binary ACIS/SAT blob, which at the moment cannot be read by FreeCAD.

C++ importer

This importer can import the following DXF objects:

  • lines
  • polylines (and lwpolylines)
  • arcs
  • circles
  • ellipses
  • splines
  • points
  • texts and mtexts
  • dimensions
  • leaders
  • blocks (only geometry, texts, dimensions and attributes inside blocks are skipped)
  • layers
  • paper space objects

Legacy importer

This importer can import the following DXF objects:

  • lines
  • polylines (and lwpolylines)
  • arcs
  • circles
  • ellipses
  • splines
  • 3D faces
  • texts and mtexts
  • leaders
  • layers

Exporting

There are also two exporters. The legacy exporter exports to the R12 DXF format, the C++ exporter to the R14 DXF format. Both formats can be handled by many applications.

C++ exporter

Some of the features and limitations of this exporter are:

  • All FreeCAD 2D geometry is exported, except Draft CubicBezCurves, Draft BezCurves and Draft Points.
  • Straight edges from faces of 3D objects are exported, but curved edges only if they are on a plane parallel to the XY plane of the global coordinate system. Note that a DXF created from 3D objects will contain duplicate lines.
  • Texts and dimensions are not exported.
  • Colors are ignored.
  • Layers are mapped from object names.

Legacy exporter

Some of the features and limitations of this exporter are:

  • All FreeCAD 2D geometry is exported, except Draft Points. But ellipses, B-splines and Bézier curves are not exported properly.
  • 3D objects are exported as flattened 2D views.
  • Compound objects are exported as blocks.
  • Texts and dimensions are exported.
  • The colors in the DXF are based on the line color of objects. Black is mapped to "ByBlock", other colors are mapped using AutoCAD Color Index (ACI) colors.
  • Layers are mapped from layer and group names. When groups are nested, the deepest group gives the layer name.

Installing

For licensing reasons, the required DXF import/export libraries needed by the legacy version of the importer are not part of the FreeCAD source code. For more information see: FreeCAD and DXF Import.

Preferences

See Import Export Preferences.

DWG

Because the DWG format is a proprietary, closed and undocumented format it is hard for open-source projects like FreeCAD to support it. That is why FreeCAD relies on external converters to read and write DWG files. To import a DWG file a converter is used to create a DXF first, which can then be processed by the FreeCAD DXF importer. When exporting to DWG the opposite conversion happens: the DXF created by the FreeCAD DXF exporter is turned into a DWG.

Note that the DXF format allows a 1:1 conversion of the DWG format. All applications that can read and write DWG files can do the same with DXF files, with no data loss. So asking for DXF files instead of DWG files, and supplying DXF files in turn, should not cause any problems.

There is built-in support for the following DWG converters:

See Import Export Preferences and FreeCAD and DWG Import for more information.

Scripting

See also: Autogenerated API documentation and FreeCAD Scripting Basics.

To export objects to DXF use the export method of the importDXF module.

importDXF.export(objectslist, filename, nospline=False, lwPoly=False)
  • For the Windows OS: use a / (forward slash) as the path separator in filename.

Example:

import FreeCAD as App
import Draft
import importDXF

doc = App.newDocument()

polygon1 = Draft.make_polygon(3, radius=500)
polygon2 = Draft.make_polygon(5, radius=1500)

doc.recompute()

objects = [polygon1, polygon2]
importDXF.export(objects, "/home/user/Pictures/myfile.dxf")