Difference between revisions of "Draft DXF/pl"

From FreeCAD Documentation
Jump to navigation Jump to search
(Updating to match new version of source page)
 
(One intermediate revision by one other user not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{Docnav
+
{{Docnav/pl
 
|
 
|
 
|[[Draft_SVG|SVG]]
 
|[[Draft_SVG|SVG]]
Line 9: Line 9:
 
{{GuiCommand
 
{{GuiCommand
 
|Name=Draft DXF
 
|Name=Draft DXF
|MenuLocation={{StdMenu|[[Std File Menu|File]]}} → Export → Autodesk DXF 2D (*.dxf)
+
|MenuLocation=-
 
|Workbenches=[[Draft Workbench|Draft]]
 
|Workbenches=[[Draft Workbench|Draft]]
|Shortcut={{KEY|Ctrl}}+{{KEY|E}}
+
|Shortcut=-
 
|SeeAlso=[[FreeCAD and DXF Import]], [[FreeCAD and DWG Import]]
 
|SeeAlso=[[FreeCAD and DXF Import]], [[FreeCAD and DWG Import]]
 
|Empty=1
 
|Empty=1
 
}}
 
}}
  
== Description ==
+
==Description==
{{Emphasis|See also:}} [[FreeCAD and DXF Import|FreeCAD and DXF Import]] and [[FreeCAD and DWG Import|FreeCAD and DWG Import]].
 
  
This function opens a [[DXF|DXF]] file, any version from 12 to 2007, to a new document.
+
Draft DXF is a software module used by the [[File:Std_Open.svg|24px]] [[Std_Open|Std Open]], [[File:Std_Import.svg|24px]] [[Std_Import|Std Import]] and [[File:Std_Export.svg|24px]] [[Std_Export|Std Export]] commands to handle the DXF file format.
  
 
[[Image:Screenshot qcad.jpg]]
 
[[Image:Screenshot qcad.jpg]]
 
{{Caption|Qcad drawing exported to DXF, which is subsequently opened in FreeCAD}}
 
{{Caption|Qcad drawing exported to DXF, which is subsequently opened in FreeCAD}}
  
== Opening ==
+
==Importing==
  
The following DXF object types are currently supported:
+
DXF versions R12 - 2007 are supported.
 +
 
 +
The following DXF objects can be imported:
 
* lines
 
* lines
 
* polylines and lwpolylines
 
* polylines and lwpolylines
Line 35: Line 36:
 
* dimensions
 
* dimensions
 
* blocks (only geometry. texts, dims and attributes inside blocks will be skipped)
 
* blocks (only geometry. texts, dims and attributes inside blocks will be skipped)
* points {{Version|0.13}}
+
* points
* leaders {{Version|0.13}}
+
* leaders
 
+
* ... (list is incomplete).
Other DXF entities are currently not imported because there is no corresponding FreeCAD object. As new functionality gets implemented, it will be possible to import more entity types.
 
 
 
== Installing ==
 
 
 
{{Emphasis|Note:}} for licensing reasons, the [[DXF|DXF]] import/export libraries are not part of the FreeCAD source code anymore. For that reason, they must be installed by you, the user, after you install FreeCAD. There is a way to allow FreeCAD to do that automatically, or you can do it manually.
 
 
 
=== Automatically ===
 
 
 
Starting from version 0.15, you only need to mark the {{MenuCommand|Edit → Preferences → Import/Export → DXF/DWG → "Allow FreeCAD to automatically download the DXF libraries"}} option to have FreeCAD take automatically care of downloading and installing these libraries. For older versions, you will need to do it manually.
 
 
 
=== Manually ===
 
 
 
Libraries must be downloaded from https://github.com/yorikvanhavre/Draft-dxf-importer
 
There is a very complete step-by-step [[Dxf_Importer_Install|tutorial]] that will explain you the necessary steps.
 
  
== Importing ==
+
==Exporting==
This works the same way as opening, but it will add the contents of the DXF file in the active document instead of creating a new document.
 
  
Tutorial: [[Dxf_Importer_Install|Dxf Importer Install]]
+
Files are exported in the R12 DXF format which can be handled by many applications.
  
== Exporting ==
+
The following FreeCAD objects can be exported:
The exported DXF is compatible with Autocad version 12 and up, so it should open in about any application that supports dxf format.
 
Currently the following FreeCAD objects get exported:
 
 
* lines and wires (polylines)
 
* lines and wires (polylines)
 
* arcs and circles
 
* arcs and circles
Line 66: Line 50:
 
* colors are mapped from objects RGB colors to autocad color index (ACI). Black will always be "by layer"
 
* colors are mapped from objects RGB colors to autocad color index (ACI). Black will always be "by layer"
 
* layers are mapped from group names. When groups are nested, the deepest group gives the layer name.
 
* layers are mapped from group names. When groups are nested, the deepest group gives the layer name.
* dimensions, which are exported with "Standard" dimstyle
+
* dimensions, which are exported with "Standard" dimstyle.
 +
* ... (list is incomplete).
 +
 
 +
==Installing==
  
== Preferences ==
+
For licensing reasons, the required [[DXF|DXF]] import/export libraries are not part of the FreeCAD source code.
 +
For more information see: [[FreeCAD_and_DXF_Import|FreeCAD and DXF Import]].
  
The following parameters can be specified in the [[Preferences Editor|Preferences Editor]], in the menu {{MenuCommand|Edit → Preferences → Import-Export}}.
+
==Preferences==
* Import style: This lets you choose the way objects from the dxf file will be drawn in FreeCAD. You can choose between:
 
** None: this is the faster way, there is no conversion, all objects will be black with 2px width (FreeCAD default)
 
** Use default color and linewidth: All imported dxf objects will take current linewidth/color from the draft command bar
 
** Original color and linewidth: Objects will keep the color and linewidth (if specified) they have in the dxf file
 
** Colors mapped to linewidth: If this option is selected, the mapping file option below is used.
 
* Color mapping file: This allows you to specify a mapping file to be used for translating dxf colors to color and linewidth, the same way as a plot style works in Autocad. The mapping file must be a tab-separated text file. There is a nice free utility called [http://www.noliturbare.com/TablePrintGUI.php Plot style viewer] that can convert Autocad CTB or STB (plot styles) files to tab-separated mapping files ready to use in FreeCAD. Alternatively, we have a couple of [[Draft_mapping_files|home-made mapping files]] available here.
 
* Import texts: This allows you to specify whether you want to import dxf texts and dimensions. Many texts might make your work in FreeCAD very difficult, so you might want to use this option some time.
 
* Import layout objects: Turn this on if you want to import paper space object. They will be merged in the same document as model space objects.
 
  
== Scripting ==
+
For more information see: [[Import_Export_Preferences|Import Export Preferences]].
 +
 
 +
==Scripting==
 
{{Emphasis|See also:}} [[Draft API]] and [[FreeCAD Scripting Basics]].
 
{{Emphasis|See also:}} [[Draft API]] and [[FreeCAD Scripting Basics]].
  
Line 109: Line 91:
 
{{Draft Tools navi{{#translation:}}}}
 
{{Draft Tools navi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
 
{{Userdocnavi{{#translation:}}}}
{{Draft Tools navi{{#translation:}}}}
 
 
[[Category:Formats{{#translation:}}]]
 
[[Category:Formats{{#translation:}}]]
 
{{clear}}
 
{{clear}}

Latest revision as of 20:47, 12 March 2020

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский
FreeCAD.png
następny: SVG Arrow-right.svg

Draft DXF

Menu location
-
Workbenches
Draft
Default shortcut
-
Introduced in version
-
See also
FreeCAD and DXF Import, FreeCAD and DWG Import


Description

Draft DXF is a software module used by the Std Open.svg Std Open, Std Import.svg Std Import and Std Export.svg Std Export commands to handle the DXF file format.

Screenshot qcad.jpg

Qcad drawing exported to DXF, which is subsequently opened in FreeCAD


Importing

DXF versions R12 - 2007 are supported.

The following DXF objects can be imported:

  • lines
  • polylines and lwpolylines
  • circles
  • arcs
  • layers (layers containing objects are converted to FreeCAD Groups)
  • texts and mtexts
  • dimensions
  • blocks (only geometry. texts, dims and attributes inside blocks will be skipped)
  • points
  • leaders
  • ... (list is incomplete).

Exporting

Files are exported in the R12 DXF format which can be handled by many applications.

The following FreeCAD objects can be exported:

  • lines and wires (polylines)
  • arcs and circles
  • texts
  • colors are mapped from objects RGB colors to autocad color index (ACI). Black will always be "by layer"
  • layers are mapped from group names. When groups are nested, the deepest group gives the layer name.
  • dimensions, which are exported with "Standard" dimstyle.
  • ... (list is incomplete).

Installing

For licensing reasons, the required DXF import/export libraries are not part of the FreeCAD source code. For more information see: FreeCAD and DXF Import.

Preferences

For more information see: Import Export Preferences.

Scripting

See also: Draft API and FreeCAD Scripting Basics.

You can export elements to DXF by using the following function:

importDXF.export(objectslist, filename, nospline=False, lwPoly=False)

Example:

import Draft, importDXF

Polygon1 = Draft.makePolygon(3, radius=500)
Polygon2 = Draft.makePolygon(5, radius=1500)

objects = [Polygon1, Polygon2]

importDXF.export(objects, "/home/user/Pictures/myfile.dxf")
FreeCAD.png
następny: SVG Arrow-right.svg