Difference between revisions of "Draft DXF/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
 
(25 intermediate revisions by 2 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{docnav/fr
+
{{Docnav/fr
 
|
 
|
 
|[[Draft_SVG/fr|SVG]]
 
|[[Draft_SVG/fr|SVG]]
Line 9: Line 9:
 
{{GuiCommand
 
{{GuiCommand
 
|Name=Draft DXF
 
|Name=Draft DXF
|MenuLocation=File → Export → Autodesk DXF 2D (*.dxf)
+
|MenuLocation=
 
|Workbenches=[[Draft Workbench/fr|Draft]]
 
|Workbenches=[[Draft Workbench/fr|Draft]]
|Shortcut={{KEY|Ctrl}}+{{KEY|E}}
+
|Shortcut=
|SeeAlso=[[FreeCAD and DXF Import]], [[FreeCAD and DWG Import]]
+
|SeeAlso=[[FreeCAD_and_DXF_Import/fr|FreeCAD et import DXF]], [[FreeCAD_and_DWG_Import/fr|FreeCAD et import DWG]]
 
|Empty=1
 
|Empty=1
 
}}
 
}}
  
 
== Description ==
 
== Description ==
{{Emphasis|Voir aussi:}} [[FreeCAD_and_DXF_Import/fr|FreeCAD et import DXF]] et [[FreeCAD_and_DWG_Import/fr|FreeCAD et import DWG]].
 
  
Cette fonction ouvre un fichier [[DXF/fr|DXF]], n'importe quelle version de 12 à 2007, dans un nouveau document.
+
Draft DXF est un module logiciel utilisé par [[File:Std_Open.svg|24px]] [[Std_Open/fr|Std Ouvrir]], [[File:Std_Import.svg|24px]] [[Std_Import/fr|Std Importer]] et [[File:Std_Export.svg|24px]] [[Std_Export/fr|Std Exporter]] pour gérer le format de fichier DXF.
  
 
[[Image:Screenshot qcad.jpg]]
 
[[Image:Screenshot qcad.jpg]]
 
{{Caption|Qcad plan exporté en DXF qui est ensuite ouvert dans FreeCAD}}
 
{{Caption|Qcad plan exporté en DXF qui est ensuite ouvert dans FreeCAD}}
  
===Ouverture===
+
==Importation==
  
Les types d'objets .DXF suivants sont actuellement supportés:
+
Les versions DXF R12 - 2007 sont prises en charge.
  
 +
Les objets DXF suivants peuvent être importés:
 
* lignes
 
* lignes
 
* polylignes et lwpolylignes
 
* polylignes et lwpolylignes
Line 36: Line 36:
 
* dimensions
 
* dimensions
 
* blocs (géométrie seulement. Les textes, dimensions et attributs à l'intérieur des blocs seront ignorés)
 
* blocs (géométrie seulement. Les textes, dimensions et attributs à l'intérieur des blocs seront ignorés)
* points {{Version|0.13}}
+
* points
* repères (flêchés) {{Version|0.13}}
+
* repères (flêchés)
 
+
***...(liste incomplète)
Les autres entités DXF ne sont actuellement pas importées car il n'y a pas d'objet FreeCAD correspondant. Au fur et à mesure que de nouvelles fonctionnalités seront implémentées, il sera possible d'importer davantage de types d'entités.
 
 
 
==Installation==
 
 
 
{{Emphasis|Note:}} pour des raisons de licence, les bibliothèques [[DXF/fr|DXF]] import/export ne font plus partie du code source FreeCAD. Pour cette raison, ils doivent être installés par vous, l'utilisateur, après avoir installé FreeCAD. Il y a une manière automatique de le faire avec FreeCAD ou vous pouvez le faire manuellement.
 
 
 
===Automatiquement===
 
 
 
Depuis la version 0.15, vous avez seulement besoin de marquer dans {{MenuCommand|Edition → Préférences → Import/Export → DXF/DWG → "Autoriser FreeCAD à télécharger automatiquement les bibliothèques DXF"}} pour que FreeCAD prenne automatiquement soin de télécharger et d'installer ces bibliothèques. Pour les anciennes versions, vous devrez le faire manuellement.
 
 
 
===Manuellement===
 
 
 
L'ensemble doit être téléchargé sur https://github.com/yorikvanhavre/Draft-dxf-importer
 
 
 
Ici un [[Dxf_Importer_Install/fr|tutoriel]] vous explique pas à pas la procédure complète à suivre.
 
 
 
==Importation==
 
 
 
Cela fonctionne de la même manière que pour l'ouverture d'un fichier, mais le contenu du fichier DXF sera ajouté au document actif, au lieu de créer un nouveau document.
 
 
 
Tutorial: [[Dxf_Importer_Install/fr|Dxf Importer Install]]
 
  
 
==Exportation==
 
==Exportation==
  
Le fichier .DXF exporté est compatible avec la version Autocad 2012 et plus, il devrait donc s'ouvrir dans n'importe quelle application qui supporte le format .DXF. Actuellement, les objets suivants sont exportés par FreeCAD :
+
Les fichiers sont exportés au format R12 DXF qui peut être géré par de nombreuses applications.
  
 +
Les objets FreeCAD suivants peuvent être exportés:
 
* lignes et fils (polylignes)
 
* lignes et fils (polylignes)
 
* arcs et cercles
 
* arcs et cercles
* textes
+
* des textes
* les couleurs sont mappées à partir des objets, aux couleurs RVB, indice de couleur '''([http://sub-atomic.com/~moses/acadcolors.html ACI])''' d'Autocad. Le noir sera toujours la couleur "de la couche (layer)".
+
* Les couleurs sont mappées des couleurs RVB des objets à l'index de couleurs Autocad (ACI). Le noir sera toujours "par couche"
* les couches (layers) sont mappées à partir des noms de groupe. Lorsque des groupes sont imbriqués, le plus profond du groupe donne le nom au calque (layer).
+
* les calques sont mappés à partir des noms de groupe. Lorsque des groupes sont imbriqués, le groupe le plus profond donne le nom de la couche.
* les dimensions, sont exportées avec le style "Standard" [http://exchange.autodesk.com/autocadmep/fra/online-help/BLDSYS/2012/fra/pages/WS1a9193826455f5ffa23ce210c4a30acaf-5041.htm dimstyle]
+
* dimensions, qui sont exportées avec un style "standard".
 +
* ... (la liste est incomplète).
  
== Préférences ==
+
==Installation==
  
Les paramètres suivants peuvent être spécifiés dans les [[Preferences_Editor/fr|Préférences]] depuis le menu {{MenuCommand|Édition → Préférences → Import-Export}}.
+
Pour des raisons de licence, les bibliothèques d'importation/exportation [[DXF/fr|DXF]] requises ne font pas partie du code source de FreeCAD.
* Le style d'importation : Cela vous permet de choisir la manière dont les objets du fichier dxf seront établis dans FreeCAD.
+
Pour plus d'informations, voir: [[FreeCAD_and_DXF_Import/fr|FreeCAD et importation DXF]].
* Vous pouvez choisir entre :
 
** Aucun : c'est le moyen plus rapide, il n'y a pas de conversion, tous les objets seront de couleur noire avec une largeur de 2 pixels (par défaut FreeCAD).
 
** Utiliser la couleur par défaut, et, la largeur de ligne : Tous les objets dxf importés auront la largeur/couleur de ligne en cours dans la barre de commande projet.
 
** Couleurs d'origine, et, largeur de ligne : les objets garderont la couleur, et, la largeur de la ligne (si spécifié) tels qu'ils sont dans le fichier DXF.
 
** Couleurs mappées à la largeur de la ligne : Si cette option est sélectionnée, l'option fichier de mapping ci-dessous est utilisé.
 
* Fichier de mapping Couleur : Cela vous permet de spécifier un fichier de mapping à être utilisé pour traduire les couleurs dxf à la couleur, et, la largeur de la ligne, de la même manière qu'un style de tracé fonctionnant dans Autocad. Le fichier de mapping doit être un fichier texte séparé par des tabulations. Il existe un sympathique utilitaire gratuit appelé '''[http://www.noliturbare.com/TablePrintGUI.php Plot style viewer]''' qui peut convertir les fichiers Autocad '''CTB''' (styles de tracé de couleur) ou '''STB''' (styles de tracé nommé) en fichiers séparés par des tabulations cartographiques utilisables dans FreeCAD. Sinon, nous avons une paire de [[Draft_mapping_files/fr|fichiers made FreeCAD]] cartographiques Disponibles.
 
* Textes d'importation : Cela vous permet de spécifier si vous voulez importer les textes, et, les dimensions contenues dans le fichier dxf ou non. Beaucoup de textes pourraient rendre votre travail dans FreeCAD très lourd, de sorte que vous pouvez utiliser cette option quand bon vous semble.
 
* Les modèles importés : Activez cette fonction si vous voulez importer l'objet de l'espace papier. Ils seront fusionnés dans le même document que les objets de l'espace objet.
 
  
== Script ==
+
==Préférences==
 +
 
 +
Pour plus d'informations, voir: [[Import_Export_Preferences/fr|Préférences d'Import Export]].
 +
 
 +
==Script==
 
{{Emphasis|Voir aussi:}} [[Draft API/fr|Draft API]] et [[FreeCAD Scripting Basics/fr|FreeCAD Scripts de base]].
 
{{Emphasis|Voir aussi:}} [[Draft API/fr|Draft API]] et [[FreeCAD Scripting Basics/fr|FreeCAD Scripts de base]].
  
Line 105: Line 82:
 
}}
 
}}
  
{{docnav/fr
+
{{Docnav/fr
 
|
 
|
 
|[[Draft_SVG/fr|SVG]]
 
|[[Draft_SVG/fr|SVG]]
Line 112: Line 89:
 
}}
 
}}
  
[[Category:Formats/fr]]
+
{{Draft Tools navi{{#translation:}}}}
 
+
{{Userdocnavi{{#translation:}}}}
{{Draft Tools navi/fr}}
+
[[Category:Formats{{#translation:}}]]
 
 
{{Userdocnavi/fr}}
 
 
{{clear}}
 
{{clear}}

Latest revision as of 19:52, 13 March 2020

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎português do Brasil • ‎română • ‎svenska • ‎čeština • ‎русский
FreeCAD.png
Page suivante: SVG Arrow-right.svg

Draft DXF

Menu location
Workbenches
Draft
Default shortcut
Introduced in version
-
See also
FreeCAD et import DXF, FreeCAD et import DWG


Description

Draft DXF est un module logiciel utilisé par Std Open.svg Std Ouvrir, Std Import.svg Std Importer et Std Export.svg Std Exporter pour gérer le format de fichier DXF.

Screenshot qcad.jpg

Qcad plan exporté en DXF qui est ensuite ouvert dans FreeCAD


Importation

Les versions DXF R12 - 2007 sont prises en charge.

Les objets DXF suivants peuvent être importés:

  • lignes
  • polylignes et lwpolylignes
  • cercles
  • arcs
  • calques (les calques contenant des objets sont convertis en groupes dans FreeCAD)
  • textes and Mtextes (textes multi-lignes)
  • dimensions
  • blocs (géométrie seulement. Les textes, dimensions et attributs à l'intérieur des blocs seront ignorés)
  • points
  • repères (flêchés)
      • ...(liste incomplète)

Exportation

Les fichiers sont exportés au format R12 DXF qui peut être géré par de nombreuses applications.

Les objets FreeCAD suivants peuvent être exportés:

  • lignes et fils (polylignes)
  • arcs et cercles
  • des textes
  • Les couleurs sont mappées des couleurs RVB des objets à l'index de couleurs Autocad (ACI). Le noir sera toujours "par couche"
  • les calques sont mappés à partir des noms de groupe. Lorsque des groupes sont imbriqués, le groupe le plus profond donne le nom de la couche.
  • dimensions, qui sont exportées avec un style "standard".
  • ... (la liste est incomplète).

Installation

Pour des raisons de licence, les bibliothèques d'importation/exportation DXF requises ne font pas partie du code source de FreeCAD. Pour plus d'informations, voir: FreeCAD et importation DXF.

Préférences

Pour plus d'informations, voir: Préférences d'Import Export.

Script

Voir aussi: Draft API et FreeCAD Scripts de base.

Vous pouvez exporter des éléments vers un fichier DXF en utilisant la fonction suivante:

importDXF.export(objectslist, filename, nospline=False, lwPoly=False)

Exemple:

import Draft, importDXF

Polygon1 = Draft.makePolygon(3, radius=500)
Polygon2 = Draft.makePolygon(5, radius=1500)

objects = [Polygon1, Polygon2]

importDXF.export(objects, "/home/user/Pictures/myfile.dxf")
FreeCAD.png
Page suivante: SVG Arrow-right.svg