Difference between revisions of "Draft Coordinates/fr"

From FreeCAD Documentation
Jump to navigation Jump to search
(Created page with "Image:Draft_Coordinates_Toolbar.png {{Caption|Coordonnées Draft saisies dans la barre d'outils de la commande}}")
Line 41: Line 41:
 
{{Caption|Coordonnées Draft saisies dans la barre d'outils de la commande}}
 
{{Caption|Coordonnées Draft saisies dans la barre d'outils de la commande}}
  
<div class="mw-translate-fuzzy">
+
La barre d'outils de la commande Draft est une barre d'outils intelligente qui modifie son contenu en fonction de l'outil utilisé et de la saisie requise de l'utilisateur. Par exemple, lorsque vous utilisez [[Draft Circle/fr|Cercle Draft]], la barre d'outils de la commande vous demandera le point central, puis la valeur du rayon. Ces deux paramètres peuvent être indiqués en sélectionnant un point dans la vue 3D ou en entrant des nombres.
La barre de commande est une barre d'outils '''intelligente''' : en effet son contenu change en fonction de l'outil utilisé, et, l'action requise de l'utilisateur. Pour dessiner un cercle, par exemple, la barre de commande demande d'abord le centre du cercle, puis le rayon.  
 
Ces deux valeurs peuvent toutes deux être renseignées en cliquant un point à l'écran, ou par la saisie de nombres.
 
</div>
 
  
 
<div class="mw-translate-fuzzy">
 
<div class="mw-translate-fuzzy">

Revision as of 17:02, 1 September 2019

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

Description

Les outils Atelier Draft vous permettent de sélectionner graphiquement les points, les distances, les rayons et les angles en cliquant sur la vue 3D avec le pointeur.

Toutefois, quand ces paramètres nécessite la précision, il est possible de saisir des valeurs exactes dans la fenêtre de dialogue de l'outil.

Deux interfaces sont possibles: Vues Tâches et Barre d'outils de commande. L'interface par défaut est sélectionnée dans le menu Edition → Préférences → Draft → Paramètres généraux → Réglages généraux Draft.

Fenêtre Vues Tâches

Le panneau Vues Tâches est une fenêtre intelligente qui modifie son contenu en fonction de l'outil utilisé et de la saisie requise de l'utilisateur. Par exemple, lorsque vous utilisez Cercle Draft, le panneau vous demandera le point central, puis la valeur du rayon. Ces deux paramètres peuvent être indiqués en sélectionnant un point dans la vue 3D ou en entrant des nombres.

Chaque fois que des champs de saisie apparaissent dans Vues Tâches, vous pouvez y entrer des nombres. De plus, vous verrez que ces chiffres reflètent le mouvement du pointeur.

  • Appuyez sur Tab ou Entrée pour passer aux champs X, Y et Z. En appuyant sur Entrée lorsque vous vous trouvez dans le champ Z, cela enregistrera le point.

En fonction de l'outil de brouillon spécifique utilisé, d'autres options peuvent être disponibles.

  • Appuyez sur R pour basculer entre les coordonnées absolues et relatives.
  • Appuyez sur T pour passer du mode normal au mode continu.
  • Appuyez sur L pour basculer entre le mode filaire et le mode rempli.
  • Appuyez sur P pour passer du mode original au mode copie.

Draft Coordinates Taskview.png

Taskview, premier écran de l'outil Cercle, saisissant les coordonnées du centre


Draft Coordinates Taskview 2.png

Taskview, deuxième écran de l'outil Cercle, saisissant le rayon


Barre d'outils de commande

(Novembre 2018) Depuis FreeCAD 0.17, la barre d'outils de la commande Draft n'est plus le mode d'interface Draft préféré. Maintenant, Vues Tâches (Taskview) est préféré. Les informations suivantes risquent de ne plus être exactes ou de ne pas fonctionner comme décrit.


Draft Coordinates Toolbar.png

Coordonnées Draft saisies dans la barre d'outils de la commande


La barre d'outils de la commande Draft est une barre d'outils intelligente qui modifie son contenu en fonction de l'outil utilisé et de la saisie requise de l'utilisateur. Par exemple, lorsque vous utilisez Cercle Draft, la barre d'outils de la commande vous demandera le point central, puis la valeur du rayon. Ces deux paramètres peuvent être indiqués en sélectionnant un point dans la vue 3D ou en entrant des nombres.

À chaque fois qu'un champ de saisie de nombre apparaît dans la barre de commande, vous pouvez saisir un nombre. Vous constaterez également que les nombres affichés reflètent les mouvements du curseur de la souris.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


Il peut parfois être difficile d'aligner des objets en travaillant dans l'espace 3D. Vous pouvez verrouiller la coordonnée Z afin de vous assurer que tout ce que vous dessinerez reposera sur un même plan horizontal. Quand vous ouvrez FreeCAD, la coordonnée en Z est verrouillée par défaut à 0.00, mais vous pouvez facilement la changer : simplement déverrouiller, changer la valeur en Z, puis verrouillez-la à nouveau. Si la coordonnée en Z est verrouillée, vous ne pourrez pas dessiner sur des plans non-horizontaux.

La plupart des commandes de la Planche à dessin fonctionnent désormais en 3D, il suffit de déverrouiller la coordonnée en Z, et, de passer la vue dans un angle plus approprié, et, ce que vous dessinerez ensuite sera aligné à cette vue.

Lorsque vous entrez les coordonnées à partir clavier, assurez vous que le pointeur de votre souris soit hors de la zone de travail le seul mouvement de la souris modifie les coordonnées du champ sélectionné et vous serez obligé de répéter votre entrée.

Set the number of decimals

Par défaut, FreeCAD travaille avec deux décimales, pour modifier le nombre de décimales, vous devez :

  • ajouter un nouveau élément integer Decimals dans le menu Outils → Editer parametres... → BaseApp/Preferences/Units/
  • faites clic droit dans la fenêtre → sélectionnez Nouvel article entier → tapez le nom Decimals et entrez le nombre de décimales voulues. (FreeCAD travaille avec maximum 7 décimales)
  • puis cliquez sur le bouton Sauvegarder sur disque, pour valider votre modification.
  • fermez et retournez dans FreeCAD pour activer votre modification.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.
PreferencesDecimals 01 fr.png