Difference between revisions of "Draft Coordinates"

From FreeCAD Documentation
Jump to navigation Jump to search
m (minor changes to describe multiple point entry)
 
(38 intermediate revisions by 6 users not shown)
Line 1: Line 1:
In all Draft tools, when you are asked for 3d point locations, distances, radiuses, angles or any other numeric data, you can always choose to enter those values graphically, by picking on the screen with your mouse, or directly by entering numbers with the keyboard. The first method is usually more intuitive, but when you work with absolute precision, you often need to enter a precise number and be sure the coordinate you entered is exact. Therefore, the command bar of the Draft module can always accept number input:
+
<languages/>
 +
<translate>
 +
<!--T:12-->
 +
{{Docnav
 +
|
 +
|[[Draft Constrain|Constraining]]
 +
|[[Draft_Module|Draft_Module]]
 +
|IconC=Workbench_Draft.svg
 +
}}
  
 +
== Description == <!--T:1-->
 +
 +
</translate>
 +
{{TOCright}}
 +
<translate>
 +
<!--T:13-->
 +
The [[Image:Workbench_Draft.svg|24px]] [[Draft Workbench]] tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the [[3D view]] with the pointer.
 +
 +
<!--T:14-->
 +
However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.
 +
 +
<!--T:15-->
 +
There are two interfaces possible: taskview (recommended) and command toolbar. The default interface is selected in the menu {{MenuCommand|Edit → Preferences → Draft → General settings → Draft interface mode}}.
 +
 +
== Taskview panel == <!--T:16-->
 +
 +
<!--T:17-->
 +
The Taskview panel (AKA [[Task panel]]) is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using [[Image:Draft_Circle.svg|24px]] [[Draft Circle]], the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the [[3D view]] or by entering numbers.
 +
 +
<!--T:18-->
 +
Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.
 +
* Press {{KEY|Tab}} or {{KEY|Enter}} to advance to the X, Y and Z fields; pressing {{KEY|Enter}} when in the Z field will record the point.
 +
 +
<!--T:19-->
 +
Depending on the specific Draft tool under use, there may be other options available.
 +
* Press {{KEY|R}} to switch between absolute and relative coordinates.
 +
* Press {{KEY|T}} to switch between normal mode and continue mode.
 +
* Press {{KEY|L}} to switch between wireframe mode and filled mode.
 +
* Press {{KEY|P}} to switch between original mode and copy mode.
 +
 +
<!--T:2-->
 +
[[Image:Draft_Coordinates_Taskview.png]]
 +
{{Caption|Taskview, first screen for the Circle tool, entering center coordinates}}
 +
 +
<!--T:20-->
 +
[[Image:Draft_Coordinates_Taskview_2.png]]
 +
{{Caption|Taskview, second screen for the Circle tool, entering the radius}}
 +
 +
== Command toolbar == <!--T:21-->
 +
 +
<!--T:22-->
 +
{{VeryImportantMessage|(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.}}
 +
 +
<!--T:23-->
 +
[[Image:Draft_Coordinates_Toolbar.png]]
 +
{{Caption|Draft coordinates entered in the command toolbar}}
 +
 +
<!--T:3-->
 +
The Draft command toolbar is an intelligent toolbar that changes its contents according to the tool being used, and the input required from the user. For example, when using [[Draft Circle]], the command toolbar will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.
 +
 +
<!--T:4-->
 +
Whenever you see input fields appearing on the command toolbar, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.
 +
* Press {{KEY|Tab}} or {{KEY|Enter}} to advance to the X, Y and Z fields; pressing {{KEY|Enter}} when in the Z field will record the point.
 +
* Press {{KEY|R}} to switch between absolute and relative coordinates.
 +
* Press {{KEY|P}} to switch between original mode and copy mode.
 +
* Press {{KEY|L}} to lock or unlock the Z coordinate. {{Emphasis|This is now deprecated: the {{KEY|L}} key now toggles the fill mode of closed shapes.}}
 +
 +
=== Locking the Z coordinate === <!--T:24-->
 +
 +
<!--T:25-->
 
[[Image:Draft_Coordinates.jpg]]
 
[[Image:Draft_Coordinates.jpg]]
 +
{{Caption|Draft coordinates entered in the command toolbar (older FreeCAD)}}
 +
 +
<!--T:6-->
 +
It can be hard to align objects when working in 3D space. For this reason, you can lock the Z coordinate so you'll be certain that everything you draw will lie in the same horizontal plane. When you open FreeCAD, the Z coordinate is locked by default at 0.00, but you can change this; just unlock it, change the Z value, and lock it again. If the Z coordinate is locked, you won't be able to draw in non-horizontal planes.
  
The Draft command bar is an "intelligent" toolbar, which means its contents change according to the tool being used and the input required from the user. When you draw a circle, for example, the command bar will successively ask you for the circle center, then the radius. Those two values can both be indicated by picking a point on the screen or by entering numbers.
+
<!--T:7-->
 +
Most Draft tools work in the working plane defined by [[Draft SelectPlane]]. Therefore, it is usually not necessary to lock the Z coordinate, just establish the correct working plane.
  
Whenever you see the number input fields appearing on the command bar, you can enter numbers in them You will see that those numbers also reflect the movements of your mouse cursor. You can tab through the X,Y and Z fields to set the coordinates. Pressing enter in the Z field will record the point. Repeating the entry of new X, Y and Z coordinates will set the second point for a line and/or  subsequent points for a wire.
+
== Set the number of decimals == <!--T:26-->
  
The following shortcuts can also be used:
+
<!--T:9-->
* {{KEY|SPACE BAR}} to swap between absolute and relative coordinates
+
By default, FreeCAD shows two decimal places in quantities. To change the number of decimal places shown change the preferences:
* {{KEY|C}} to swap between original mode and copy mode
+
* Go to {{MenuCommand|Edit → Preferences → General → Units}}, and set "Number of decimals" to the desired value.
* {{KEY|L}} to lock/unlock the Z coordinate
+
* Then press {{Button|Apply}} and {{Button|OK}}.
* {{KEY|TAB}} or {{KEY|ENTER}} switches to the next field (for ex. from X to Y or from Y to Z)
 
  
Sometimes, it can be hard to align objects when working in 3D space. You can lock the Z coordinate, so you'll be certain that everything you draw will lie in the same horizontal plane. When you open FreeCAD, the Z coordinate is locked by default at 0.00, but you can easily change it, just unlock, change the Z value, and lock again. If Z coordinate is locked, you won't be able to draw in non-horizontal planes.
+
<!--T:27-->
 +
Another way is using the parameter editor:
 +
* Go to {{MenuCommand|Tools → Edit parameters → BaseApp → Preferences → Units}}, and change the "Value" of "Decimals" to the desired number.
 +
* If "Decimals" doesn't exist you can create it; right click in the window and select {{MenuCommand|New integer item → Enter the name →}}, type in "Decimals", and proceed to enter the desired number.
 +
* Then click {{Button|Save to disk}} and {{Button|Close}}.
 +
* Restart FreeCAD to activate your changes.
  
Most of the Draft commands now work in 3D, just unlock the Z coordinate and switch the view to the appropriate angle, and what you'll draw next will be aligned to that view.
+
<!--T:10-->
 +
[[Image:PreferencesDecimals_01_en.png]]
 +
{{Caption|Parameter editor to change the decimal places shown by a numerical value}}
 +
{{clear}}
  
[[Category:User Documentation]]
+
<!--T:11-->
 +
{{Docnav
 +
|
 +
|[[Draft Constrain|Constraining]]
 +
|[[Draft_Module|Draft_Module]]
 +
|IconC=Workbench_Draft.svg
 +
}}
  
{{languages | {{es|Draft Coordinates/es}} {{fr|Draft Coordinates/fr}} {{se|Draft Coordinates/se}} }}
+
</translate>
 +
{{Draft Tools navi{{#translation:}}}}
 +
{{Userdocnavi{{#translation:}}}}
 +
{{clear}}

Latest revision as of 17:55, 21 February 2020

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

Description

The Workbench Draft.svg Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview (recommended) and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel (AKA Task panel) is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle.svg Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft Coordinates Taskview.png

Taskview, first screen for the Circle tool, entering center coordinates


Draft Coordinates Taskview 2.png

Taskview, second screen for the Circle tool, entering the radius


Command toolbar

(November 2018) Since FreeCAD 0.17, the Draft command toolbar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft Coordinates Toolbar.png

Draft coordinates entered in the command toolbar


The Draft command toolbar is an intelligent toolbar that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the command toolbar will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the command toolbar, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.
  • Press R to switch between absolute and relative coordinates.
  • Press P to switch between original mode and copy mode.
  • Press L to lock or unlock the Z coordinate. This is now deprecated: the L key now toggles the fill mode of closed shapes.

Locking the Z coordinate

Draft Coordinates.jpg

Draft coordinates entered in the command toolbar (older FreeCAD)


It can be hard to align objects when working in 3D space. For this reason, you can lock the Z coordinate so you'll be certain that everything you draw will lie in the same horizontal plane. When you open FreeCAD, the Z coordinate is locked by default at 0.00, but you can change this; just unlock it, change the Z value, and lock it again. If the Z coordinate is locked, you won't be able to draw in non-horizontal planes.

Most Draft tools work in the working plane defined by Draft SelectPlane. Therefore, it is usually not necessary to lock the Z coordinate, just establish the correct working plane.

Set the number of decimals

By default, FreeCAD shows two decimal places in quantities. To change the number of decimal places shown change the preferences:

  • Go to Edit → Preferences → General → Units, and set "Number of decimals" to the desired value.
  • Then press Apply and OK.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.

PreferencesDecimals 01 en.png

Parameter editor to change the decimal places shown by a numerical value