Difference between revisions of "Draft Coordinates"

From FreeCAD Documentation
Jump to navigation Jump to search
(→‎Description: More details)
(→‎Taskview panel: Second level, not third level)
Line 10: Line 10:
 
There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu {{MenuCommand|Edit → Preferences → Draft → General settings → Draft interface mode}}.
 
There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu {{MenuCommand|Edit → Preferences → Draft → General settings → Draft interface mode}}.
  
=== Taskview panel ===
+
== Taskview panel ==
  
 
The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using [[Draft Circle]], the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.
 
The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using [[Draft Circle]], the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Revision as of 18:48, 22 November 2018

Other languages:
Deutsch • ‎English • ‎Türkçe • ‎español • ‎français • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(中国大陆)‎

Description

Draft Workbench tools allow you to pick points, distances, radiuses, and angles graphically by clicking on the 3D view with the pointer.

However, when these parameters need to be precise, it is possible to enter the exact values in the dialog for the tool.

There are two interfaces possible: taskview and command toolbar. The default interface is selected in the menu Edit → Preferences → Draft → General settings → Draft interface mode.

Taskview panel

The Taskview panel is an intelligent window that changes its contents according to the tool being used, and the input required from the user. For example, when using Draft Circle, the panel will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the 3D view or by entering numbers.

Whenever you see input fields appearing on the Taskview, you can enter numbers in them; moreover, you will see that those numbers reflect the movement of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.

Depending on the specific Draft tool under use, there may be other options available.

  • Press R to switch between absolute and relative coordinates.
  • Press T to switch between normal mode and continue mode.
  • Press L to switch between wireframe mode and filled mode.
  • Press P to switch between original mode and copy mode.

Draft coordinates entered in the Taskview

Draft options entered in the Taskview

Draft command bar

(November 2018) Since FreeCAD 0.17, the Draft Command bar is no longer the preferred Draft interface mode. Now the Taskview is preferred. The following information may no longer be accurate or work as described.


Draft coordinates entered in the Command toolbar

The Draft command bar is an intelligent toolbar, which means its contents change according to the tool being used, and the input required from the user. For example, when using Draft Circle, the command bar will ask you for the center point, and then the radius value. These two parameters can be indicated by either picking a point on the screen or by entering numbers.

Whenever you see input fields appearing on the command bar, you can enter numbers in them; moreover, you will see that those numbers reflect the movements of the pointer.

  • Press Tab or Enter to advance to the X, Y and Z fields; pressing Enter when in the Z field will record the point.
  • Press R to switch between absolute and relative coordinates.
  • Press P to switch between original mode and copy mode.
  • Press L to lock or unlock the Z coordinate. This is now deprecated: the L key now toggles the fill mode of closed shapes.

Locking the Z coordinate

It can be hard to align objects when working in 3D space. For this reason, you can lock the Z coordinate so you'll be certain that everything you draw will lie in the same horizontal plane. When you open FreeCAD, the Z coordinate is locked by default at 0.00, but you can change this; just unlock it, change the Z value, and lock it again. If the Z coordinate is locked, you won't be able to draw in non-horizontal planes.

Most Draft tools work in the working plane defined by Draft SelectPlane. Therefore, it is usually not necessary to lock the Z coordinate, just establish the correct working plane.

Set the number of decimals

By default, FreeCAD shows two decimal places in quantities. To change the number of decimal places change the preferences:

  • Go to Edit → Preferences → General → Units, and set "Number of decimals" to the desired value.
  • Then press Apply and OK.

Another way is using the parameter editor:

  • Go to Tools → Edit parameters → BaseApp → Preferences → Units, and change the "Value" of "Decimals" to the desired number.
  • If "Decimals" doesn't exist you can create it; right click in the window and select New integer item → Enter the name →, type in "Decimals", and proceed to enter the desired number.
  • Then click Save to disk and Close.
  • Restart FreeCAD to activate your changes.
PreferencesDecimals 01 en.png