Difference between revisions of "Customize Toolbars/de"

From FreeCAD Documentation
Jump to navigation Jump to search
(Typo)
(Updating to match new version of source page)
 
(64 intermediate revisions by 3 users not shown)
Line 1: Line 1:
 
<languages/>
 
<languages/>
{{TutorialInfo/de|Thema=SampleTopic|Level=Anfänger|Time=5 Minuten|Author=[[User:Mario52|Mario52]]|FCVersion=Alle}}
+
{{TutorialInfo/de
 +
|Topic=Beispielthema
 +
|Level=Anfänger
 +
|Time=5 Minuten
 +
|Author=[[User:Mario52|Mario52]]
 +
|FCVersion=Alle
 +
}}
  
<small>Status: FreeCAD-Version 0.16</small>
+
==Synopsis==
  
 +
<div class="mw-translate-fuzzy">
 
==Zusammenfassung==
 
==Zusammenfassung==
Dieses Tutorial behandelt die Anpassung von Werkzeugleisten. Werkzeuge (inklusive Makro-Werkzeugen) können in verschiedenen Arbeitsbereichen verwendet werden. In einem Beispiel wird durch Erzeugung eines '''Menütextes''', eines '''Tooltips''' und eines '''Piktogramms''' aus einem Makro ein Makro-Werkzeug. Anschließend wird dieses Makro-Werkzeug Teil einer zusätzlichen Werkzeugleiste in einem Arbeitsbereich.
+
Dieses Tutorium zeigt dir die Anpassung von Werkzeugleisten. Werkzeuge (einschließlich Makrowerkzeuge) können in verschiedenen Arbeitsbereichen verwendet werden. In einem Beispiel wird ein Makro zu einem Makrowerkzeug, indem ein '''Menütext''', eine '''Werkzeugspitze''' und ein '''Symbol''' erstellt wird. Danach wird dieses Makrowerkzeug Teil einer zusätzlichen Werkzeugleiste in einem Arbeitsbereich.
 +
</div>
  
==Vorgehen==
+
==Usage==  
  
<u>'''1.''' Aufruf des Anpassungs-Menüs "Benutzerdefiniert"</u>
+
<div class="mw-translate-fuzzy">
 +
==Verwendung====
 +
<u>'''1.''' Finde das Anpassungsmenü </u>
 +
</div>
  
*Klicke {{MenuCommand|Haupt-Menü → Werkzeuge → Benutzerdefiniert...}},
+
*Klicke {{MenuCommand/de|Hauptmenü → Werkzeuge → Benutzerdefiniert}},
  
[[File:CustomizeToolBar 01.png|640px|center|Benutzerdefiniert...]]
+
[[File:CustomizeToolBar 01.png|640px|center|Benutzerdefiniert]]
 
{{clear}}
 
{{clear}}
  
* oder mache einen Rechts-Klick (rechte Maustaste) in irgendeine Werkzeugleiste.
+
*oder rechtsklicke auf eine beliebige Werkzeugleiste.
  
 
[[File:CustomizeToolBar 02.png|640px|center|Rechter Mausklick]]
 
[[File:CustomizeToolBar 02.png|640px|center|Rechter Mausklick]]
 
{{clear}}
 
{{clear}}
  
*Das Menü (Fenster) "Benutzerdefiniert" öffnet sich.
+
*Das Anpassungsfenster erscheint.
  
[[File:CustomizeToolBar 03.png|640px|center|Das Fenster 'Benutzerdefiniert' erscheint]]
+
[[File:CustomizeToolBar 03.png|640px|center|Das Anpassungsfenster erscheint]]
 
{{clear}}
 
{{clear}}
  
<u>'''2.''' Erzeugen eines Makro-Werkzeugs aus einem Makro</u>
+
<u>'''2.''' Erzeuge ein Makro zu einem Makro-Werkzeug</u>
  
*Klicke auf den Reiter "Makros"
+
*Wähle den "Makro" Reiter.
  
*Für das Zufügen eines Icons für das vorgesehene Makro-Werkzeug klicke auf das Symbol &nbsp; {{KEY|... }}.
+
*Um ein Symbol für das bereitgestellte Makro hinzuzufügen, klicke auf die Pixmap Schaltfläche (labelled {{KEY|... }}).
  
[[File:Customize4de.jpg|640px|center|Select a toolbar]]
+
[[File:CustomizeToolBar 04.png|640px|center|Wähle eine Werkzeugleiste]]
 
{{clear}}
 
{{clear}}
  
* Suche ein passendes Icon in der Icon-Sammlung von FreeCAD.
+
*Suche nach einem geeigneten Symbol aus den vorhandenen Symbolen von FreeCAD,
  
 
<div class="mw-collapsible mw-collapsed toccolours">
 
<div class="mw-collapsible mw-collapsed toccolours">
  
&nbsp; &nbsp; &nbsp; [... oder füge eines aus einem benutzerdefinierten "Icon-Ordner" ein.]
+
&nbsp; &nbsp; &nbsp; [oder füge Dein eigenes Symbol durch klicken von {{Button|Symbole hinzufügen...}}] hinzu. &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;(erweitere für ein Beispiel)
  
 
<div class="mw-collapsible-content">
 
<div class="mw-collapsible-content">
  
[[File:CustomizeToolBar 05.png|640px|center|Add icon]]
+
[[File:CustomizeToolBar 05.png|640px|center|Symbol hinzufügen]]
 
{{clear}}
 
{{clear}}
  
&nbsp; &nbsp; &nbsp;[Der Ordner mit benutzerdefinierten Icons wird durch Klicken auf "Icon-Ordner" geöffnet.
+
&nbsp; &nbsp; &nbsp;[Du erhälst ein Dateiauswahlfenster, wähle deine benutzerdefinierte Bilddatei (PNG format, 64x64 pixels)]
&nbsp; &nbsp; &nbsp; Eines anklicken und mit Klick auf "OK" annehmen.]
 
  
[[File:CustomizeToolBar 06.png|640px|center|Get a file]]
+
[[File:CustomizeToolBar 06.png|640px|center|Hole eine Datei]]
 
{{clear}}
 
{{clear}}
  
Line 55: Line 65:
 
</div>
 
</div>
  
*Klicke auf  {{KEY|OK}}.
+
* Wähle dein Symbol und klicke {{KEY|OK}}.
  
[[File:Customize5de.jpg|640px|center|Select your icon]]
+
[[File:Customize5de.jpg|640px|center|Wähle dein Symbol]]
 
{{clear}}
 
{{clear}}
  
*Das ausgewählte Icon wird neben dem Symbol &nbsp; {{KEY|...}} angezeigt.
+
* Das von dir gewählte Symbol wird nun neben der Pixmap Schaltfläche mit der Beschriftung {{KEY|...}} angezeigt.
  
[[File:Customize6de.jpg|640px|center|Your icon is displayed]]
+
[[File:Customize6de.jpg|640px|center|Dein Symbol wird angezeigt]]
 
{{clear}}
 
{{clear}}
  
*Vorgesehenes Makro in der Zeile "Makro:" auswählen.
+
*Wähle das mitgelieferte Makro in der Zeile '''Makro:''' aus und gib einen '''Menütext''': an (der als Textbeschriftung im Menü erscheint); fülle auch die '''Werkzeugspitze':'' aus (das ist der Text, der erscheint, wenn sich die Maus über der Schaltfläche auf der Symbolleiste befindet); weitere Zeilen sind optional.
 
 
* "Menütext:" eintragen (erscheint als Text-Label in Werkzeugleiste).
 
 
 
* "Tooltipp:" eintragen (erscheint als Text-Zeile beim Überstreichen des Icons mit der Maus).
 
&nbsp; &nbsp;  &nbsp;  &nbsp; [Ausfüllen weiterer Zeilen ist optional.]
 
  
*Auf  {{KEY|Add}} klicken.
+
* Klicke die Schaltfläche {{KEY|Add}}.
  
[[File:CustomizeToolBar 09.png|640px|center|Click the button]]
+
[[File:CustomizeToolBar 09.png|640px|center|Drücke die Schaltfläche]]
 
{{clear}}
 
{{clear}}
  
* Die Programm-Ergänzung (Makro) ist nun als Makro-Werkzeug installiert.
+
*Die Schaltfläche des Makrowerkzeugs ist nun erstellt.
  
[[File:CustomizeToolBar 10.png|640px|center|Your button is created]]
+
[[File:CustomizeToolBar 10.png|640px|center|Deine Schaltfläche ist erstellt]]
 
{{clear}}
 
{{clear}}
  
<u>'''3.''' Erstellen einer ergänzenden Werkzeugleiste außerhalb des Arbeitsbereichs "Makro", die das kreierte "Makro-Werkzeug" enthält</u>
+
<u>'''3.''' Erstelle eine Werkzeugleiste außerhalb des Arbeitsbereichs '''Makro''', die das erstellte '''Makrowerkzeug''' enthält</u>
 
 
*Auf den Reiter '''Symbolleisten''' klicken und den Arbeitsbereich wählen, der um eine Werkzeugleiste ergänzt werden soll (z.B. '''Körper''' (Part)).
 
  
&nbsp; &nbsp; &nbsp; &nbsp; [Seit Version 0.15 kann anstattt eines Arbeitsbereiches &nbsp;{{KEY|[[File:Freecad.svg|16px]] Global}}&nbsp;  gewählt werden.  
+
* Wähle die Registerkarte '''Werkzeugleisten''' und wähle den Arbeitbereich (für den die Werkzeugleiste vorgesehen ist) in der Aufklappliste auf der rechten Seite ('''Teil''' in diesem Beispiel).
  
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; In diesem Fall lässt sich die zu erstellende Zusatz-Werkzeugleiste in jedem Arbeitsbereich aktivieren.]
+
&nbsp; &nbsp; &nbsp; &nbsp; [Seit Version 0.15 gibt es einen Arbeitsbereich &nbsp;{{KEY|[[File:Freecad.svg|16px]] Global}}&nbsp; Werkzeugleiste.
 +
Wenn dies ausgewählt wird, befindet sich die bereitgestellte Werkzeugleiste in jedem Arbeitsbereich.]
  
[[File:CustomizeToolBar 11.png|640px|center|Toolbars tab]]
+
[[File:CustomizeToolBar 11.png|640px|center|Werkzeugleistenreiter]]
 
{{clear}}
 
{{clear}}
  
*Wähle '''Makros''' in linkem Fenster-Teil (Zeile enthält standardmäßig '''Datei''').
+
*Wähle in der Aufklappliste auf der linken Seite '''Makros'''.
  
[[File:CustomizeToolBar 12.png|640px|center|Macros]]
+
[[File:CustomizeToolBar 12.png|640px|center|Makros]]
 
{{clear}}
 
{{clear}}
  
*Die Makro-Werkzeuge werden zusammen mit ihren Icons  darunter gelistet (auch das oben erstellte).
+
*Das Makrowerkzeug mit seinem Symbol erscheint in der Liste.
  
[[File:CustomizeToolBar 13.png|640px|center|Your icon is listed]]
+
[[File:CustomizeToolBar 13.png|640px|center|Dein Symbol wird aufgeführt]]
 
{{clear}}
 
{{clear}}
  
*Klicke auf {{KEY|Neu...}}
+
* Klicke die Schaltfläche {{KEY|Neu}}.
  
[[File:CustomizeToolBar 14.png|640px|center|Click on "New"]]
+
[[File:CustomizeToolBar 14.png|640px|center|Klicke auf "Neu"]]
 
{{clear}}
 
{{clear}}
  
*Trage einen  Namen für die vorgesehene zusätzliche Werkzeugleiste ein. Bestätige mit "OK".
+
*Im Fenster "Neue Werkzeugleiste" gib den Namen der bereitgestellten zusätzlichen Werkzeugleiste für den '''Part''' Arbeitsbereich ein und klicke auf {{KEY|OK}}
  
[[File:CustomizeToolBar 15.png|640px|center|Enter the name for your toolbar]]
+
[[File:CustomizeToolBar 15.png|640px|center|Gib den Namen für die Werkzeugleiste ein]]
 
{{clear}}
 
{{clear}}
  
*Diese Werkzeugleiste ist nun kreiert.
+
*Die Werkzeugleiste ist nun erstellt.
  
*Klicke  z.B. auf  das kreierte Makro-Werkzeug. Durch Klicken auf den nach rechts zeigenden {{KEY|blauen Pfeil}} wird es auch  in die rechts kreierte Werkzeugleiste eingetragen.
+
<div class="mw-translate-fuzzy">
 +
*Um das Creadet Makrowerkzeug dieser Symbolleiste hinzuzufügen, wähle es im linken Fenster aus und klicke dann auf die {{KEY|Button}} Schaltfläche, wobei der Pfeil nach rechts zeigt.
 +
</div>
  
[[File:CustomizeToolBar 16.png|640px|center|Select your macro]]
+
[[File:CustomizeToolBar 16.png|640px|center|Wähle Dein Makro]]
 
{{clear}}
 
{{clear}}
  
* Dem Arbeitsbereich Körper (Part) ist nun eine "Camera" genannte Werkzeugleiste mit dem Makro-Werkzeug  '''Camera''' zugefügt  worden.
+
* Du hast nun eine Werkzeugleiste mit dem Namen "Kamera" erstellt (mit dem Makrowerkzeug '''Kamera''' darin)
  
*Klicke auf {{KEY|Schließen}}.
+
*Klicke die {{KEY|Close}} Schaltfläche.
  
[[File:CustomizeToolBar 17.png|640px|center|Close]]
+
[[File:CustomizeToolBar 17.png|640px|center|Schließen]]
 
{{clear}}
 
{{clear}}
  
* Diese zusätzliche Werkzeugleiste wird beim Rechts-Klick auf die Werkzeugleiste des Arbeitsbereiches Körper (Part) auch sichtbar. Die Icons ihrer Werkzeuge (im Beispiel nur '''Camera''') werden sichtbar, nachdem die Leiste aktiviert worden ist (blauer Haken gesetzt).
+
*Deine neue Werkzeugleiste ist jetzt im Rechtsklickmenü der Werkzeugleisten enthalten. Seine Symbole (in unserem Beispiel nur die Kamera) sind sichtbar, wenn die Symbolleiste aktiviert ist (blaues Häkchen).
  
[[File:CustomizeToolBar 18.png|640px|center|New Toolbar]]
+
[[File:CustomizeToolBar 18.png|640px|center|Neue Werkzeugleiste]]
 
{{clear}}
 
{{clear}}
  
 +
<div class="mw-translate-fuzzy">
 +
==Hinweise für Python basierte Funktionen wie die im Draft==
 +
Wenn du eine Draft oder eine andere Python basierte Funktion in einer Werkzeugleiste verwenden möchtest, scheinen diese in der Aufklappliste auf der linken Seite nicht verfügbar zu sein. Du musst zuerst den entsprechenden Arbeitsbereich laden, z.B. Draft, und dann findest du die verfügbaren Funktionen, wenn du "Python" im linken Aufklappmenü auswählst.
 +
</div>
 +
 +
See also [[Interface_Customization|Interface Customization]].
  
 +
[[Category:Preferences{{#translation:}}]]
 
{{clear}}
 
{{clear}}

Latest revision as of 20:51, 20 November 2020

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎hrvatski • ‎italiano • ‎polski • ‎română • ‎svenska • ‎čeština • ‎русский • ‎中文(台灣)‎

Base ExampleCommandModel.png Tutorial

Thema
Beispielthema
Niveau
Anfänger
Zeit zum Abschluss
5 Minuten
Autor
Mario52
FreeCAD version
Alle
Beispieldatei(en)
None


Synopsis

Zusammenfassung

Dieses Tutorium zeigt dir die Anpassung von Werkzeugleisten. Werkzeuge (einschließlich Makrowerkzeuge) können in verschiedenen Arbeitsbereichen verwendet werden. In einem Beispiel wird ein Makro zu einem Makrowerkzeug, indem ein Menütext, eine Werkzeugspitze und ein Symbol erstellt wird. Danach wird dieses Makrowerkzeug Teil einer zusätzlichen Werkzeugleiste in einem Arbeitsbereich.

Usage

Verwendung==

1. Finde das Anpassungsmenü

  • Klicke Hauptmenü → Werkzeuge → Benutzerdefiniert,
Benutzerdefiniert


  • oder rechtsklicke auf eine beliebige Werkzeugleiste.
Rechter Mausklick


  • Das Anpassungsfenster erscheint.
Das Anpassungsfenster erscheint


2. Erzeuge ein Makro zu einem Makro-Werkzeug

  • Wähle den "Makro" Reiter.
  • Um ein Symbol für das bereitgestellte Makro hinzuzufügen, klicke auf die Pixmap Schaltfläche (labelled ... ).
Wähle eine Werkzeugleiste


  • Suche nach einem geeigneten Symbol aus den vorhandenen Symbolen von FreeCAD,

      [oder füge Dein eigenes Symbol durch klicken von Symbole hinzufügen...] hinzu.                  (erweitere für ein Beispiel)

Symbol hinzufügen


     [Du erhälst ein Dateiauswahlfenster, wähle deine benutzerdefinierte Bilddatei (PNG format, 64x64 pixels)]

Hole eine Datei


  • Wähle dein Symbol und klicke OK.
Wähle dein Symbol


  • Das von dir gewählte Symbol wird nun neben der Pixmap Schaltfläche mit der Beschriftung ... angezeigt.
Dein Symbol wird angezeigt


  • Wähle das mitgelieferte Makro in der Zeile Makro:' aus und gib einen Menütext: an (der als Textbeschriftung im Menü erscheint); fülle auch die Werkzeugspitze': aus (das ist der Text, der erscheint, wenn sich die Maus über der Schaltfläche auf der Symbolleiste befindet); weitere Zeilen sind optional.
  • Klicke die Schaltfläche Add.
Drücke die Schaltfläche


  • Die Schaltfläche des Makrowerkzeugs ist nun erstellt.
Deine Schaltfläche ist erstellt


3. Erstelle eine Werkzeugleiste außerhalb des Arbeitsbereichs Makro, die das erstellte Makrowerkzeug enthält

  • Wähle die Registerkarte Werkzeugleisten und wähle den Arbeitbereich (für den die Werkzeugleiste vorgesehen ist) in der Aufklappliste auf der rechten Seite (Teil in diesem Beispiel).

        [Seit Version 0.15 gibt es einen Arbeitsbereich  Freecad.svg Global  Werkzeugleiste. Wenn dies ausgewählt wird, befindet sich die bereitgestellte Werkzeugleiste in jedem Arbeitsbereich.]

Werkzeugleistenreiter


  • Wähle in der Aufklappliste auf der linken Seite Makros.
Makros


  • Das Makrowerkzeug mit seinem Symbol erscheint in der Liste.
Dein Symbol wird aufgeführt


  • Klicke die Schaltfläche Neu.
Klicke auf "Neu"


  • Im Fenster "Neue Werkzeugleiste" gib den Namen der bereitgestellten zusätzlichen Werkzeugleiste für den Part Arbeitsbereich ein und klicke auf OK
Gib den Namen für die Werkzeugleiste ein


  • Die Werkzeugleiste ist nun erstellt.
  • Um das Creadet Makrowerkzeug dieser Symbolleiste hinzuzufügen, wähle es im linken Fenster aus und klicke dann auf die Button Schaltfläche, wobei der Pfeil nach rechts zeigt.
Wähle Dein Makro


  • Du hast nun eine Werkzeugleiste mit dem Namen "Kamera" erstellt (mit dem Makrowerkzeug Kamera darin)
  • Klicke die Close Schaltfläche.
Schließen


  • Deine neue Werkzeugleiste ist jetzt im Rechtsklickmenü der Werkzeugleisten enthalten. Seine Symbole (in unserem Beispiel nur die Kamera) sind sichtbar, wenn die Symbolleiste aktiviert ist (blaues Häkchen).
Neue Werkzeugleiste


Hinweise für Python basierte Funktionen wie die im Draft

Wenn du eine Draft oder eine andere Python basierte Funktion in einer Werkzeugleiste verwenden möchtest, scheinen diese in der Aufklappliste auf der linken Seite nicht verfügbar zu sein. Du musst zuerst den entsprechenden Arbeitsbereich laden, z.B. Draft, und dann findest du die verfügbaren Funktionen, wenn du "Python" im linken Aufklappmenü auswählst.

See also Interface Customization.